Está en la página 1de 63

Introducción a las fórmulas

En unos pocos pasos, podrá empezar a crear fórmulas y funciones de Excel, la aplicación de
hoja de cálculo más eficaz del mundo.

Adelante >

Vuelva al principio presionando CTRL+INICIO. Para empezar el recorrido, presione CTRL+AVANZAR PÁGINA.
puede ver
fácilmente la
constante sin
seleccionar la
celda y
buscarla. Eso
puede
Las fórmulas
dificultar
pueden
cambiarla
contener más
adelante.
Puede Conceptos básicos: realizar operaciones
referencias
Conceptos Esbásicos:
celdas,sumar,
mucho
a realizar operaciones matemáticas con Excel
más restar, multiplicar y dividir en Excel sin tener que usar las funciones integradas. Solo tiene que usar algunos operadores básicos: +, -, *, /. Todas las fórmulas empieza
Números para usar: Operación:
fácil
Para colocar
referencias las
sumar,aseleccione la celda F3, escriba =C3+C4 y, después, presione ENTRAR.
constantes
matemáticas con Excel
intervalos de
celdas, donde
en 1 Suma (+)
Para
pueden
Para restar, seleccione
multiplicar,
operadores y seleccionela celda F4, escriba
la celda =C3-C4
F5, escriba y, después,
=C3*C4 presione
y, después, ENTRAR.
presione ENTRAR. 2 Resta (-)
ajustarse
constantes.
Para dividir, seleccione la restar,
celda F6, escriba =C3/C4 y, después, Multiplicación (*)
Estos son Puede
fácilmente, y sumar, multiplicar y dividir en Excelpresione
sin tenerENTRAR.
que usar las funciones
División (/)
hacer
algunos integradas. Solo tiene que usar algunos operadores básicos: +, -, *, /. Todas las
Mire esto:de
referencia
ejemplos acambie los números en las celdas C3 y C4 y vea cómo los resultados de las fórmulas cambian automáticamente. Potencia (^)
fórmulas empiezan con un signo igual (=).
ellas en
fórmulas: las
CRÉDITO ADICIONAL: Puede elevar un valor a una potencia mediante el operador exponencial (^), por ejemplo =A1^A2. Puede escribirlo con AltGr+^. En la celda F7, escriba =C3^C
fórmulas.
Vaya hacia abajo para obtener más detalles. MIRE ESTO
=A1+B1
Siguiente
Por ejemplo:
=10+20 paso1 Para sumar, seleccione la celda F3, escriba =C3+C4 y después presione Cambie los números aquí y vea
cómo los resultados de las
Seleccione
=SUMA(A1:A1
Más la
información ENTRAR.
sobre las fórmulas, celdas e seintervalos
Excel
celda
0) se compone
amarilla de celdas individuales que agrupan en filas y columnas. Las filas están numeradas y las columnas fórmulas
tienen cambian
letras. Hay más de 1 millón de filas y 16000 columnas
con 12 a automáticamente.
continuación.
Verá que 2
Observará que, en el tercer
Para ejemplo
restar, anterior,lausamos
seleccione la función
celda F4, escribaSUMA.
=C3-C4 Unay función
despuésespresione
un comando predefinido que toma valores, los calcula de alguna forma y devuelve un resul
Las fórmulas
usamos la con funciones
ENTRAR. empiezan con un signo igual, seguido del nombre de la función con los argumentos (los valores que usa una función para calcular) entre paréntesis.
función SUMA
con un
intervalo de
celdas. No 3
Información sobre Para
algunas multiplicar,
fórmulas seleccione la celda F5, escriba =C3*C4 y después presione
=10+20 es
escriba "4" o una ENTRAR.
fórmula, donde 10 y 20 son constantes y el signo + es el operador.
"8"
=SUM(A1:A10) es una fórmula, donde SUMA es el nombre de función, los paréntesis de apertura y cierre contienen los argumentos de la fórmula y A1:A10 es el intervalo de celda
directamente
=SUM(A1:A10;C1:C10) es una fórmula, donde SUMA es el nombre de función, los paréntesis de apertura y cierre contienen los argumentos de la fórmula y A1:A10;C1:C10 son los
en la fórmula.
4 Para dividir, seleccione la celda F6, escriba =C3/C4 y después presione
ENTRAR.
Anterior
Siguiente
Más información en la Web
Vaya hacia abajo para obtener más detalles Siguiente paso
Usar Excel como una calculadora
Información general sobre fórmulas en Excel
Funciones de Excel (por categoría)
Operador Operador
Más información sobre las fórmulas, celdas
e intervalos
Operador Operador
Más información sobre las fórmulas, celdas
Funciones de Excel (orden alfabético)
Aprendizaje gratuito de Excel en línea
e intervalos =A1+B1 =10+20
Referencia Referencia
Excel se compone de celdas individuales que se agrupan en filas y columnas. Las Constante
de celda de celda
filas están numeradas y las columnas tienen letras. Hay más de 1 millón de filas y
16000 columnas, y se pueden incluir fórmulas en cualquiera de ellas.

Las fórmulas pueden contener referencias a celdas, referencias a intervalos de


Función Argumento
celdas, operadores y constantes. Estos son algunos ejemplos de fórmulas:

=A1+B1
=10+20
=SUMA(A1:A10)
=SUMA(A1:A10)
Un intervalo de celdas contiene una celda inicial, dos
Observará que en el tercer ejemplo anterior, usamos la función SUMA. Una función puntos y una celda final. Al seleccionar un intervalo de
es un comando predefinido que toma valores, los calcula de alguna forma y devuelve celdas de una fórmula, Excel agrega automáticamente los
dos puntos.
un resultado. Por ejemplo, la función SUMA toma las referencias de celda o intervalos
que especifique y los suma. En este ejemplo toma las celdas A1 a A10 y las suma.
Excel tiene más de 400 funciones que puede explorar en la pestaña Fórmulas.

Las fórmulas con funciones empiezan con un signo igual, seguido del nombre de la
función con los argumentos (los valores que usa una función para calcular) entre Función Argumento
paréntesis.

Para confirmar una fórmula, presione ENTRAR. Cuando lo haga la fórmula se


calculará y el resultado se mostrará en la celda. Para ver la propia fórmula, puede ver
=SUMA(A1:A10;C1
la barra de fórmulas debajo de la cinta de opciones, o presionar F2 para entrar en el Un intervalo de celdas
Modo de edición, donde verá la fórmula en la celda. Presione ENTRAR de nuevo
para finalizar la fórmula y calcular el resultado.
Paréntesis de apertura

Anterior Siguiente
Anterior Siguiente

Más información en la Web


Usar Excel como una calculadora

Información general sobre fórmulas en Excel

Funciones de Excel (por categoría)

Funciones de Excel (por orden alfabético) 

Aprendizaje gratuito de Excel en línea


Fórmulas: Respuestas:
3
-1
2
0.5
1
a celda F7, escriba =C3^C4.
CRÉDITO
ADICIONAL
Puede elevar un valor a una
potenciaincluir
de filas y 16000 columnas, y se pueden mediante el en cualquiera de ellas.
fórmulas
operador exponencial (^), por
ejemplo =C3^C4. Puede
escribirlo
orma y devuelve un resultado. Por ejemplo,conlaMayús+^.
función SUMA toma las referencias de celda o intervalos que especifique y los suma. En este ejemplo toma las celdas A1 a A10 y las suma. Excel
ular) entre paréntesis.

0 es el intervalo de celdas de la función.


y A1:A10;C1:C10 son los intervalos de celdas de la función separados por una coma.

INFORMACIÓN ÚTIL
Operador Las constantes son valores que especifica en las celdas o
fórmulas. Mientras que =10+20 puede calcular lo mismo
que =A1+B1, no se recomienda usar constantes. ¿Por qué?
Porque no puede ver fácilmente la constante sin seleccionar
la celda y buscarla. Eso puede dificultar cambiarla más
adelante. Es mucho más fácil colocar las constantes en
INFORMACIÓN ÚTIL
Operador Las constantes son valores que especifica en las celdas o
fórmulas. Mientras que =10+20 puede calcular lo mismo

=10+20 que =A1+B1, no se recomienda usar constantes. ¿Por qué?


Porque no puede ver fácilmente la constante sin seleccionar
la celda y buscarla. Eso puede dificultar cambiarla más
adelante. Es mucho más fácil colocar las constantes en
celdas, donde pueden ajustarse fácilmente, y hacer
Constante Constante referencia a ellas en las fórmulas.

Por ejemplo: Seleccione la celda amarilla con 12 a


continuación. Verá que usamos la función SUMA con un
intervalo de celdas. No escriba "4" o "8" directamente en la
fórmula.

A10) Valores
4
na celda inicial, dos
onar un intervalo de 8
automáticamente los 12

El punto y coma separa varios argumentos

Argumento

A10;C1:C10)
rvalo de celdas Otro intervalo de celdas

ra Paréntesis de cierre. Excel normalmente lo agregará


automáticamente cuando presione ENTRAR.
das A1 a A10 y las suma. Excel tiene más de 400 funciones que puede explorar en la pestaña Fórmulas.
Aunque es el
seleccione
intervalocolocar
posible con
el mouse en
números y
presione
una fórmula
ENTRAR.
de este modo,
Esto
sumará
no es los
valores de las
recomendable
aceldas
menos D3,que
D4,
D5 y D6. La
sea
respuesta
Introducción a las funciones
absolutamente
Introducción a las funciones
debería serEsto
necesario.
Las funciones le permiten hacer varias tareas, como realizar operaciones matemáticas, buscar valores o incluso calcu Fruta Importe
170.
se conoce
como
Ahora una vamos a probar Autosuma. Seleccione la celda en la columna de Carne (celda G7) y vaya a Fórmulas > AutosumaManzanas > seleccione SUMA. Verá que50Excel escribe automáticamen
constanteLas y esfunciones le permiten hacer varias tareas, como realizar operaciones matemáticas, Naranjas 20 etc. Insertar función le
Vaya a la pestaña Fórmulas y examine la Biblioteca de funciones, donde se muestran las funciones por categorías, como Texto, Fecha y hora,
fácil olvidar
Este buscar
métodovalores
es unahí.
que está o incluso
abreviado calcular
de teclado muy fechas y horas.laProbemos
útil. Seleccione celda D15,varias formas
después de sumar
presione Alt = y luego ENTRAR. S Plátanos 60
En
Vayacambio,
Cuando hacia valores
se para
empiece
abajo con la función
a escribir
obtenerun SUMA.
nombre
más de función después de presionar =, Excel abrirá IntelliSense, que mostrará
detalles. todas las funciones empezando
Limones 40 con las letras que
CRÉDITO ADICIONAL
recomienda
Pruebe la función CONTAR con cualquiera de los métodos que ya probó. La función CONTAR cuenta el número de celdas SUMA
de un> rango que contienen170 números.
hacer
Siguiente
referencia a 1
paso En la columna de Cantidad de Fruta (celda D7), escriba =SUMA(D3:D6), o
otra
Más celda,
información sobreescriba =SUMA(, después seleccione el intervalo con el mouse y presione
funciones Elemento Importe
como la celda
Ahora ENTRAR. Esto sumará los valores de las celdas D3, D4, D5 y D6. La respuesta
Devamos
Si la función
F51. a verpudiese
esta SUMA la anatomía
debería serhablar,de algunas funciones. La función SUMA está estructurada así: Pan 50
170.diría que devuelve la suma de todos los valores de las celdas D38 a D41 y toda la columna H. SUMA es el nombre de la función, D38:D41 es el p
forma, se ve Donuts 100
fácilmente
La función y devuelve la fecha actual. Cuando Excel vuelva a calcular se actualizará automáticamente.
HOY Galletas 40
MIRE oculta 2
no se ESTO Ahora vamos a probar Autosuma. Seleccione la celda amarilla en la
Seleccione
dentro de una estas celdas.
columnaDespués, en la (celda
de Carne esquinaG7)
inferior derecha
y vaya de la ventana
a Fórmulas de Excel,>busque
> Autosuma SUMAR: 170 en la barra
seleccione Pasteles
de la parte inferior. Esa es la50
Barra de estado y es otra man
fórmula. SUMA. Verá que Excel escribe automáticamente la fórmula. Presione Tartas 20
Más información en la Web para confirmar. La característica Autosuma tiene todas las
ENTRAR SUMA >
Todo sobre la función SUMA
funciones más comunes.
Usar Autosuma para sumar números
Todo sobre la3función CONTAR
Este es un método abreviado de teclado muy útil. Seleccione la celda D15,
Aprendizaje gratuito de Excel en línea
después presione A l t y luego = ENTRAR. SUMA se introducirá
Volver al principio
automáticamente.
Siguiente paso

Vaya hacia abajo para obtener más detalles. Siguiente paso

Más información sobre funciones


Más información sobre funciones
Vaya a la pestaña Fórmulas y examine la Biblioteca de funciones, donde se
muestran las funciones por categorías, como Texto, Fecha y hora, etc. Insertar
funciónle permitirá buscar funciones por nombre y abrir a un asistente de funciones
que puede ayudarle a crear la fórmula. Fruta Importe
Manzanas 50
Cuando empiece a escribir un nombre de función después de presionar =, Excel Naranjas 20
abrirá IntelliSense, que mostrará todas las funciones empezando con las letras que Plátanos 60
escriba. Cuando encuentre la que desee, presione la tecla Tab y Excel completará Limones 40
automáticamente el nombre de la función y escribirá el paréntesis de apertura. SUMA > 170
También mostrará los argumentos necesarios y opcionales.

Elemento Importe
Ahora vamos a ver la anatomía de algunas funciones. La función SUMA está Automóviles 20
estructurada así: Camiones 10
Bicicletas 10
El nombre de El primer Argumentos Patines 40
función. argumento. adicionales,
Es obligatorio separado por
casi siempre. comas (,). Total:
180

=SUMA(D38:D41;H:H) DETALLE IMPORTANTE


Haga doble clic en esta celda. Verá el 100 hacia el fin
Si la función SUMA pudiese hablar, diría “Devuelve la suma de todos los valores en Aunque es posible colocar números en una fórmula
este modo, no es recomendable a menos que sea
las celdas D38 a D41 y de toda la columna H”. absolutamente necesario. Esto se conoce como una
constante y es fácil olvidar que está ahí. En cambio, s
Ahora, vamos a probar una que no necesita argumentos. recomienda hacer referencia a otra celda, como la ce
F51. De esta forma, se ve fácilmente y no se oculta
dentro de una fórmula.
La función HOY devuelve la fecha actual. Cuando Excel
vuelva a calcular se actualizará automáticamente.
constante y es fácil olvidar que está ahí. En cambio, s
recomienda hacer referencia a otra celda, como la ce
F51. De esta forma, se ve fácilmente y no se oculta
dentro de una fórmula.
La función HOY devuelve la fecha actual. Cuando Excel
vuelva a calcular se actualizará automáticamente.

=HOY()

Más información en la Web


Todo sobre la función SUMA

Usar Autosuma para sumar números

Todo sobre la función CONTAR

Aprendizaje gratuito de Excel en línea

Volver al principio Siguiente paso

Aprendizaje gratuito de Excel en línea


Vuelva al principio presionando CTRL+Inicio. Para continuar con el paso siguiente, presione CTRL+AVANZAR PÁGINA.
Carnicería Importe
Ternera 50
Pollo 30
Cerdo 10
Pescado 50
SUMA >

Elemento Importe
Pan 50
Donuts 100
Galletas 40
Pasteles 50
Tartas 20
CONTAR >

CRÉDITO ADICIONAL
Pruebe la función CONTAR con
cualquiera de los métodos que ya
probó. La función CONTAR cuenta el
número de celdas de un rango que
contienen números.
MIRE ESTO
Seleccione estas celdas. Después, en la
esquina inferior derecha de la ventana de
Excel, busque esto:

Esa es la Barra de estado y es otra manera


de encontrar rápidamente un total y otros
detalles sobre una celda o intervalo
seleccionado.

Valor adicional Nuevo total


100 180

MPORTANTE
en esta celda. Verá el 100 hacia el final.
ble colocar números en una fórmula de
es recomendable a menos que sea
necesario. Esto se conoce como una
ácil olvidar que está ahí. En cambio, se
er referencia a otra celda, como la celda
ma, se ve fácilmente y no se oculta
órmula.
ácil olvidar que está ahí. En cambio, se
er referencia a otra celda, como la celda
ma, se ve fácilmente y no se oculta
órmula.
CRÉDITO
ADICIONAL
Pruebe a usar
MIRE ESTOo
MEDIANA
Seleccione
MODO aquí.
cualquier
intervalo
Función de
MEDIANA le
PROMEDIO
después
valor
Función PROMEDIO
números y el
proporciona
mire
Use lacentral
la barra función
de PROMEDIO para obtener el promedio de números en un intervalo de celdas. Fruta Importe
de un conjunto
Seleccione
estado
de datos, Use la función
para la celda D7 yPROMEDIO
después usepara obtener elpara
el Autosuma promedio deuna
agregar números enPROMEDIO.
función un intervalo de Manzanas 50
obtener
mientras unceldas. la celda G7 y escriba una función PROMEDIO escribiendo =PROMEDIO(G3:G6).
que
Ahora seleccione Naranjas 20
promedio
MODO le
En la celda D15,
instantáneo.
proporciona la puede usar Autosuma o escribir para introducir otra función PROMEDIO. Plátanos 60
opción que se 1 Seleccione la celda D7 y después use Autosuma para agregar una función Limones 40
produce con PROMEDIO.
Activar a la hoja anterior PROMEDIO >
más
Ir a la siguiente hoja
frecuencia.
Elemento Importe
Vínculos para 2 obtener
Ahora seleccione la celda G7 y escriba una función PROMEDIO escribiendo
más información en la Web Pan 50
=PROMEDIO(G3:G6).
Seleccione esta opción para obtener información en la Web sobre la función PROMEDIO Donuts 100
Seleccione esta opción para obtener información en la Web sobre la función MEDIANA Galletas 40
3 Enpara
Seleccione esta opción la celda D15,
obtener puede usar
información en laAutosuma
Web sobre laofunción
escribir para introducir otra
MODO Pasteles 50
función
Seleccione esta opción PROMEDIO.
para obtener información en la Web sobre el aprendizaje gratuito de Excel. Tartas 20
PROMEDIO >

Anterior
Anterior Siguiente
Siguiente

Más información en la Web


Todo sobre la función PROMEDIO

Todo sobre la función MEDIANA

Todo sobre la función MODO

Aprendizaje gratuito de Excel en línea Más información sobre la función SUMA


Aprendizaje gratuito de Excel en línea
En algunas de las sugerencias anteriores, le mostramos cóm
De la celda C37 a la D41 hay datos con dos columnas: Fruta
La fórmula de la celda D42 es =SUMA(D38:D41).
Si la función SUMA en la celda D42 pudiera hablar, diría: Sum
Esta es otra forma para usarla:
De la celda C47 a la D48 hay datos con dos columnas: Eleme

Más información en la Web


Todo sobre la función SUMA
Todo sobre la función SUMAR.SI
Usar Excel como calculadora
Aprendizaje gratuito de Excel en línea
Vuelva al principio presionando CTRL+Inicio. Para continuar
Carnicería Importe
Ternera 50 MIRE ESTO
Seleccione cualquier intervalo
Pollo 30 de números y después mire la
Cerdo 10 barra de estado para obtener un
Pescado 50 Promedio instantáneo.
PROMEDIO >

Elemento Importe
Pan 50
Donuts 100
Galletas 40
Pasteles 50
Tartas 20

CRÉDITO ADICIONAL
Pruebe a usar MEDIANA o
MODO aquí.
MEDIANA le proporciona el valor
central de un conjunto de datos,
mientras que MODO le
proporciona la opción que se
produce con más frecuencia.

la función SUMA
encias anteriores, le mostramos cómo usar la función SUMA. Aquí encontrará más información.
1 hay datos con dos columnas: Fruta y Cantidad.
D42 es =SUMA(D38:D41).
a celda D42 pudiera hablar, diría: Sume los valores en las celdas D38, D39, D40 y D41.

8 hay datos con dos columnas: Elemento y Cantidad.

Excel en línea
onando CTRL+Inicio. Para continuar con el paso siguiente, presione CTRL+AVANZAR PÁGINA.
INFORMACIÓN
ÚTIL
Puede usar MIN
o MAX con
varios intervalos
Seleccione
o valores para la
celda D7 y
Funciones MIN y MAX
mostrar
Ahora el
después
En la celdauseD15,
el
seleccione
mayor
Funcioneso menor
la
MIN y MAX
puede
Asistenteusarde el
celda
de los G7
valores,
y Fruta Importe
Asistente
Use
Autosuma de
la función
paraMIN para obtener el número mínimo de un rango de celdas.
como
escriba una
Autosuma
agregar unao
UseMAX la función MINelpara obtener el de
número más pequeño de un rango de celdas. Manzanas 50
=MIN(A1:A10;B
Use
función
la función
MAX para obtener número máximo un rango de celdas.
escribir
función para
MIN.
1:B10) o Use la función MAX para obtener el número más pequeño de un rango de celdas.
escribiendo Naranjas 20
introducir
=MAX(A1:A10;B una
=MAX(D3:D6).
función
Másdonde B1 o
1), MIN Plátanos 60
MAX.
contiene un en
información
valor
la Web 1
de umbral, Seleccione la celda D7 y después use el Asistente de Autosuma para Limones 40
como 10, en agregar una función MIN. MIN >
cuyo caso la
Todo sobre
fórmula no la función MIN
devolverá
Todo sobreun2 Ahora seleccione la celda G7 y escriba una función MAX escribiendo
la función MAX Elemento Importe
resultado =MAX(D3:D6).
Aprendizaje
menor que 10. gratuito de Excel en línea Pan 50
Donuts 100
3 En la celda D15, puede usar el Asistente de Autosuma o escribir para
Galletas 40
introducir una función MIN o MAX.
Pasteles 50
Tartas 20
MIN o MAX >
Anterior Siguiente

INFORMACIÓN ÚTIL
Puede usar MIN o MAX con varios interv
Más información en la Web
Puede utilizar cualquiera MIN o MAX con varios intervalos o valores para mostrar el mayor o menor de los valores, como =MIN(A1:A10;B1:B10) o =MAX(A1:A10;10).
valores para mostrar el mayor o menor d
valores, como =MIN(A1:A10;B1:B10) o
Más información en la Web =MAX(A1:A10;B1), donde B1 contiene un
umbral, como 10, en cuyo caso la fórmul
Todo sobre la función Todo
MIN sobre la función MIN devolverá un resultado menor que 10.
Todo sobre la función MAX
Todo sobre la función MAX
Usar Excel como calculadora
Aprendizaje gratuito de Excel en línea
Aprendizaje gratuito de Excel en línea
Carnicería Importe
Ternera 50
Pollo 30
Cerdo 10
Pescado 50
MAX >

Elemento Importe
Pan 50
Donuts 100
Galletas 40
Pasteles 50
Tartas 20
10

FORMACIÓN ÚTIL
de usar MIN o MAX con varios intervalos o
res para mostrar el mayor o menor de los
res, como =MIN(A1:A10;B1:B10) o
AX(A1:A10;B1), donde B1 contiene un valor de
bral, como 10, en cuyo caso la fórmula no
olverá un resultado menor que 10.
que Excel
de
una un díaun y
persona
muestre
basándose
después en
resta
número
los
el minutos.
tiempo que
negativo
Así,
utilizó para
porque aún no
01/01/2017
comer. El *24
ha escrito su
12:30
al final sede la
cumpleaños,
En la celda
almacena
fórmula
puede
D28, escriba usar
como
convierte laloSI
una
=AHORA(), función
42736.5208.
parte Si
así:
Funciones de fecha
que
la le
hora dará
o la
fecha
fraccionaria
Funciones de
=SI(D7="";"";D
hora
aparecen actual y fecha
del
7-D6),
Excel día que
que
puede proporcionarle la fecha actual, según la configuración regional de su equipo. También puede agregar y restar fechas.
se
como actualizará
números
Excel
dice ve
"SI en
D7 es
cada
como vez
ese, que
horas.
igual
Consulte Sin
acalcule.
nada,
laExcel
función HOY, que proporciona la fecha de hoy. Estas son funciones dinámicas o volátiles, por lo que, al abrir el libro mañana, tendrá la fecha de mañana. En la celda D6
Excel
puede
embargo,
entonces debe puede proporcionarle la fecha actual, según la configuración regional de su
no
Si
Restar
dar necesita
presionar Ctrla escriba su siguiente cumpleaños en formato DD/MM/AA en la celda D7 y vea cómo Excel le indica cuántos días faltan usando =D7-D6 en la celda D8.
fechas:
formato
muestres
+cambiar
1 > Númeroelequipo. También puede agregar y restar fechas.
la celda
Agregar
nada; en como
fechas:
caso supongamos que desea saber en qué fecha vence una factura, o cuándo tiene que devolver un libro de la biblioteca. Puede agregar días a una fecha para obtener
formato
ynúmero.
seleccionar de
contrario, Para Funciones de fecha
hora, puede ir
un
ello, formato
muestra
afecha vaya
CTRL+1 D7a de
> 1 Consulte la función HOY, que proporciona la fecha de hoy. Estas son
Inicio
menos >uD6".
hora.
funciones dinámicas o volátiles, por lo que, al abrir el libro mañana, tendrá
Fecha de hoy:
Número >>
Formato Su cumpleaños:
Hora
Celdas > (Ctrl+1)
y la fecha de mañana. , escriba =HOY().
seleccionar
Funciones el hora
>formato
Número
Excel puede >deproporcionarle la hora actual, según la configuración regional de su equipo. También puede agregar y restarDías hastaPor
horas. su ejemplo,
cumpleaños: 0 un seguim
es posible que deba realizar
que
Número >2
desee.
decimales. 2 Restar fechas: escriba su siguiente cumpleaños en formato DD/MM/AA en
Días del período de gracia:
la celda D7 y vea cómo Excel le indica cuántos días faltan usando =D7-D6
La factura vence el: 30/12/99
en la celda D8.
Si esta fórmula pudiese hablar, diría "Tome la hora de salida y réstela de la hora de entrada, después reste las horas del almuerzo y multiplique el resultado por 24 para convertir la
Anterior
Siguiente 3 Agregar fechas: supongamos que desea saber la fecha de vencimiento de INFORMACIÓN ÚTIL
una factura, o cuándo tiene que devolver un libro de la biblioteca. Puede Excel mantiene fechas y horas en función del númer
Más información en la Web
agregar días a una fecha para obtener la información. En la celda D10, días desde el 1 de enero de 1900. Las horas se conse
Todo sobre la función HOY en partes fraccionarias de un día basándose en los
escriba un número de días aleatorio. En la celda D11, hemos agregado minutos. Así, 01/01/2017 12:30 se almacena como
Todo sobre la función AHORA
=D6+D10 para calcular la fecha de vencimiento a partir de la fecha actual. 42736.5208. Si la hora o fecha aparecen como núme
Todo sobre la función FECHA como ese, puede presionar Ctrl+1 > Número > y
Aprendizaje gratuito de Excel en línea seleccionar un formato de Fecha u Hora.

Funciones de hora
Excel puede proporcionarle la hora actual, según la configuración regional de su
equipo. También puede agregar y restar horas. Por ejemplo, es posible que deba
realizar un seguimiento de cuántas horas trabajó un empleado cada semana y Funciones de hora
calcular su paga y las horas extra.
Excel puede proporcionarle la hora actual, según la configuración regional de su
equipo. También puede agregar y restar horas. Por ejemplo, es posible que deba
realizar un seguimiento de cuántas horas trabajó un empleado cada semana y
calcular su paga y las horas extra. Hora actual:

1 En la celda D28, escriba =AHORA(), lo que le dará la hora actual y se


actualizará cada vez que Excel calcule. Si necesita cambiar el formato de Horas diarias trabajadas
hora, puede ir a Ctrl+1 > Número > Hora > y seleccionar el formato que Hora de entrada: 8:00
desee. Fin del almuerzo: 12:00
Inicio del almuerzo: 13:00
2 Sumar horas entre intervalos de tiempo: en la celda D36 hemos escrito Hora de salida: 17:00
=((D35-D32)-(D34-D33))*24, que calcula la hora de inicio y finalización
Total de horas: 8
de una persona y después resta el tiempo que utilizó para comer. El *24 al
final de la fórmula convierte la parte fraccionaria del día que Excel ve en
horas. Sin embargo, debe dar formato a la celda como número. Para ello,
vaya a Inicio > Formato > Celdas (Ctrl+1) > Número > Número > 2
decimales.

3 Si esta fórmula pudiese hablar, diría "Tome la hora de salida y réstela de la


hora de entrada, después reste las horas de comida y multiplique el
resultado por 24 para convertir las fracciones de Excel en horas", o
=((Hora de entrada - Hora de salida)-(Inicio del almuerzo - Fin del Fecha y hora estáticas
almuerzo))*24. Fecha: 27/09/17
*24 para convertir Hora: 8:52
fracciones de Excel a un
Hora de salida Fin del almuerzo día laboral

INFORMACIÓN ÚTIL
=((D35-D32)-(D34-D33))*24 Puede usar métodos abreviados de teclado para
escribir las fechas y horas que no cambian
continuamente:
Hora de entrada Inicio del almuerzo Fecha: Ctrl+;
Hora: Ctrl+Mayús+:

Los paréntesis interiores () aseguran que Excel calcula las partes


de la fórmula por sí mismas. Los paréntesis externos aseguran que
Excel multiplica el resultado final interno por 24.
Los paréntesis interiores () aseguran que Excel calcula las partes
de la fórmula por sí mismas. Los paréntesis externos aseguran que
Excel multiplica el resultado final interno por 24.

Anterior Siguiente

Más información en la Web


Todo sobre la función HOY

Todo sobre la función AHORA

Todo sobre la función FECHA

Aprendizaje gratuito de Excel en línea


mañana. En la celda D6, escriba =HOY().

DETALLE IMPORTANTE
e deba realizar un seguimiento
Si no de cuántas
desea horasmuestre
que Excel trabajó un
un empleado cada semana y calcular su paga y las horas extra.
número negativo
porque aún no ha escrito su cumpleaños, puede usar una
función SI así: =SI(D7="";"";D7-D6), que dice "SI D7 es
igual a nada, entonces muestra nada; en caso contrario,
muestra D7 menos D6".
por 24 para convertir las fracciones de Excel en horas", o =((Hora de entrada - Hora de salida)-(Inicio del almuerzo - Fin del almuerzo))*24.

L
as en función del número de
1900. Las horas se conservan
n día basándose en los
:30 se almacena como
ha aparecen como números
Ctrl+1 > Número > y
echa u Hora.
eclado para
mbian
ello, usaremos
comillas para
crear una
nueva cadena
de texto. Esta
vez, escriba
=D3&";
VALE LA"&C3. PENA
La parte &";
EXPLORAR
"&
Si nonos sabe qué
permite
En la celdaunir
Unir texto en celdas diferentes
formato de
Unir
MIRE
una
Hay coma
C36,
código texto
ESTO
escriba
muchas
usar,yenun
celdas diferentes
ocasiones usando Excel en las que querrá combinar texto en celdas diferentes. Un ejemplo muy común es que puede tener nombres y apellidos, y desea combinarlos
Las
=C28&"
puede fórmulas,
espacio con
usar el Nombre Apellidos
En la celda
especialmente
texto en E3, escriba =D3&C3 para unir el nombre y los apellidos.
C37, > las
"&TEXTO(D28;
Ctrl+1 escriba Marina Rodríguez
las grandes,
celdas.
"DD/MM/AAA
Número para
=C29&"
pueden Hay muchas ocasiones usando Excel en las que querrá combinar texto en celdas
A").
dar
Para crear el anombre completo, se deberán unir el nombre y los apellidos, pero usar un espacio sin una coma. En F3, escriba =C3&" "&D3. Espinosa
formato
"&TEXTO(D29;
Carlos
resultar
DD/MM/AAAA
cualquier diferentes. Un ejemplo muy común es que puede tener nombres y apellidos, y desea Ene Palacios
"H:MM").
difíciles de
es el
celda
H:MM código
como
es el de
combinarlos como nombre, apellidos o nombre completo. Afortunadamente, Excel
Vaya
leer,
formato hacia
pero paraabajo para obtener más detalles. María Gómez
desee.
formato denos permite hacerlo con el signo Y comercial (&) que puede escribir con Mayús+6.
puede
Siguiente
el
Después dividir Esteban Torres
código
los de para
elementos
día/mes/año,
seleccione
Usar texto
Horas:Minutos la
y números juntos Óscar Valentín
con
por
opción espacios
ejemplo
,así:
por
Mire ejemplo
las celdas
25/09/2017.
Personalizado.
13:30.
1 C28:D29.
En la celda
¿PuedeE3,ver
escriba
que la =D3&C3 paraestán
fecha y la hora unir el
ennombre y los apellidos.Puede combinarlos con el Íker
celdas independientes? símbolo &, como seValladares
muestra en las celdas C32:C33, pero no
Puede copiar Irene Robledo
=C28
el código& " "de&
TEXTO(D28;"D
formato que2 Sin embargo RodríguezMarina no parece correcto. Es necesario agregar
D/MM/AAAA")
se muestra a la una coma y un espacio. Para ello, usaremos comillas para crear una nueva
fórmula.
cadena de texto. Esta vez, escriba =D3&"; "&C3. La parte &"; "& nos
Más información en la Web
permite unir una coma y un espacio con el texto en las celdas.
Todo sobre la función TEXTO
Combinar texto y números
3 Para
Aprendizaje gratuito crearen
de Excel el línea
nombre completo, se deberán unir el nombre y los apellidos,
pero usar un espacio sin una coma. En F3, escriba =C3&" "&D3.

Vaya hacia abajo para obtener más detalles. Siguiente

Usar texto y números juntos


Usar texto y números
Ahora, usaremos el & para unir texto y números, no solo texto y texto Fecha de hoy: 06/05/18
Hora actual: 12:56
Mire las celdas C28:D29. ¿Puede ver que la fecha y la hora están en celdas
independientes? ¿Puede combinarlos con el símbolo &, como se muestra en las
celdas C32:C33, pero no tiene un buen aspecto, no es así? Desafortunadamente, Excel
no sabe cómo desea dar formato a los números, por lo que los divide a su formato
Ahora, usaremos el & para unir texto y números, no solo texto y texto

Mire las celdas C28:D29. ¿Puede ver que la fecha y la hora están en celdas
independientes? ¿Puede combinarlos con el símbolo &, como se muestra en las Unir texto y números
celdas C32:C33, pero no tiene un buen aspecto, no es así? Desafortunadamente, Excel Fecha de hoy: 43226
no sabe cómo desea dar formato a los números, por lo que los divide a su formato Hora actual: 43226.5389898378
más básico, que es la fecha de la serie en este caso. Es necesario que indiquemos
explícitamente a Excel cómo dar formato a la parte del número de la fórmula, para Dar formato a texto y números
que lo muestre como desea en la cadena de texto resultante. Puede hacerlo con la Fecha de hoy: 02/21/Sunday
función TEXTO y un código de formato. Hora actual: 12:56

1 En la celda C36, escriba =C28&" "&TEXTO(D28;"DD/MM/AAAA").


DD/MM/AAAA es el código de formato para el día/mes/año, por ejemplo
25/09/2017.

VALE LA PENA EXPLORAR


2 En la celda C37, escriba =C29&" "&TEXTO(D29;"H:MM"). H:MM es el Si no sabe qué formato de código usar, puede usar
formato de código de para Horas:Minutos, por ejemplo 13:30. Ctrl+1 > Número para dar formato a cualquier celda
como desee. Después seleccione la opción
Personalizada. Puede copiar el código de formato que
se muestra a la fórmula.
Anterior Siguiente

Más información en la Web


Todo sobre la función TEXTO

Combinar texto y números

Aprendizaje gratuito de Excel en línea


Apellidos, nombre Nombre completo
Rodríguez; Marina Marina Rodríguez
MIRE ESTO
Las fórmulas, especialmente las grandes,
pueden resultar difíciles de leer, pero puede
dividir los elementos con espacios así:

=C28 & " " & TEXTO(D28;"DD/MM/AAAA")

XPLORAR
e código usar, puede usar
r formato a cualquier celda
eccione la opción
piar el código de formato que
A
automáticame
ejemplo
impuesto
pondrá en
continuación,
nte. Silas
consultando
sobre
mayúscula es así, la
hemos
presione
fórmula enla la
ventas
automáticame
agregado como una
tecla
celda
un
nte. Los para
Tab
rango D12. con
instrucción
SUGERENCIA
escribirla.
Preparamos SI
Esto
nombre
En
números
para
Copie
DEL laEXPERTO
celda
calcular
desde con
no D9la
es
escriba
tienen un
=SI(C12<100;"
un valor rango
que de
los
celda
Los
con
Menor gastos
rangosD9
nombre que de
hasta
con
y
0,0825.
=SI(C9="Manz
estar
envío
la
nombre D10. entre
si La
es
Aquí la
lo
100";"Mayor
fórmula
ana";VERDADE
comillas. ElEno
indica
necesario.
respuesta
permiten
introducimos
igual
que,
RO;FALSO).
texto
la
debería
definirceldasianormal,
100").
la celda
F35
ser La
desde
Instrucciones SI
¿Qué
E33
respuesta es
como Síporque ocurre
ooNoasiSI
igual
Instrucciones
verá
FALSO
términos
Fórmulas
escribe
Sí,
correcta
tiene multiplica
=SI(E35="Sí";S
una
valores que
naranja
un
en es>estar
unnola
Las
Definir
número
celda instrucciones
verdadero.
entre F31 mayor
comillas por SI le permiten realizar comparaciones lógicas entre las condiciones. Por lo general, una instrucción SI indica que, si una condición es verdadera, se realizará una a
UM(D28:D29)*
es
solo
nombre.
o una
iguallugar a 100y
el
como impuesto
1.25;0). pasa
manzana.
después
Ahora,
en
sobre
aquí: la celda siEsto
las
volver
aindica
usarlos
quiere
C12? "Si Las
la instrucciones SI le permiten realizar comparaciones lógicas entre las condiciones.
en
cambiar
ventas,
=SI(C3="Manz
celda
todo un E35de lo
es
libro.
los gastos Por
contrario,
ana";"Sí";"No" de lo general, una instrucción SI indica que, si una condición es verdadera, se
igual
Puede
envío, a solo
Sí,
ver
devuelve
)todos los
realiza realizará una acción, en caso contrario, se realizará otra. Las fórmulas pueden
0.
la suma
tiene que
de
rangos
Vaya la
realizar columna
haciacon devolver
abajo para texto, valores
obtener másodetalles.
incluso más cálculos.
Pruebe
Cantidad
nombre alade
de la
acción
Siguiente
cambiar enSíun y Instrucciones SI
tabla
este
lugar yanterior
libro puede
No en
yInstrucción la celda SI conSIotra función
multiplícalo
haciendo
Las
usar instrucciones
el nombre clic pueden forzar cálculos adicionales que se deben realizar si se cumple una condición. Aquí vamos aManzana
evaluar una celda para ver si deben aplicarse impuestos sob
E33
por
en
de
cómo
para
1,25,
Fórmulas
envío cambia
ver
de
en 1
lo
> En la celda D9 escriba= =SI(C9="Manzana";VERDADERO;FALSO). La Naranja
contrario,
Administrador
cualquier lugar respuesta correcta es VERDADERO.
el
de cálculo.
devuelve
nombres. 0".
del libro.
Haga clic aquí 50
para obtener
INFORMACIÓN
más 2 ÚTILCopie desde la celda D9 hasta la D10. Aquí la respuesta debería ser FALSO
Al crear una fórmula,
información. porque una naranja
Excel colocará no es una manzana.
automáticamente bordes de colores alrededor de los intervalos a los que hace referencia la fórmula y los intervalos correspondientes en la fór
DETALLE IMPORTANTE
Anterior VERDADERO y FALSO son, a diferencia de otra
Siguiente
3 Pruebe otro ejemplo consultando la fórmula en la celda D12. Preparamos palabras en Excel, fórmulas en el sentido de qu
=SI(C12<100;"Menor que 100";"Mayor o igual a 100"). ¿Qué ocurre si tienen que estar entre comillas y Excel las pon
Más información enescribe
la Webun número mayor o igual a 100 en la celda C12? mayúscula automáticamente. Los números no
Todo sobre la función SI que estar entre comillas. El texto normal, com
No, tiene que estar entre comillas como, por e
Todo sobre la función SI.CONJUNTO en el siguiente caso:
Instrucciones SI avanzadas =SI(C3="Manzana","Sí","No")
Aprendizaje Vaya hacia
gratuito abajo
de Excel para obtener más detalles.
en línea Siguiente

Instrucción SI con otra función Elemento


Widget
Doohickey
Las instrucciones SI pueden forzar cálculos adicionales que se deben realizar si se
cumple una condición. Aquí vamos a evaluar una celda para ver si deben aplicarse
impuestos sobre las ventas y calcular si la condición es verdadera.
Las instrucciones SI pueden forzar cálculos adicionales que se deben realizar si se
cumple una condición. Aquí vamos a evaluar una celda para ver si deben aplicarse
impuestos sobre las ventas y calcular si la condición es verdadera.

1 En la celda F33, hemos escrito


=SI(E33="Sí";F31*Impuesto_sobre_las_ventas;0), donde se configura el
impuesto sobre las ventas como un rango con nombre con un valor de
0,0825. La fórmula indica que, si la celda E33 es igual a Sí, multiplica la
celda F31 por el impuesto sobre las ventas, de lo contrario, devuelve 0.

Pruebe a cambiar Sí y No en la celda E33 para ver cómo cambia el cálculo.

2 A continuación, hemos agregado una instrucción SI para calcular los gastos


de envío si es necesario. En la celda F35 verá
SUGERENCIA DEL EXPERTO
=SI(E35="Sí";SUM(D28:D29)*1.25;0). Esto indica "Si la celda E35 es igual Los rangos con nombre permiten definir términos o
a Sí, realiza la suma de la columna Cantidad de la tabla anterior y valores en un solo lugar y después volver a usarlos en
multiplícalo por 1,25, de lo contrario, devuelve 0". todo un libro. Puede ver todos los rangos con nombre d
este libro haciendo clic en Fórmulas > Administrador de
nombres. Haga clic aquí para obtener más información.
3 Después, cambie el 1,25 en la fórmula en la celda F35 a "Gastos de envío".
Cuando empiece a escribir, la corrección automática de Excel debería
encontrarla automáticamente. Si es así, presione la tecla Tab para escribirla.
Esto es un rango con nombre y lo introducimos desde Fórmulas >
Asignar nombre. Ahora, si quiere cambiar los gastos de envío, solo tiene
que realizar la acción en un lugar y puede usar el nombre de envío en
cualquier lugar del libro.

Anterior Siguiente

Más información en la Web


Todo sobre la función SI

Todo sobre la función SI.CONJUNTO

Instrucciones SI avanzadas

Aprendizaje gratuito de Excel en línea


ue, si una condición es verdadera, se realizará una acción, en caso contrario, se realizará otra. Las fórmulas pueden devolver texto, valores o incluso más cálculos.

Instrucciones SI

Menor que 100

fórmula y los intervalos correspondientes en la fórmula serán del mismo color. Puede ver esto si selecciona la celda F33 y presiona F2 para modificar la fórmula.
DETALLE IMPORTANTE
VERDADERO y FALSO son, a diferencia de otras
palabras en Excel, fórmulas en el sentido de que no
tienen que estar entre comillas y Excel las pondrá en
mayúscula automáticamente. Los números no tienen
que estar entre comillas. El texto normal, como Sí o
No, tiene que estar entre comillas como, por ejemplo,
en el siguiente caso:
=SI(C3="Manzana","Sí","No")

Cantidad Coste Total


2 9.76 € 19.52 €
3 3.42 € 10.26 €
Subtotal 13.18 € 29.78 €

¿Impuesto sobre las ventas? Sí 2.46 € INFORMACIÓN ÚTIL


Al crear una fórmula, Excel colocará automáticamente
bordes de colores alrededor de los intervalos a los que
¿Gastos de envío? Sí 6.25 € hace referencia la fórmula y los intervalos
correspondientes en la fórmula serán del mismo color.
Puede ver esto si selecciona la celda F33 y presiona F2
Total 38.48 € para modificar la fórmula.

GERENCIA DEL EXPERTO


angos con nombre permiten definir términos o
es en un solo lugar y después volver a usarlos en
un libro. Puede ver todos los rangos con nombre de
ibro haciendo clic en Fórmulas > Administrador de
bres. Haga clic aquí para obtener más información.
encapsularem
error #N/A,
os
En la
puedela fórmula
usar
celda
BUSCARV
una
D22,función
escriba de
existente
control
=BUSCARV(C2 deasí
en la
errores celda
2;C17:D20;2;F
D43:
denominada
ALSO). La
SI.ERROR
respuestaen la
=SI(C43="";"";
celda
correcta G43:para
BUSCARV(C43;
=SI.ERROR(BU
manzanas es
Ahora, intente
C37:D41;2;FAL
BUSCARV
SCARV(F43;F3
50. BUSCARV
hacerlo eneslauna de las funciones más utilizadas en Excel (y también una de nuestras favoritas). BUSCARV le permite buscar un valor en una columna a la izquierda, después devue
BUSCARV
SO))
BUSCARV
7:G41;2;FALSO
buscó
sección de
);"").
carnes, SI.ERROR
manzanas, en lalo
Esto
indica indica
encontró, que que
si
=BUSCARV(A1;B:C;2;FALSO)
celda
si la G22.C43
celda
BUSCARV
después fue a
BUSCARV
Debería
¿Qué
es igual
devuelve
la desea
columna a un buscar? es una de las funciones más utilizadas en Excel (y también una de nuestras
nada
de
obtener
(""), elfavoritas). BUSCARV le permite buscar un valor en una columna a la izquierda,
devuelve
resultado
Si
la lo encuentra,
derecha
resultado y ¿a cuántas columnas a la derecha desea que aparezca un valor?
nada,
válido,
devolvió de lodespués devuelve información en otra columna a la derecha si encuentra a una
la
¿Dónde
=BUSCARV(F22
contrario, desea buscarlo?
mostrarlo,
cantidad. de
coincidencia. BUSCARV
;F17:G20;2;FAL
devuelve
¿Desea
lo a una
contrario, coincidencia exacta o dice:
una aproximada?
SO).
resultados de
no mostrar ¿Qué desea Si lo encuentra, ¿a cuántas
BUSCARV.
nada (""). No
Tenga en
EXPERIMENTO
se muestra buscar? columnas a la derecha desea
cuenta
Intente
nada el
seleccionar
aquí (""), que aparezca
diferentes elementos de las listas desplegables. unque
Verá valor?
las celdas de resultado se actualizan al instante con los nuevos valores.
segundo
pero también
Vaya hacia abajo para obtener más detalles.
paréntesis
puede usarde
Siguiente
cierre
números al final
(0,1,
de
2, la fórmula.
BUSCARV
etc.), o y #N/A se encontrará en una situación donde BUSCARV no puede encontrar lo que ha solicitado y devuelve un error (#N/A). A veces, es simplemente porque el valor de
Constantemente,
Cierra la
texto, como
instrucción
=BUSCARV(A1;B:C;2;FALSO)
SI.
"La fórmula
DETALLE no
IMPORTANTE
es correcta".
SI.ERROR es lo que se denomina un controlador de errores global, lo que significa que suprimirá cualquier error que pueda producir la fórmula. Esto puede provocar problemas si
Fruta Importe
¿Dónde ¿Desea a una
Una regla general es no agregar controladores de errores en las fórmulas hasta que sepa con total seguridad que funcionan Manzanas
correctamente. 50
desea coincidencia
Anterior Naranjas 20
buscarlo? exacta o una
Siguiente aproximada? Plátanos 60
Más información en la Web Limones 40
Todo sobre la función BUSCARV
1 En la INDICE
Todo sobre las funciones Y COINCIDIR
celda D22, escriba =BUSCARV(C22;C17:D20;2;FALSO). La respuesta Manzanas
Todo sobre la función SI.ERROR
correcta para manzanas es 50. BUSCARV buscó manzanas, lo encontró,
Use tablas dinámicas después fue a datos
para analizar de unade
la columna hoja
la de cálculoy devolvió la cantidad.
derecha
Aprendizaje gratuito de Excel en línea EXPERIMENTO
Intente seleccionar diferentes elementos de las listas
2 Ahora, intente hacerlo en la sección de carnes, en la celda G22. Debería desplegables. Verá que las celdas de resultado se actualizan
obtener el resultado =BUSCARV(F22;F17:G20;2;FALSO). instante con los nuevos valores.

Vaya hacia abajo para obtener más detalles. Siguiente


Vaya hacia abajo para obtener más detalles. Siguiente

BUSCARV y #N/A Si la función SUMA en la celda D42 pudiera hablar, diría: Sume los valores en las
Elemento Importe
Pan 50
Invariablemente, se encontrará en una situación donde BUSCARV no puede encontrar Donuts 100
lo que ha solicitado y devuelve un error (#N/A). A veces, es simplemente porque el Galletas 40
valor de búsqueda no existe, o puede ser porque la celda de referencia todavía no Pasteles 50
tiene un valor.
Tartas 20

1 Si sabe que el valor de búsqueda existe, pero desea ocultar el error si la celda #N/A
de la búsqueda está en blanco, puede usar una instrucción SI. En este caso,
encapsularemos la fórmula BUSCARV existente así en la celda D43:

=SI(C43="";"";BUSCARV(C43;C37:D41;2;FALSO)) DETALLE IMPORTAN


SI.ERROR es lo que se denom
Esto indica que "Si la celda C43 es igual a nada (" "), devuelve nada, de lo global, lo que significa que sup
pueda producir la fórmula. Es
contrario, devuelve resultados de BUSCARV". Tenga en cuenta el segundo Excel le da una notificación de
paréntesis de cierre al final de la fórmula. Cierra la instrucción SI. error legítimo que debe soluc

Una regla general es no agreg


2 Si no sabe con seguridad si existe el valor de búsqueda, pero desea las fórmulas hasta que sepa co
suprimir el error #N/A, puede usar una función de control de errores funcionan correctamente.
denominada SI.ERROR en la celda G43:
=SI.ERROR(BUSCARV(F43;F37:G41;2;FALSO);""). SI.ERROR indica que si
“BUSCARV devuelve un resultado válido, mostrarlo, de lo contrario, no
mostrar nada ("")”. No se muestra nada aquí (""), pero también puede usar
números (0,1, 2, etc.), o texto, como "La fórmula no es correcta".

Anterior Siguiente
Anterior Siguiente

Más información en la Web


Todo sobre la función BUSCARV

Todo sobre las funciones INDICE y COINCIDIR

Todo sobre la función SI.ERROR

Use tablas dinámicas para analizar datos de una hoja de cálculo

Aprendizaje gratuito de Excel en línea


olumna a la izquierda, después devuelve información en otra columna a la derecha si encuentra a una coincidencia. BUSCARV dice:

s, es simplemente porque el valor de búsqueda no existe, o puede ser porque la celda de referencia todavía no tiene un valor.

Carnicería Importe
Ternera 50
Pollo 30
Cerdo 10
Pescado 50

Cerdo

erentes elementos de las listas


e las celdas de resultado se actualizan al
s valores.
hablar, diría: Sume los valores en las celdas D38, D39, D40 y D41.
Elemento Importe
Pan 50
Donuts 100
Galletas 40
Pasteles 50
Tartas 20

Pastelería

DETALLE IMPORTANTE
SI.ERROR es lo que se denomina un controlador de errores
global, lo que significa que suprimirá cualquier error que
pueda producir la fórmula. Esto puede provocar problemas si
Excel le da una notificación de que la fórmula contiene un
error legítimo que debe solucionarse.

Una regla general es no agregar controladores de errores en


las fórmulas hasta que sepa con total seguridad que
funcionan correctamente.
varios
criterios. Así,
en este
ejemplo,
puede buscar
frutas y tipos,
en lugar de
solo frutas.
Seleccione la

Funciones condicionales: SUMAR.SI


celda H17 ycondicionales: SUMAR.SI
Funciones
escriba
Las funciones condicionales le permiten sumar, obtener el promedio, contar u obtener el mínimo o el máximo de un inte
=SUMAR.SI.CO Fruta Importe
NJUNTO(H3:H
SUMAR.SI le permite sumar en un intervalo según un criterio específico que busca en otro intervalo, como el número Manzanas 50
SUGERENCIA Las funciones condicionales le permiten sumar, obtener el promedio, contar u obtener
14;F3:F14;F17;
DEL EXPERTO
G3:G14;G17). 150 Naranjas 20
Cada una el
de mínimo o el máximo de un intervalo según una condición determinada o los
¿Qué intervalo desea ver?
SUMAR.SI.CON Plátanos 60
las celdas
CONTAR.SI.CO
JUNTO criterios
estáde que especifique. Como, por ejemplo, ¿de todas las frutas en la lista, cuántas
¿Qué
frutas valor
y tipos(texto o número) desea buscar? Limones 40
NJUNTO
estructuradaessonlo manzanas? O bien, ¿cuántas naranjas son del tipo Florida?
tiene
¿Para una
así: cada
mismo lista
que coincidencia, en qué intervalo desea sumar? Manzanas 50
desplegable
SUMAR.SI, Naranjas 20
donde
pero lepuede
seleccionar
permite
1
usar20
SUMAR.SI le permite sumar en un intervalo según un criterio específico Plátanos 60
diferentes
¿Quéesintervalo
Este
varios el que busca
desea sumar? en otro intervalo, como el número de manzanas que tiene. Limones 40
frutas.
segundo
criterios. Así, Seleccione la celda D17 y escriba =SUMAR.SI(C3:C14;C17;D3:D14).
Este es el yprimer
Pruébelo vea intervalo para buscar coincidencias Manzanas 50
intervalo
en este para SUMAR.SI está estructurada así:
Estos
cómo se
buscar
ejemplo,son los criterios de la primera coincidencia Naranjas 20
actualizan
coincidencias
puede buscar Plátanos 60
automáticame
frutas y tipos, ¿Qué intervalo ¿Para cada coincidencia, en
Estos
nte lassondelos criterios de la segunda coincidencia
desea ver? qué intervalo desea sumar? Limones 40
en lugar
fórmulas.
solo frutas.
Seleccione
Vaya hacia abajola para obtener más detalles. Fruta SUMAR.SI
celda H64
Siguiente paso y Manzanas
escriba
=SUMAR.SI(C3:C14;C17;D3:D14)
Funciones condicionales: CONTAR.SI
=CONTAR.SI.C
ONJUNTO(F50:
CONTAR.SI y CONTAR.SI.CONJUNTO le permiten contar valores de un intervalo según unos criterios que especifique. Son un poco diferentes de las otras funciones SI y SI.CONJUNT
F61;F64;G50:G
Seleccione
61;G64). la celda D64 y escriba =CONTAR.SI(C50:C61;C64). CONTAR.SI está estructurada así:
CONTAR.SI.CO3 ¿Qué valor (texto o número)
NJUNTO está
¿Qué intervalo desea ver? desea buscar?
estructurada
¿Qué
así: valor (texto o número) desea buscar?
21 SUMAR.SI.CONJUNTO es lo mismo que SUMAR.SI, pero le permite usar
varios criterios. Así, en este ejemplo, puede buscar frutas y tipos, en lugar
Este es el primer intervalo para contar
de solo frutas. Seleccione la celda H17 y escriba
Estos son los criterios de la primera coincidencia
=SUMAR.SI.CONJUNTO(H3:H14;F3:F14;F17;G3:G14;G17).
Este es el segundoSUMAR.SI.CONJUNTO
intervalo para contar está estructurada así:
Estos son los criterios de la segunda coincidencia
¿Qué Estos son los Estos son los
intervalo criterios de la criterios de la
desea primera segunda
sumar? coincidencia coincidencia
3;C92:C103;C1
0;D92:D103;D
106)
MIN.SI.CONJU
NTO
=MAX.SI.CONJ
Vaya hacia abajo para obtener más detalles. ¿Qué
UNTO(E92:E10 Estos son los Estos son los
3;C92:C103;C1 intervalo criterios de la criterios de la
Siguiente desea primera segunda
06;D92:D103;
Más
D106)funciones condicionales sumar? coincidencia coincidencia

Vaya hacia abajo para obtener más detalles.


Siguiente
=SUMAR.SI.CONJUNTO(H3:H14;F3:F14;F17;G3:G14;G17)
SUMAR.SI con un argumento de valor
Este es un ejemplo de la función SUMAR.SI con mayor (>) para encontrar todos los valores mayores de un determinado importe:
100
Sume algunos
...Busque valores
en estas basados en este criterio:
celdas... Este es el Este es el segundo
...y, si el valor es mayor que 50, súmelo. primer intervalo intervalo para
para buscar buscar
coincidencias coincidencias
NOTA: Si nota que realiza muchas fórmulas condicionales, es posible que una tabla dinámica sea una solución mejor. Consulte este artículo sobre tablas dinámicas para obtener m
Más información en la Web
Todo sobre la función SUMAR.SI
Todo sobre la función SUMAR.SI.CONJUNTO
Todo sobre laVaya hacia
función abajo para obtener más detalles.
CONTAR.SI Siguiente
Todo sobre la función CONTAR.SI.CONJUNTO
Todo sobre la función PROMEDIO.SI
Todo sobre la función PROMEDIO.SI.CONJUNTO Fruta Importe
Todo sobre la función MIN.SI.CONJUNTO Manzanas 50
Funciones condicionales: CONTAR.SI
Todo sobre la función MAX.SI.CONJUNTO Naranjas 20
Crear una lista desplegable Plátanos 60
Aprendizaje gratuito deyExcel
CONTAR.SI en línea
CONTAR.SI.CONJUNTO le permiten contar valores de un intervalo Limones 40
Volver al principio
según unos criterios que especifique. Son un poco diferentes de las otras funciones Manzanas 50
Siguiente SI y SI.CONJUNTO, porque solo tienen criterios y un intervalo de criterios. No evalúan Naranjas 20
un intervalo y después buscan en otro para resumir. Plátanos 60
Limones 40
1 Seleccione la celda D64 y escriba =CONTAR.SI(C50:C61;C64). CONTAR.SI Manzanas 50
está estructurada así: Naranjas 20
¿Qué intervalo
desea ver? Plátanos 60
Limones 40
¿Qué intervalo
desea ver?

Fruta CONTAR.SI
=CONTAR.SI(C50:C61;C64) Manzanas 3

¿Qué valor (texto o número)


desea buscar?

2 CONTAR.SI.CONJUNTO es lo mismo que SUMAR.SI, pero le permite usar


varios criterios. Así, en este ejemplo, puede buscar frutas y tipos, en lugar
de solo frutas. Seleccione la celda H64 y escriba
=CONTAR.SI.CONJUNTO(F50:F61;F64;G50:G61;G64).
CONTAR.SI.CONJUNTO está estructurada así:

Este es el primer Este es el segundo


intervalo para contar intervalo para contar

=CONTAR.SI.CONJUNTO(F50:F61;F64;G50:G61;G64)

Estos son los criterios de Estos son los criterios de


la primera coincidencia la segunda coincidencia

Vaya hacia abajo para obtener más detalles. Siguiente

Fruta Tipo
Manzanas Fuji

Más funciones condicionales Naranjas Florida


Más funciones condicionales Plátanos Cavendish
Limones Rugoso
Ya sabe SUMAR.SI, SUMAR.SI.CONJUNTO, CONTAR.SI y CONTAR.SI.CONJUNTO. Manzanas Manzana paraíso
Ahora puede probar por su cuenta otras funciones, como Naranjas Ombligo
PROMEDIO.SI.CONJUNTO, MAX.SI.CONJUNTO, MIN.SI.CONJUNTO. Están Plátanos Bizcocho de soletilla
estructuradas del mismo modo, por lo que cuando reciba una fórmula escrita, Limones Eureka
simplemente puede cambiar el nombre de la función por la que desee. Hemos Manzanas Manzana paraíso
preparado todas las funciones que necesitará para la celda E106, por lo que puede Naranjas Ombligo
copiar y pegar estas, o intentar escribirlas usted para la práctica. Plátanos Cavendish
Limones Eureka
SUMAR.SI =SUMAR.SI(C92:C103;C106;E92:E103)
SUMAR.SI.CONJUNTO =SUMAR.SI.CONJUNTO(E92:E103;C92:C103;C106;D92:D103;D106)
PROMEDIO.SI =PROMEDIO.SI(C92:C103;C106;E92:E103) Fruta Tipo
PROMEDIO.SI.CONJUNTO =PROMEDIO.SI.CONJUNTO(E92:E103;C92:C103;C106;D92:D92;D106) Limones Eureka
CONTAR.SI =CONTAR.SI(C92:C103;C106)
CONTAR.SI.CONJUNTO =CONTAR.SI.CONJUNTO(C92:C103;C106;D92:D103;D106)
MAX.SI.CONJUNTO =MAX.SI.CONJUNTO(E92:E103;C92:C103;C106;D92:D103;D106)
MIN.SI.CONJUNTO =MAX.SI.CONJUNTO(E92:E103;C92:C103;C106;D92:D103;D106)

Vaya hacia abajo para obtener más detalles. Siguiente

Elemento Importe
SUMAR.SI con un argumento de valor Pan
Donuts
50
100
Galletas 40
Este es un ejemplo de la función SUMAR.SI con mayor (>) para encontrar todos los Pasteles 50
valores mayores de un determinado importe:
Tartas 20
Sume algunos ...Busque en ...y, si el valor 100
valores estas celdas... es mayor que
basados en 50, súmelo.
este criterio:
Sume algunos ...Busque en ...y, si el valor
valores estas celdas... es mayor que
basados en 50, súmelo.
este criterio:

=SUMAR.SI(D118:D122;">50")

NOTA: Si nota que realiza muchas fórmulas condicionales, es posible que una tabla
dinámica sea una solución mejor. Consulte este artículo sobre tablas dinámicas para
obtener más información.

Más información en la Web


Todo sobre la función Todo sobre la función
SUMAR.SI SUMAR.SI.CONJUNTO
Todo sobre la función Todo sobre la función
CONTAR.SI CONTAR.SI.CONJUNTO
Todo sobre la función Todo sobre la función
PROMEDIO.SI PROMEDIO.SI.CONJUNTO
Todo sobre la función Todo sobre la función
MIN.SI.CONJUNTO MAX.SI.CONJUNTO

Crear una lista desplegable Aprendizaje gratuito de


Excel en línea

Volver al principio Siguiente paso


Fruta Tipo Importe
Manzanas Fuji 50
Naranjas Florida 20
Plátanos Cavendish 60
Limones Rugoso 40
Manzanas Manzana paraíso 50
Naranjas Ombligo 20
Plátanos Bizcocho de soletilla 60
Limones Eureka 40
Manzanas Manzana paraíso 50
Naranjas Ombligo 20
Plátanos Cavendish 60
Limones Eureka 40

Fruta Tipo SUMAR.SI.CONJUNTO


Naranjas Florida

s otras funciones SI y SI.CONJUNTO, porque solo tienen criterios y un intervalo de criterios. No


SUGERENCIA DELevalúan un intervalo y después buscan en otro para resumir.
EXPERTO
Cada una de las celdas de frutas y tipos tiene una
lista desplegable donde puede seleccionar
diferentes frutas. Pruébelo y vea cómo se
actualizan automáticamente las fórmulas.
tablas dinámicas para obtener más información.

Fruta Tipo Importe


Manzanas Fuji 50
Naranjas Florida 20
Plátanos Cavendish 60
Limones Rugoso 40
Manzanas Manzana paraíso 50
Naranjas Ombligo 20
Plátanos Bizcocho de soletilla 60
Limones Eureka 40
Manzanas Manzana paraíso 50
Naranjas Ombligo 20
Plátanos Cavendish 60
Limones Eureka 40
Fruta Tipo CONTAR.SI.CONJUNTO
Naranjas Florida 1

Importe
50
20
60
40
50
20
60
40
50
20
60
40

Inténtelo
80
INFORMACIÓN ÚTIL
Haga doble clic en esta celda y verá que la fórmula
es diferente. Concretamente, el criterio de suma es
">=50", lo que significa mayor o igual que 50. Puede
usar otros operadores, como "<=50", que es menor
o igual a 50. Y "<>50", que indica que no es igual a
50.
argumento
presione
aparecerán IR.en
Cuando
la parte
INFORMACIÓN vea
BUSCARV
inferior del
ÚTIL
resaltado,
formulario.
A medida que haga
clic en Aceptar
Haga cliclaen
escriba
en la parte
Aceptar
sección de
inferior.
cuando haya
cada Al
seleccionar
terminado, yse
argumento,
una
Excel función
mostrará la en
MIRE ESTO
Deje que el Asistente para funciones le guíe
la
Dejelista,
que
introduciráExcel
el Asistente para funciones ledesea,
guíe pero no tiene claro cómo crearla, puede usar el Asistente para funciones para ayudarle.
Si conocelaella
descripción
Debería
mostrará
del
nombre de la función que
fórmula.
argumento
obtener el en
sintaxis.
la parte
resultado
inferior del
=BUSCARV(C10
formulario,
;C5:D8;2;FALSOSi conoce el nombre de la función que desea, pero no tiene claro cómo crearla, Fruta Importe
encima del
)INFORMACIÓN puede usar el Asistente para funciones para ayudarle. Manzanas 50
resultado de la ÚTIL
Puede
fórmula. escribir referencias de celdas e intervalos, o seleccionarlos con el mouse. Naranjas 20
1 Seleccione la celda D10 y vaya a Fórmulas > Insertar función> escriba Plátanos 60
Anterior BUSCARV en el cuadro Buscar una función , y presione IR. Cuando vea Limones 40
Siguiente BUSCARV resaltado, haga clic en Aceptar en la parte inferior. Al seleccionar
una función en la lista, Excel mostrará la sintaxis.
Más información en la Web Manzanas 50
Información general sobre fórmulas en Excel
Funciones de2ExcelDespués escriba los argumentos de función en los cuadros de texto
(por categoría)
Funciones de Excelcorrespondientes.
(orden alfabético) A medida que escriba cada uno, Excel lo evaluará y le MIRE ESTO
mostrará Debería obtener el resultado
Aprendizaje gratuito de Excel el
enresultado,
línea con el resultado final en la parte inferior. Haga clic
=BUSCARV(C10;C5:D8;2;FALSO)
en Aceptar cuando haya terminado, y Excel introducirá la fórmula.

INFORMACIÓN ÚTIL
Puede escribir referencias de celdas e intervalos, o
seleccionarlos con el mouse.

INFORMACIÓN ÚTIL
A medida que escriba la sección de cada argumento, se
mostrará la descripción del argumento en la parte inferior d
formulario, encima del resultado de la fórmula.
INFORMACIÓN ÚTIL
A medida que escriba la sección de cada argumento, se
mostrará la descripción del argumento en la parte inferior d
formulario, encima del resultado de la fórmula.

Anterior Siguiente

Más información en la Web


Información general sobre fórmulas en Excel

Funciones de Excel (por categoría)

Funciones de Excel (por orden alfabético)

Aprendizaje gratuito de Excel en línea


O
er el resultado
0;C5:D8;2;FALSO)

celdas e intervalos, o

n de cada argumento, se
umento en la parte inferior del
do de la fórmula.
n de cada argumento, se
umento en la parte inferior del
do de la fórmula.
INFORMACIÓN
ÚTIL
Hacer clic en
Opciones le
Corregir
permite Corregir errores de fórmula
En algúnerrores
momento,
establecer las
de fórmula
verá una fórmula que tiene un error, que Excel mostrará con #ErrorName. Los errores pueden ser útiles, ya que indican si algo no funciona, pero pueden ser di
Comprobación
reglas para de errores: vaya a Fórmulas > Comprobación de errores. Se cargará un cuadro de diálogo que le indicará la causa general del error específico. En la celda D9, el erro
Si hace clic
cuando Fruta pasos de cálculo, Importe
se en Ayuda sobre este Error, se abrirá un tema de ayuda específico para el mensaje de error. Si hace clic en Mostrar se cargará un cuadro de diálogo de
muestran En algún momento, verá una fórmula que tiene un error, que Excel mostrará con Manzanas
o sehaga clic en Evaluar, Excel analizará la fórmula sección por sección. No siempre indicará por qué se produce 50
Cada vez que un error, pero si señalará dónde. Desde allí, observe el te
pasan por#ErrorName.
alto Los errores pueden ser útiles, ya que indican si algo no funciona, pero Naranjas 20
EXPERIMENTO
errores enpueden ser difíciles de corregir. Afortunadamente, hay varias opciones que pueden
¿Qué
Excel. está mal aquí? Sugerencia: Intentamos hacer una SUMA de todos los elementos. Plátanos 60
ayudarle a localizar el origen del error y corregirlo. Limones 40
Anterior
Siguiente
1 Comprobación de errores: vaya a Fórmulas > Comprobación de errores. Manzana #N/A
Se cargará un cuadro de diálogo que le indicará la causa general del error
Más información en la Web
específico. En la celda D9, el error #N/A se debe a que no hay ningún valor
Detectar errores en fórmulas
coincidente con "Manzana". Puede solucionarlo usando un valor que exista,
Cómo evitar fórmulassuprimiendo
rotas el error con SI.ERROR, o pasarla por alto teniendo en cuenta
Evaluar paso a paso una fórmula anidada
que desaparecerá cuando usa un valor que exista.
Aprendizaje gratuito de Excel en línea

INFORMACIÓN ÚTIL
2 Si hace clic en Ayuda sobre este error, se abrirá un tema de ayuda Hacer clic en Opciones le permite establecer
específico para el mensaje de error. Si hace clic en Mostrar pasos de las reglas para cuando se muestran o se pasan
cálculo, se cargará un cuadro de diálogo de Evaluar fórmula. por alto errores en Excel.
Fruta Importe
Manzanas 50
Naranjas 20
Plátanos 60
Limones 40

Total #NAME?

EXPERIMENTO
¿Qué está mal aquí? Sugerencia: Intenta
hacer una SUMA de todos los elemento

3 Cada vez que haga clic en Evaluar, Excel analizará la fórmula una sección
de cada vez. No siempre indicará por qué se produce un error, pero si
señalará dónde. Desde allí, observe el tema de ayuda para deducir qué ha
fallado en la fórmula.

Anterior Siguiente

Más información en la Web


Detectar errores en fórmulas

Cómo evitar la ruptura de las fórmulas

Evaluar una fórmula anidada paso a paso

Aprendizaje gratuito de Excel en línea


Aprendizaje gratuito de Excel en línea
unciona, pero pueden ser difíciles de corregir. Afortunadamente, hay varias opciones que pueden ayudarle a localizar el origen del error y corregirlo.

TIL
permite establecer
muestran o se pasan
MENTO
mal aquí? Sugerencia: Intentamos
UMA de todos los elementos.
¿Tiene más preguntas sobre Excel?
Presione ALT+Q y escriba lo que quiera saber.
Continuemos. Hay más que aprender con Excel:
LinkedIn Learning: Cursos de vídeo para todos los niveles, desde principiante a avanzado. Llévelo a su ritmo.
Comunidad: Formule preguntas y conéctese con otros aficionados a Excel.
¿Más novedades?Los suscriptores de Office 365 obtienen actualizaciones continuas y nuevas características.
¿Tiene más preguntas sobre Excel?
Presione ALT+Q y escriba lo que quiera saber.
¿Tiene más preguntas sobre Excel?
Continuemos. Hay más que aprender con Excel:
LinkedIn Learning: Cursos de vídeo para todos los niveles, desde principiante a avanzado. Llévelo a su ritmo.
Comunidad: Formule preguntas y conéctese con otros aficionados a Excel.
¿Más novedades?Los suscriptores de Office 365 obtienen actualizaciones continuas y nuevas características.

Haga clic en el botón Información y escriba lo que quiera saber.

Continuemos. Hay más que aprender con Excel:

LinkedIn Learning Comunidad


Cursos de vídeo para Formule preguntas
todos los niveles, desde y conéctese con
principiante a avanzado. otros aficionados a
Llévelo a su ritmo. Excel.

Obtener más Obtener más


información información (solo
disponible en inglés)
¿Más novedades?
Los suscriptores de
Office 365 obtienen
actualizaciones
continuas y nuevas
características.
Obtener más
información