Está en la página 1de 3

Principios de Algoritmos

PRACTICA 2

NOMBRES Y APELLIDOS JAISEN PLINIO AGUILAR MANCHEGO

1. Una compañía de seguros está abriendo un departamento de finanzas y estableció


un programa para captar clientes que consiste en lo siguiente si el monto por el
que se efectúa la fianza es menor que S/. 50,000 la cuota a pagar será por el 3% del
monto, y si el monto es mayor que S/. 50,000 la cuota a pagar será del 2%. La
compañía desea determinar cuál será la cuota que debe pagar un cliente.( 6p)
1.-algoritmo CAPTAR CLIENTES
2.-deinir capital,interés COMO REAL
3.-escribir “escribe el capital para financiar”
4.-leer capital
5.-capital<50000 entonces
6.-interes=capital*.03
7.-si no
8.-interes=capital*.02
9.-fin si
10.-escribir”el interés a pagar S/.”, interés
11.-escribir”la cuota total que debes pagar es”S/., capital+interés
12.-finalgoritmo

2. Un obrero necesita calcular su salario semanal, en cual se obtiene de la siguiente


manera: (5p)
 Si trabaja 40 horas o menos se le paga $16 por hora.
 Si trabaja más de 40 horas se le paga $16 por cada una de las primeras 40
horas y $20 por cada hora adicional.
Donde HT es horas totales, HE es horas extra, SS es salario semanal
1.-algoritmo SALARIO_SEMANAL
2.-leer HT,HE,SS
3.-si HT>40 entonces
4.-HE = HT – 40
5.-ss=he*20+40*16
6.-si no
7-ss=ht*16
8.-fin si
9.-imprimir ss
10.-fin algoritmo

3. Construir un algoritmo que permita ingresar un número e indique si es múltiple


de  2 , 3 ó 4.. (6p)

1.-algoritmo MULTIPLO
2.-definir M,N,O entero
3.-escribir”escribe un numero”
4.-leer n
5.-si n mod =2 entonces
6.-escribir”el numero”M”es multiplo de dos”
7.-si no
8.-escribir “elnumero “”no es multiplo de dos”
5.-si n mod =3 entonces
6.-escribir”el numero”N”es multiplo de tres”
7.-si no
8.-escribir “elnumero “N”no es multiplo de tres”
5.-si n mod =4 entonces
6.-escribir”el numero”O”es multiplo de cuatro”
7.-si no
8.-escribir “elnumero “O”no es multiplo de cuatro”
9.-fin si
10.-fin algoritmo

4. Escribir un programa que lea tres números enteros por teclado y emita un mensaje
indicando si están o no ordenados crecientemente. (3p)

1.-algoritmo
2.-definir a,b,c como entero
3.-escribir”da,me tres numero”
4.-leer a,b,c
5.-si a>b entonces
6.-si a>c entonces
7.-escribir”el numero “A”es el mayor de los tres”
8.-si no
9.- escribir”el numero “C”es el mayor de los tres”
10.-fin si
11.-si no
12.-si b>c entonces
13.- escribir”el numero “b”es el mayor de los tres”
14.-si no
15.- escribir”el numero “c”es el mayor de los tres”
16.-fin si
17.-escribir”si no están ordenados decrecientemente”,a,b,c
18.-fin si
17.-fin algoritmo

También podría gustarte