Está en la página 1de 4

PA-P3

PRINCIPIOS DE ALGORITMOS
PRÁCTICA N° 3

ESTRUCTURAS SECUENCIALES

INDICADOR DE LOGRO DE LA SESIÓN: Al final de la sesión, el alumno elabora pseudocódigos básicos,


empleando estructuras secuenciales.

EJERCICIOS SECUENCIALES

1. Elabore un algoritmo que dados como datos de entrada el radio y la altura de un


cilindro, calcular el área lateral y el volumen del cilindro.
A=2π
radio*altura V = π
radio2*altura

1.- Algoritmo calcular_el_ área_ lateral_ y_ el_ volumen_ del_ cilindro


Variables A,V,R,h Como Real
inicio
2.- Escribir "ingrese radio"
3.- Leer r
4.- Escribir "Ingrese altura"
5.- Leer h 
Pi=3.1416
6.- A<-Z*PI*r*h
7.- V<-PI*(r^2)*h
8.- Escribir "El area lateral es" ,A
9.- Escribir "El volumen de cilindro es" ,V
10.-FinALgoritmo

2. Un maestro desea saber qué porcentaje de hombres y que porcentaje de mujeres hay
en un grupo de estudiantes.

1.- Algoritmo porcentaje_de_hombres_ y_ mujeres


variables H,M Como Entero
Variables PH, PM Como Real
inicio
2.- Escribir "Ingrese cantidad de hombres"
3.- Leer H
4.- Escribir "Ingrese cantidad de mujeres"
5.- Leer MPH<-(H/100)PM<-(M/100)
6.- Escribir "El porcentaje de Hombres es”, PM
Escribir "el porcentaje de Mujeres es" ,PM
8.- Finalgoritmo

3. Queremos conocer los datos estadísticos de una asignatura, por lo tanto, necesitamos
1
un algoritmo que lea el número de desaprobados, aprobados, notables y sobresalientes
de una asignatura, y nos devuelva:
a. El tanto por ciento de alumnos que han superado la asignatura.
b. El tanto por ciento de desaprobados, aprobados, notables y sobresalientes
de la asignatura.

1.- Algoritmo datos_estadísticos_de_una_asignatura


Variables A,D,N,SS Como Entero
Variables T,PA Como Real
inicio
2.- Escribir "Ingrese cantidad de aprobados"
3.- Leer A
4.- Escribir "Ingrese cantidad de desaprobados"
5.- Leer D
6.- Escribir "Ingrese cantidad de notables"
7.- Leer N
8.- Escribir "Ingrese cantidad de sobresalientes"
9.- Leer SST<-A+D+N+SS
10.- PA<-(A+SS+N)/100
11.- Escribir "El porcentaje de alumnos que han superado la asignatura es",PA
12.- FinAlgoritmo

4. Un departamento de climatología ha realizado recientemente su conversión al sistema métrico.


Diseñar un algoritmo para realizar las siguientes conversiones:
a. Leer la temperatura dada en la escala Celsius e imprimir en su equivalente
Fahrenheit (la fórmula de conversión es “F=9/5 ºC+32”).
b. Leer la cantidad de agua en pulgadas e imprimir su equivalente en milímetros
(25.5 mm = 1pulgada

1.- Algoritmo leer_temperatura_y leer cantidad_de_agua


Variables C,F,mm,P Como Real
inicio
2.- Escribir "ingrese escala celcius"
3.- Leer C
4.- F<-(9/5)*C+32
5.- Escribir "Ingrese cantidad de pulgadas"
6.- Leer P
7.- mm<-P*25.5
8.- Escribir "El equivalente en fahrenheit es", F
9.- Escribir "El equivalente en Milimetros es", mm
10.- Finalgoritmo

5. El precio de un automóvil nuevo para un comprador es la suma total de: el costo del vehículo,
porcentaje de la ganancia del vendedor y de los impuestos aplicables. Suponer una ganancia del
vendedor del 12% en todas las unidades y un impuesto del 6% y diseñar un algoritmo para mostrar
el precio para el comprador.

1.- Algoritmo
Variables cv, PG,imp,PC Como Real
inicio
2.- PG<-0.12imp<-0.06

2
3.- Escribir "Ingrese costo de vehículo"
4.- Leer cv
5.- PC<-cv+PG+imp
6.- Escribir "El precio del comprador es",PC
7.- FinProceso

6. Convertir una cantidad de segundos a su equivalente en días, horas, minutos y segundos.

1. Algoritmo días_en_horas
Variables H,D,S,M como real
inicio
2.- Escribir "Ingrese cantidad de segundos"
3.- Leer S
D<-S/86400
H<-S/3600
M<-S/60
S<-S
4.- Escribir "La cantidad de segundos en A dias",D
5.- Escribir "La cantidad de segundos en A horas",H
6.- Escribir "La cantidad de segundos en A minutos",M
7.- Escribir "La cantidad de segundos en A segundos",S
8.- FinProceso

7. Un millonario excéntrico tenía tres hijos: Carlos, José y Marta. Al morir dejó el siguiente legado: A
José le dejó 4/3 de lo que le dejó a Carlos. A Carlos le dejó 1/3 de su fortuna. A Marta le dejo la
mitad de lo que le dejó a José. Preparar un algoritmo para darle la suma a repartir e imprima cuanto
le tocó a cada uno.

1.- algoritmo
Variables LegadoDe Carlos,Jose y Marta
inicio
  2.- Escribir Sin Saltar "Ingrese el valor de fortuna:";
3.- Leer fortuna;
  4.- legado_de_Carlos <- fortuna/3.0;
  5.- legado_de_Jose <- legado_de_Carlos*4.0/3.0;
  6.- legado_de_Martha <- legado_de_Jose/2.0;
  7.- Escribir "Valor de legado de Carlos: ", legado_de_Carlos;
  8.- Escribir "Valor de legado de Jose: ", legado_de_Jose;
  9.- Escribir "Valor de legado de Martha: ", legado_de_Martha;

10.- FinProceso

3
8. Hacer un algoritmo para ingresar una medida en metros, y que imprima esa medida expresada en
centímetros, pulgadas, pies y yardas. Los factores de conversión son los siguientes:
1 yarda = 3 pies
1 pie = 12 pulgadas
1 metro = 100 centímetros
1 pulgada = 2.54 centímetros

9. Escriba un programa para calcular el tiempo transcurrido, en minutos, necesario para hacer
un viaje. La ecuación es tiempo transcurrido = distancia total/velocidad promedio. Suponga
que la distancia está en kilómetros y la velocidad en kilómetros/hora.

También podría gustarte