Está en la página 1de 2

ESTRUCTURAS CONDICIONALES ANIDADAS

1.- Calcular la utilidad que un trabajador recibe en el reparto anual de utilidades si este se
le asigna como un porcentaje de su salario mensual que depende de su antigüedad en la
empresa de acuerdo con la siguiente tabla:

Tiempo Utilidad
Menos de 1 año 5 % del salario
1 año o más y menos de 2 años 7% del salario
2 años o más y menos de 5 años 10% del salario
5 años o más y menos de 10 años 15% del salario
10 años o más 20% del salario

1.-algoritmo UTILIDADES
2.-definir años, salario y utilidades COMO REAL
3.-escribir ”ESCRIBIR LA CANTIDAD DE AÑOS QUE VA TRABAJAR”
4.-leer años
5.-escribir “INGRESE SU SALARIO”
6.-leer salario
7.-si años <-1 entonces
8.-utilidad<-0.05*salario
9.-si no
10.-si 1<-años y años<-2 entonces
11.-utilidad<-0.07*salario
12.-si no
13.-si 2<=2 años y años <=5 entonces
14.-utilidad<-0.1*salario
15.-si no
16.-si 5<-años y años<-10 entonces
17.-utilidad<-0.15*salario
18.-si no
19.-utilidad<-0.2*salario
20.-fin si
21.-escribir “LA UTILIDAD QUE RECIBIRA ES”, utilidad
22.-fin algoritmo
ESTRUCTURAS CONDICIONAL MULTIPLE
2. Realizar un programa que permita ingresar un número correspondiente a los días de
una semana y muestre el nombre del día.
1.-algoritmo DÍA
2.-definir contador, d ENTERO
3.-escribir "INTRODUCE UN NÚMERO DEL 1 AL 7"
4.-leer d
5.-si (d >=1 ) and (d <= 7)
6.-en caso de contador hacer
7.- 1: escribir "lunes";
8.- 2: escribir "martes";
9.- 3: escribir "miércoles";
10.- 4: escribir "jueves";
11.- 5: escribir "viernes";
12.- 6: escribir "sábado";
13.- 7: escribir "domingo";
14.-fin si
15.-si no
16.-escribir "EL VALOR NO ES VÁLIDO";
17.-fin si
18.-fin algoritmo