Está en la página 1de 7

19 comentariosPor lcflores el 9 de febrero de 2009

Cómo insertar fórmulas en tablas de Word
Categorías: Trucos, Word, Tags: Calculos, Formulas, Tablas, Word Microsoft Excel no es la única aplicación de MS Office que permite usar fórmulas, con Microsft Word también podrás realizar cálculos y usar fórmulas (antes de que lo

preguntes, a día de hoy Power Point no lo permite).
Las fórmulas de Word puedes insertarlas cuando necesites realizar un cálculo o sumar celdas en una tabla de Word, son mucho mas limitadas que las fórmulas de Excel, pero pueden ser de gran utilidad como veremos a continuación. Cómo insertar un cálculo en Word En Word podemos insertar un cálculo en cualquier lugar de nuestro documento. Para ello nos serviremos de la funcionalidad que tienen los campos de Word. Los campos permiten realizar multitud de funciones: combinar datos, mostrar información del sistema, referencias, fórmulas…. en nuestro caso sólo vamos a tratar la opción de generar fórmulas que nos permitan almacenar un cálculo. Por ejemplo algo tan sencillo como insertar el número de segundos al año = 365*24*60*60:
• • • •

Clic donde desees que Word imprima la información.
Presiona “CTRL + F9″ para insertar un par de caracteres de campo ({ }). Inserta la fórmula entre las “llaves“, {=365*24*60*60} Pulsa “F9″.

También podemos realizar los mismos pasos a través de la opción para insertar un campo del menú de Word.

• Aparecerá una ventana y Word automáticamente rellenará la fórmula en función de los números que haya en la tabla. dentro del submenú “Tabla“. Sino es correcta podemos cambiarla. puede que sea más rápido realizarlo directamente en Word. selecciona “Fórmula…“. • Nos permite también dar formato al número. Sin embargo si sólo quieres crear una pequeña tabla con algunos números. . es una opción interesante para que el resultado final sea aun mejor. La opción más común es incrustar una hoja de Excel dentro del propio documento Word. Por ejemplo: Para insertar una nueva fórmula en la tabla debes realizar los siguientes pasos: • • Sitúate dentro de la celda en la cual deseas incluir la fórmula En el menú de Word. sin duda es la mejor opción si tienes que realizar cálculos complejos. medias… etc.Cómo insertar una fórmula en una tabla de Word Algo bastante común es tener que insertar tablas con números y cálculos de totales.

sólo tienes que situarse dentro del campo/fórmula y pulsar “F9″. También puedes hacer clic con el botón derecho y pulsar actualizar campos. Para estos casos. LEFT dentro de una fórmula de SUMA (o similar) sumará todas las celdas que estén a su izquierda. si dentro de unos días añadimos columnas a nuestra tabla la fórmula seguirá funcionando. Actualización de todas las fórmulas Para actualizar todas las fórmulas al mismo tiempo sólo tienes que seguir los siguientes dos pasos: • • Selecciona todo pulsando la combinación de teclas “CTRL + E”. puede ser muy tedioso e incluso ocasionar errores en los cálculos al tener que actualizar una a una todas fórmulas. Pulsa “F9″. . pero si tienes varias. Actualización automática de las fórmulas Puede que haya veces que se nos olvide actualizar todas las fórmulas con el método anterior o simplemente sea demasiado tedioso. hay métodos para “obligar” a que Word actualice de forma automática todas las fórmulas.• Pulsa el botón aceptar y la formula se insertará en la tabla. Por ejemplo. Si sólo tienes una fórmula esto es sencillo. Automáticamente se actualizarán todas las fórmulas seleccionadas. Actualización de las fórmulas Para actualizar una fórmula o un campo en Word. NOTA: Son especialmente interesantes las funciones LEFT o ABOVE.

Microsoft Office Word 2007 incluye compatibilidad integrada para escribir y modificar ecuaciones. actualizar el documento (no recomendable por que iría todo muy lento)…etc. Si una ecuación se escribió en una versión anterior de Word y desea modificarla usando Office Word 2007. vea Insertar un símbolo o un carácter especial. Por evento entendemos acciones de abrir. NOTA El comando Ecuación no está disponible en modo de compatibilidad. Equation 3. cuando abran nuestro documento es muy probable que no se actualicen automáticamente las fórmulas. Para desactivar el modo de compatibilidad. debe usar el complemento usado para escribir la ecuación. Math Type no se incluía en versiones anteriores de Word. Para obtener más información. cerrar el documento.0 o el complemento Math Type. vea la sección Convertir un documento a Office Word 2007. .Update 7: Next campo 8: Next rango 9: End Sub NOTA: Cuidado con el uso de macros en documentos. puede usar los códigos de caracteres Unicode y las entradas de Autocorrección matemática que reemplazan texto por símbolos. Por ejemplo.0 venía incluido en versiones anteriores de Word y está disponible en Office Word 2007. 1: Sub AutoOpen() 2: Dim rango As Range 3: Dim campo As Field 4: For Each rango In ActiveDocument. con la siguiente Macro se actualizarían todas las fórmulas al abrir el documento Word.La solución es una Macro asociada a un evento de Word.Fields 6: campo. debe tenerlo instalado. Para obtener más información. Por lo tanto.StoryRanges 5: For Each campo In rango. convierta el documento a formato de archivo de Word 2007. ¿Qué desea hacer? • • • • • • Escribir una ecuación Insertar una ecuación con formato previo o utilizada frecuentemente Insertar una estructura matemática utilizada habitualmente Cambiar una ecuación escrita en Office Word 2007 Cambiar una ecuación escrita en una versión anterior Convertir un documento a Office Word 2007 Escribir una ecuación Cuando escriba una ecuación. pero estaba a la venta. Las versiones anteriores usaban el complemento Microsoft Equation 3. si enviamos el fichero a otra persona. al abrir el documento recibirá un mensaje de alerta (o no. Si ha comprado Math Type. Es posible que parte del contenido de este tema no pueda aplicarse a algunos idiomas. dependiendo de su configuración de seguridad) y por defecto se desactivaran las macros.

En el grupo Símbolos de la ficha Insertar. En el grupo Símbolos de la ficha Insertar. Seleccione cualquier otra opción que desee. en el grupoHerramientas. a continuación. haga clic en Ecuaciones. haga clic en la flecha que hay junto a Ecuaciones y después en la ecuación que desee. Word convierte automáticamente la ecuación en una ecuación formateada profesionalmente. En Herramientas de ecuaciones de la ficha Diseño. haga clic en la flecha bajoEcuación y. 2. . haga clic en la flecha bajoEcuación y. a continuación. Escriba una ecuación. Seleccione la ecuación que desee agregar. VOLVER AL PRINCIPIO Insertar una estructura matemática utilizada habitualmente 1. 1.Cuando se escribe una ecuación. 2. 4. escriba un nombre nuevo para la ecuación. AGREGAR UNA ECUACIÓN A LA LISTA DE ECUACIONES UTILIZADAS FRECUENTEMENTE 1. en Insertar nueva ecuación. en Insertar nueva ecuación. 3. VOLVER AL PRINCIPIO Insertar una ecuación con formato previo o utilizada frecuentemente • En la ficha Insertar. En el cuadro de diálogo Crear nuevo bloque de creación. en el grupo Símbolos. En la lista Galería. 5. haga clic en Ecuaciones y después en Guardar selección en galería de ecuaciones.

MODIFICAR UNA ECUACIÓN ESCRITA CON EQUATION 3. MODIFICAR UNA ECUACIÓN ESCRITA CON MATH TYPE Para modificar una ecuación escrita con Math Type. 2. Seleccione la ecuación que desee modificar. 2. Haga doble clic en la ecuación que desee modificar. es necesario usar el complemento utilizado para escribir la ecuación. es necesario tener instalado Math Type. Realice los cambios que desee. VOLVER AL PRINCIPIO Cambiar una ecuación escrita en una versión anterior Para cambiar una ecuación escrita en una versión anterior utilizando el complemento Equation 3. VOLVER AL PRINCIPIO Cambiar una ecuación escrita en Office Word 2007 1. Si la estructura contiene marcadores de posición.2.0 1. 3. En Math Type.0 o el complemento Math Type. haga clic en el tipo de estructura que desea. haga clic en ellos y escriba los números o los símbolos que desea. una fracción o un radical. Haga doble clic en la ecuación que desee modificar. . . y después en la estructura que desea. modifique la ecuación. Al abrir un documento que contenga una ecuación escrita en una versión anterior de Word. Si desea obtener ayuda en el Editor de ecuaciones. por ejemplo. Los marcadores de posición son unos cuadros pequeños y punteados que se muestran en la ecuación. haga clic en Temas de Ayuda del Editor de ecuaciones en el menú Ayuda. 1. 2. En Herramientas de ecuaciones de la ficha Diseño del grupoEstructuras. no puede usar la compatibilidad integrada ni cambiar ecuaciones a menos que convierta el documento a Office Word 2007. Realice los cambios que desee.

haga clic en Contenido e índice en el menúAyuda. o el documento volverá a la versión anterior.3. En el menú Archivo. VOLVER AL PRINCIPIO Convertir un documento a Office Word 2007 Si convierte el documento y lo guarda como archivo de Office Word 2007. Haga clic en el botón de Microsoft Office NOTA Tras convertir el documento. y. Si desea obtener ayuda en Math Type. haga clic en Cerrar y volver a nombre del documento que contiene la ecuación. haga clic en Guardar. a continuación. 1. no podrá usar versiones anteriores de Word para cambiar las ecuaciones en el documento. haga clic enConvertir. a continuación. Haga clic en el botón de Microsoft Office y. VOLVER AL PRINCIPIO . debe guardarlo como un documento de Office Word 2007.