Está en la página 1de 4

Benemrita Universidad Autnoma de Puebla

Preparatoria 2 de octubre de 1968

I n f o r m t i c a

I I I

Profesora Minerva Gmez Marcos

Algoritmos: Ejercicios de clase


3 DM

Jimnez Lpez Mara Teresa

2013-2014

Manuel tiene un hermano menor en 2 ao de primaria y no puede aprenderse las tablas de multiplicar, por lo que necesita un programa que dado el nmero de la tabla de multiplicar se la muestre a continuacin Datos de entrada: nmero de tabla Datos de salida: Resultados Proceso: Nmero de tabla por nmeros del 1 al 10 Proceso Tablademultiplicar 1. 2. 3. 4. 5. 6. 7. 8. 9. 10. 11. 12. 13. Escribir Dame el nmero de la tabla a practicar; Leer Numtabla; Escribir Numtabla, x1=, numtabla*1; Escribir Numtabla, x2=, numtabla*2; Escribir Numtabla, x3=, numtabla*3; Escribir Numtabla, x4=, numtabla*4; Escribir Numtabla, x5=, numtabla*5; Escribir Numtabla, x6=, numtabla*6; Escribir Numtabla, x7=, numtabla*7; Escribir Numtabla, x8=, numtabla*8; Escribir Numtabla, x9=, numtabla*9; Escribir Numtabla, x10=, numtabla*10; Fin proceso

Un empleado desea calcular el pago neto que percibe resultante de las siguientes deducciones IMSS 5%, INFONAVIT 16%, en horas con un precio de $100 hora. (15 das y jornadas de 8 horas mximo) Datos de entrada: Nmero de horas trabajadas, pago por hora, reducciones Datos de salida: pago neto Proceso: nmhoras*p_hora-44 Proceso P_NETO 1. 2. 3. 4. 5. 6. Escribir "Dame el nmero de horas trabajadas"; Leer nmhoras; Escribir "dame el pago por hora"; Leer p_hora; Escribir "el pago neto es", nmhoras*p_hora-44; FinProceso

Multiplicacin de dos nmeros Datos de entrada: num1 num2 Datos salida: Producto Proceso: producto<-num1*num2 Algoritmo: Proceso MULTIPLICACION2NUMEROS 1. 2. 3. 4. 5. 6. 7. Escribir "dame el primer nmero"; Leer num1; Escribir "dame el segundo nmero"; Leer num2; Producto<-num1*num2; Escribir "El resultado de", num1 "X" num2, "es", Producto; FinProceso