Está en la página 1de 3

lOMoARcPSD|5076925

examen resuelto pc1

Principios de algoritmos (Universidad Tecnológica del Perú)

StuDocu no está patrocinado ni avalado por ningún colegio o universidad.


Descargado por Marcos Bustamante Diaz (markbd6@hotmail.com)
lOMoARcPSD|5076925

CURSO: Principios de Algoritmos

PRÁCTICA Nº 01

DOCENTE: Mg. Raùl Jimenez Drago

ALUMNO: Ramirez Huamán Cristina Danitza


…………………………………………………………………………………

Sede (donde se toma la evaluación) Arequipa

FACULTAD Ingeniería

9129
Período lectivo 2020-2 Sección Aula ……… Turno Mañana
(Turno - Grupo)

Fecha de evaluación 21 / 09/2020 Horario 11:40 – 12:40 Fila (*)

INDICACIONES GENERALES.

 Apagar celulares
 Prohibido el intercambio de materiales

Algoritmo de la Vida Cotidiana 6 ptos

1. Participación en un Concurso de Algoritmos


Inscribirse en el Concurso
Leer las reglas
Obtener información identificar las fases del desarrollo
Realizar los problema requeridos
Recopilarlos resultados
Terminar el Algoritm

2. Organizar una Fiesta de Cumpleaños

Planificar la Fiesta
Obtener un presupuesto
Alquilar un local
Realizar una lista de Invitados
Elegir un tema de la fiesta
Decorar el lugar
Colocar los bocaditos
Colocar música
Organizar los juegos
Premiaciones de los juegos
Terminar fiesta
Limpiar todo

Descargado por Marcos Bustamante Diaz (markbd6@hotmail.com)


lOMoARcPSD|5076925

Estructura Secuencial (Análisis y Pseudo Codigo con método PSeint) 14 ptos

3. Ingrese por teclado el nombre del trabajador y su sueldo actual, calcular el nuevo sueldo de un si obtuvo un
incremento del 25% sobre su sueldo actual. Mostrar el nombre del trabajador y su nuevo sueldo.

Proceso IncrementoSueldo
Definir sueldo, incremento, nuevo_sueldo Como Real
Escribir "ingrese el sueldo actual de Juan"
Leer sueldo
incremento <- sueldo*0.25
nuevo_sueldo<- sueldo + incremento
Escribir "El nuevo sueldo de Juan con un incremento del 25% es: ", nuevo_sueldo
FinProceso

4. Ingrese por teclado el nombre del cliente y el costo de una PC; por estar de promoción la empresa, se aplicará
un descuento del 15% del costo, donde el neto es la diferencia del costo menos el descuento. Aplique el 18%
del neto donde el monto a pagar es la suma del neto más IGV. Visualice el descuento, neto, IGV y el monto a
pagar.

Proceso DescuentoDeCompra
Definir descuento,neto icv total a pagar
escribir "ingrese el total de la compra"

Leer tc
tc <- tc*0.15
total_pagar<- tc-descuento

Escribir "El total a pagar es igual a :" total_pagar


FinProceso

Descargado por Marcos Bustamante Diaz (markbd6@hotmail.com)