Está en la página 1de 84

Captulo 2:

Implementacin de VLAN
en las redes de campus

CCNP SWITCH: Implementacin Switching IP

SWITCH v6 Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

Chapter 2 Objectives
Disear y planificar las VLAN, trunk, y abordar para
satisfacer los requerimientos del negocio, los requisitos
tcnicos y las limitaciones.
Configurar las VLAN y los trunk de VLAN en la red del
campus para apoyar los requerimientos tcnicos y de
negocio.
Configurar VTP en la red del campus para apoyar los
requerimientos tcnicos y de negocio.
Describir las VLAN privadas y configurar VLANs privadas
en la red del campus para apoyar los requerimientos
tcnicos y de negocio.
Configurar y verificar una EtherChannel en una topologa
de Capa 2 que contiene loops de switch.
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

Implementing
VLAN
Technologies in
a Campus
Network

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

Virtual Local Area Network (VLAN)

Una VLAN es un grupo lgico de los dispositivos finales.


Los Broadcast se encuentran dentro de las VLAN.
El diseo moderno tiene 1 VLAN = 1 subred IP.
Los Trunks conectan switches con el fin de transportar
mltiples VLANs.
Los dispositivos de capa 3 interconectan las Vlan.
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

Descripcin general de las VLAN

Definiciones de VLAN
La VLAN (LAN virtual) es una particin lgica de una red
de capa 2.
Se pueden crear varias particiones para que coexistan
varias VLAN.
Cada VLAN es un dominio de difusin, que generalmente
posee su propia red IP.
Las VLAN se aslan mutuamente y los paquetes pueden
pasar entre ellas solamente mediante un router.
La particin de la red de capa 2 se lleva a cabo dentro de
un dispositivo de capa 2 (por lo general, un switch).

Los hosts que se agrupan dentro de una VLAN


desconocen la existencia de esta.
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

End-to-End VLANs

Cada VLAN se distribuye geogrficamente por toda la red.


Los usuarios se agrupan en cada VLAN independientemente de la
ubicacin fsica, tericamente facilitando la gestin de red.
Como usuario se mueve a lo largo de un campus, la pertenencia a la
VLAN de ese usuario sigue siendo el mismo.
Los Switches estn configurados para modo servidor VTP o modo
cliente.
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

Local VLANs

Crear VLANs locales con los lmites fsicos en lugar de las funciones de trabajo
de los usuarios.
Existen VLANs locales entre las capas de acceso y distribucin.

El trfico de una VLAN local, se encamina a la distribucin y los niveles


centrales (Core).
Los Switches estn configurados en el modo transparente VTP.
STP slo se utiliza para evitar los Loop inadvertidas en el armario de cableado.
De una a tres VLAN por switch de la capa de acceso son recomendadas.
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

VLANs in Enterprise Campus Design

Las VLAN se utilizan en la capa de acceso deben extenderse ms all


de su Switch distribucin asociada.
El trfico se encamina desde la VLAN local, ya que se pasa de la capa
de distribucin en el ncleo.
Los bloques pueden contener de uno a tres VLAN cada uno.
STP se limita al acceso y Switch de distribucin
Se utiliza DHCP para asignar direcciones IP a los usuarios.
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

Best Practices for VLAN Design


De una a tres VLAN por mdulo de acceso y limitar esas VLANs a un par de
switches de acceso y los switches de distribucin.
Evite el uso de VLAN 1 como el "agujero negro" para todos los puertos no
utilizados. Utilice una VLAN dedicada separada de VLAN 1 para asignar todos
los puertos no utilizados.
Separar la VLAN de voz, VLAN de datos, la VLAN de administracin, la VLAN
nativa, las VLAN de agujeros negros, y el valor por defecto VLAN (VLAN 1).
Evite VTP al usar VLANs locales; uso permitido manualmente VLANs en los
trunk.
Por puertos troncales, desactive el protocolo dinmico de Trunking (DTP) y
configurar enlaces troncales. Utilice IEEE 802.1Q en lugar de ISL porque tiene
un mejor soporte para QoS y es un protocolo estndar.
Configuracin manual de puertos de acceso que no estn destinados
especficamente para un enlace troncal.
Prevn todo el trfico de datos de la VLAN 1; slo permitir los protocolos de
control se ejecute en VLAN 1 (DTP, VTP, STP BPDU, PAgP, LACP, CDP, etc.)
Evite el uso de Telnet a causa de los riesgos de seguridad; habilitar la
compatibilidad con SSH en VLAN de administracin.
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

VLAN Support on Catalyst Switches


Catalyst Switch

Max VLANs

VLAN ID Range

2940

1 - 1005

2950/2955

250

1 - 4094

2960

255

1 - 4094

2970/3550/3560/3750

1055

1 - 4094

2848G/2980G/4000/4500

4094

1 - 4094

6500

4094

1 - 4094

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

10

VLAN Ranges on Catalyst Switches


VLAN Range

Range

Usage

Popagated via VTP?

0, 4095

Reserved

Para el uso del sistema solamente.


Usted no puede ver o utilizar estos.

n/a

Normal

Por defecto de Cisco. Puede utilizar


esta VLAN, pero no puede
eliminarlo.

Yes

2 1001

Normal

Para las VLAN Ethernet. Puede


crear, utilizar y eliminar .

Yes

1002 1005

Normal

Defecto de Cisco para FDDI y Token


Ring. No es posible eliminar.

Yes

1006 1024

Reserved

Para el uso del sistema solamente.


Usted no puede ver o utilizar estas.

n/a

1025 - 4094

Reserved

For Ethernet VLANs only.

VTP v3 solamente.
No se admite en v1 o
v2 VTP. Requiere el
modo VTP
transparente para la
configuracin.

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

11

Configuration: Create a VLAN


Para crear una nueva VLAN en el modo de configuracin
global.
Switch(config)# vlan vlan-id

vlan-id is 2-1001 or 1025-4094

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

12

Configuration: Name a VLAN


Para nombrar una VLAN en el modo de configuracin de
VLAN.
Switch(config-vlan)# name vlan-name

vlan-name es un descriptor para la VLAN.


Poner el nombre a una VLAN es opcional.

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

13

Example: Creating and Naming a VLAN


Entre en el modo de configuracin global:
Switch# configure terminal

Crear una nueva VLAN con un nmero de identificacin


especial:
Switch(config)# vlan vlan-id

(Opcional) Nombre de la VLAN:


Switch(config-vlan)# name vlan-name
Switch# configure terminal
Switch(config)# vlan 5
Switch(config-vlan)# name Engineering
Switch(config-vlan)# exit

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

14

Tipos de Puertos en un Switch


Access:

Una sola VLAN.


Generalmente paquetes sin etiquetar.
Etiqueta el puerto del switch.
Destinados a equipos finales.

Trunk:
Una o ms VLANes.
Los paquetes van marcados con la VLAN.
Objetivo: extender trfico de VLANes ms all del switch
local.

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

15

Puerto de Acceso
Access:

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

16

Puerto de Acceso
Trunk:

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

17

Configuration: Disable Trunk Negotiation on a


Port
Para desactivar la negociacin del trunk en un puerto del
switch.
Switch(config-if)# switchport mode access

Este comando es opcional, pero se recomienda por motivos


de seguridad. Un puerto de acceso no necesita negociar la
formacin de del trunk.

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

18

Configuration: Macro for Access Port


Para configurar una macro opcional para los puertos de
acceso Switch.
Switch(config-if)# switchport host

Este comando optimiza un puerto de Capa 2 para una


conexin de host.
Esta macro establece el modo de puerto de acceso,
permite spanning-tree portfast, y deshabilita EtherChannel.

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

19

Configuration: Assign Port to VLAN


Para asignar un puerto a una VLAN en el modo de
configuracin de interfaz.
Switch(config-if)# switchport access vlan vlan-id

vlan-id es una VLAN creada anteriormente.

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

20

Example: Assigning a Port to a VLAN


Entre en el modo de
configuracin de interfaz:
Switch(config)# interface
interface-id

Configurar una descripcin para


el dispositivo (s) conectado al
puerto:
Switch(config-if)# description
string

Configurar un macro para el


acceso al puerto:

Asignar puertos a VLAN:


Switch(config-if)# switchport
access vlan vlan-id

Habilitar la interfaz:
Switch(config-if)# no shutdown

Vuelva al modo EXEC


privilegiado.
Switch(config-if)# end

Switch(config-if)# switchport
host
Switch(config)# interface FastEthernet 5/6
Switch(config-if)# description PC A
Switch(config-if)# switchport host
switchport mode will be set to access
spanning-tree portfast will be enabled
channel group will be disabled
Switch(config-if)# switchport access vlan 200
Switch(config-if)# no shutdown
Switch(config-if)# end
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

21

Verification: VLAN Configuration


El comando show vlan y sus derivados son los comandos
ms tiles para la visualizacin de la informacin
relacionada con las VLAN. Las dos formas siguientes
tienen el mismo resultado.
Switch# show vlan id 3
VLAN Name

Status

Ports

---- -------------------------------- --------- ------------------------------3

VLAN0003

VLAN Type

SAID

active
MTU

Fa0/1

Parent RingNo BridgeNo Stp

BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ -----3

enet

100003

1500

Switch# show vlan name VLAN0003


VLAN Name
Status
Ports
---- -------------------------------- --------- --------------------3
VLAN0003
active
Fa0/1
VLAN Type SAID
MTU
Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ -----3
enet 100003
1500 0
0
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

22

Verification: Interface Configuration


El comando show running-config tiene una opcin
palabra clave interface para permitir la salida de interfaz
especfica.
Switch# show running-config interface FastEthernet 5/6
Building configuration...
!
Current configuration :33 bytes
interface FastEthernet 5/6
switchport access vlan 200
switchport mode access
switchport host
end

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

23

Verification: Switch Port Configuration


Uno de los comandos ms tiles para mostrar la
informacin de configuracin de VLAN especficas a un
puerto de switch es el show interfaces
interface_id switchport
Switch# show interfaces f0/18 switchport
Name: Fa0/18
Switchport: Enabled
Administrative Mode: static access
Operational Mode: down
Administrative Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 20 (VLAN0020)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: 150 (VLAN0150)
<output omitted>
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

24

Verification: MAC Address Information


Puede ver la direccin MAC de informacin especfica para
una interfaz y una VLAN asociada.
Switch# show mac-address-table interface GigabitEthernet 0/1 vlan 1

Mac Address Table


-----------------------------------------Vlan
Mac Address
Type
Ports
--------------------1
0008.2199.2bc1 DYNAMIC Gi0/1
Total Mac Addresses for this criterion: 1

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

25

Implementing
Trunking in a
Campus Network

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

26

VLAN Trunking
Los Trunks llevan el trfico de mltiples VLANs a travs de un
nico enlace fsico (multiplexacin). Trunking se utiliza para
extender la capa 2 operaciones en toda la red.
El host de la izquierda en la VLAN 2 puede comunicarse con el
host a la derecha en la VLAN 2 a travs del enlace troncal; sobre
el mismo enlace del trunk, los hosts de VLAN 1 puede
comunicarse simultneamente.

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

27

VLAN Trunking with Inter-Switch Link (ISL)

ISL es un protocolo de trunking Cisco-propietario.


ISL es casi obsoleto.
ISL encapsula las tramas Ethernet, aadiendo 30 bytes de
sobrecarga (26 bytes de cabecera y 4 bytes FCS).
ISL se admite en la falta de acceso de capa switches Cisco.

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

28

VLAN Trunking with IEEE 802.1Q

802.1Q es un protocolo estndar de la industria con amplio


soporte.
IEEE 802.1Q tiene menor overhead de trama de ISL.
Overhead 802.1Q es 4 bytes.
802.1Q tiene el campo 802.1p QoS para el apoyo.
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

29

Native VLAN with IEEE 802.1Q

El estndar 802.1Q especifica cmo el switch debe manejar las tramas sin
etiquetar enviados o recibidos en un puerto de enlace troncal 802.1Q.

Un puerto de enlace troncal 802.1Q se le asigna un PVID predeterminado, que


est asociado con todo el trfico sin etiquetar en el puerto. Todo el trfico con
un ID de VLAN nula se supone que pertenecen al PVID predeterminado puerto.
Un paquete con un ID de VLAN igual al puerto de salida PVID defecto se enva
sin etiquetar. El resto del trfico se enva con una etiqueta VLAN.
Se recomienda configurar de forma proactiva los dos extremos de un enlace
troncal 802.1Q con una VLAN nativa distinta de todas las dems redes VLAN.
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

30

Dynamic Trunking Protocol (DTP)

Access - Pone el interfaz en modo no trunking permanente y negocia para convertir el enlace en un enlace no trunk La
interfaz se convierte en una interfaz no trunk incluso si la interfaz vecina no est de acuerdo con el cambio.

Trunk - Pone el interfaz en modo de enlace trunk permanente y negocia para convertir el enlace en un enlace troncal. La
interfaz se convierte en una interfaz de troncal incluso si la interfaz vecina no est de acuerdo con el cambio.

Dynamic desirable - Realiza la interfaz intentar activamente para convertir el enlace a un enlace troncal. La interfaz se
convierte en una interfaz de troncal si la interfaz vecina se establece en del trunk, o el modo automtico deseable.

Dinamic auto - Hace que la interfaz dispuesta a convertir el enlace a un enlace troncal. La interfaz se convierte en una
interfaz de troncal si la interfaz vecina se establece en del trunk o en el modo deseable. Este es el modo por defecto para
todas las interfaces Ethernet en Cisco IOS.

Nonegotiate - Pone la interfaz en modo de enlace trunk permanente, pero evita que la interfaz genere tramas de DTP.
Usted debe configurar la interfaz vecina manualmente como una interfaz de troncal para establecer un enlace troncal. Utilice
este modo cuando se conecta a un dispositivo que no sea compatible con DTP.

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

31

Design with VLAN Trunks

Los Trunks interconectan los switches de capa de acceso .


Los Trunks conectan switches de capa de acceso a los switches de la capa de distribucin.

Enlaces de capa 3 realizan la de interconexin del ncleo y switches de la capa de


distribucin.
Switches de capa de acceso estn configurados en un spanning-tree,, topologa libre de
bucles en forma de V. Si un enlace de distribucin falla, HSRP o VRRP proporcionan una
puerta de enlace predeterminada alternativa.
Recomendado: apague DTP y manualmente agregar las VLAN en los trunk.
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

32

Configuring an Interface for Trunking


Seleccione el tipo de encapsulacin:
Switch(config-if)# switchport trunk encapsulation {isl | dot1q |
negotiate}

Configure la interfaz como un trunk Capa 2:


Switch(config-if)# switchport mode {dynamic {auto | desirable} |
trunk}

Especifique la VLAN nativa:


Switch(config-if)# switchport trunk native vlan vlan-id

Configurar las VLAN permitidas para este trunk:


Switch(config-if)# switchport trunk allowed vlan {add | except |
all | remove} vlan-id[,vlan-id[,vlan-id[,...]]]
Switch(config)# interface FastEthernet 5/8
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport nonegotiate
Switch(config-if)# switchport trunk allowed vlan 1-100
Switch(config-if)# no shutdown
Switch(config-if)# end

optional

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

33

Verifying Trunk Configuration


Switch# show running-config interface f5/8
Building configuration...
Current configuration:
!
interface FastEthernet5/8
switchport mode dynamic desirable
switchport trunk encapsulation dot1q
end
Switch# show interfaces f5/8 switchport
Name: Fa5/8
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: trunk
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Enabled
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Switch# show interfaces f5/8 trunk
Port
Mode
Encapsulation
Fa5/8
desirable
n-802.1q
Port
Fa5/8

Status
trunking

Native vlan
1

Vlans allowed on trunk


1-1005

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

34

Troubleshooting Trunk Links


Asegrese de que el modo de interfaz Capa 2 configurado
en ambos extremos del enlace es vlido. El modo de trunk
debe ser trunk o desirable para al menos un lado del
trunk.
Asegrese de que el tipo de encapsulacin trunk
configurada en ambos extremos del enlace es vlido y
compatible.
En los troncales IEEE 802.1Q, asegrese de que la VLAN
nativa es la misma en ambos extremos del trunk
Al utilizar DTP, asegrese de que ambos extremos del
enlace se encuentran en el mismo dominio VTP.

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

35

VLAN Trunking
Protocol

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

36

VLAN Trunking Protocol (VTP)

VTP es un protocolo propietario de Cisco que automatiza la propagacin


de la informacin de la VLAN entre switches a travs de enlaces trunk
Esto reduce al mnimo los errores de configuracin y las incoherencias
de configuracin.
VTP no configura puertos de switch de pertenencia a la VLAN.
Tres tipos de mensajes VTP se envan a travs de Capa 2 multicast en
la VLAN 1.
Dominios VTP definen conjuntos de switches interconectados que
comparten la misma configuracin de VTP.

Chapter 2

2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

37

VTP Modes
Mode

Description

Client

No se puede crear, modificar o eliminar las VLAN en la interfaz de lnea


de comandos (CLI).
Anuncios Reenva a otros switches.
Sincroniza la configuracin VLAN con ltima informacin recibida de
otros switches en dominio de administracin.
No guarda la configuracin de VLAN en la RAM no voltil (NVRAM).

Server

Puede crear, modificar y eliminar redes VLAN.


Enva y reenva anuncios a otros switches.
Sincroniza la configuracin VLAN con ltima informacin recibida de
otros switches en dominio de administracin.
Guarda la configuracin de VLAN en la NVRAM.

Transparent

Puede crear, modificar y eliminar redes VLAN slo en el switch local.


Reenva publicaciones VTP recibidos desde otros switches en el mismo
dominio de administracin.
No sincronizar su configuracin VLAN con la informacin recibida de
otros switches en dominio de administracin.
Guarda la configuracin de VLAN en la NVRAM.

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

38

VTP Operation

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

39

VTP Pruning

VTP pruning evita inundaron de trfico se propaguen a los switches que no


tienen miembros en VLAN especficas.
VTP pruning utiliza anuncios de VLAN para determinar cundo una conexin
trunk est inundando el trfico innecesariamente. Los switch 1 y 4 en los
puertos de soporte figura estticamente configurados en la VLAN Roja.
El trfico de broadcast de la estacin de A no se reenva a Switches 3, 5 y 6 ya
que el trfico de la VLAN Roja ha sido pruning en el link indicado en Los
Switches 2 y 4.
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

40

VTP Versions
Tres versiones del VTP: V1, V2, V3.
Versiones no son interoperables (por ejemplo, V2 soporta VLANs token
ring pero V1 no lo hace).
Type-Length-Value (TLV) cambios de configuracin no reconocidos se
propagan por V2 servidores y clientes y stos no reconocido TLV se
pueden almacenar en la NVRAM.
Los switches transparentes V1 inspeccionar mensajes VTP para el
nombre de dominio y la versin y reenviar un mensaje slo si la versin
y el nombre de dominio son igual. V2 switches transparentes reenviar
mensajes de VTP en modo transparente sin comprobar las versiones.
V2 realiza comprobaciones de coherencia VLAN (nombres y valores de
VLAN) slo cuando se introduce nueva informacin a travs de la CLI o
va SNMP. V2 no realiza comprobaciones cuando la nueva informacin
se obtiene a partir de un mensaje VTP o cuando la informacin se lee
de la memoria NVRAM. Si el hash MD5 de un mensaje VTP recibida es
correcta, V2 acepta la informacin de los mensajes VTP.
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

41

VTP Message Types


Summary Advertisements
Subset Advertisements
Advertisement Requests

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

42

VTP Summary Advertisements

Por defecto, Catalyst switches emitir anuncios de resumen en


incrementos de 5 minutos. Resumen anuncios informan switches
adyacentes del nombre actual de dominio VTP y el nmero de revisin
de configuracin.
Cuando el switch recibe un resumen anuncio paquete, el switch
compara el nombre de dominio VTP a su propio nombre de dominio
VTP. Si el nombre es diferente, el switch ignora el paquete. Si el
nombre es el mismo, el switch compara la revisin de la configuracin
de su propia revisin. Si su propia revisin de la configuracin es mayor
o igual, se ignora el paquete. Si es inferior, se enva una solicitud de
anuncio.

Chapter 2

2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

43

VTP Subset Advertisements

Al agregar, eliminar o cambiar una VLAN, el servidor VTP, donde los


cambios se realizan incrementos de la revisin de la configuracin y
emite un resumen anuncio. Uno o varios anuncios subconjunto siguen
el resumen anuncio.
Un subconjunto anuncio contiene una lista de informacin de la VLAN.
Si hay varias VLANs, ms de un subconjunto anuncio puede ser
obligado a anunciar todas las VLANs.

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

44

VTP Subset Advertisements

Al agregar, eliminar o cambiar una VLAN, el servidor VTP, donde los


cambios se realizan incrementos de la revisin de la configuracin y
emite un resumen anuncio. Uno o varios anuncios subconjunto siguen
el resumen anuncio.
Un subconjunto anuncio contiene una lista de informacin de la VLAN.
Si hay varias VLANs, ms de un subconjunto anuncio puede ser
obligado a anunciar todas las VLANs.
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

45

VTP Advertisement Requests


Un switch emite un anuncio de solicitud de VTP en estas situaciones:
El switch se ha restablecido.
El nombre de dominio de VTP se ha cambiado.
El switch ha recibido un resumen anuncio VTP con una revisin de la
configuracin ms alta que su propia.

Tras la recepcin de una solicitud de anuncio, un dispositivo de VTP


enva un resumen anuncio.
Uno o ms anuncios subconjunto siguen el resumen anuncio.

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

46

VTP Authentication
Dominios VTP, puede obtenerse mediante el uso de la funcin
de contrasea de VTP. Es importante asegurarse de que todos
los switches en el dominio VTP tienen la misma contrasea y el
nombre de dominio; de otro modo, un switch no se convertir en
un miembro del dominio VTP. Los switches de Cisco utilizan
MD5 para codificar las contraseas en palabras de 16 bytes.
Estas contraseas se propagan dentro de los anuncios de
resumen de VTP. En VTP, las contraseas se distingue entre
maysculas y minsculas y puede ser de 8 a 64 caracteres de
longitud. El uso de la autenticacin de VTP es una prctica
recomendada.
Por defecto, un switch Catalyst no tiene una contrasea de VTP.
El switch no configura automticamente el parmetro de
contrasea, a diferencia de otros parmetros que se configuran
automticamente cuando se recibe un VTP anuncio.
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

47

Configuring VTP
Step 1. Entre en el modo de configuracin global:
Switch# configure terminal

Step 2. Configure el modo VTP como servidor:


Switch(config)# vtp mode server

Step 3. Configure el nombre de dominio:


Switch(config)# vtp domain domain_name

Step 4. (Optional.) Habilitar VTP versin 2:


Switch(config)# vtp version 2

Step 5. (Optional.) Indique la contrasea VTP:


Switch(config)# vtp password password_string

Step 6. (Optional.) Habilitar VTP pruning en el dominio de


administracin:
Switch(config)# vtp pruning
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

48

VTP Configuration Example


This example creates a VTP server with domain name
Modular_Form, password genus, and pruning enabled.

Switch# configure terminal


Switch(config)# vtp mode server
Setting device to VTP SERVER mode.
Switch(config)# vtp domain Modular_Form
Switch(config)# vtp password genus
Switch(config)# vtp pruning
Switch(config)# end

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

49

Verifying VTP Configuration (1)


El comando ms til para verificar la configuracin de VTP
es el comando show vtp status. La salida se muestra
incluye la versin VTP, el nmero de revisin de
configuracin VTP, el nmero de VLAN soportado
localmente, el modo VTP operativo, el nombre de dominio
VTP, y el modo VTP pruning.
Switch# show vtp status
VTP Version : 2
Configuration Revision : 247
Maximum VLANs supported locally : 1005
Number of existing VLANs : 33
VTP Operating Mode : Server
VTP Domain Name : Modular_Form
VTP Pruning Mode : Enabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0x45 0x52 0xB6 0xFD 0x63 0xC8 0x49 0x80
Configuration last modified by 0.0.0.0 at 8-12-99 15:04:4
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

50

Verifying VTP Configuration (2)


Utilice el comando show vtp counters para mostrar
informacin sobre el funcionamiento de VTP. Si hay algn
problema con respecto a la operacin del VTP, este
comando le ayuda buscar actualizaciones VTP tipo de
mensaje.
Switch# show vtp counters
VTP statistics:
Summary advertisements received : 7
Subset advertisements received : 5
Request advertisements received : 0
Summary advertisements transmitted : 997
Subset advertisements transmitted : 13
Request advertisements transmitted : 3
Number of config revision errors : 0
Number of config digest errors : 0
Number of V1 summary errors : 0
VTP pruning statistics:

Trunk Join Transmitted


device
------ ---------------Fa5/8
43071

Join Received

Summary advts received from non-pruning-capable

------------42766

----------------5

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

51

VTP Troubleshooting
Compruebe que switches estn interconectados por
enlaces troncales activos.
Compruebe que el protocolo de enlace troncal coincide en
extremos opuestos de un enlace troncal.
Compruebe el nombre de dominio VTP (maysculas y
minsculas) y la contrasea.
Compruebe el modo VTP de los switches
Compruebe las versiones del VTP de los interruptores.

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

52

Private VLANs

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

53

Motivation for Private VLANs


Los proveedores de servicios a menudo tienen dispositivos de mltiples
clientes, adems de sus propios servidores, en una sola zona
desmilitarizada (DMZ) segmento o VLAN. Como los problemas de
seguridad abundan, se hace ms importante para proporcionar
aislamiento de trfico entre los dispositivos, a pesar de que puedan
existir en el mismo segmento de nivel 3 y VLAN.
La mayora de los conmutadores basados en Cisco IOS implementan
VLANs privadas para mantener algunos puertos de switch compartidos
y algunos puertos de switch aislados, a pesar de que todos los puertos
se mantienen en la misma VLAN.

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

54

pVLAN Port Types


Isolated
Promiscuous
Community

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

55

pVLAN Structure Supporting VLANs

Primary Private VLAN


Secondary Private VLAN
Community Private VLAN
Isolated Private VLAN

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

56

Configuring pVLANs - Steps

Paso 1. Ajuste el modo VTP transparente.


Paso 2. Crear las PVLAN secundarias.
Paso 3. Cree el PVLAN primaria.
Paso 4. Asociar la PVLAN secundario con el PVLAN primaria.
Slo un aislado PVLAN se puede asignar a un PVLAN primaria,
pero ms de una comunidad PVLAN se puede asignar a un
PVLAN primaria.
Paso 5. Configure una interfaz como un puerto aislado o
comunidad.
Paso 6. Asociar el puerto aislado o puerto de la comunidad con
el par PVLAN primaria-secundaria.
Paso 7. Configure una interfaz como un puerto promiscuo.
Paso 8. Localizar en un mapa el puerto promiscuo a la par
PVLAN primaria-secundaria.

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

57

Configuring pVLANs - Commands


Switch(config)# vlan pvlan-id
Switch(config-vlan)# private-vlan {community | isolated | primary}

Switch(config-vlan)# exit
Switch(config)# vlan primary-vlan-id
Switch(config-vlan)# private-vlan association {secondary-vlan-list | add
secondary-vlan-list | remove secondary-vlan-list}
Switch(config-vlan)# interface vlan primary-vlan-id
Switch(config-if)# private-vlan mapping {secondary-vlan-list | add
secondary-vlan-list | remove secondary-vlan-list}
Switch(config-if)# interface type slot/port
Switch(config-if)# switchport
Switch(config-if)# switchport mode private-vlan {host | promiscuous}
Switch(config-if)# switchport private-vlan host-association primary-vlanid secondary-vlan-id
Switch(config-if)# switchport private-vlan mapping primary-vlan-id
{secondary-vlan-list | add secondary-vlan-list | remove secondary-vlanlist}

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

58

Verifying pVLAN Configuration


Los dos comandos ms tiles para este propsito son:
show interface switchport and show vlan
private-vlan.
Switch# show vlan private-vlan
Primary Secondary
Type
------- ---------------------100
200
community
100
300
isolated

Interfaces
-----------------

Switch# show interfaces FastEthernet 5/2 switchport


Name: Fa5/2
Switchport: Enabled
Administrative Mode: private-vlan host
Operational Mode: down
Administrative Trunking Encapsulation: negotiate
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative private-vlan host-association: 100 (VLAN0200) 300 (VLAN0300)
Administrative private-vlan mapping: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

59

pVLAN Scenario 1: Single Switch

Una DMZ corporativa contiene dos servidores DNS, un servidor web y un


servidor SMTP. Todos los servidores y su enrutador de conexin estn en la
misma subred.
Los servidores DNS son copias redundantes, por lo que necesitan comunicarse
entre s para actualizar sus entradas y al Internet. Adems de eso, tambin tienen
que comunicarse con Internet.
El servidor Web y el servidor SMTP necesita comunicarse con Internet, pero por
razones de seguridad, el servidor SMTP no debe ser accesible desde la Web o
los servidores DNS. El servidor web debe ser accesible desde Internet, pero no
del servidor SMTP.
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

60

pVLAN Configuration for Scenario 1


Switch(config)# vtp transparent
Switch(config)# vlan 201
Switch(config-vlan)# private-vlan isolated
Switch(config)# vlan 202
Switch(config-vlan)# private-vlan community
Switch(config-vlan)# vlan 100
Switch(config-vlan)# private-vlan primary
Switch(config-vlan)# private-vlan association 201,202
Switch(config-vlan)# interface fastethernet 0/24
Switch(config-if)# switchport mode private-vlan promiscuous
Switch(config-if)# switchport private-vlan mapping 100 201,202
Switch(config-if)# interface range fastethernet 0/1 - 2
Switch(config-if)# switchport mode private-vlan host
Switch(config-if)# switchport private-vlan host-association 100 202
Switch(config-if)# interface range fastethernet 0/3 - 4
Switch(config-if)# switchport mode private-vlan host
Switch(config-if)# switchport private-vlan host-association 100 201

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

61

pVLAN Scenario 2: Multiple Switches

Un puerto troncal transporta la VLAN primaria y secundaria VLAN a un switch


vecino como cualquier otra VLAN.
Una caracterstica de PVLAN a travs de mltiples switches es que el trfico de un
puerto aislado en un switch no llega a un puerto aislado en otro switch.

Configure PVLAN en todos los switches en el camino, lo que incluye los dispositivos
que no tienen puertos PVLAN para mantener la seguridad de su configuracin
PVLAN, y evitar el uso de otras redes VLAN configuradas como PVLAN.
Como se muestra en la figura, los switches SWA y SWB tienen los mismos PVLAN
sobre dos switches diferentes y estn conectados a travs del enlace troncal.
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

62

pVLAN Configuration for Scenario 2


Para configurar una interfaz de capa 2 como un puerto de enlace troncal VLAN
privada, utilice el comando de interfaz:
Switch(config-if)# switchport private-vlan association trunk
primary_vlan_ID secondary_vlan_ID

Si el puerto est establecido en promiscua, utilice el comando de asignacin


de:
Switch(config-if)# switchport private-vlan mapping primary_vlan_ID
secondary_vlan_list

Una vez configurado el trunk, permitir VLAN con el comando.


Switch(config-if)# switchport private-vlan trunk allowed vlan
vlan_list

Configure el VLAN nativa con siguiente comando.


Switch(config-if)# switchport private-vlan trunk native vlan
vlan_id

Switch(config)# interface fastethernet 5/2


Switch(config-if)# switchport mode private-vlan trunk secondary
Switch(config-if)# switchport private-vlan trunk native vlan 10
Switch(config-if)# switchport private-vlan trunk allowed vlan 10, 3,301302
Switch(config-if)# switchport private-vlan association trunk 3 301
Switch(config-if)# switchport private-vlan association trunk 3 302
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

63

pVLAN Verification for Scenario 2


Switch# show interfaces fastethernet 5/2 switchport
Name: Fa5/2
Switchport: Enabled
Administrative Mode: private-vlan trunk secondary
Operational Mode: private-vlan trunk secondary
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: 10
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations:
3 (VLAN0003) 301 (VLAN0301)
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Operational Normal VLANs: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

64

pVLAN Edge (Protected Port) Feature


El borde PVLAN (puerto protegido)
caracterstica tiene slo una importancia
local para el switch (a diferencia de
PVLAN), y no hay aislamiento previsto
entre dos puertos protegidos ubicados en
diferentes switches.
Un puerto protegido no reenva el trfico
a cualquier otro puerto que es tambin
un puerto protegido en el mismo
conmutador.
El trfico no se puede reenviar entre
puertos protegidos en L2, todo el trfico
que pasa entre los puertos protegidos
debe ser enviada a travs de un
dispositivo L3.

Switch(config-if)# switchport protected

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

65

Configuring Link
Aggregation with
Etherchannel

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

66

EtherChannel Technology
Hasta 8 conexiones fsicas se
pueden agrupar en un nico enlace
lgico EtherChannel.
Por lo general, EtherChannel se
utiliza para los enlaces troncales.
Configuracin aplicada a la interfaz
de canal de puerto afecta a todas las
interfaces fsicas asignados al canal
de puerto.
Los puertos deben ser idnticos y
configurados de la misma forma
El balanceo de carga se lleva a cabo
entre los enlaces fsicos en un
EtherChannel.
EtherChannels pueden ser
interfaces de L2 o L3.
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

67

EtherChannel Management Protocols


Port Aggregation Protocol (PAgP) es un protocolo propietario de
Cisco que ayuda en la creacin automtica de enlaces EtherChannel.
Cuando un enlace EtherChannel se configura utilizando PAgP,
paquetes PAgP se envan entre los puertos-EtherChannel capaz para
negociar la formacin de un canal.
Cuando PAgP identifica enlaces Ethernet coincidentes, que agrupa
los enlaces en un EtherChannel. STP aade el EtherChannel como
un nico puerto de puente.

Modos de PAgP
Modo Activo = desirable
Modo Passivo = auto

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

68

EtherChannel Management Protocols


Link Aggregation Control Protocol (LACP) forma parte de una

especificacin IEEE (802.3ad) que tambin permite que varios puertos


fsicos son agrupados para formar un EtherChannel.
LACP permite a un switch negociar de forma automtica un EtherChannel mediante
el envo de paquetes LACP a los pares.
Se lleva a cabo una funcin similar a PAgP con Cisco EtherChannel.
Debido LACP es un estndar IEEE, puede utilizarlo para facilitar EtherChannels en
entornos mixtos de conmutacin. En un entorno de Cisco, se admiten los dos
protocolos.
Usa system priority y Port Priority el valor menor es mejor.
Modos de LACP

Modo Activo = active


Modo Passivo = passive
Nota: LACP, puede agrupar 16 link pero solo 8 estarn en funcionamiento segn la
especificacin del Port priority y el switch con la menor prioridad indica las puertas
que estarn encendidos.
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

69

PAgP Modes

Mode

Purpose

Auto

Coloca una interfaz en un estado de negociacin pasiva en el que la interfaz responde a los
paquetes PAgP que recibe, pero no inicia la negociacin PAgP (por defecto).

Desirable

Coloca una interfaz en un estado de negociacin activa en la que la interfaz inicia


negociaciones con otras interfaces mediante el envo de paquetes PAgP. Interfaces
configuradas en el modo "on" no intercambian paquetes PAgP.

On

Fuerza a la interfaz de canalizar sin PAgP.

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

70

LACP Modes

Mode

Purpose

Passive

Coloca un puerto en un estado de negociacin pasiva. En este estado, el


puerto responde a los paquetes LACP que recibe, pero no inicia la
negociacin de paquetes LACP (por defecto).

Active

Coloca un puerto en un estado de negociacin activa. En este estado, el


puerto inicia negociaciones con otros puertos mediante el envo de
paquetes LACP.

On

Fuerza a la interfaz para el canal sin PAgP o LACP.

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

71

Configuring EtherChannel
Step 1. Especificar las interfaces que compondrn el grupo EtherChannel. Utilizando los
comandos de rango le permite seleccionar varias interfaces y configurar todos juntos.
Una buena prctica es comenzar por el cierre de estas interfaces, de modo que la
configuracin incompleta no empezar a crear actividad en el enlace:
Switch(config)# interface range interface_type [interface_range]

Step 2. Especificar el protocolo de canalizacin para ser utilizado. Este comando no es


aplicable a todas las plataformas Catalyst. Tambin puede especificar el protocolo de
canalizacin en el Trmite 3:
Switch(config-if-range)# channel-protocol {pagp | lacp}

Step 3. Crear la interfaz port-channel, si es necesario, y asignar las interfaces


especificadas a ella:
Switch(config-if-range)# channel-group number mode {active | on | {auto
[non-silent]} | {desirable [non-silent]} | passive

Step 4. Especifique la interfaz puerto-canal. Cuando est en el modo de configuracin de


interfaz, puede configurar parmetros adicionales. Las interfaces fsicas heredarn estos
parmetros. Cuando esta configuracin se ha completado, se puede volver a activar los
puertos fsicos en el paquete EtherChannel:
Switch(config)# interface port-channel number
Switch(config-if)# interface parameters

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

72

Example: EtherChannel Configuration


Switch(config)# interface fastethernet 0/23
Switch(config-if)# channel-group 2 mode active
Switch(config)# interface fastethernet 0/24
Switch(config-if)# channel-group 2 mode active
Switch(config)# interface port-channel 2
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport trunk native VLAN 99
Switch(config-if)# switchport trunk allowed VLAN 2,3,99

Remote Switch configuration


RSwitch(config)# interface fastethernet 0/23
RSwitch(config-if)# channel-group 5 mode on
RSwitch(config)# interface fastethernet 0/24
RSwitch(config-if)# channel-group 5 mode on
RSwitch(config)# interface port-channel 5
RSwitch(config-if)# switchport mode trunk
RSwitch(config-if)# switchport trunk native VLAN 99
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

73

Verifying EtherChannel (1)


Puede utilizar varios comandos para verificar una configuracin
EtherChannel. En cualquier miembro de interfaz fsica de un paquete
EtherChannel, el comando show interfaces interface_id
proporciona informacin sobre la funcin de la
interfaz en el EtherChannel.
Interfaz FastEthernet 0/24 a continuacin es parte de EtherChannel
paquete 1.
El protocolo de este EtherChannel es LACP.
Switch# show interfaces fa0/24 etherchannel
Port state = Up Sngl-port-Bndl Mstr Not-in-Bndl
Channel group = 1
Mode = Active Gcchange = Port-channel = null
GC = Pseudo port-channel = Po1
Port index = 0
Load = 0x00
Protocol = LACP

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

74

Verifying EtherChannel (2)


El comando show etherchannel number port-channel puede
utilizar para mostrar informacin sobre un puerto especfico portchannel.
Debajo de un Port-channel1 consta de dos puertos fsicos, Fa0/23 y
Fa0/24.
Se utiliza LACP en modo activo.
Est bien conectado a otro switch con configuration.This compatibles es
por eso que el Port-channel se dice que est en uso.
Switch# show etherchannel 1 port-channel
Port-channels in the group:
--------------------------Port-channel: Po7
(Primary Aggregator)
Age of the Port-channel = 195d:03h:10m:44s
Logical slot/port = 0/1
Number of ports = 2
Port state = Port-channel Ag-Inuse
Protocol = LACP
Ports in the Port-channel:
Index
Load
Port
EC state
No of bits
------+------+--------+--------------+----------0
55
fa0/23
Active
4
1
45
fa0/24
Active
4
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

75

Verifying EtherChannel (3)


Cuando varias interfaces de Port-channel se configuran en el mismo
dispositivo, el comando show etherchannel summary es til para mostrar la
informacin de una lnea por Port-channel.
Como se muestra a continuacin; el switch tiene tres EtherChannels
configurados: Grupos 2 y 7 utilizan LACP y el Grupo 9 utiliza PAgP. Cada
EtherChannel tiene las interfaces de los que figuran. Los tres grupos son de
capa 2 EtherChannels y estn en uso (SU junto al nmero de Port-channel).
Switch# show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 2
Number of aggregators: 2
Group
Port-channel Protocol
Ports
------+-------------+-----------+-------------------------------------------2
Po2(SU)
LACP
g0/49(P) g0/50(P) g0/51(P) g0/52(P)
7
Po7(SU)
LACP
g0/47(P) g0/48(P)
9
Po9(SU)
PAgP
g0/8(P) g0/9(P)
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

76

Verifying EtherChannel (4)


El comando show running-config interface
interface_id El show interface running-config
Interface_Id comando muestra las secciones de su
configuracin relacionados con EtherChannel. El
argumento de interfaz puede ser fsica o lgica.
Switch# show running-config interface g0/48
Building configuration...
Current configuration : 154 bytes
interface GigabitEthernet0/48
switchport access vlan 41
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 7 mode active
Switch# show running-config interface port-channel 7
Building configuration...
Current configuration : 92 bytes
interface Port-channel7
switchport trunk encapsulation dot1q
switchport mode trunk
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

77

EtherChannel Load Balancing

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

78

EtherChannel Load Balancing Example


Aqu el mecanismo balanceo de carga EtherChannel est configurado
para utilizar pares de direcciones IP de origen y destino.
Esta regla se aplica a IPv4 e IPv6 de trfico, mientras que el
mecanismo de balanceo de carga no-IP utiliza de origen y destino
pares de direcciones MAC.
Se observ que con el balanceo de carga IP de origen-destino, el
balanceo termina ms como 70-30 en los enlaces!
Switch(config)# port-channel load-balance src-dst-ip
Switch(config)# exit
Switch# show etherchannel load-balance
EtherChannel Load-Balancing Configuration:
src-dst-ip
EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Source XOR Destination MAC address
IPv4: Source XOR Destination IP address
IPv6: Source XOR Destination IP address
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

79

Troubleshooting EtherChannel

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

80

Chapter 2 Summary
A VLAN is a logical grouping of switch ports independent of physical location. Local
VLANs are now recommended over end-to-end VLAN implementations.
A trunk is a Layer 2 point-to-point link between networking devices carry the traffic of
multiple VLANs.
ISL and 802.1Q are the two trunking protocols that can connect two switches.
VTP is used to distribute and synchronize information about VLANs configured throughout
a switched network.
VTP pruning helps to stop flooding of unnecessary traffic on trunk links.

Device communication within the same VLAN can be fine-tuned using pVLANs. A pVLAN
is associated to a primary VLAN, and then mapped to one or several ports. A primary
VLAN can map to one isolated and several community VLANs. pVLANs can span across
several switches using regular 802.1q trunks or pVLAN trunks.
Use EtherChannel by aggregating individual, similar links between switches.
EtherChannel can be dynamically configured between switches using either the Ciscoproprietary PAgP or the IEEE 802.3ad LACP. EtherChannel load balances traffic over all
the links in the bundle. The method that is chosen directly impacts the efficiency of this
load-balancing mechanism.
Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

81

Chapter 2 Labs
Lab 2-1
Lab 2-2

Static VLANS, VLAN Trunking, and VTP Domains


Configuring EtherChannel

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

82

Resources
Catalyst 3560 Switch Command Reference
www.cisco.com/en/US/docs/switches/lan/catalyst3560/softw
are/release/12.2_52_se/command/reference/3560cr.html

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

83

Chapter 2
2007 2010, Cisco Systems, Inc. All rights reserved.

Cisco Public

84