P. 1
IMPORTANCIA DE LOS MÉTODOS NUMÉRICOS

IMPORTANCIA DE LOS MÉTODOS NUMÉRICOS

|Views: 6.958|Likes:
Publicado porfenix2802

More info:

Published by: fenix2802 on Sep 15, 2010
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as DOCX, PDF, TXT or read online from Scribd
See more
See less

08/20/2013

pdf

text

original

1.1.

IMPORTANCIA DE LOS MÉTODOS NUMÉRICOS Son técnicas mediante las cuales es posible formular problemas matemáticos de tal forma que puedan resolverse usando operaciones aritméticas. Trata de diseñar métodos para ³aproximar´ de una manera eficiente las soluciones de problemas expresados matemáticamente. El objetivo principal del análisis numérico es encontrar soluciones ³aproximadas´ a problemas complejos utilizando sólo las operaciones más simples de la aritmética. Los métodos numéricos pueden ser aplicados para resolver procedimientos matemáticos en: Cálculo de derivadas Integrales Ecuaciones diferenciales Operaciones con matrices Interpolaciones Ajuste de curvas Polinomios 1.2 CONCEPTOS BÁSICOS: Cifras significativas.- Es el conjunto de dígitos confiables o necesarios que representan el valor de una magnitud independientemente de las unidades de medidas utilizadas. Confiables.- Por que dependen del instrumento de medición empleado. Necesarias.- Por que depende de leyes, reglamentos, normas o costumbres. Exactitud y precisión Exactitud.- Lo que está más cerca del valor verdadero. Se refiere a que tan cercano está el valor medido o calculado con el valor verdadero. Precisión.- Se refiere a que tan cercano esta un valor individual medido o calculado con respecto a los otros. 1.3 TIPOS DE ERRORES. Error.- Es la discrepancia que existe entre la magnitud ³verdadera´ y la magnitud obtenida. Error absoluto.- Es igual a la diferencia entre el valor verdadero y el valor aproximado: EA = Vv - Va Error Relativo.- Es el cociente del error absoluto respecto al valor verdadero: ER =

y y y y y y y

EA Vv

=

Vv  Va Vv

Error Relativo Porcentual: ERP =

EA * 100 % Vv

1.3.2 ERROR POR REDONDEO. (Er): El error de redondeo es el que ocurre al aumentar o disminuir artificialmente el valor de una magnitud. Por ejemplo, tenemos en valor de e = 2.718281828« hasta el infinito. Si cortamos redondeando el número en 8 cifras significativas después del punto decimal e=2.71828183, estamos teniendo un error de redondeo de Er= 2.718281828 ± 2.71828183 = 0.0000000002 =2 X 10 -9 1.3.3 ERROR POR TRUNCAMIENTO. (Et): resulta de truncar un proceso infinito para obtener un proceso finito. 1.3.4 ERROR NUMÉRICO TOTAL. (ENT): El error numérico total se entiende como la suma de los errores de redondeo y truncamiento introducidos en el cálculo. ENT = Er + Et Ejemplo: tomando el ejemplo del valor de e, el ENT = 0.0000000002 + 0.0000000006 = 0.0000000008 1.4 SOFTWARE DE CÓMPUTO NUMÉRICO:Los programas computacionales son únicamente conjuntos de instrucciones que dirigen a la computadora para realizar una cierta tarea. En la actualidad, las computadoras y los métodos numéricos ofrecen una alternativa para los cálculos complicados.

..forma): Devuelve el número pasado en formato decimal a número Romano PI():Devuelve el valor de la constante pi POTENCIA(número. según se cumpla o no una condición NO(valor_lógico) : Invierte el valor lógico proporcionado Y(valor_logico1...):Devuelve la media aritmética de la lista de valores VAR(número1..argumento2. No dejes espacios antes o después de cada paréntesis.valor_si_verdadero.) :Comprueba si algún valor lógico es verdadero y devuelve VERDADERO Funciones de información ESBLANCO(valor) : Comprueba si se refiere a una celda vacía ESERR(valor) :Comprueba si un valor es un error ESLOGICO(valor) :Comprueba si un valor es lógico ESNOTEXTO(valor):Comprueba si un valor no es de tipo texto y y y y y y y y y y y y y y y y y y y .y y y y y y y y y y y y y y y y y y y y y y y 1..número2.número2.La sintaxis de cualquier función es: nombre función(argumento1..) :Devuelve la media armónica de un conjunto de números positivos MAX(número1...) :Comprueba si todos los valores son verdaderos O(valor_logico1.. Elegir la opción Insertar función.tamaño):Devuelve el número de combinaciones para un número determinado de elementos COS(número):Devuelve el coseno de un ángulo ENTERO(número):Redondea un número hasta el entero inferior más próximo EXP(número):Realiza el cálculo de elevar "e" a la potencia de un número determinado FACT(número):Devuelve el factorial de un número NUMERO.número2.MAYOR(matriz....) :Devuelve el valor mínimo de la lista de valores MEDIANA(número1...número2..argumentoN) Siguen las siguientes reglas: Si la función va al comienzo de una fórmula debe empezar por el signo =. Los argumentos o valores de entrada van siempre entre paréntesis. empezando desde una estimación inicial..número2. Ejemplo: =SUMA(A1:C8) Si queremos introducir una función en una celda: Situarse en la celda donde queremos introducir la función...potencia):Realiza el cálculo de elevar un número a la potencia indicada PRODUCTO(número1.. O bien. fórmulas o funciones. Los argumentos pueden ser valores constantes (número o texto). Hacer clic en la pestaña Fórmulas. un método iterativo trata de resolver un problema (como una ecuación o un sistema de ecuaciones) mediante aproximaciones sucesivas a la solución.valor_logico2.núm_divisor) :Devuelve el resto de la división Funciones estadística MEDIA.5 MÉTODOS ITERATIVOS. Aparecerá el siguiente cuadro de diálogo Insertar función: Funciones matemática y trigonométrica ABS(número):Devuelve el valor absoluto de un número ALEATORIO() :Devuelve un número entre 0 y 1 COMBINAT(número..número2.ARMO(número1.número2..) : Devuelve el valor que más se repite en la lista de valores PROMEDIO(número1.k) :Devuelve el valor k-ésimo mayor de un conjunto de datos K. En matemática computacional..número2..ESIMO.. 1.ESIMO.valor_logico2.. hacer clic sobre el botón de la barra de fórmulas.MENOR(matriz..) :Devuelve el valor máximo de la lista de valores MIN(número1.k):Devuelve el valor k-ésimo menor de un conjunto de datos Funciones lógicas FALSO() : Devuelve el valor lógico Falso VERDADERO: Devuelve el valor lógico Verdadero SI(prueba_logica.. Los argumentos deben de separarse por un punto y coma .... Una función es una fórmula predefinida por Excel (o por el usuario) que opera con uno o más valores y devuelve un resultado que aparecerá directamente en la celda o será utilizado para calcular la fórmula que la contiene.):Devuelve la varianza de una lista de valores K.) :Devuelve la mediana de la lista de valores MODA(número1.):Devuelve el resultado de realizar el producto de todos los números pasados como argumentos RAIZ(número):Devuelve la raiz cuadrada del número indicado RESIDUO(número.valor_si_falso) : Devuelve un valor u otro..Análisis de sensibilidad en programación lineal (investigación operativa) con Excel FUCIONES EN EXCEL...ROMANO(número..

impresión y salida del programa € Cada botón de la barra de herramientas Matemáticas abre otra barra de herramientas de operadores o símbolos.Distribución muestral y Teorema Central del Límite (estadística) con Minitab.0 SP2 o posterior. recomendado 512 MB o más. Es el software de análisis estadístico..) ‡ Adobe Acrobat Reader 7. 2. ‡ Internet Explorer versión 6. ‡ Teclado y ratón o dispositivo de puntero compatible. Mathcad es la herramienta de estándar industrial pensada para los cálculos técnicos de ingenieros de todo el mundo. ‡ Microsoft Data Access Components (MDAC) 2.Presentación de conceptos mediante representación gráfica de funciones 3D (análisis) con MathCad. EM64T) compatible con Pentium. ‡ MSXML 4. Estadística aplicaciones informáticas de análisis tienen la ventaja de ser precisa. caracteres griegos y gráficos con estos botones.6 o posterior.0. Windows XP SP2 o posterior. fiable y. Software Windows 2000 SP4. la funcionalidad y la solidez necesarias para el cálculo. Introducción a Mathcad € El espacio de trabajo de Mathcad € Regiones € Cálculos sencillos € Definiciones y variables € Gráficos € Almacenamiento.0. así como investigación estadística. (No es necesario que sea el navegador predeterminado.y y y ESTEXTO(valor) :Comprueba si un valor es de tipo texto ESNUMERO(valor) :Comprueba si un valor es de tipo numérico TIPO(valor) :Devuelve un número que representa el tipo de datos del valor 1. ‡ Unidad de CD-ROM o DVD (sólo para la instalación mediante CD).NET Framework® 2. € € € € € € € € € € € Capacidades de MathCad: Resolver ecuaciones diferenciales con varios métodos numéricos Graficar funciones en dos o tres dimensiones El uso del alfabeto griego (letras griegas mayúsculas y minúsculas) Cálculo de expresiones simbólicas Operaciones con arreglos (vectores y matrices) Solución simbólica de un sistema de ecuaciones Encontrar la gráfica (la curva de tendencia) de un grupo de datos Implementación de subprogramas Encontrar raíces de polinomios y funciones Funciones estadísticas y distribuciones de probabilidad Encontrar valores propios o autovalores y vectores propios o autovectores Requisitos del sistema Hardware: Procesador de 32 (x86) o 64 bits (x86-64. En el CD de Mathcad encontrará los siguientes requisitos: ‡ Microsoft . en general más rápido que las estadísticas de computación y dibujo gráficos a mano.Es utilizado en Windows XP.0. ‡ SVGA o tarjeta de gráficos superior y monitor. ‡ 550 MB de espacio libre en el disco duro (250 MB para Mathcad. ‡ 256 MB de memoria RAM. 100 MB para los requisitos previos y 200 MB de espacio para almacenamiento temporal durante lainstalación). Puede ser utilizado para el aprendizaje acerca de las estadísticas. Se pueden insertar numerosos operadores. la manipulación de datos y el diseño industrial. . Mathcad proporciona todas las capacidades resolutivas. recomendado más de 700 MHz. 400 MHz o superior.

texto y gráficos en toda la hoja. De forma predeterminada.5=. seleccione Región de texto en el menú Insertar o simplemente pulse [³] y comience a escribir. Si tiene abierta una hoja de trabajo de gran tamaño. Cálculos sencillos € Aunque Mathcad puede efectuar cálculos matemáticos complejos. Griego: caracteres griegos. € Simbólica: modificadores y palabras clave simbólicos. Programación: elementos de programación. también puede utilizarse como una simple calculadora. € € Gráfico: herramientas de gráficos y tipos de gráficos en dos y tres dimensiones. Para crear una región de texto. Si la región que desea crear es una región matemática. Verá una cruz pequeña. Para comenzar una nueva región en Mathcad. realice lo siguiente: 1. 2. Para efectuar el primer cálculo.Botón: Barra de herramientas € Calculadora: operadores aritméticos. Cada ecuación. Regiones Mathcad le permite introducir ecuaciones. Escriba 15-8/104. utilice la opción Ir a página del menú Editar para desplazarse con mayor rapidez por la hoja de trabajo. Mathcad entiende que escribe en lenguaje matemático. Matriz: operadores de matrices y vectores. Pulse en una zona en blanco de la hoja de trabajo. € € € Booleano: operadores lógicos y comparativos de una expresión booleana. € Evaluación: signos de igual para la definición y la evaluación. € Cálculo: derivadas.  La barra de herramientas: Estándar permite el acceso rápido a numerosos comandos de menús  La barra de herramientas: Formato contiene botones y listas de desplazamiento para especificar las características de fuente de las ecuaciones y del texto. límites y productos y sumas iteradas. 2. Cuando escriba el signo igual o pulse [ = ] en la barra de herramientas Calculadora. . 3. parte de texto o elemento se considera una región. Mathcad calculará el resultado. Una hoja de trabajo de Mathcad es una colección de todas esas regiones. Puede abrir tantas hojas de trabajo como permitan los recursos del sistema disponibles. Verá una cruz pequeña. siga estos pasos: 1. Trabajo con hojas de trabajo Al iniciar Mathcad.Todo lo que escriba aparecerá en la cruz. Pulse sobre la hoja de trabajo. puede comenzar a escribir donde coloque la cruz. integrales. se abre una hoja de trabajo de Mathcad.

. Escriba acc/2[Espacio]*t^2. escriba d(3. realice lo siguiente: 1. Pulse con el ratón debajo de las dos definiciones. La cruz se desplaza debajo de la primera definición. 2. Las barras de herramientas de matemáticas le permiten introducir numerosos operadores y caracteres griegos. Escriba dos puntos con la tecla correspondiente [:] o pulse en la barra de herramientas Calculadora para insertar un símbolo de definición. Definiciones y variables La versatilidad y eficacia de Mathcad se ponen rápidamente de manifiesto cuando se empiezan a utilizar variables y funciones.8. En primer lugar.8. Para definir acc como ±9. Escriba el nombre de la variable. defina la función d(t) escribiendo d(t): 2. Escriba ahora otra definición: 1.5. escriba: acc:±9. Escriba el valor que se va a asignar a la variable. Gracias a la definición de variables y funciones. puede editarla pulsando en ella e introduciendo nuevos caracteres. como 3.Complete la definición con la expresión: 1600+acc/2[Espacio]*t^2[Intro] Para evaluar la función en un valor específico. 1. podrá utilizarlas en otras expresiones: 1. Tal y como se muestra. € Estos pasos le muestran cómo definir una variable: 1. números y operadores. El valor puede ser un número simple o una combinación compleja de números y variables previamente definidas.5)=. 3.€ Una vez que la ecuación aparece en pantalla. € Ahora que se han definido las variables acc y t. 2. 2. se pueden vincular las ecuaciones y utilizar resultados intermedios en cálculos posteriores. Pulse el signo igual [=]. Definición de funciones Para añadir la definición de una función a la hoja de trabajo. Pulse [Intro].

Formato de resultados Puede definir el formato de visualización de todos los números que Mathcad calcula y muestra en pantalla. Pulse en una zona en blanco de la hoja de trabajo. realice lo siguiente: 1. Pulse la ficha Traza. 3. entre otros. Creación de gráficos básicos: Para crear un gráfico X-Y. Pulse en el resultado. La configuración de este cuadro de diálogo afecta al aspecto de los resultados. Seleccione Gráfico > Gráfico X-Y en el menú Insertar o pulse en la barra de herramientas Gráfico. Seleccione Resultado en el menú Formato para abrir el cuadro de diálogo Formato de resultado. además de gráficos de superficie. de dispersión y de contorno tridimensionales. 2. Estos marcadores de posición pueden contener una función. Pulse dos veces "traza 1" en la celda que aparece bajo "Etiqueta de la leyenda" en la tabla.Pulse dos veces en el gráfico para abrir el cuadro de diálogo Formato. Escriba un nombre para la traza. por ejemplo Displacement. 3. También puede escribir [@]. Puesto que ha definido t como un número simple. no es posible utilizarlo como intervalo de números en un gráfico. incluidos el número de decimales y el empleo de la notación exponencial y de los ceros a la derecha. 2. Mathcad inserta un gráfico X-Y en blanco. Elimine primero el valor de t en la hoja de trabajo. Formato de gráficos 1. Puede definir t como intervalo de valores. 2. Complete los marcadores de posición del eje x (parte central) con t y el marcador de posición del eje y (parte central izquierda) con d(t). 1. . una expresión o el nombre de una variable. Gráficos: Mathcad proporciona una gran variedad de gráficos polares y gráficos X-Y bidimensionales.

Este puede realizar cálculos numéricos y simbólicos. implícita. 7. Mathcad recordará su ubicación la próxima vez que abra la aplicación. De forma predeterminada. RTF de Microsoft Word. Seleccione Guardar en el menú Fichero. Pulse "Aceptar". También es posible guardar el fichero en otros formatos. como HTML. con algebra. Desactive la casilla de verificación "Ocultar leyenda" y seleccione la posición "Inferior izquierda³ para la leyenda. 4. búsquela con el cuadro de diálogo Guardar como. XMCT como plantillas de hojas de trabajo de Mathcad nuevas o en versiones de Mathcad anteriores. € barra de herramientas Estándar. como la leyenda. 2. integrales (definidas e indefinidas). polinomios deTaylor Representación gráfica de funciones en forma explícita. Almacenamiento de hojas de tra: Para guardar una hoja de trabajo: 1. € Impresión: Para imprimir. "Programas de Cálculo Simbólico". paramétrica y en coordenadas polares. Para guardarlo en otra carpeta. vectores y matrices al igual que una calculadora científica. € Salida de Mathcad: Para cerrar Mathcad. que podemos definir como programas para PC que sirven para trabajar con matemáticas usando las notaciones propias (simbólicas) de esta ciencia. . trigonometría y análisis.    ¿Qué se puede hacer conDerive? Operaciones con vectores. además de representaciones graficas en dos y tres dimensiones. XML de Mathcad (. Resolución de ecuaciones diferenciales mediante métodos numéricos (cálculo) con Derive: ¿Qué es derive? Derive es un programa de ordenador. seleccione Vista preliminar en el menú Fichero o pulse en la en la barra de herramientas Estándar. Pulse fuera del gráfico para cancelar la selección. también puede seleccionar Guardar como página Web en el menú Fichero. aparece el cuadro de diálogo Guardar como. expresiones. Resolución de ecuaciones y de sistemas de ecuaciones. matrices y determinantes. 5.4. series. Observe que la línea de muestra de debajo de d(t) refleja ahora el formato nuevo. seleccione Imprimir en el menú Fichero o pulse Para obtener una vista previa de la página impresa. Para guardar como HTML. 8. el cual procesa variables. € € € € Almacenamiento. Derivadas. seleccione Salir en el menú Fichero. límites. el siguiente paso consiste en guardarla o imprimirla.XMCD) o XML de Mathcad comprimido (XMCDZ). 5. Seleccione un grosor de línea de 3 desde la columna siguiente y el color azul en la columna ³Color´. Mathcad muestra el gráfico como una línea punteada. Pulse en la celda de la columna ³Línea´ de la tabla para seleccionar una línea punteada. es decir. impresión y salida del programa Una vez que se ha creado una hoja de trabajo. [Ctrl] S. funciones. entre las que se incluye MCD. Mathcad guarda el fichero en un formato nativo de Mathcad. 6. Si el fichero no se ha guardado antes. Si ha movido las barras de herramientas. Resolución de ecuaciones diferenciales mediante métodos numéricos (cálculo) con Mathematica. Escriba el nombre del fichero en el cuadro de texto que aparece en pantalla.

de modo que aumenta así sensiblemente el espectro de sus aplicaciones. Entradas fijas producen salidas fijas Estático. Es una construcción intelectual y descriptiva de una entidad en la cual un observador tiene interés. (El análisis de sensibilidad puede ayudar). Es una representación de la realidad que ayuda a entender cómo funciona. 6. Estado del sistema como cambios en el tiempo Tiempo-continuo. carreteras. Los cambios de estado del sistema se dan en momentos discretos del tiempo. Simulación Es la construcción de modelos informáticos que describen la parte esencial del comportamiento de un sistema de interés. pero su ejecución en la realidad es difícil o imposible (armas. Operaciones con polinomios y fracciones algebraicas. medicamentos.        ‡ ‡ ‡ ‡ ‡ ‡                . No es posible modificar la realidad. campañas de marketing) Se requiere cambiar el periodo de observación del experimento (cambio climático. La escala de tiempo puede ser alterado según la necesidad. ¿Cuándo no es apropiado simular? Cuando: El desarrollo del modelo de simulación requiere mucho tiempo. Entradas fijas produce salidas diferentes Determinístico. La simulación es imprecisa y no se puede medir su imprecisión. carreteras). hospitales). Es necesario desarrollar experimentos. etc. Programación Pero. El modelo permite que los estados del sistema cambien en cualquier momento. migraciones. El sistema aún no existe (aviones. El sistema simulado imita la operación del sistema actual sobre el tiempo. Tiempo-discreto. Derivese suministra con varios ficheros de funciones para propósitos diversos como resolver ecuaciones diferenciales. observado y analizado. Permite experimentar con sistemas (reales o propuestos) en casos en los que de otra manera esto sería imposible o impráctico. si es que no se dispone de un modelo que la interprete. Uno o más parámetros aleatorios. Un modelo es un sistema desarrollado para entender la realidad y en consecuencia para modificarla. Tipos de modelos: Estocástico. Estado del sistema como un punto en el tiempo Dinámico.  Representación gráfica de funciones de dos variables. La idea es obtener una representación simplificada de algún aspecto de interés de la realidad. trabajar en Álgebra Lineal. así como diseñar y realizar experimentos con el modelo y extraer conclusiones de sus resultados para apoyar la toma de decisiones. problemas nuevos). es posible programar funciones que usen las distintas capacidades del programa. La historia artificial del sistema puede ser generado. El desarrollo del modelo es costoso comparado con sus beneficios. Se construyen para ser transmitidos. Las conclusiones acerca de las características del sistema actual pueden ser inferidos. Supuestos simples son usados para capturar el comportamiento importante. No se puede interrumpir la operación del sistema actual (plantas eléctricas. en cierta dirección. además. Técnicas de modelado y simulación ¿Qué es un modelo? Es una abstracción de la realidad. Se usa como un paradigma para analizar sistemas complejos. ¿Cuándo es apropiado simular? Cuando: No existe una completa formulación matemática del problema (líneas de espera. población).

Se escribe la instrucción o el nombre del programa y se da a Enter. CommandHistory: Muestra los últimos comandos ejecutados en Command Windows. MATrixLABoratory Es un lenguaje de programación (inicialmente escrito en C) pararealizar cálculosnuméricos con vectores y matrices.m . Representación de resolución de ecuaciones con matlab:         ¿Qué es Matlab?.7. Se puede recuperar el comando haciendo doble Currentdirectory: Situarse en el directorio donde se va a trabajar Help(también se puede usar desde comandwindows) Workspace: Para ver las variables que se están usando y sus dimensiones (si son matrices) Editor del Matlab: Todos los ficheros de comandos Matlab deben de llevar la extensión . Cuenta con paquetes de funciones especializadas Elementos básicos del escritorio de Matlab Command Windows: Donde seejecutan todas las instrucciones y programas. tanto reales como complejos. Como caso particular puede también trabajarcon números escalares.

You're Reading a Free Preview

Descarga
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->