P. 1
Laviev Plc

Laviev Plc

|Views: 10|Likes:

More info:

Published by: Jermy Abraham Carrasco on Aug 13, 2013
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as DOCX, PDF, TXT or read online from Scribd
See more
See less

08/14/2014

pdf

text

original

Conecte LabVIEW a Cualquier PLC Utilizando OPC

Fecha de publicación: 21 de noviembre 2012 | 25 calificaciones que | 3,92 FUERA de 5 | PDF

Visión de conjunto
Este artículo es parte de una serie delineando las capacidades del registro de datos LabVIEW and Supervisory Control (DSC) del módulo. Haz clic aquí para ver la lista de otros artículos.

El software NI LabVIEW puede comunicarse con cualquier controlador lógico programable (PLC) en una variedad de maneras. OLE for Process Control (OPC) define el estándar para la comunicación de datos de la planta en tiempo real entre los dispositivos de control e interfaces hombre-máquina (HMI). Servidores OPC están disponibles para casi todos los PLCs y controladores de automatización programables (PACs). En este tutorial, aprenderá a utilizar LabVIEW para comunicarse con un PLC conectado en red utilizando OPC.

Tabla de contenidos
El registro de datos LabVIEW y el Módulo de Control Supervisorio (DSC) se utiliza en este tutorial. Este módulo incluye herramientas para registrar datos en una base de datos histórica en red, en tiempo real y tendencias históricas, la gestión de alarmas y eventos, redes de LabVIEW Real-Time y dispositivos OPC en un sistema completo y añadir seguridad a interfaces de usuario. Con estas características, LabVIEW se convierte en un potente paquete de HMI / SCADA para aplicaciones de control industrial. Requerimientos • Windows 7/Vista/XP • NI LabVIEW Full Development System y LabVIEW DSC • Servidores NI OPC

Ver existentes PLC Etiquetas con NI OPC Servers 2012
Los pasos de esta sección se describen para NI OPC Servers 2012, pero medidas similares pueden ser utilizados para las versiones anteriores de NI OPC Servers. 1. Lanzamiento NI OPC Servers 2012 seleccionando Inicio »Todos los programas» Instrumentos »NI OPC Servers 2012» NI OPC Configuración Nacional de Servidores . Con NI OPC Servers 2012, puede crear, configurar y ver las etiquetas que están asociadas con los PLCs. NI OPC Servers 2012 debe iniciar con un proyecto de simulación de PLC ya cargado. Este proyecto simula PLC que ya se han creado y configurado en NI OPC Servers 2012.

2.

Nota: Si este proyecto de simulación no se ha cargado en NI OPC Servers 2012, seleccione Archivo »Abrir ... y vaya a C: \ Archivos de programa \ National Instruments \ Shared \ NI OPC Servers \ V5 \ Projects \ simdemo.opf . El proyecto debe ser similar a la figura 1.

3. Estas etiquetas. 1. haga clic en Archivo »Nuevo proyecto . que están vinculados a los registros de los PLC. visite dispositivo y controlador compatible Plug-in lista de NIServidor OPC .V5 carpeta y seleccione Examples. En el marco del Nacional Instruments. Ver las etiquetas Sine expandiendo ejemplos de simulación y selección de funciones . Conecte LabVIEW a OPC Tags mediante la creación de un servidor de I / O En esta sección. que se puede utilizar para ver los datos de la etiqueta OPC. se pueden leer en LabVIEW. El I / O Server actualiza automáticamente LabVIEW con los valores de las variables actuales a una tasa que se especifique. NI OPC Quick Client Viendo simulados seno OPC Etiquetas Nota: Para ver una lista de dispositivos / drivers compatibles con NI OPC.Figura 1. inicie el cliente rápida seleccionando Herramientas >> Launch OPC Quick Client . Esto abre un nuevo Proyecto de LabVIEW. 1. Selecciona el dispositivo para supervisar. Las etiquetas pueblan en el extremo derecho de la ventana. Figura 2. 4. Si la Ayuda contextual ventana no está visible. Observe que todas las etiquetas en el seno pueblan más a la derecha y la ventana están actualizando con los datos sinusoidales simuladas como se muestra en la Figura 2. presione Ctrl + H para mostrar la ventana. Ver los datos de las etiquetas OPC del PLC En NI OPC Servers 2012. En la Introducción ventana de LabVIEW. 2. NI OPC Servers 2012 Viendo PLCs simulados 3. Mantenga esta ventana abierta para obtener información útil acerca de los elementos bajo el cursor. 3. En la ventana de Proyecto de LabVIEW. como se muestra en la Figura 3. creará una interfaz de LabVIEW para las etiquetas del OPC llamado I / O Server.NIOPCServers. haga clic derecho en Mi PC y seleccione New »Servidor de E / S . .Funtions simulación . 2.

Creación de un nuevo servidor de E / S a través del Proyecto de LabVIEW 4. 5.Figura 3. Esto crea una conexión de LabVIEW para las etiquetas del OPC. Elija Nacional Instruments.NIOPCServers.V5 del campo servidores OPC registrados y establecer Velocidad de actualización (ms) a 100. que se actualiza cada 100 ms. Seleccione OPC Cliente en la ventana Create New I / O Server y haga clic en Continuar. .

Seleccione Aceptar . puede compartir datos a través de aplicaciones de LabVIEW en un solo equipo o en la red. que le da acceso nativo en LabVIEW a los datos del PLC. 2. 2. Haga clic en la biblioteca recién creada y seleccione Crear variables ligadas . que se unen a las etiquetas del OPC. Crear variables compartidas que conectan con el OPC Etiquetas través del servidor de E / S En esta sección. seleccione las etiquetas del OPC para unir las variables compartidas que por la navegación a los datos simulados seno del servidor OPC como se muestra en la figura 5. crear variables compartidas. 1. Una biblioteca se crea automáticamente en la ventana del explorador de proyectos para administrar el servidor de E / S.La Figura 4. 3. haga clic en Mi PC y seleccione New »Biblioteca . Guarde el proyecto como OPCDemoProject y la biblioteca como OPCDemoLibrary seleccionando Archivo »Guardar todo desde la ventana Explorador de proyectos. Con la variable compartida.. que se utilizan para conectar a las etiquetas de OPC del PLC.. . 7. Configuración del OPC Client I / O Server 6. En la ventana de Proyecto de LabVIEW. Crear nuevas variables compartidas que están obligados a etiquetas OPC del PLC. 1. En la ventana Crear variables Bound. Esto crea una nueva biblioteca para las variables compartidas.

Pase el ratón sobre las diferentes categorías para explorar los componentes de interfaz de usuario en LabVIEW. . Haga clic con elOPCItems biblioteca y seleccione Lista de Vigilancia para visualizar las variables compartidas. Seleccione un gráfico de forma de onda de la paleta de controles. 2. cuadros. aparece el panel frontal. 3. seleccione Herramientas »Distributed System Manager . 3. haga clic en Mi PC y seleccione New »VI . 4. desplegar. Ahora tiene acceso a los datos del PLC de forma nativa en LabVIEW a través de las variables compartidas. seleccionando expreso »Gráfico Indicadores» Gráfico . Por defecto. poniéndolas a disposición de la red a otros equipos. Seleccione todos los elementos sinusoidales y haga clic en Agregar y en Aceptar.lvlib en la ventana Explorador de proyectos. como se muestra en la Figura 6. relojes. Utilizando OPC Tag de datos en LabVIEW 1. En la ventana Explorador de proyectos. Desde el Explorador de proyectos. tales como gráficos. Esto crea un nuevo instrumento virtual o VI. etc. haga clic en la biblioteca OPCItems y seleccionando Deploy . Un VI se utiliza para crear una interfaz de usuario gráfica y el código ejecutable. Nota: El administrador del sistema distribuido es nuevo en LabVIEW 8. LabVIEW tiene muchos componentes integrados de interfaz de usuario. que se unen a las etiquetas OPC del PLC. replegar. 3. 5. Esta publica las variables compartidas. Visualización de variables compartidas con Distributed System Manager 1. Esto abre una ventana que puede utilizar para administrar sus variables compartidas de diversas maneras (ver. clientes OPC y el LabVIEW Real-Time PAC . Las versiones anteriores de LabVIEW hicieron esto de ir aHerramientas »variable compartida» administrador de variables y arrastrando las variables compartidas en las Variables Vistos:ventanas. alarmas y eventos directamente a una base de datos sin tener que escribir una aplicación de LabVIEW. Implementar las variables compartidas.) En el panel del árbol del Administrador de variables. seleccione Hecho . Seleccione View »Controls Palette o haga clic en cualquier lugar en el panel frontal para abrir la paleta de controles. que es la interfaz de usuario de la VI. que se pueden utilizar para construir una poderosa interfaz de usuario intuitiva. y colocarlo en el panel frontal. expanda el elemento localhost en la categoría Mi Systems.6. Esto agrega las nuevas variables compartidas para la biblioteca que se creó anteriormente. En el editor de variables múltiples. 2. haga clic en la biblioteca y seleccionarGuardar como . etc. 2.Figura 5. Esto crea variables compartidas que están vinculados a las etiquetas y los carga en el editor de variables múltiples OPC del PLC. Seleccione OPC Etiquetas enlazar a variables compartidas 4. Las variables compartidas se actualizan con los datos sinusoidales simulados. Guarde la nueva biblioteca como OPCItems. Nota: El Módulo LabVIEW DSC aumenta variables compartidas mediante la adición de la capacidad de registrar los datos.

La Figura 6. Seleccione un gráfico de forma de onda de la paleta Controls .

6. 7. 8. Seleccione el alambre Connect herramienta como se muestra en la Figura 8. Arrastre y suelte el Sine1 variable compartida desde el explorador de proyectos con el Diagrama de bloques del VI. Seleccione View »Herramientas Paleta o presione Shift + clic derecho para mostrar la paleta de herramientas. El Diagrama de Bloques es donde se genera el comportamiento de la aplicación. que selecciona la herramienta adecuada en función de la ubicación del cursor. seleccionar Window »Show Diagram Bloquear o presione Ctrl + E para mostrar el diagrama de bloques.Figura 7. Waveform Chart Situado en el panel frontal 4. 5. que contiene varias herramientas para construir el diagrama de bloques. Esta herramienta se utiliza para conectar los terminales juntos en el diagrama de bloques. En el VI. Al pasar los datos en este terminal. En el Explorador de proyectos. . Observe el icono del diagrama de bloques que representa la tabla en el panel frontal. se puede visualizar en el gráfico en el panel frontal. Por defecto se utiliza la herramienta de selección automática de la herramienta. expanda el OPCItems biblioteca y seleccione la Sine1 variable compartida. La variable compartida actúa como una fuente de datos a otros terminales en el diagrama de bloques.

haga clic en el Sine1 variable compartida y luego en el gráfico de forma de onda . Seleccione la herramienta de alambre Connect 9. desplácese a Programación »Estructuras» While Loop . La paleta de funciones contiene cientos de funciones de análisis. Seleccione la herramienta de selección automática de herramientas de la paleta de herramientas. La Figura 10.Figura 8. Conexión Diagrama de bloques Artículos Ahora los flujos de datos de la variable compartida a la tabla de forma de onda cuando el VI se está ejecutando. 10. Utilice el alambre Connect herramienta para conectar el Sine1 variable compartida a la gráfica de forma de onda . Abra la paleta de funciones seleccionando View »Functions Palette o clic con el botón derecho en cualquier lugar en el diagrama de bloques. 12. Selección automática de la herramienta de la paleta de herramientas 11. Esto permite ajustar un loop mientras que alrededor de una sección de código. Cableado de los terminales Together Terminales conectados La Figura 9. funciones de control y estructuras de programación gráfica. Seleccionar un bucle while de la paleta de funciones. . Una vez seleccionado el bucle while. como se muestra en la Figura 9. el cursor aparece como se muestra en la Figura 12.

La Figura 11. Utilizando el cursor bucle while. Mientras Cursor Loop 13. Selección de un bucle While Figura 12. haga clic en el Loop Condición y seleccionar Crear control . Ahora cree un control de parada en bucle while.Esto coloca un botón Detener en el panel frontal que permite al usuario detener el VI. coloque un bucle while en todo el variable compartida y el gráfico de forma de onda haciendo clic y arrastrando el cursor. .

Un esperar hasta el próximo ms múltiple VI se debe añadir al bucle de manera que el ciclo se ejecutará cada cantidad del sistema de segundo. . 14.La Figura 13. pondrá en funcionamiento lo más rápido posible. A medida que el bucle while es ahora. en este caso 100 ms. La colocación de un ciclo Mientras en todo el Shared Variable y gráfico de forma de onda El bucle while hace que el código dentro de él para ejecutar continuamente hasta que se detiene por el usuario o la lógica adicional en el VI.

Botón Ejecutar 17. Cuando la aplicación empieza a ejecutarse. Vuelva al panel frontal.La Figura 14. . verá la onda sinusoidal Sine1 muestra en el gráfico de forma de onda. La Figura 17. Adición de temporización al Loop While 15.. seleccionando Window »Show Panel frontal o pulsando Ctrl + E .. 16. Haga clic en el Run botón en la barra de herramientas para ejecutar el VI. ventana una vez que la implementación se completa. Haga clic en Cerrar en el Deploy .

para que puedas incorporar potentes funciones de análisis y control de la solución.Figura 18. Completo panel frontal . . ¡Enhorabuena! Se accede con éxito los datos del PLC en su aplicación de LabVIEW.Viendo PLC de datos en un gráfico de forma de onda 18.

You're Reading a Free Preview

Descarga
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->