Está en la página 1de 24

HOJA DE CLCULO EXCEL

FRMULAS
Una frmula introducida en una celda puede estar compuesta de
cualquiera de los siguientes elementos:
Operadores como el signo (+) para la suma, o el signo (*) para la
multiplicacin, o el signo (/) para la divisin, o el signo (-) para la resta o el
signo (^) para la potencia.
Referencias de celdas (incluyendo celdas de rangos con nombre)
Valores o cadenas
Funciones de hoja de clculo (como SUMA o PROMEDIO)

Una frmula puede estar formada por 1024 caracteres. Despus de


introducir una frmula en una celda, sta presenta el resultado de la
frmula que aparece en la barra de frmulas cuando la celda est activa.

Ofimtica - Excel Parte 2

HOJA DE CLCULO EXCEL


Referencias de celdas y rangos
La referencia de celda tiene cuatro estilos:
Relativa. La referencia es totalmente relativa. Cuando se copia la frmula,
la referencia de la celda se ajusta a su nueva colocacin. Por ejemplo, A1.
Absoluta. La referencia es totalmente absoluta. Cuando se copia la
frmula, la referencia de la celda no cambia. Por ejemplo $A$1.
Fila Absoluta. La referencia es parcialmente absoluta. Cuando se copia la
frmula, la parte de la columna se ajusta, pero la parte de la fila no
cambia. Por ejemplo: A$1.
Columna Absoluta. La referencia es parcialmente absoluta. Cuando se
copia la frmula, la parte de la fila se ajusta, pero la parte de la columna
no cambia. Por ejemplo: $A1.
Todas las referencias de celdas y rangos son relativas por defecto. Para
cambiar una referencia basta con aadir el signo del dlar ($)
manualmente.
Ofimtica - Excel Parte 2

HOJA DE CLCULO EXCEL


Ejemplo de referencias no relativas

Ofimtica - Excel Parte 2

HOJA DE CLCULO EXCEL


Referenciar otras hojas o libros de clculo
Las referencias a celdas y rangos no deben encontrarse necesariamente en
la misma hoja de la frmula. Para referirse a una celda de una hoja de
clculo diferente hay que colocar, antes de la referencia de la celda, el
nombre de la hoja seguida por un signo de exclamacin.
=Hoja2!A1+1
Tambin es posible crear frmulas de vnculo para referirse a una celda de
un libro de trabajo diferente. Para ello hay que anotar, antes de la
referencia de la celda, el nombre del libro (entre corchetes), el nombre de
la hoja de clculo y el signo de exclamacin.
=[Libro1]Hoja1!A1+1

Ofimtica - Excel Parte 2

HOJA DE CLCULO EXCEL


Referenciar otras hojas o libros de clculo
Si el libro de trabajo incluye en la referencia uno o ms espacios, es
necesario encerrarlo (y el nombre de la hoja) entre apstrofos. Por
ejemplo:
=[Base de datos.xls]Hoja8!A1+1
Si el libro de trabajo est cerrado, es necesario aadir la ruta de acceso a la
referencia del libro de trabajo. He aqu un ejemplo:
=C:\Mis Documentos\[Base de datos.xls]Hoja8!A1+1

Ofimtica - Excel Parte 2

HOJA DE CLCULO EXCEL


El uso de nombres
Se pueden nombrar celdas, rangos, filas, columnas, grficos y otros
objetos. Una ventaja nica que proporciona Excel es la de poder asignar
nombres a valores o frmulas que ni siquiera aparecen en las celdas de la
hoja de clculo.

Nombrar celdas y rangos


Se pueden crear nombres para las celdas o los rangos mediante
INSERTAR NOMBRE DEFINIR (o presionando Control-F3).
Se puede elegir INSERTAR NOMBRE CREAR para la creacin de
nombres automticamente para celdas o rangos basados en ttulos de filas
o columnas de una hoja de clculo.

Ofimtica - Excel Parte 2

HOJA DE CLCULO EXCEL


Nombrar celdas y rangos
Por ejemplo en la siguiente figura, B2:E2 tienen designado el nombre Norte,
B3:E3 se denomina Sur, y as sucesivamente. Verticalmente, B2:B5 tiene
designado el nombre de Trim-1, C2:C5 el de Trim-2, etc.

Ofimtica - Excel Parte 2

HOJA DE CLCULO EXCEL


Aplicar nombres a referencias existentes
Si se crea un nuevo nombre para una celda o rango, Excel no usa
automticamente el nombre en lugar de las referencias existentes en las
frmulas. Por ejemplo, suponiendo que existe la siguiente frmula en la
celda F10:
=A1-A2
Si se define el nombre Ingresos para la celda A1 y Gastos para la celda A2,
Excel no cambiar automticamente la frmula a =Ingresos-Gastos. Sin
embargo, es bastante fcil reemplazar las referencias a celdas o rangos por
sus correspondientes nombres. Primero hay que seleccionar el rango que
se quiere modificar. Despus se elige el comando INSERTAR, NOMBRE,
APLICAR. En el cuadro de dilogo Aplicar nombres hay que seleccionar
los nombres que se quieren aplicar y despus hacer clic en el botn
Aceptar. Excel reemplaza las referencias del rango con los nombres en las
celdas seleccionadas.
Ofimtica - Excel Parte 2

HOJA DE CLCULO EXCEL


Interseccin de nombres
Excel posee un operador especial denominado operador de interseccin
que aparece cuando est trabajando con rangos. Este operador es el
operador espacio. Al usar nombres con el operador interseccin se facilita
la creacin de frmulas significativas. Por ejemplo la siguiente frmula
=Trim-2 Sur
devolver el resultado 180 (o interseccin del rango Trim-2 y el rango Sur.
Para obtener el total de la regin Oeste, se puede usar la funcin:
=SUMA(Oeste)
Ofimtica - Excel Parte 2

HOJA DE CLCULO EXCEL


Designar nombres para columnas y filas
Con Excel tambin se pueden designar nombres para filas y columnas
completas. En el ejemplo anterior, se ha asignado el nombre Trim-1 al rango
B2:B5. De forma alternativa, se puede designar el nombre Trim-1 a toda la
columna B, Trim-2 a toda la columna C, etc...

mbito de los nombres


Normalmente, una celda o rango denominado tiene un mbito a nivel de un libro
de clculo; en otras palabras, se puede usar el nombre en cualquier hoja de
clculo de un libro.
Los nombres que tienen un mbito de hoja de clculo se podrn usar slo en la
hoja donde fueron definidos; de hecho, un nombre de este tipo no ser visible en
el Cuadro de nombres de una hoja en la que no est definido. Tampoco se
encontrar el nombre al nivel de una hoja de clculo en el cuadro de dilogo
definir nombre de cualquier hoja en la que no est definido.
Ofimtica - Excel Parte 2

10

HOJA DE CLCULO EXCEL


mbito de los nombres
Para crear un nombre a nivel de una hoja de clculo, se debe definir el mismo
precedido por el nombre de la hoja, por ejemplo:
=Hoja1!Ventas

Nombrar constantes

Esto se hace con la opcin INSERTAR DEFINIR NOMBRE.


Ofimtica - Excel Parte 2

11

HOJA DE CLCULO EXCEL


Nombrar frmulas
Adems de nombrar celdas, rangos y constantes tambin se puede introducir una
frmula directamente en la casilla Se refiere a: del cuadro de dilogo Definir
nombre para crear el nombre de la frmula.

Ofimtica - Excel Parte 2

12

HOJA DE CLCULO EXCEL


Funciones
Las funciones de una hoja de clculo permiten realizar clculos u operaciones
que, de otra forma, seran imposibles de realizar.
La forma ms sencilla de localizar la funcin deseada es utilizar el cuadro de
dilogo Pegar funcin. El acceso a dicho cuadro de dilogo se efecta haciendo
clic en el botn de Pegar Funcin de la barra de herramientas Estndar (o
seleccionando INSERTAR, PEGAR FUNCION).
Se da clic sobre el botn fx, o se
utiliza la opcin Insert Function.

En la caja de dilogo, se
selecciona la funcin que
quiero aplicar. Fjese que
estn organizadas en
categoras.
Ofimtica - Excel Parte 2

13

HOJA DE CLCULO EXCEL


Funciones

Ofimtica - Excel Parte 2

14

Funciones
Ejemplo:

Para sumar una serie de datos...

Puede usar la frmula:


=d1+d2+d3+d4+d5, o

Puede usar la funcin:


=SUM(d1:d5).

Ofimtica - Excel Parte 2

15

HOJA DE CLCULO EXCEL


Ejemplos de funciones:

=PROMEDIO(nmero1; nmero2, ...)


=SUMA(nmero1; nmero2; ...)
=SI(prueba_lgica;valor_si_verdadero; valor_si_falso)
=CONTAR.SI(A1:A3;"<>SUSPENSO")

Ofimtica - Excel Parte 2

16

Funciones en Excel
Hay funciones matemticas y trigonomtricas, estadsticas,
financieras, de texto, de fecha y hora, lgicas, de base de
datos, de bsqueda y referencia y de informacin.
siguen las siguientes reglas:
Si la funcin va al comienzo de una frmula debe empezar por el signo =.
Los argumentos o valores de entrada van siempre entre parntesis. No
dejes espacios antes o despus de cada parntesis.
Los argumentos pueden ser valores constantes (nmero o texto), frmulas
o funciones.
Los argumentos deben de separarse por un punto y coma ;.
Ejemplo: =SUMA(A1:C8)

Ofimtica - Excel

17

HOJA DE CLCULO EXCEL


Ejemplos de funciones:
=SUMA.SI(rango; criterio; rango_suma)

Ofimtica - Excel Parte 2

18

HOJA DE CLCULO EXCEL


Categoras de funciones
Financieras
Fecha y Hora
Matemticas y Trigonomtricas
Estadsticas
Bsqueda y referencia
Bases de Datos
Texto
Lgicas
Informacin
Ofimtica - Excel Parte 2

19

AutoSum

Ofimtica - Excel Parte 2

20

Copiar frmulas y funciones


El fill handleaparece en la parte inferior
derecha de la celda activa.
Al poner el cursor sobre el fill handle,
ste se convierte en una cruz color negro.
Al dar clic y arrastrar se copia el contenido
de la celda hacia la direccin trazada.
FILL HANDLE

Ofimtica - Excel Parte 2

21

Copiar frmulas y funciones


(cont.)
Fjese que al copiar frmulas o funciones,
las referencias de celda o datos van
cambiando.
Si usted est copiando un valor que debe
mantenerse fijo, tiene que convertirlo a lo
que se conoce como Referencia absoluta,
sta se plantea as: $C$4.
Ofimtica - Excel Parte 2

22

Relativa/Absoluta
Relativa
Absoluta

Ofimtica - Excel Parte 2

23

Clculo automtico

Ofimtica - Excel Parte 2

24