Está en la página 1de 8

Cisco Devices - VoIP Services

Setup Interfaces basic configuration


R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 192.168.10.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface serial 0/0
R1(config-if)#ip address 10.10.10.1 255.255.255.252
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
R1(config-if)#exit

R2(config)#interface fastEthernet 0/0


R2(config-if)#ip address 172.16.10.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface serial 0/0
R2(config-if)#ip address 10.10.10.2 255.255.255.252
R2(config-if)#clock rate 64000
R2(config-if)#no shutdown
R2(config-if)#exit

Confgure Routing Protocol.

R1(config)#router eigrp 25
R1(config-router)#network 192.168.10.0 0.0.0.255
R1(config-router)#network 10.10.10.0 0.0.0.3
R1(config-router)#exit
R1(config)#key chain EIGRPAUTH
R1(config-keychain)#key 1
R1(config-keychain-key)#key-string WSA2012*
R1(config-keychain-key)#end
R1#configure terminal

1
Cisco Devices - VoIP Services

R1(config)#interface Serial 0/0


R1(config-if)#ip authentication mode eigrp 25 md5
R1(config-if)#ip authentication key-chain eigrp 25 EIGRPAUTH
R1(config-if)#end

R2(config)#router eigrp 25
R2(config-router)#network 172.16.10.0 0.0.0.255
R2(config-router)#network 10.10.10.0 0.0.0.3
R2(config-router)#exit
R2(config)#key chain EIGRPAUTH
R2(config-keychain)#key 1
R2(config-keychain-key)#key-string WSA2012*
R2(config-keychain-key)#end
R2#configure terminal
R2(config)#interface Serial 0/0
R2(config-if)#ip authentication mode eigrp 25 md5
R2(config-if)#ip authentication key-chain eigrp 25 EIGRPAUTH
R2(config-if)#end

Key chain EIGRPAUTH Creates a key chain for authentication

Key 1 Will be the key 1 on this key chain

Key-string WSA2012* Sets the key for the keychain

All EIGRP traffic on this interface will


Ip authentication mode eigrp 25 md5
be encrypted with md5
The key to use in order to secure
Ip authentication key-chain eigrp 25
traffic on both sides is specified by
EIGRPAUTH
the key-chain.

Setup a DHCP Pool for clients to connect

R1(config)#ip dhcp pool POOL1


R1(dhcp-config)#network 192.168.10.0 255.255.255.0
R1(dhcp-config)#default-router 192.168.10.1
R1(dhcp-config)#option 150 ip 192.168.10.1
R1(dhcp-config)#exit

R2(config)#ip dhcp pool POOL1


R2(dhcp-config)#network 172.16.10.0 255.255.255.0
R2(dhcp-config)#default-router 172.16.10.1
R2(dhcp-config)#option 150 ip 172.16.10.1
R2(dhcp-config)#exit

Option 150 sets a TFTP server for clients receiving DHCP addressing

2
Cisco Devices - VoIP Services

Configure Telephony Service parameters that enable voip services in the router

R1(config)#telephony-service
R1(config-telephony)#max-ephones 72
R1(config-telephony)#max-dn 277
R1(config-telephony)#auto assign 1 to 100
R1(config-telephony)#auto assign 60 to 140
R1(config-telephony)#ip source-address 192.168.10.1 port 2000
R1(config-telephony)#exit

R2(config)#telephony-service
R2(config-telephony)#max-ephones 72
R2(config-telephony)#max-dn 277
R2(config-telephony)#auto assign 1 to 100
R2(config-telephony)#auto assign 60 to 140
R2(config-telephony)#ip source-address 172.16.10.1 port 2000
R2(config-telephony)#exit

telephony-service Enters global telephony configuration mode.

max-ephones 72 Sets the maximum ethernet phones that are able to


register
max-dn 277 Sets the maximum directory numbers to assign to
registered ephones
auto assign 1 to 100 Directory number 1 to 100 will be auto assigned to
first registered ephones
auto assign 60 to 140 Directory number 60 to 140 will be auto assigned to
first registered ephones
ip source-address 192.168.10.1 port 2000 IP Address of VoIP server (192.168.10.1) using cisco’s
default VoIP port (2000)

Create some directory numbers in order to test the service

R1(config)#ephone-dn 1
R1(config-ephone-dn)#number 1000
R1(config-ephone-dn)#exit
R1(config)#ephone-dn 2
R1(config-ephone-dn)#number 2000
R1(config-ephone-dn)#exit

R2(config)#ephone-dn 1
R2(config-ephone-dn)#number 3000
R2(config-ephone-dn)#exit
R2(config)#ephone-dn 2
R2(config-ephone-dn)#number 4000
R2(config-ephone-dn)#exit

3
Cisco Devices - VoIP Services

Ephone-dn 1 Ethernet Phone Directory Number 1 configuration

Number 3000 Number to assign to first ephone directory number


registered.

Dial-Peer allows numbers from a network to call to another network that’s using a range of dn totally
different from the ones configured locally. This is the dial-peer configuration used in this topology:
R1(config)# dial-peer voice 1 voip
R1(config-dial-peer)#session target ipv4:10.10.10.2
R1(config-dial-peer)#destination-pattern 3...
R1(config-dial-peer)#exit
R1(config)# dial-peer voice 2 voip
R1(config-dial-peer)#session target ipv4:10.10.10.2
R1(config-dial-peer)#destination-pattern 4...
R1(config-dial-peer)#exit

R2(config)# dial-peer voice 1 voip


R2(config-dial-peer)#session target ipv4:10.10.10.1
R2(config-dial-peer)#destination-pattern 1...
R2(config-dial-peer)#exit
R2(config)# dial-peer voice 2 voip
R2(config-dial-peer)#session target ipv4:10.10.10.1
R2(config-dial-peer)#destination-pattern 2...
R2(config-dial-peer)#exit

Sets a voice tag intended for VoIP traffic transmission


Dial-peer voice 1 voip
with a Dial-peer
Specifies which peer will be the dial-peer for the
Session target ipv4:10.10.10.2
connection

Destination-pattern 3... The dial pattern of the dial-peer’s network.

TESTING VOIP SERVICES WITH CISCO IP COMMUNICATOR

1. Clients will register to the default TFTP server specified in the DHCP Pool we created, automatically
they’ll register to the first ephone-dn available.

4
Cisco Devices - VoIP Services

2. Test dial-peer configuration by dialing any of the registered ephones.

3. Session is initiated, users can call each other.

5
Cisco Devices - VoIP Services

4. Re-Register each Softphone to the contrary network, in order to register a different MAC and make
use of the other extension.

6
Cisco Devices - VoIP Services

5. After softphones have re-registered to the other server, test settings by dialing the other user’s
number.

7
Cisco Devices - VoIP Services

También podría gustarte