Está en la página 1de 3

COMANDOS PARA CONFIGURACIÓN DE PUERTOS CON VLANS Y

MODOS DE PUERTOS EN SWITCH

Switch(config)#interface fastEthernet 0/1 (se selecciona la interfaz a configurar)


Switch(config-if)#switchport mode trunk (para interfaz en modo troncal)
Switch(config-if)#switchport mode access (para interfaz en modo acceso)
Switch(config-if)#switchport access vlan xx (xx es el número de vlan a la cual
pertenecerá ese puerto)
Switch(config-if)#switchport voice vlan xx (xx es el número de vlan a la cual
pertenecerá el puerto de voz)
Switch(config-if)#spanning-tree portfast (solamente para puertos access)

COMANDOS PARA CONFIGURACIÓN BÁSICA DE ROUTER


(DIRECCIONES IP - DHCP - RUTA ESTATICA)

Router(config)#interface fastEthernet 0/1.ID (se selecciona la interfaz a configurar


y donde se configurar la sub interfaz, id es el número de la vlan asignada a la sub
interfaz)
Router(config-subif)#encapsulation dot1Q ID (el ID es el número de la vlan
asignada a la sub interfaz)
Router(config-subif)#ip address dir-ip mascara-subred (la direccion ip
corresponde a una dir de host)
Router(config-if)#exit
Router(config)#interface fastEthernet 0/1 (se entra a la interfaz a la cual pertenece
la o las sub interfaces creadas)
Router(config-if)#no shutdown
Router(config-if)#exit

Router(config)#ip dhcp excluded-address xxx (xxx el la dir ip que se desea excluir


en el server dhcp, generalmente las direcciones asignadas estaticamente)
Router(config)#ip dhcp pool xxx (xxx es el nombre del pool del server DHCP)
Router(dhcp-config)#network dir-de-red mascara-subred (la direccion ip
corresponde a la dirección ip de la red)
Router(dhcp-config)#default-router dir-ip-gateway (la direccion ip gateway
corresponde a la dirección asignada en el puerto del router de esa sub red)
Router(dhcp-config)#option 150 ip dir-ip-gateway (solo se configura si ese pool
DHCP va a asignar direcciones ip a teléfonos IP)
Router(dhcp-config)#exit

Router(config)#ip route dir-red-no-conocida mascara dir-ip-siguiente-salto


COMANDOS PARA CONFIGURACIÓN DEL CISCO CALL MANAGER

Router(config)#telephony-service
Router(config-telephony)#max-ephones xx (xx es el # de teléfonos que se van a
configurar)
Router(config-telephony)#max-dn xx (xx es el # de extensiones que se van a crear)
Router(config-telephony)#no auto-reg-ephone (este comando se utiliza si no se
quiere un auto registro de los teléfonos ip)
Router(config-telephony)#auto assign 1 to x (este comando se usa cuando se quiere
que los telefonos se auto registen, 1 to x indica q se autoregistrarán de 1 a 5
teléfonos )
Router(config-telephony)#ip source-address dir-ip-gateway port 2000 (la direccion
ip gateway se usa como dir ip del server VoIP de Cisco)
Router(config-telephony)#exit

Router(config)#ephone-dn 1 (1 es el numero de la cuenta donde se va a configurar


la extensión)
Router(config-ephone-dn)#number xxx (xxx es el número de la extensión)
Router(config-ephone-dn)#exit

Para teléfonos que no se auto registran...

Router(config)#ephone xx (xx es el # del telefono a configurar)


Router(config-ephone)#mac-address xxx (xx es el # de la mac de la vlan en el
teléfono a configurar)
Router(config-ephone)#button 1:1 (el primer # corresponde a la cuenta 1 del
teléfono y el segundo 1 corresponde al dn1 creado anteriormente, cambia de
acuerdo al dn a configurar en el teléfono)
Router(config-ephone)#type 7960 (7960 corresponde al tipo de dispositivo
configurado, es decir teléfono ip cisco)
Router(config-ephone)#exit

COMANDOS PARA CONFIGURACIÓN DIAL PEER

Router(config)#dial-peer voice 20 voip (20 puede ser cambiado por cualquier


número y se recomienda que sean los primeros números q coinciden de las
extensiones del servidor voip diferente al que se está configurando)
Router(config-dial-peer)#destination-pattern 20. (20 puede ser cambiado por los
primeros números q coinciden de las extensiones del servidor voip diferente al
que se está configurando y el punto sirve para que conicida cualquier número )
Router(config-dial-peer)#session target ipv4:172.16.0.2 (172.16.0.2 es la dir ip del
puerto del siguiente salto hacia el servidor ip para donde va)
COMANDOS PARA CONFIGURACIÓN QOS

Switch(config)#mlsqos
Switch(config)#interface fastEthernet0/1 (se selecciona y configura en cada interfaz
q conecta directamente a un teléfono)

Se pone algún comando de los siguientes acorde a la necesidad:

Switch(config-if)#mls qos cos 5 (5 hace referencia al servicio VoIP y se pone si se


quiere que confíe plenamente en el servicio de telefonía )

Switch(config-if)#mls qos trust device cisco-phone (Se pone si se quiere que confíe
plenamente en el dispositivo )

Switch(config-if)#mls quos trust cos (Se pone si se quiere que confíe en cualquier tipo
de servicio o dispositivo q se conecte ene se puerto, osea algo genérico)

También podría gustarte