Está en la página 1de 24

1.

OBJETIVOS:

1.

Configurar OSPF bsico para el esquema de red mostrado. Publicar


todas las redes conectadas a cada router en OSPF usando el mtodo
ms simple disponible. Para inyectar redes externas en el dominio
OSPF, redistribuir las rutas estticas en R1. Estas rutas deberan ser
marcadas como tipo E1.

2.

OSPF nunca debera formar relaciones de vecindario en cualquier


interfaz donde otros routers OSPF no existen (como se muestra en el
diagrama).

3.

Todos los routers del rea 0 deberan usar autenticacin MD5 con sus
vecinos. Los routers en el rea 23 deberan ser configurados para
soportar autenticacin en texto plano con sus vecinos. Todas las claves
deben ser configuradas como cisco.

4. Los routers del rea 45 estn limitados en su capacidad y no deberan


recibir rutas de redes externas al dominio OSPF. Estos routers deberan
alcanzar la red externa usando una ruta por defecto la cual no puede ser
configurada estticamente.
5.

Los routers del rea 23 no deben recibir ningn LSA tipo 3, 4 o 5


del resto de la red OSPF. Estos routers deberan alcanzar la red
externa usando una ruta por defecto con un costo inicial OSPF de
100.

6. Cuando se complete el ejercicio, todos los routers deberan poder hacer


ping a cada ruta en la tabla de enrutamiento OSPF.

2.

DESARROLLO:

Objetivos:
1. Configurar OSPF bsico para el esquema de red
mostrado. Publicar todas las redes conectadas a cada
router en OSPF usando el mtodo ms simple
disponible. Para inyectar redes externas en el dominio
OSPF, redistribuir las rutas estticas en R1. Estas rutas
deberan ser marcadas como tipo E1.
CONFIGUARACION DE INTERFACE PARA CADA AREA
AREA 0

R1#configure terminal
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 10.100.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#exit
R1#
R2#configure terminal
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 10.100.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#exit
R2#
R4#configure terminal
R4(config)#interface fastEthernet 0/0
R4(config-if)#ip address 10.100.1.4 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#exit
R4#
R6#configure terminal
R6(config)#interface fastEthernet 0/0
R6(config-if)#ip address 10.100.1.6 255.255.255.0
R6(config-if)#no shutdown
R6(config-if)#exit
R6(config)#exit
R6#

AREA 23

R2#configure terminal
R2(config)#interface serial 0/0
R2(config-if)#ip address 10.23.1.2 255.255.255.0
R2(config-if)# bandwidth 500
R2(config-if)# clock rate 500000
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#exit
R2#
R3#configure terminal
R3(config)#interface serial 0/0
R3(config-if)#ip address 10.23.1.3 255.255.255.0
R3(config-if)# bandwidth 500
R3(config-if)# clock rate 500000
R3(config-if)#no shutdown

R3(config-if)#exit
R3(config)#exit
R3#
CREACION DE LAS INRTEFACES LOOPBACK
R3#configure terminal
R3(config)#interface loopback 0
R3(config-if)# ip address 172.30.0.1
R3(config)#interface loopback 1
R3(config-if)# ip address 172.30.1.1
R3(config)#interface loopback 2
R3(config-if)# ip address 172.30.2.1
R3(config)#interface loopback 3
R3(config-if)# ip address 172.30.3.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#exit
R3#

255.255.255.0
255.255.255.0
255.255.255.0
255.255.255.0

AREA 45

R4#configure terminal
R4(config)#interface serial 0/0
R4(config-if)#ip address 10.45.1.4 255.255.255.0
R4(config-if)# bandwidth 500
R4(config-if)# clock rate 500000
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#exit
R4#
R5#configure terminal
R5(config)#interface serial 0/0
R5(config-if)#ip address 10.45.1.5 255.255.255.0
R5(config-if)# bandwidth 500
R5(config-if)# clock rate 500000
R5(config-if)#no shutdown
R5(config-if)#exit
R5(config)#exit
R5#

AREA 67

R6#configure terminal
R6(config)#interface serial 0/0
R6(config-if)#ip address 10.67.1.6 255.255.255.0
R6(config-if)# bandwidth 500
R6(config-if)# clock rate 500000
R6(config-if)#no shutdown
R6(config-if)#exit
R6(config)#exit
R6#
R7#configure terminal
R7(config)#interface serial 0/0
R7(config-if)#ip address 10.67.1.7 255.255.255.0
R7(config-if)# bandwidth 500
R7(config-if)# clock rate 500000
R7(config-if)#no shutdown
R7(config-if)#exit
R7(config)#exit
R7#
AREA78

R7#configure terminal
R7(config)#interface serial 0/1
R7(config-if)#ip address 10.67.1.7 255.255.255.0
R7(config-if)# bandwidth 500
R7(config-if)# clock rate 500000
R7(config-if)#no shutdown
R7(config-if)#exit
R7(config)#exit
R7#
R8#configure terminal
R8(config)#interface serial 0/0
R8(config-if)#ip address 10.67.1.8 255.255.255.0
R8(config-if)# bandwidth 500
R8(config-if)# clock rate 500000
R8(config-if)#no shutdown

R8(config-if)#exit
R8(config)#exit
R8#

VERIFICACION DE LA RED
R3#ping 10.100.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.100.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/32/44 ms
R3#
R8#ping 10.45.1.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.10, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R8#

NO EXISTE ENLACE ENTRE R8 Y EL RESTO DE LAS AREAS,


FALTA ENLACE VIRTUAL
CONFIGURACION DE OSPF
R1#configure terminal
R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)# network 10.100.1.0 0.0.0.255 area 0
R1(config-router)#exit
R1(config)#exit
R1#
R2#configure terminal
R2(config)#router ospf 1
R2(config-router)#router-id 2.2.2.2
R2(config-router)# network 10.23.1.0 0.0.0.255 area 23
R2(config-router)# network 10.100.1.0 0.0.0.255 area 0
R2(config-router)#exit
R2(config)#exit
R2#
R3#configure terminal
R3(config)#router ospf 1
R3(config-router)#router-id 3.3.3.3
R3(config-router)# network 10.23.1.0 0.0.0.255 area 23
R3(config-router)#exit
R3(config)#exit
R3#
R4#configure terminal
R4(config)#router ospf 1
R4(config-router)#router-id 4.4.4.4

R4(config-router)# network 10.45.1.0 0.0.0.255 area 45


R4(config-router)# network 10.100.1.0 0.0.0.255 area 0
R4(config-router)#exit
R4(config)#exit
R4#
R5#configure terminal
R5(config)#router ospf 1
R5(config-router)#router-id 5.5.5.5
R5(config-router)# network 10.45.1.0 0.0.0.255 area 45
R5(config-router)#exit
R5(config)#exit
R5#
R6#configure terminal
R6(config)#router ospf 1
R6(config-router)#router-id 6.6.6.6
R6(config-router)# network 10.67.1.0 0.0.0.255 area 67
R6(config-router)# network 10.100.1.0 0.0.0.255 area 0
R6(config-router)#exit
R6(config)#exit
R6#
Creamos un enlace virtual para
que R8 se comunique con los
R7#configure terminal
dems routers
R7(config)#router ospf 1
R7(config-router)#router-id 7.7.7.7
R7(config-router)#area 67 virtual-link 6.6.6.6
R7(config-router)# network 10.67.1.0 0.0.0.255 area 67
R7(config-router)# network 10.78.1.0 0.0.0.255 area 78
R7(config-router)#exit
R7(config)#exit
R7#
R8#configure terminal
R8(config)#router ospf 1
R8(config-router)#router-id 8.8.8.8
R8(config-router)# network 10.78.1.0 0.0.0.255 area 78
R8(config-router)#exit
R8(config)#exit
R8#

VERIFICACION DE LA CONEXIN DEL ROUTER R8


R8#ping 10.45.1.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.100.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/32/44 ms
R8#

AREA EXTERNA

R1(config)#ip forward-protocol nd
R1(config)#ip route 172.31.0.0 255.255.255.0
R1(config)#ip route 172.31.1.0 255.255.255.0
R1(config)#ip route 172.31.2.0 255.255.255.0
R1(config)#ip route 172.31.3.0 255.255.255.0
R1(config)#exit
R1#

Null0
Null0
Null0
Null0

PARA REDISTRIBUIR LAS RUTAS ESTATICAS DEL ROUTER R1 SE


REALIZA LO SIGUIENTE:
Hacemos un show ip route en R8 para ver las rutas E1
R8#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 2 subnets
C
10.78.1.0 is directly connected, Serial0/0
O IA 10.67.1.0 [110/128] via 10.78.1.7, 00:00:04, Serial0/0
Vemos que no se muestra las rutas E1 del router R1
Configurando en el router R1
R1#conf ter
R1(config)#router ospf 1
R1(config-router)#redistribute static subnets metric 50 metric-type 1
R1(config-router)#exit
R1(config)#exit
R1#

HACEMOS LA PRUEBA EN EL ROUTER R1 CON UN SHOW IP


ROUTER

R8#SHow IP route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
O
O
O
O

172.31.0.0/24 is subnetted, 4 subnets


E1 172.31.3.0 [110/188] via 10.78.1.7,
E1 172.31.2.0 [110/188] via 10.78.1.7,
E1 172.31.1.0 [110/188] via 10.78.1.7,
E1 172.31.0.0 [110/188] via 10.78.1.7,

00:01:28,
00:01:28,
00:01:28,
00:01:28,

Serial0/0
Serial0/0
Serial0/0
Serial0/0

10.0.0.0/24 is subnetted, 5 subnets


O IA 10.23.1.0 [110/202] via 10.78.1.7, 00:07:36, Serial0/0
O IA 10.45.1.0 [110/202] via 10.78.1.7, 00:07:26, Serial0/0
C
10.78.1.0 is directly connected, Serial0/0
O IA 10.67.1.0 [110/128] via 10.78.1.7, 00:08:09, Serial0/0
O IA 10.100.1.0 [110/138] via 10.78.1.7, 00:07:55, Serial0/0
R8#

2. OSPF nunca debera formar relaciones de vecindario en


cualquier interfaz donde otros routers OSPF no existen
(como se muestra en el diagrama).
HACEMO UN SHOW IP ROUTER EN EL ROUTER R1

CONFIGURANDO EN EL ROUTER R1 PARA QUE NO EXISTA RELACION


DE VECINDAD
R1#configure terminal
R1(config)#router ospf 1
R1(config-router)#passive-interface default
R1(config-router)#
*Mar
1 00:12:33.359: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2
FastEthernet0/0 from 2WAY to DOWN, Neighbor Down: Interface down
detached
*Mar
1 00:12:33.359: %OSPF-5-ADJCHG: Process 1, Nbr 4.4.4.4
FastEthernet0/0 from FULL to DOWN, Neighbor Down: Interface down
detached
*Mar
1 00:12:33.359: %OSPF-5-ADJCHG: Process 1, Nbr 6.6.6.6
FastEthernet0/0 from FULL to DOWN, Neighbor Down: Interface down
detached
R1(config-router)#^Z
R1#
VERIFICAMO CON UN SHOW

on
or
on
or
on
or

3. Todos los routers del rea 0 deberan usar autenticacin


MD5 con sus vecinos. Los routers en el rea 23 deberan
ser configurados para soportar autenticacin en texto
plano con sus vecinos. Todas las claves deben ser
configuradas como cisco.
PARA EL AREA 0
CONFIGURAMOS EL ROUTER R1

R1#configure terminal
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip ospf authentication message-digest
R1(config-if)#ip ospf message-digest-key 1 md5 cisco
R1(config-if)#exit
R1#

VERIFICAMOS EL ROUTER R1

R1#show ip ospf interface


FastEthernet0/0 is up, line protocol is up
Internet Address 10.100.1.1/24, Area 0
Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 10
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 1.1.1.1, Interface address 10.100.1.1
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:02
Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0

Next 0x0(0)/0x0(0)
El router R1 utiliza
Last flood scan length is 0, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
autentificacin 1 MD5
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
Message digest authentication enabled
Youngest key id is 1

CONFIGURAMOS EL ROUTER R2
R2#configure terminal
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip ospf authentication message-digest
R2(config-if)#ip ospf message-digest-key 1 md5 cisco
R2(config-if)#exit
R2(config)#exit
R2#

VERIFICAMOS EL ROUTER R2
R2#show ip ospf interface
FastEthernet0/0 is up, line protocol is up
Internet Address 10.100.1.2/24, Area 0
Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 10
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 2.2.2.2, Interface address 10.100.1.2
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:02
Supports Link-local Signaling (LLS)
Index 1/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 2
El router R2 utiliza
Last flood scan time is 0 msec, maximum is 0 msec
1 MD5
Neighbor Count is 0, Adjacent neighbor count is autentificacin
0
Suppress hello for 0 neighbor(s)
Message digest authentication enabled
Youngest key id is 1
Serial0/0 is up, line protocol is up
Internet Address 10.23.1.2/24, Area 23
Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:07
Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 4
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 3.3.3.3
Suppress hello for 0 neighbor(s)
R2#

CONFIGURAMOS EL ROUTER R4
R4#configure terminal
R4(config)#interface fastEthernet 0/0
R4(config-if)#ip ospf authentication message-digest
R4(config-if)#ip ospf message-digest-key 1 md5 cisco
R4(config-if)#exit
R4(config)#exit
R4#
VERIFICAMOS EL ROUTER R4
R4#show ip ospf interface
FastEthernet0/0 is up, line protocol is up
Internet Address 10.100.1.4/24, Area 0
Process ID 1, Router ID 4.4.4.4, Network Type BROADCAST, Cost: 10
Transmit Delay is 1 sec, State BDR, Priority 1
Designated Router (ID) 2.2.2.2, Interface address 10.100.1.2
Backup Designated router (ID) 4.4.4.4, Interface address 10.100.1.4
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:03
Supports Link-local Signaling (LLS)
Index 1/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 4 msec El router R4 utiliza
Neighbor Count is 1, Adjacent neighbor count is 1
autentificacin 1 MD5
Adjacent with neighbor 2.2.2.2 (Designated Router)
Suppress hello for 0 neighbor(s)
Message digest authentication enabled
Youngest key id is 1
Serial0/0 is up, line protocol is up
Internet Address 10.45.1.4/24, Area 45
Process ID 1, Router ID 4.4.4.4, Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:00
Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
R4#
CONFIGURAMOS EL ROUTER R6
R6#configure terminal
R6(config)#interface fastEthernet 0/0
R6(config-if)#ip ospf authentication message-digest
R6(config-if)#ip ospf message-digest-key 1 md5 cisco
R6(config-if)#exit
R6(config)#exit
R6#

VERIFICAMOS EL ROUTER R6
R6#show ip ospf interface
FastEthernet0/0 is up, line protocol is up
Internet Address 10.100.1.6/24, Area 0
Process ID 1, Router ID 6.6.6.6, Network Type BROADCAST, Cost: 10
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 6.6.6.6, Interface address 10.100.1.6
Backup Designated router (ID) 4.4.4.4, Interface address 10.100.1.4
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:09
Supports Link-local Signaling (LLS)
Index 2/3, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 11
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 2, Adjacent neighbor count is 2
El router R6 utiliza
Adjacent with neighbor 2.2.2.2
1 MD5
Adjacent with neighbor 4.4.4.4 (Backup Designated autentificacin
Router)
Suppress hello for 0 neighbor(s)
Message digest authentication enabled
Youngest key id is 1
OSPF_VL0 is up, line protocol is up
Internet Address 10.67.1.6/24, Area 0
Process ID 1, Router ID 6.6.6.6, Network Type VIRTUAL_LINK, Cost: 64
Configured as demand circuit.
Run as demand circuit.
DoNotAge LSA allowed.
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:02
Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 3
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 7.7.7.7 (Hello suppressed)
Suppress hello for 1 neighbor(s)
Serial0/0 is up, line protocol is up
Internet Address 10.67.1.6/24, Area 67
Process ID 1, Router ID 6.6.6.6, Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:06
Supports Link-local Signaling (LLS)
Index 1/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 7
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 1

Adjacent with neighbor 7.7.7.7


Suppress hello for 0 neighbor(s)

PARA EL AREA 23
CONFIGURAMOS EL ROUTER R2
R2#configure terminal
R2(config)#interface serial 0/0
R2(config-if)#ip ospf authentication
R2(config-if)#ip ospf authentication-key cisco
R2(config-if)#exit
R2#

VERIFICAMOS EL ROUTER R2
R2#show ip ospf interface
FastEthernet0/0 is up, line protocol is up
Internet Address 10.100.1.2/24, Area 0
Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 10
Transmit Delay is 1 sec, State DROTHER, Priority 1
Designated Router (ID) 6.6.6.6, Interface address 10.100.1.6
Backup Designated router (ID) 4.4.4.4, Interface address 10.100.1.4
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:03
Supports Link-local Signaling (LLS)
Index 1/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 2
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 2, Adjacent neighbor count is 2
Adjacent with neighbor 4.4.4.4 (Backup Designated Router)
Adjacent with neighbor 6.6.6.6 (Designated Router)
Suppress hello for 0 neighbor(s)
Serial0/0 is up, line protocol is up
Internet Address 10.23.1.2/24, Area 23
Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_POINT,
Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:06
Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 4, maximum is 4
Last flood scan time is 0 msec, maximum is 4 msec Autentificacin en
Neighbor Count is 0, Adjacent neighbor count is 0 texto plano habilitada

Suppress hello for 0 neighbor(s)


Simple password authentication enabled

CONFIGURAMOS EL ROUTER R3
R3#configure terminal
R3(config)#interface serial 0/0
R3(config-if)#ip ospf authentication
R3(config-if)#ip ospf authentication-key cisco
R3(config-if)#exit
R3(config)#exit
R3#

VERIFICAMOS EL ROUTER R3
R3#show ip ospf interface
Serial0/0 is up, line protocol is up
Internet Address 10.23.1.3/24, Area 23
Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:07
Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 3
Autentificacin en
Last flood scan time is 0 msec, maximum is 0 msec
texto plano habilitada
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
Simple password authentication enabled

4. Los routers del rea 45 estn limitados en su capacidad y


no deberan recibir rutas de redes externas al dominio
OSPF. Estos routers deberan alcanzar la red externa
usando una ruta por defecto la cual no puede ser
configurada estticamente.

Verificamos el estado actual del router R5


R5#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
C
O
O
O

10.0.0.0/24 is subnetted, 4 subnets


10.45.1.0 is directly connected, Serial0/0
IA 10.78.1.0 [110/202] via 10.45.1.4, 00:00:00, Serial0/0
IA 10.67.1.0 [110/138] via 10.45.1.4, 00:00:00, Serial0/0
IA 10.100.1.0 [110/74] via 10.45.1.4, 00:00:33, Serial0/0

Configuramos R5 para que no reciba rutas externas


R5#configure terminal
R5(config)#router ospf 1
R5(config-router)#area 45 stub
R5(config-router)#
R5(config-router)#exit
R5#
Verificando
R5#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 1 subnets

C
10.45.1.0 is directly connected, Serial0/0
R5#

Verificamos el estado actual del router R4


R4#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.31.0.0/24 is subnetted, 4 subnets
O E1 172.31.3.0 [110/60] via 10.100.1.1, 00:01:40, FastEthernet0/0
O E1 172.31.2.0 [110/60] via 10.100.1.1, 00:01:40, FastEthernet0/0
O E1 172.31.1.0 [110/60] via 10.100.1.1, 00:01:40, FastEthernet0/0
O E1 172.31.0.0 [110/60] via 10.100.1.1, 00:01:40, FastEthernet0/0
10.0.0.0/24 is subnetted, 5 subnets
O IA 10.23.1.0 [110/74] via 10.100.1.2, 00:01:40, FastEthernet0/0
C
10.45.1.0 is directly connected, Serial0/0
O IA 10.78.1.0 [110/138] via 10.100.1.6, 00:01:42, FastEthernet0/0
O IA 10.67.1.0 [110/74] via 10.100.1.6, 00:01:42, FastEthernet0/0
C
10.100.1.0 is directly connected, FastEthernet0/0
R4#

Configurando para que no muestre rutas externas


R4#configure terminal
R4(config)#router ospf 1
R4(config-router)#area 45 stub
R4(config-router)#exit
R4(config)#exit
R4#
Verificando

R4#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 5 subnets

O IA 10.23.1.0 [110/210] via 10.100.1.2, 00:11:50, FastEthernet0/0


C
10.45.1.0 is directly connected, Serial0/0
O IA 10.78.1.0 [110/274] via 10.100.1.6, 00:11:50, FastEthernet0/0
O IA 10.67.1.0 [110/210] via 10.100.1.6, 00:11:50, FastEthernet0/0
C
10.100.1.0 is directly connected, FastEthernet0/0
5. Los routers del rea 23 no deben recibir ningn LSA
tipo 3, 4 o 5 del resto de la red OSPF. Estos routers
deberan alcanzar la red externa usando una ruta por
defecto con un costo inicial OSPF de 100.
Con figurando el router R3
R3#configure terminal
R3(config)#router ospf 1
R3(config-router)#area 23 stub no-summary
R3(config-router)#exit
R3(config)#exit
R3#
Verificando el estado actual de R3
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.30.0.0/24 is subnetted, 4 subnets
172.30.2.0 is directly connected, Loopback2
172.30.3.0 is directly connected, Loopback3
172.30.0.0 is directly connected, Loopback0
172.30.1.0 is directly connected, Loopback1
10.0.0.0/24 is subnetted, 1 subnets
C
10.23.1.0 is directly connected, Serial0/0
R3#
Configurando costo por defecto a 100
Para R3
C
C
C
C

R3#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#router ospf 1
R3(config-router)#area 23 d
R3(config-router)#area 23 default-cost 100
R3(config-router)#exit
R3(config)#exit
R3#

R3#show running-config
router ospf 1
router-id 3.3.3.3
log-adjacency-changes
area 23 default-cost 100
network 10.23.1.0 0.0.0.255 area 23
Con figurando el router R2
R2#configure terminal
R2(config)#router ospf 1
R2(config-router)#area 23 stub no-summary
R2(config-router)#exit
R2(config)#exit
Verificando el estado actual de R2
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 5 subnets
C
10.23.1.0 is directly connected, Serial0/0
O IA 10.45.1.0 [110/74] via 10.100.1.4, 00:00:05, FastEthernet0/0
O IA 10.78.1.0 [110/138] via 10.100.1.6, 00:00:07, FastEthernet0/0
O IA 10.67.1.0 [110/74] via 10.100.1.6, 00:00:07, FastEthernet0/0
C
10.100.1.0 is directly connected, FastEthernet0/0
Configurando costo por defecto a 100
Para R2
R2#configure terminal
R2(config)#router ospf 1
R2(config-router)#area 23 default-cost 100
R2(config-router)#exit
R2#
R2#show run
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
area 23 default-cost 100
network 10.23.1.0 0.0.0.255 area 23
network 10.100.1.0 0.0.0.255 area 0

6.
Cuando se complete el ejercicio, todos los routers
deberan poder hacer ping a cada ruta en la tabla de
enrutamiento OSPF.
Para R8
R8#ping 10.23.1.0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.23.1.0, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/37/60 ms
R8#ping 10.23.1.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.23.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/29/60 ms
R8#ping 10.23.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.23.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/28/60 ms
R8#ping 172.30.0.0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.30.0.0, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/37/48 ms
R8#ping 10.45.1.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.45.1.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/38/52 ms
R8#ping 10.45.1.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.45.1.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/36/48 ms
R8#ping 10.67.1.6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.67.1.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/12/16 ms
R8#
Para R5
R5#ping 10.100.1.1
Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.100.1.1, timeout is 2 seconds:


!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/32/68 ms
R5#ping 172.30.0.0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.30.0.0, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/28/48 ms
R5#ping 10.78.1.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.78.1.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/36/56 ms
R5#

3.

CONCLUSIONES:

Se pudo configurar OSPF bsico para el esquema de red mostrado.


Publicar todas las redes conectadas a cada router en OSPF usando el
mtodo ms simple disponible. Para inyectar redes externas en el
dominio OSPF, se redistribuyo las rutas estticas en R1. Estas rutas se
marcaron como tipo E1.

Se hizo que OSPF nunca formara relaciones de vecindario en


cualquier interfaz donde otros routers OSPF no existan (como se
muestra en el diagrama). Luego se debe deshacer la anterior
configuracin para que se pueda hacer ping entre todos los routers .

los routers del rea 0 usan autenticacin MD5 con sus vecinos. Los
routers en el rea 23 fueron configurados para soportar autenticacin
en texto plano con sus vecinos. Todas las claves fueron configuradas
como cisco.

se realiz exitosamente y correctamente los objetivos propuestos

UNIVERSIDAD MAYOR DE SAN SIMN


FACULTAD DE CIENCIAS Y TECNOLOGA
CARRERA DE INGENIERA ELECTRNICA

LABORATORIO N5
CONFIGURACION DE AREAS ESPECIALES
OSPF

Materia: Com. de datos


Estudiante: Fabiola Chugar Mancilla

COCHABAMBA BOLIVIA

Junio, 2014