Está en la página 1de 8

SOLUCIN DE EJERCICIOS

EJERCICIO 01:
Disear un algoritmo que visualice y sume la serie de nmeros 3,6,9,12,99

PSEUDOCDIGO
Algoritmo Sumatoria_Serie
Escribir 'La sumatoria de la serie de forma:'
Escribir '3,6,9,12,...,99'
Escribir 'La suma es:'
s <- 3*((33*(1+33))/2)
Escribir s
FinAlgoritmo

DIAGRAMA DE FLUJO

ALGORITMOS EJERCICIOS PROPUESTOS

2016

DIAGRAMA NASSI SCHENEIDERMAN

EJERCICIO 02:
Escribir un algoritmo que lea cuatro nmeros y a continuacin visualice el mayor de
los cuatro.

PSEUDOCDIGO
Algoritmo mayor_cuatro_numeros
Escribir 'Hallar el mayor de cuatro nmeros:'
Escribir 'Ingresar el primer nmero: '
Leer n1
Escribir 'Ingresar el segundo nmero: '
Leer n2
Escribir 'Ingresar el tercer nmero: '
Leer n3
Escribir 'Ingresar el cuarto nmero: '
Leer n4
Si n1>n2 Y n1>n3 Y n1>n4 Entonces
Escribir 'El nmero mayor es:'
Escribir n1
Sino
Si n2>n3 Y n2>n4 Entonces
Escribir 'El nmero mayor es:'
Escribir n2
Sino
Si n3>n4 Entonces
Escribir 'El nmero mayor es: '
Escribir n3
Sino
2 PROGRAMACIN PARA INGENIEROS

ALGORITMOS EJERCICIOS PROPUESTOS


Escribir 'El nmero mayor es: '
Escribir n4
FinSi
FinSi
FinSi
FinAlgoritmo

DIAGRAMA DE FLUJO

3 PROGRAMACIN PARA INGENIEROS

2016

ALGORITMOS EJERCICIOS PROPUESTOS

2016

DIAGRAMA NASSI SCHENEIDERMAN

EJERCICIO 03:
Escribir un algoritmo que calcule la superficie de un tringulo en funcin de la base
y la altura.

PSEUDOCDIGO
Algoritmo superficie_triangulo
Escribir 'Clculo de la superficie de un tringulo: '
Escribir 'Ingresar la base: '
Leer base
Escribir 'Ingresar la altura: '
Leer altura
Escribir 'La superficie es: '
s <- (1/2)*(base*altura)
Escribir s
FinAlgoritmo

4 PROGRAMACIN PARA INGENIEROS

ALGORITMOS EJERCICIOS PROPUESTOS

DIAGRAMA DE FLUJO

DIAGRAMA NASSI SCHENEIDERMAN

5 PROGRAMACIN PARA INGENIEROS

2016

ALGORITMOS EJERCICIOS PROPUESTOS

2016

EJERCICIO 04:
Calcular y visualizar la longitud de la circunferencia y el rea de un crculo de radio
dado.

PSEUDOCDIGO
Algoritmo longitud_area_circulo
Escribir 'Clculo del rea y longitud de un circulo: '
Escribir 'Ingresar el radio del crculo: '
Leer radio
areacir <- (3.1416)*(radio*radio)
longcir <- 2*3.1416*radio
Escribir 'El rea del crculo en unidades cuadradas es: '
Escribir areacir
Escribir 'La longitud del crculo es: '
Escribir longcir
FinAlgoritmo

DIAGRAMA DE FLUJO

6 PROGRAMACIN PARA INGENIEROS

ALGORITMOS EJERCICIOS PROPUESTOS

2016

DIAGRAMA NASSI SCHENEIDERMAN

EJERCICIO 05:
Escribir un algoritmo que encuentre el salario semanal de un trabajador, dada la
tarifa horaria y el nmero de horas trabajadas diariamente.

PSEUDOCDIGO
Algoritmo superficie_triangulo
Escribir 'Clculo de la superficie de un tringulo: '
Escribir 'Ingresar la base: '
Leer base
Escribir 'Ingresar la altura: '
Leer altura
Escribir 'La superficie es: '
s <- (1/2)*(base*altura)
Escribir s
FinAlgoritmo

7 PROGRAMACIN PARA INGENIEROS

ALGORITMOS EJERCICIOS PROPUESTOS

DIAGRAMA DE FLUJO

DIAGRAMA NASSI SCHENEIDERMAN

8 PROGRAMACIN PARA INGENIEROS

2016

También podría gustarte