Está en la página 1de 8

Diseño de Redes de Datos.

Guía 9
Facultad: Ingeniería
Escuela: Electrónica
Asignatura: Diseño de Redes de Datos

Tema: Enrutamiento dinámico OSPF


Contenidos

 Configuración Básica de los Router.


 Configuración de interfaces LOOPBACK
 Configuración del protocolo OSPF
 Cambio de roles en los router.
 Configuración de los temporizadores.
 Configuración de autentificación.

Objetivos Específicos
 Configurar interfaces loopback
 Configurar OSPF de área simple
 Verificar las adyacencias y roles en OSPF
 Configurar los temporizadores de OSPF
 Configurar autenticación en OSPF

Materiales y Equipo
 Computadora con simulador Packet Tracer
Procedimiento

Configuración Básica de los Router.

1. Armar la siguiente topología en el simulador.


Diseño de Redes de Datos. Guia 9
2

NOTA: Para esta configuración el Router1 usará cables DCE, por lo que Router0 y Router2
usarán cables DTE.

2. Configuración de los routers

a. Configuración del Router0

Router#configure terminal
Router(config)#hostname Router0

Router0(config)#interface f0/0
Router0(config-if)#ip address 172.16.10.1 255.255.255.0
Router0(config-if)#no shutdown
Router0(config-if)#exit

Router0(config)#interface f0/1
Router0(config-if)#ip address 192.168.100.1 255.255.255.0
Router0(config-if)#no shutdown
Router0(config-if)#exit

Router0(config)#interface s0/0
Router0(config-if)#ip address 172.16.20.1 255.255.255.252
Router0(config-if)#no shutdown
Router0(config-if)#exit
Router0(config)#exit
Router0#write

b. Configuración del Router1

Router#configure terminal
Router(config)#hostname Router1

Router1(config)#interface f0/0
Router1(config-if)#ip address172.16.10.2 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#exit

Router1(config)#interface s0/0
Router1(config-if)#ip address 172.16.20.2 255.255.255.252
Router1(config-if)#clock rate 4000000
Router1(config-if)#no shutdown
Router1(config-if)#exit

Router1(config)#interface s0/1
Router1(config-if)#ip address 172.16.20.5 255.255.255.252
Router1(config-if)#clock rate 4000000
Router1(config-if)#no shutdown
Diseño de Redes de Datos. Guía 9

Router1(config-if)#exit
Router1(config)#exit
Router1#write

c. Configuración del Router2

Router#configure terminal
Router(config)#hostname Router2

Router2(config)#interface f0/0
Router2(config-if)#ip address 172.16.10.3 255.255.255.0
Router2(config-if)#no shutdown
Router2(config-if)#exit

Router2(config)#interface f0/1
Router2(config-if)#ip address 192.168.200.1 255.255.255.0
Router2(config-if)#no shutdown
Router2(config-if)#exit

Router2(config)#interface s0/0
Router2(config-if)#ip address 172.16.20.6 255.255.255.252
Router2(config-if)#no shutdown
Router2(config-if)#exit
Router2(config)#exit
Router2#write

Configuración de interfaces LOOPBACK

3. Configuración de las interfaces de loopback en cada router. Estas servirán


posteriormente para definir los roles de DR y BDR en la red multiacceso
(172.16.10.0/24).

a. Interface loopback en Router0

Router0#configure terminal
Router0(config)#interface loopback 0
Router0(config-if)#ip address 192.168.0.10 255.255.255.255
Router0(config-if)#CTRL+Z

b. Interface loopback en Router1

Router1#configure terminal
Router1(config)#interface loopback 0
Router1(config-if)#ip address 192.168.0.21 255.255.255.255
Router1(config-if)#CTRL+Z
Diseño de Redes de Datos. Guia 9
4

c. Interface loopback en Router2

Router2#configure terminal
Router2(config)#interface loopback 0
Router2(config-if)#ip address 192.168.0.32 255.255.255.255
Router2(config-if)#CTRL+Z

4. Revisar la configuración activa en cada uno de los router ( show runnig-config) y


guardela en la NVRAM una vez comprobada.

5. Antes de realizar la configuración de OSPF, revisar la tabla de enrutamiento de cada


uno de los router, en este momento solo deben aparecer las redes directamente
conectadas.

Configuración del protocolo OSPF

a. Router0:

Router0#configure terminal
Router0(config)#router ospf 1
Router0(config-router)#log-adjacency-changes
Router0(config-router)#network 192.168.100.0 0.0.0.255 area 0
Router0(config-router)#network 172.16.10.0 0.0.0.255 area 0
Router0(config-router)#network 172.16.20.1 0.0.0.0 area 0
Router0(config-router)#CTRL+Z

b. Router1:

Router1#configure terminal
Router1(config)#router ospf 1
Router1(config-router)#log-adjacency-changes
Router1(config-router)#network 172.16.20.2 0.0.0.0 area 0
Router1(config-router)#network 172.16.10.0 0.0.0.255 area 0
Router1(config-router)#network 172.16.20.5 0.0.0.0 area 0
Router1(config-router)#CTRL+Z

c. Router2:

Router2#configure terminal
Router2(config)#router ospf 1
Router2(config-router)#log-adjacency-changes
Router2(config-router)#network 192.168.200.0 0.0.0.255 area 0
Router2(config-router)#network 172.16.10.0 0.0.0.255 area 0
Router2(config-router)#network 172.16.20.6 0.0.0.0 area 0
Router2(config-router)#CTRL+Z
Diseño de Redes de Datos. Guía 9

Nota: Observe que las redes looback no entraran en el proceso de enrutamiento, estas solo
servirán para la designación de roles de los router OSPF.

6. Verifique ahora las tablas de enrutamiento de cada uno de los router con el comando
show ip route, podrá notar claramente las rutas que provienen del enrutamiento
implementado con OSPF

7. Configure las estaciones de trabajo, según a la LAN que pertenecen.

8. Verifique la conectividad entre los enlaces con las herramientas Ping y Traceroute.
Una vez comprobada almacene los cambios en la configuración en la NVRAM.

9. Reinicie los router al mismo tiempo (utilice el botón Power Cycle Devices en el
simulador)

Verificación de las adyacencias y los roles

10. Mostrar las adyacencias (vecinos) descubiertos por OSPF. Para ello usar el siguiente
comando:
RouterX#show ip ospf neighbor

11. También se puede utilizar la variante del comando para obtener mayor información

RouterX#show ip ospf neighbor detail

12. Contestar algunas preguntas:

¿Cuál de los enrutadores desempeña este rol DR?


¿Se ha elegido además un BDR? ¿Cuál?
¿Son las direcciones de las interfaces loopback los correspondientes RouterID de cada
enrutador?

13. Verificar el estado de las interfaces con respecto a OSPF para cada router.

RouterX#show ip ospf interface fastethernet 0/x


RouterX#show ip ospf interface serial 0/x

Cambio de roles en los router.

14. Cambiar la elección de DR modificando la prioridad de la interface fastethetnet 0/0 de


Router1.

Configuración en Router1 para ser DR

Router1#configure terminal
Router1(config)#interface fastethernet 0/0
Router1(config-if)#ip ospf priority 50
Router1(config-if)#CTRL+Z
Diseño de Redes de Datos. Guia 9
6

15. Guarde la configuración.

16. Reiniciar nuevamente los router.

17. Una vez se tenga acceso al CLI digitar el siguiente comando y observe los mensajes
en pantalla.
Router1#debug ip ospf events

18. Cuando ya no necesite ver los mensajes de depuración, detenga la salida de estos en
el CLI
Router1#undebug all

19. Usar nuevamente el comando show ip ospf interface f0/0, en Router1 para verificar
que ahora este es el DR para la red 172.16.10.0 / 24, y que además efectivamente
su prioridad es de 50.

Configuración de los temporizadores.

20. Revisar el valor actual (por defecto) de los temporizadores hello-interval y dead-
interval. Se pueden revisar la configuración por cada interfaz.

RouterX#show ip ospf interface fastethernet 0/0

21. Cambiar los temporizadores en Router0

Router0#configure terminal

Router0(config)#interface f0/0
Router0(config-if)#ip ospf hello-interval 5
Router0(config-if)#ip ospf dead-interval 20
Router0(config-if)#exit

Router0(config)#interface s0/0
Router0(config-if)#ip ospf hello-interval 5
Router0(config-if)#ip ospf dead-interval 20
Router0(config-if)#CTRL+Z

22. Esperar 40 segundos máximos para ver como el cambio de los valores en los
temporizadores de un solo enrutador causa la pérdida de contacto con sus vecinos
(realizar ping entre las estaciones de trabajo y observar las tablas de enrutamiento).
Las adyacencias se recuperarán cuando se haya cambiado los valores en todos los
router.

23. Cambiar los temporizadores en los dos router restantes, debe utilizar los mismos
tiempos configurados en Router0.

24. Guarde los cambios en la NVRAM de cada router.

25. Verifique que exista comunicación nuevamente


Diseño de Redes de Datos. Guía 9

Configuración de autentificación.

26. Configuración de autenticación en OSPF en un solo enrutador (para forzar la pérdida


de adyacencias).

Router0#configure temrinal
Router0(config)#interface f0/0
Router0(config-if)#ip ospf message-digest-key 1 md5 7 cisco
Router0(config-if)#exit

Router0(config)#interface s0/0
Router0(config-if)#ip ospf message-digest-key 1 md5 7 cisco
Router0(config)#exit

Router0(config)#router ospf 1
Router0(config-router)#area 0 authentication message-digest
Router0(config-router)#CTRL+Z

27. El enrutador debería generar mensajes que notifican de la desaparición de los


vecinos.

28. Verifique la información de los vecinos (en todos los router), para comprobar que no
existen.

29. Ahora configure la autentificación en el Router1 y Router2.

30. Se deberana generar mensajes de consola indicando la reaparición de los vecinos


perdidos.

31. Comprobar las adyacencias y la tabla de enrutamiento.

Bibliografía

 Network+ 2005 In Depth, Tamara Dean; Course Technology PTR; 1 edition (March 15,
2005)
 Local Area Networks (McGraw-Hill Forouzan Networking Series), Forouzan McGraw-Hill
Education - Europe (February 1, 2002)
 CCNA Study Guide Fourth Edition, Sybex
Diseño de Redes de Datos. Guia 9
8
Hoja de cotejo:

Docente:
10
Máquina No:
1
GL:
Guía 10: Enrutamiento dinámico OSPF
a

Alumno: Máquina No:

Docente: Máquina No:


GL: Fecha:

GL:

EVALUACION
% 1-4 5-7 8-10 Nota
CONOCIMIENTO 25 Demostró poco Demostró Demostró buen
conocimiento sobre conocimiento medio conocimiento sobre
el tema de la sobre el tema de la el tema de la
práctica. práctica. práctica.
APLICACIÓN DEL 70 Realizo la Realizo la Realizo la
CONOCIMIENTO configuración configuración básica configuración básica
básica de la de la topología de la topología
topología
Comprobó el Comprobó el
funcionamiento del funcionamiento del
protocolo OSPF protocolo OSPF
manejando manejando
adecuadamente la adecuadamente la
configuración del DR y configuración del DR
BDR y BDR

Configura y
comprende la
utilización de los
temporizadores
2.5 Es un observador Participa Participa propositiva e
ACTITUD
pasivo. ocasionalmente o lo integralmente en toda
hace constantemente la práctica.
pero sin coordinarse
con su compañero.
2.5 Es ordenado pero Hace un uso adecuado Hace un manejo
no hace un uso de recursos responsable y
adecuado de los respetando las pautas adecuado de los
recursos. de seguridad, pero es recursos conforme a
desordenado. pautas de seguridad e
higiene.
TOTAL 100

También podría gustarte