Está en la página 1de 11

Que es el Pseudocdigo?

El pseudocdigo (falso lenguaje) es una descripcin de alto nivel de un algoritmo que emplea una mezcla de lenguaje natural con algunas convenciones sintcticas propias de lenguajes de programacin, como asignaciones, ciclos y condicionales. Es utilizado para describir algoritmos en libros y publicaciones cientficas, y como producto intermedio durante el desarrollo de un algoritmo. El pseudocdigo est pensado para facilitar a las personas el entendimiento de un algoritmo, y por lo tanto puede omitir detalles irrelevantes que son necesarios en una implementacin. Programadores diferentes suelen utilizar convenciones distintas, que pueden estar basadas en la sintaxis de lenguajes de programacin concretos. Sin embargo, el pseudocdigo en general es comprensible sin necesidad de conocer o utilizar un entorno de programacin especfico, y es a la vez suficientemente estructurado para que su implementacin se pueda hacer directamente a partir de l. Para que sirve el Pseudocdigo? Sirve para escribir programas de computadora en lenguaje natural de tal manera que se facilite la comprensin, prueba y posterior codificacin en un lenguaje de programacin especfico.

Vamos a precisar el PSEINT que lo pueden descargar de aqui(esta en espaol)

Empesemos

Problemas con estructuras secuenciales Nota: Se presentar al menos un ejercicio sin ningn tipo de mensaje para que los alumnos vean la diferencia con un algoritmo bien documentado.

1) Se posee un monto de dinero de $120, se gasta en supermercado $49,5 y luego en verdulera 12,10. Mostrar el saldo. Proceso gasto saldo<-120-49.5-12.10; Escribir "Saldo ",saldo; FinProceso

Usar este ejercicio para resaltar la necesidad de la utilizacin de las variables, ya que este ejercicio se ajusta nicamente para los valores constantes consignados.

2) Realizar el pseudocdigo para calcular el 15% de un valor constante. Proceso 15% cal<-325*.15; Escribir "El 15% de 325 es ",cal; FinProceso

3) Modificar el pseudocdigo anterior para que muestre el 15% de un valor ingresado. Proceso 15% Escribir "Ingrese un numero"; Leer n; cal<-n*.15; Escribir "El 15% de ",n," es ",cal; FinProceso

4) Calcular el nuevo salario de un obrero si obtuvo un incremento del 25% sobre su salario anterior.

Proceso sueldo_obrero Escribir Ingrese el Sueldo; Leer sueldo;

Nuevo<-sueldo*.25+sueldo; Escribir El nuevo sueldo es: ,nuevo; FinProceso

5) Calcular el doble de un nmero ingresado, a ese resultado calcularle el 10% y mostrar ese valor.

Proceso 10%del doble Escribir "Ingrese un numero"; Leer n doble<-n*2; por<-doble*.1; Escribir "El 10% del doble de ",n," es ",por; FinProceso

6) Informar en pantalla el promedio de cinco nmeros.

Proceso promedio_5 Escribir "Ingrese 5 numeros"; Leer n1,n2,n3,n4,n5; prom<-(n1+n2+n3+n4+n5)/5 Escribir "Promedio: ",prom; FinProceso

7) Realizar un algoritmo en el cual se obtenga la siguiente informacin 2.A + 2.B

Proceso 2.A+2.B Escribir "Ingrese un numero"; Leer A; Escribir "Ingrese otro numero" Leer B; cal<-2*a+2*b; Escribir "Resultado ",cal; FinProceso

8) Resuelva un algoritmo que solucione el problema de calcular el rea de un

triangulo con la frmula: AREA = BASE x ALTURA / 2.

Proceso Area_Triangulo Escribir "Ingrese la medida de la Base"; Leer base; Escribir "Ingrese la medida de la Altura"; Leer altura; area<-base*altura/2; Escribir "El area del triangulo es: ",area; FinProceso

9) dem para el rea de un crculo (se deber ingresar la medida del dimetro).

Proceso Area_Circulo Escribir "Superficie del circulo" Escribir "Ingrese la medida del Dimetro"; Leer diametro; radio<-diametro/2; area<-3.1416*radio*radio; Escribir "El area del Circulo es: ",area; FinProceso

10) Calcular el rea de un rectngulo conociendo el valor de sus lados.

Proceso Area_Rectangulo Escribir "Area del Rectangulo" Escribir "Ingrese la medida del lado Mayor"; Leer base; Escribir "Ingrese la medida de la Altura"; Leer altura; area<-base*altura; Escribir "El area del Rectangulo es: ",area; FinProceso

11) Conociendo el valor de la entrada al cine, calcule el monto a pagar para una delegacin de personas. Recuerde que deber hacer un descuento del 3% por cantidad.

Proceso Entradas_Cine Escribir Ingrese el valor de la entrada; Leer entrada; Escribir Ingrese la cantidad de personas Leer personas; Total<-personas*entrada; Pagar<-total-total*.03; Escribir Importe a abonar: , pagar; FinProceso

12) Ingresando la cantidad de un producto y su precio unitario, obtener como resultado el precio final que debe pagar el cliente. Proceso Total_a_pagar Escribir "Ingrese nombre del producto" Leer producto; Escribir "Precio Unitario?"; Leer Precio; Escribir "Cantidad adquirida?"; Leer cantidad; total<-precio*cantidad; Escribir "Por su compra de ",cantidad," ",producto," debera pagar $",total; FinProceso 13) Suponga que un individuo desea invertir su capital en un banco y desea saber cunto dinero ganar despus de un mes si el banco paga a razn de 2% mensual.

Proceso Inversion Escribir "Ingrese capital a invertir"; Leer cap_inv; gan<-cap_inv*0.02; Escribir "Ganacia a obtener: ",gan; FinProceso

14) Realizar una aplicacin que calcule las cuatro operaciones bsicas, suma, resta, divisin, multiplicacin, con dos nmeros. Proceso Operaciones Escribir "Ingrese un Numero";

Leer n1; Escribir "Ingrese otro Numero"; Leer n2; s<-n1+n2; r<-n1-n2; m<-n1*n2; d<-n1/n2; Escribir n1," + ",n2," = ",s; Escribir n1," - ",n2," = ",r; Escribir n1," * ",n2," = ",m; Escribir n1," / ",n2," = ",d; FinProceso

15) Un vendedor recibe un sueldo base ms un 10% extra por comisin de sus ventas, el vendedor desea saber cuanto dinero obtendr por concepto de comisiones por las tres ventas que realiza en el mes y el total que recibir en el mes tomando en cuenta su sueldo base y comisiones.

Proceso Comision Escribir "Sueldo Base del Vendedor"; Leer Sueldo; Escribir "Importe Venta 1"; Leer v1; Escribir "Importe Venta 2"; Leer v2; Escribir "Importe Venta 3"; Leer v3; tv<-v1+v2+v3; com<-tv*0.1; tc<-sueldo+com; Escribir "Sueldo: ",sueldo; Escribir "Comisin: ",com; Escribir "Total a Cobrar: ",tc; FinProceso

16) Una tienda ofrece un descuento del 15% sobre el total de la compra y un cliente desea saber cuanto deber pagar finalmente por su compra.

Proceso Descuento Escribir "Ingrese el valor de la compra: ";

Leer compra; desc<-compra*0.15; pagar<-compra-desc; Escribir "Debera pagar: ",pagar; FinProceso Modificar el ejercicio anterior para que se ingrese el porcentaje a descontar. 17) Un alumno desea saber cual ser su calificacin final en la materia de Algoritmos. Dicha calificacin se compone de los siguientes porcentajes: 55% del promedio de sus tres calificaciones parciales. 30% de la calificacin del examen final. 15% de la calificacin de un trabajo final.

Proceso Nota_Final Escribir "Ingrese nota Primer parcial: "; Leer n1; Escribir "Ingrese nota Segundo parcial: "; Leer n2; Escribir "Ingrese nota Tercer parcial: "; Leer n3; Escribir "Ingrese nota Trabajo Practico: "; Leer tp; Escribir "Ingrese nota Examen Final: "; Leer ef; prom<-(n1+n2+n3)/3; cp<-prom*0.55; cef<-ef*.3; ctp<-tp*.15; cf<-cp+cef+ctp; Escribir "Nota Final: ",cf; FinProceso

Prueba de escritorio N1 N2 N3 tp ef prom cp cef ctp cf 10 4 7 10 8 7 3.85 2.4 1.5 7.75 8 6 9 8 7 7.66 4.21 2.1 1.2 7.51

18) Un maestro desea saber que porcentaje de hombres y que porcentaje de mujeres hay en un grupo de estudiantes.

Proceso Porcentaje Escribir "Ingrese cantidad de mujeres"; Leer cm; Escribir "Ingrese cantidad de varones"; Leer cv; t<-cm+cv; pm<-cm*100/t; pv<-cv*100/t; Escribir "Porcentaje de Mujeres: ",pm,"%"; Escribir "Porcentaje de Varones: ",pv,"%"; FinProceso

19) Realizar un algoritmo que calcule la edad de una persona. Modificar el ejercicio para que solicite el ingreso del ao actual. Proceso Edad Escribir "Nombre: "; Leer nombre; Escribir "Ao de Nacimiento: "; Leer Nac; edad<-2010-Nac; Escribir nombre," tiene: ",edad," aos" FinProceso

20) Realice un algoritmo que reciba una cantidad de dinero en pesos y convierta esa misma cantidad en dlares, considerando que el dlar cotiza a 3.89. Modificar el ejercicio para que se ingrese la cotizacin actual del dlar. Proceso Pesos_a_dolares Escribir "Ingrese la cantidad de pesos a convertir:";

Leer pesos; Conv<-pesos/3.89 Escribir "$",pesos," son U$S",conv; FinProceso

Leer un numero y escribir el valor absoluto del mismo. Calcular el nmero de pulsaciones que una persona debe tener por cada 10 segundos de ejercicio, si la formula es: num. pulsaciones = (220 - edad)/10 En un hospital existen tres reas: Ginecologa, Pediatra, Traumatologia. El presupuesto anual del hospital se reparte conforme a la sig. tabla: rea Porcentaje del presupuesto Ginecologa 40% Traumatologia 30% Pediatra 30% Obtener la cantidad de dinero que recibir cada rea, para cualquier monto presupuestal. El dueo de una tienda compra un articulo a un precio determinado. Obtener el precio en que lo debe vender para obtener una ganancia del 30%. Todos los lunes, mircoles y viernes, una persona corre la misma ruta y cronometra los tiempos obtenidos. Determinar el tiempo promedio que la persona tarda en recorrer la ruta en una semana cualquiera. Tres personas deciden invertir su dinero para fundar una empresa. Cada una de ellas invierte una cantidad distinta. Obtener el porcentaje que cada quien invierte con respecto a la cantidad total invertida. 3. Queremos conocer los datos estadsticos de una asignatura, por lo tanto, necesitamos un algoritmo que lea el nmero de suspensos, aprobados, notables y sobresalientes de una asignatura, y nos devuelva: a. El tanto por ciento de alumnos que han superado la asignatura. b. El tanto por ciento de suspensos, aprobados, notables y sobresalientes de la asignatura. 4. Un departamento de climatologa ha realizado recientemente su conversin al sistema mtrico. Disear un algoritmo para realizar las siguientes conversiones: a. Leer la temperatura dada en la escala Celsius e imprimir en su equivalente Fahrenheit (la frmula de conversin es F=9/5 C+32).

b. Leer la cantidad de agua en pulgadas e imprimir su equivalente en milmetros (25.5 mm = 1 pulgada). 5. El siguiente es el men de un restaurante de bocadillos. Disear un algoritmo capaz de leer el nmero de unidades consumidas de cada alimento ordenado y calcular la cuenta total. Bocadillo de jamn (4 euros) Bocadillo dequeso (3 euros) Patatas fritas (2 euros) Refresco (1 euro) Cerveza (2 euros) 6. El coste de un automvil nuevo para un comprador es la suma total del coste del vehculo, del porcentaje de la ganancia del vendedor y de los impuestos locales o estatales aplicables (sobre el precio de venta). Suponer una ganancia del vendedor del 12% en todas las unidades y un impuesto del 6% y disear un algoritmo para leer el coste total del automvil e imprimir el coste para el consumidor. 7. Queremos realizar un pequeo programa para introducirlo en el ordenador de a bordo de nuestro coche y que nos informe del consumo medio del coche. Disea un algoritmo que lea el kilometraje de la ltima vez que se repost, el kilometraje actual, los litros de gasolina que se repostaron la ltima vez y la cantidad de gasolina actual. El algoritmo devolver la cantidad de litros cada 100 kilmetros que consume nuestro coche. 9. Dada una velocidad indicada en metros por segundo convertir la misma a kilmetros por hora.