P. 1
Comandos Turbo Pascal

Comandos Turbo Pascal

|Views: 3.499|Likes:
Publicado porXander Muñoz

More info:

Published by: Xander Muñoz on May 14, 2011
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as DOCX, PDF, TXT or read online from Scribd
See more
See less

06/12/2013

pdf

text

original

2.1.

Utilizando el teclado
Al momento de escribir nuestro programa, el teclado será el principal medio para el ingreso de texto. Algunas de las principales combinaciones de teclas para mover el cursor a través de la pantalla del editor, son las siguientes: Movimiento Teclas Carácter a la izquierda Carácter a la derecha Palabra a la izquierda Ctrl+ Palabra a la derecha Ctrl+ Línea abajo Línea arriba Pantalla abajo AvPág Pantalla arriba RePág Principio de línea Inicio Final de línea Fin Principio de la ventana Ctrl+Inicio Final de la ventana Ctrl+Fin Principio del programa Ctrl+RePág Final del programa Ctrl+AvPág Indentación Tab
Tabla 1 - Combinación de teclas para movimiento del cursor

También se puede utilizar el teclado para realizar otra serie de operaciones como borrar caracteres, abrir archivos, etc. Los comandos más importantes que se pueden ejecutar a través del teclado se muestran a continuación: Comando Teclas Borrar un carácter a la izquierda del cursor Retroceso Borrar un carácter a la derecha del cursor Suprimir Borrar la palabra a la izquierda del cursor Ctrl+T Insertar una línea Ctrl+N Borrar una línea Ctrl+Y Borrar desde el cursor hasta el final de la línea Ctrl+Q+Y Activar la barra de menús F10 Abrir un fichero F3 Guardar un fichero F2
Tabla 2 - Combinación de teclas para otros comandos

Además de caracteres, palabras, líneas, ventanas y programas, en TP podemos hablar de bloques. Un bloque es cualquier cantidad de texto (desde un simple carácter hasta cientos de líneas) que el usuario haya marcado como bloque. Para marcar un bloque hay que indicar el principio y final del mismo. En una ventana sólo puede existir un único bloque en un momento determinado. Los comandos utilizados para bloques se detallan a continuación. Comando Teclas Marcar un bloque
Mayús+ , , , Ctrl+K+B (inicio de bloque) Ctrl+K+K (fin de bloque)

Ir al principio del bloque Ctrl+Q+B Ir al final del bloque Ctrl9Q+K Copiar un bloque Ctrl+Insert, Mayús+Insert

PAS). Run (Ctrl+F9) Ejecuta el programa activo. Instituto Superior de Formación Docente Nº 6012 .4. se pasa el control a este procedimiento y también lo ejecuta sentencia a sentencia. Parameters« Especifica los parámetros que se pasan al programa cuando se ejecuta el entorno integrado de desarrollo.2. Menú Compile (Alt+C) Una vez escrito el programa fuente (archivo . desde la línea de comandos. sentencia a sentencia. el programa está listo para ser ejecutado. Trace into (F7) Ejecuta el programa.5. Salta Cátedra: Programación II (PII) Carrera: Tecnicatura Superior en Análisis de Sistemas con Orientación en Redes Informáticas Apunte de cátedra Unidad 2: El Compilador de Turbo Pascal 7. en la ventana de edición activa.Mover un bloque Ctrl+Supr. lo ejecuta como si fuera una única sentencia. paso a paso. Esta es la diferencia que tiene con la opción Step Over. 2. sentencia a sentencia. El menú Compile contiene las opciones para la compilación y ejecución de programas. compilando ese archivo y otros archivos modificados utilizándoos en el programa. Si el programa fuente ha sido modificado desde la última compilación. Program reset (Ctrl+F2) Detiene la sesión de depuración actual y devuelve el control al usuario. Cuando encuentra un procedimiento o función. ó con errores. TP vuelve a compilarlo automáticamente antes de ejecutarlo. TP muestra una ventana con el estado del proceso. la cual sólo ejecuta las sentencias del procedimiento actual. es decir. en cuyo caso el programa está listo para ser ejecutado. es necesario compilarlo para obtener un programa objeto que pueda ser ejecutado por la computadora. Mayús+Insert Borrar un bloque Ctrl+Supr Ocultar/Visualizar un bloque Ctrl+K+H Tabla 3.2. Step over (F8) Ejecuta el programa.0 Autor: Lic. Gustavo Daniel Reyes 7 de 10 Compile (ALT+F9) Compila el archivo de la ventana de edición activa. Si se encuentra con un procedimiento o función lo salta.El Carril. incluyendo la traza de los procedimientos procedimientos y funciones. los cuales deberán ser corregidos antes de volver a ser compilados sin errores para poder ejecutar el programa obtenido. en la ventana de edición activa. Build . Durante la compilación. Comandos para bloques 2. Make (F9) Constituye una versión ejecutable del archivo del programa principal. es decir. El proceso de compilación puede acabar satisfactoriamente. El menú Run permite el control sobre la ejecución de programas. Menú Run (Alt+R) Después de que el proceso de compilación haya terminado con éxito. Go to cursor (F4) Ejecuta el programa desde donde se encuentre en ese momento hasta la posición actual del cursor.

la condición a evaluar y la pasada en la que debe parar el programa. Es una pausa intencional y controlada durante la ejecución de un programa. Call stack (Ctrl+F3) Abre una ventana que contiene una lista de procedimientos y funciones actualmente llamadas en el programa que se está ejecutando. pero recompila archivos fuentes del programa.. Clear primary file Borra el nombre principal del archivo.Hace lo mismo que Make.. Añade un punto de ruptura en un cuadro de diálogo. Add watch. Se pueden insertar puntos de ruptura dependiendo de una determinada condición. se muestran las expresiones con sus valores actuales. se escriben programas que se compilan sin error (no existen errores sintácticos) pero al ejecutarlos el resultado no es el esperado (se producen errores semánticos). Information. Normalmente. que está siendo compilado actualmente. Evaluate/modify. en la línea en la que se encuentran. Destination Memory Especifica si la versión ejecutable de un programa se almacena en memoria o en disco. punto de ruptura o parada dinámica.+F7) Inserta una expresión de observación a la ventana Watch. 2. los errores sintácticos son fáciles de corregir pero no pasa lo mismo con los errores semánticos. que utiliza la pantalla completa para visualizar salidas programas. muestra su valor y. Salta Cátedra: Programación II (PII) Carrera: Tecnicatura Superior en Análisis de Sistemas con Orientación en Redes Informáticas Apunte de cátedra Unidad 2: El Compilador de Turbo Pascal 7. Para localizar estos errores. de modo que las órdenes Build o Make actúan sobre el archivo en la ventana de edición.. Register Abre la ventana Register.. (ctrl. (Ctrl+F4) Permite evaluar el nombre de una variable o expresión... User screen (Alt+F5) Abre la pantalla de usuario. permite la modificación de ese valor.2. modificar o borrar puntos de interrupción2 (breakpoints).. Breakpoints.0 . El cuadro de diálogo de puntos de ruptura muestra todos los puntos de ruptura insertados. Permite insertar. Especifica el archivo principal de un programa. Menú Debug (Alt+D) A menudo... Muestra una ventana con información del archivo activo. Primary File... En esta ventana. haciendo activa.. si es posible. Output Muestra la ventana de salida (Output). Watch Muestra una ventana que permiten el control sobre las vistas de variables y expresiones de la ventana Watch. Cuando esta ventana está activa. 2 Breakpoint: punto de interrupción. se pueden insertar/borrar expresiones pulsando la tecla Insert/Supr.. podemos utilizar las herramientas que proporciona TP para depurar programas incluidas en el menú Debug.El Carril. cuyo código fuente se encuentra en archivos múltiples.6. Un punto de interrupción permite detener un programa en ejecución exactamente en la línea en la que se insertó. la cual permite comprobar la salida del programa que estamos ejecutando. sin tener en cuenta si han sido modificados o no modificados. Add Breakpoint. Instituto Superior de Formación Docente Nº 6012 .

. Go to next (Alft+F8) Salta al siguiente mensaje la ventana Messages.. de modo que pueda inspeccionar salidas de programas. Guarda los parámetros de configuración modificados en el archivo TURBO. Permite indicar a TP en que directorios debe buscar para encontrar los archivos que necesita en la compilación. Memory sizes.El Carril.TP. Salta Cátedra: Programación II (PII) Carrera: Tecnicatura Superior en Análisis de Sistemas con Orientación en Redes Informáticas Apunte de cátedra Unidad 2: El Compilador de Turbo Pascal 7. Edita.TP.. Especificar opciones de compilación. Messages Abre la ventana de mensajes (Messages). Especifica las opciones relativas al proceso de enlace.0 Autor: Lic..... que se utiliza para detectar patrones en archivos. Directories. añade o borra herramientas de programas. Especifica las opciones relativas al depurador integrador... guardado automático de ficheros.7. Compiler. 2..Autor: Lic. las opciones del ratón o los colores para la ventana de edición.). Instituto Superior de Formación Docente Nº 6012 .. tipo UNIX.. 3 Utilidad de la línea de comandos. enlazado (linkeado) y ejecución de programas. Menú Tools (Alt+T) Permite acceder a diferentes programas auxiliares. Debugger.8. Grep (Shift+F2) Invoca la utilidad Grep3. Save as.. Go to previous (Alt+F7) Salta al mensaje anterior la ventana Messages. Environment Esta opción contiene un submenú en el que es posible cambiar las preferencias del usuario (tamaño de la ventana. las opciones de la ventana de edición. en lugar de hacerlo en el archivo por defecto TURBO.. Linker... Gustavo Daniel Reyes 8 de 10 2. Guarda los parámetros de configuración en el archivo especificado.2. Gustavo Daniel Reyes 9 de 10 Save Todas las opciones que han sido modificadas en una sesión de trabajo (incluidas las opciones de búsqueda y el destino del archivo ejecutable) se restauran cuando se vuelve a ejecutar TP. Open. que se pueden utilizar en el trabajo diario. Menú Options (Alt+O) El Menú Options contiene comandos que permiten modificar el entorno de trabajo y cambiar las opciones de configuración que TP inicializa por defecto. .. Abre un archivo con información de parámetros.. Tools.2. escrita originalmente para ser usada con el sistema operativo Unix. Especifica los tamaños de memoria por defecto de un programa.

You're Reading a Free Preview

Descarga
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->