Está en la página 1de 4

Configuración de Telefonía con Equipos activos de Red

En esta guía se proporcionan los comandos básicos para configurar una pequeña planta telefónica
con la utilización de un router y un switch.

Para este ejemplo utilizaremos el simulador de redes de Cisco llamado Packet Tracer, en el cuál
configuraremos un Router 2800 y un Switch 2950 de 24 puertos. En esta practica nos valdremos de
tecnologías como Vlans, routing, y dhcp para hacer que funcione correctamente nuestro ejercicio,
obteniendo como resultado final una llamada IP entre dos dispositivos (teléfonos IP) separada del
trafico de datos de la red.

La topología a usar será la siguiente:

Paso 1: Configuración de Vlan's dentro del switch, para efectos de nuestro manual la vlan 10,
corresponderá a la vlan denominada “voz” y la vlan 20 a la vlan denominada datos.

Switch>enable
Switch#configure terminal
Switch(config)#vlan 10 #se crea la vlan 10 (voz)
Switch(config-vlan)#name voz #se asigna nombre a la vlan
Switch(config-vlan)#exit
Switch(config)#vlan 20 #se crea la vlan 20 (datos)
Switch(config-vlan)#name datos
Switch(config-vlan)#exit

Paso 2: Definir en los puertos del switch que vlans son permitidas en cada uno, para este ejemplo
agruparemos los puertos del switch Fastethernet 0/1 y 0/2 para el acceso de vlan's y el fastethernet
0/3 como troncal con nuestro router.

Switch(config)# interface range fastEthernet 0/1-2 #Agrupamos interfaces


Switch(config-if-range)#switchport mode access # se definen los puertos como puertos acceso
Switch(config-if-range)#switchport access vlan 20 #se permite el trafico de la vlan datos
Switch(config-if-range)#switchport voice vlan 10 #se permite el trafico y define el tipo de vlan voz
Switch(config-if-range)# exit

Documento elaborado por Pablo Yela para la Licenciatura en Tecnología y Administración de Telecomunicaciones Universidad
Galileo, Guatemala 07/2014
Paso 3: Definir el puerto fastethernet 0/3 como troncal hacia el router.

Switch(config)# interface fastEthernet 0/3


Switch(config-if)#switchport mode trunk
Switch(config)#do wr

Router 2800

Paso 4: Configurar las interfaces para aceptar trafico entre vlans de datos y voz.

Router>enable
Router#configure terminal
Router(config)#interface fastEthernet 0/0
Router(config-if)#no shutdown #se enciende la interfaz
Router(config)#interface fastEthernet 0/0.10 #se crea la subinterfaz para vlan voz
Router(config-subif)#encapsulation dot1Q 10 #nos permite usar varias redes logicas en un mismo
medio
Router(config-subif)#ip address 192.168.10.1 255.255.255.0 # se define la ip
Router(config)#interface fastethernet 0/0.20 #se crea la subinterfaz para vlan datos
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 192.168.20.1 255.255.255.0
Router(config-subif)#exit
Router(config)#

Paso 5: Configuración de los pools de DHCP para las diferentes Vlans.

Pool de la vlan de telefonía.

Router(config)#ip dhcp pool 10 # se define el pool para la vlan de voz


Router(dhcp-config)#network 192.168.10.0 255.255.255.0 # se define el rango de ips a asignar
Router(dhcp-config)#default-router 192.168.10.1 # se define la puerta de enlace del segmento voz
Router(dhcp-config)#option 150 ip 192.168.10.1 # se indica que se utilizarán dispositivos
especiales (150 telefonos IP).
Router(dhcp-config)#exit #regresa al modo de configuración.

Pool de la vlan datos

Router(config)#ip dhcp pool 20


Router(dhcp-config)#network 192.168.20.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.20.1
Router(dhcp-config)#exit

Paso 6: Configuración de la telefonía

Router(config)#telephony-service
Router(config-telephony)#auto assign 1 to 2 #automaticamente asigna numeros de extensiones a
los botones

Documento elaborado por Pablo Yela para la Licenciatura en Tecnología y Administración de Telecomunicaciones Universidad
Galileo, Guatemala 07/2014
Router(config-telephony)#auto-reg-ephone #automaticamente registra los telefonos en la
configuracion del servicio de telefonia
Router(config-telephony)#create cnf-files #crea los archivos que serán enviados a los ephones para
su funcinamiento.
Router(config-telephony)#ip source-address 192.168.10.1 port 2000 # indica la dirección ip y el
puerto que usará el servicio telefónico
Router(config-telephony)#max-dn 2 #el máximo de extensiones
Router(config-telephony)#max-ephones 2 #el máximo de ephones en el servicio

Paso 7: Crear los teléfonos

Router(config)#ephone 1
Router(config-ephone)#exit
Router(config)#ephone 2
Router(config-ephone)#exit

Paso 8: Asignar extensiones

Router(config)#ephone-dn 1
Router(config-ephone-dn)#number 100
Router(config-ephone-dn)#exit
Router(config)#ephone-dn 2
Router(config-ephone-dn)#number 110
Router(config-ephone-dn)#do wr

Si todo lo anterior ha sido realizado correctamente el resultado debería de ser la asignación de


nuestras extensiones a los teléfonos IP, y aparte la asignación de direcciones del rango 192,168,20,0
a las computadoras de la topología.

Fig.2 : Teléfonos IP con extensión asignada. Rango 192.168.10.0

Documento elaborado por Pablo Yela para la Licenciatura en Tecnología y Administración de Telecomunicaciones Universidad
Galileo, Guatemala 07/2014
Fig.3: Ip's asignadas a las computadoras del segmento 192.168.20.0

Cabe destacar que este es un manual básico, las posibilidades de trabajar con telefonía sobrepasan el
alcance de este tutorial, por lo cuál se recomienda la investigación más profunda sobre este tema si
el alumno deseare conocer más sobre este servicio.

Documento elaborado por Pablo Yela para la Licenciatura en Tecnología y Administración de Telecomunicaciones Universidad
Galileo, Guatemala 07/2014