Está en la página 1de 30

Fase 3 Simular una red de VoIP en NGN

Oswaldo Álvarez Morales

Ángela Vargas Arcila

Tutor

Universidad Nacional Abierta y a Distancia UNAD

Escuela de Ciencias Básicas Tecnológicas e Ingenierías – ECBTI

Especialización en Redes de Nueva Generación

Grupo: 219006A _954

Noviembre de 2021
Introducción

El protocolo VoIP (Voice over Internet Protocol) es un método para hacer llamadas

telefónicas por internet o a través de redes privadas. Las llamadas tradicionales deben

atravesar una serie de conmutadores y circuitos, que son propiedad de las compañías

telefónicas, que controlan el proceso y las tarifas. El uso de VoIP permite, tanto a

empresas como usuarios particulares, lograr un considerable ahorro de costos,

especialmente en llamadas de larga distancia (1)

Desde el punto de vista técnico, VoIP es un método de comunicación que emplea las

normas rivales SIP y H.323. Las dos se encargan de enrutar conversaciones de voz a

través de internet o de redes basadas en IP y definen protocolos inspirados en los

sistemas telefónicos tradicionales. Los protocolos de señalización reemplazan las

funciones de las centralitas privadas ordinarias (PBX) y corren a cargo de servidores

PBX con software de aplicaciones.

El desarrollo de la guía consiste en simular una red VoIP sencilla a través del software

de simulación Packert Tracer, configurando el router y el switch a la cual se deben

conectar dos teléfonos IPs. Los resultados de la situación demuestran la efectividad de la

conexión y configuración.
Objetivos

 Implementar los fundamentos de la tecnología de VoIP usando herramienta de

software libre para el diseño de soluciones de comunicación de voz a través de

servicios de integración en redes de nueva generación usando normas vigentes

de los estándares de la industria.

 Simular una red VoIP sencilla a través del software Cisco Packet Tracert.
Tabla de ilustraciones

Imagen 1 Configuración Router.................................................................................................................6

Imagen 2 configuración pool de direcciones Router.................................................................................6

Imagen 3 Creación de Vlans Switch...........................................................................................................9

Imagen 4 Configuración de nombre y asignación de Password en RouterA-1........................................13

Imagen 5 Configuración RouterB-1.........................................................................................................14

Imagen 6 Configuración SwitchA-1 y SwitchB-1......................................................................................14

Imagen 7 Creación de Vlans SwitchA-1...................................................................................................15

Imagen 8 Configuración Vlans SwitchB-1................................................................................................16

Imagen 9 Configuración dhcp RouterA-1................................................................................................18

Imagen 10 Se verifica el funcionamiento correcto del servidor dhcp en la parte A................................18

Imagen 11 Configuración dhcp RouterB-1...............................................................................................19

Imagen 12 Se verifica la asignación dhcp de la parte B...........................................................................19

Imagen 13 Configuración pasos 4 y 5 en RouterB-2................................................................................22

Imagen 14 Activación alimentación PoE SwitchA-1.................................................................................23

Imagen 15 Habilitación marcado sitio a sitio...........................................................................................26

Imagen 16 Llamada exitosa entre el teléfono 4002 y 4001 de la sección A............................................26

Imagen 17 Llamada exitosa entre los teléfonos B2 y el teléfono análogo de la sección B......................27

Imagen 18 Llamada exitosa entre dos teléfonos de la sección A y la sección B......................................27

Imagen 19 Ping exitoso entra dos computadores de la sección A y la sección B.....................................28


Desarrollo.

Parte 1. El estudiante debe seleccionar un dispositivo de red que permita la conexión de

dispositivos ve Voip, en este caso se debe usar los siguientes

Equipo Interfaz IP Address Gateway

Router Fa0/0.1 192.168.10.1/24 No aplica

Switch Vlan 10 Voz 192.168.10.1/24

IP Phone 0 fa dhcp 192.168.10.1/24

IP Phone 1 fa dhcp 192.168.10.1/24


Configuración Router

Imagen 1 Configuración Router.

Imagen 2 configuración pool de direcciones Router


Router>ena

Router#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#interface fa0/0

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

do wr

Building configuration...

[OK]

Router(config-if)#interface fa0/0.1

Router(config-subif)#

%LINK-5-CHANGED: Interface FastEthernet0/0.1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.1, changed state to up

Router(config-subif)#encapsulation dot1Q 10

Router(config-subif)#ip address 192.168.10.1 255.255.255.0

Router(config-subif)#no shutdown

Router(config-subif)#exit

Router(config)#ip dhcp pool voz


Router(dhcp-config)#network 192.168.10.0 255.255.255.0

Router(dhcp-config)#default-router 192.168.10.1

Router(dhcp-config)#option 150 ip 192.168.10.1

Router(dhcp-config)#do wr

Router(dhcp-config)#exit

Router(config)#ip dhcp excluded-address 192.168.10.1

Router(config)#do wr

Building configuration...

[OK]

Router(config)#telephony-service

Router(config-telephony)#max-dn 5

Router(config-telephony)#max-ephones 5

Router(config-telephony)#ip source-address 192.168.10.1 port 2000

Router(config-telephony)#auto assign 1 to 5

Router(config-telephony)#do wr

Building configuration...

[OK]

Router(config-telephony)#exit

Router(config)#ephone-dn 1

Router(config-ephone-dn)#%LINK-3-UPDOWN: Interface ephone_dsp DN 1.1, changed state

to up

Router(config-ephone-dn)#number 54001
Router(config-ephone-dn)#exit

Router(config)#ephone-dn 2

Router(config-ephone-dn)#%LINK-3-UPDOWN: Interface ephone_dsp DN 2.1, changed state

to up

Router(config-ephone-dn)#number 54002

Router(config-ephone-dn)#exit

Router(config)#do wr

Building configuration...

[OK]

Router(config)#

Configuración Switch

Imagen 3 Creación de Vlans Switch


Switch>ena

Switch#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)#vlan 20

Switch(config-vlan)#name Datos

Switch(config-vlan)#exit

Switch(config)#vlan 10

Switch(config-vlan)#name Voz

Switch(config-vlan)#exit

Switch(config)#do wr

Building configuration...

[OK]

Switch(config)#int range f0/1-6

Switch(config-if-range)#switchport access vlan 20

Switch(config-if-range)#switchport voice vlan 10

Switch(config-if-range)#inter gigabitEthernet 0/1

Switch(config-if)#switchport mode trunk

Switch(config-if)#

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to

down

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to

up
no shutdown

Switch(config-if)#exit

Switch(config)#
Ejercicio 2.

Paso 1

Construir la topología en packet tracert Abra un nuevo archivo PT y use el dispositivo y

las herramientas de conexiones en PT para crear la topología que se muestra en la

primera página de esta práctica de laboratorio. Los teléfonos IP en el sitio A recibirán

alimentación a través de Ethernet (PoE) del conmutador, pero los teléfonos IP en el sitio

B deben configurarse con fuentes de alimentación.

Paso 2 En cada enrutador y conmutador:

• Establezca el nombre de host como se indica en el diagrama de topología • Establezca

la contraseña enable secret como class


• Deshabilitar búsquedas de DNS • Establecer una contraseña de Telnet y consola como

Cisco

• Configure las direcciones IP como se indica en el cuadro anterior.

Imagen 4 Configuración de nombre y asignación de Password en RouterA-1


Imagen 5 Configuración RouterB-1

Imagen 6 Configuración SwitchA-1 y SwitchB-1


En cada switch:

• Crear VLAN 10 con el nombre VOZ

• Crear VLAN 20 con el nombre DATOS

• Crear VLAN 99 con el nombre GESTIÓN

En cada PC: Configurar para recibir la dirección IP a través de DHCP

Imagen 7 Creación de Vlans SwitchA-1


Imagen 8 Configuración Vlans SwitchB-1

Paso 3

Configurar el servicio DHCP en los routers

Los dispositivos VoIP y las PC en PT necesitan recibir información de direccionamiento

IP por DHCP. Cada enrutador deberá actuar como el servidor DHCP para su ubicación.

Vamos a separar las redes de voz y datos en cada ubicación, por lo que necesitaremos

dos grupos de DHCP. La opción especial DHCP 150 se utiliza para enviar la dirección 9

CUCME a los dispositivos VoIP para que puedan registrarse y recibir información de

configuración. Aunque esta opción es solo requerido en la VLAN de voz, lo hemos

incluido en la VLAN de datos en caso de que alguna vez se utilicen softphones en las
PC Los comandos para configurar los grupos DHCP en el RouterA-1 se dan a

continuación. Tendrá que modificarlos según corresponda para RouterB-1 y aplicarlos

allí también.

RouterA-1(config)# ip dhcp pool VOICE

RouterA-1(dhcp-config)# network 172.16.10.0 255.255.255.0

RouterA-1(dhcp-config)# default-router 172.16.10.1

RouterA-1(dhcp-config)# option 150 ip 172.16.10.1

RouterA-1(config)# ip dhcp pool DATA

RouterA-1(dhcp-config)# network 172.16.20.0 255.255.255.0

RouterA-1(dhcp-config)# default-router 172.16.20.1

RouterA-1(dhcp-config)# option 150 ip 172.16.10.1


Imagen 9 Configuración dhcp RouterA-1

Imagen 10 Se verifica el funcionamiento correcto del servidor dhcp en la parte A.


Imagen 11 Configuración dhcp RouterB-1

Imagen 12 Se verifica la asignación dhcp de la parte B.


Paso 4

Habilite el servicio VoIP básico en cada enrutador. La opción 150 de DHCP indica a los

dispositivos VoIP que reciben direcciones que se pongan en contacto con el enrutador

para obtener información de registro y configuración. A continuación, debemos

configurar el enrutador para proporcionar servicio de voz a esos dispositivos. Habilite el

servicio VoIP y establezca el número máximo de dispositivos VoIP y números de

directorio en 5 en cada enrutador. También permitiremos que los teléfonos se registren

automáticamente y obtengan un número de extensión automáticamente de los números

de directorio 1-5. Finalmente, se debe seleccionar la IP saliente y el número de puerto

para el tráfico VoIP del enrutador. Los comandos de configuración de ejemplo para

RouterA-1 se dan a continuación. Modifique y aplique también al enrutador B-1.

RouterA-1(config)# telephony-service

RouterA-1(config-telephony)# max-ephones 5

RouterA-1(config-telephony)# max-dn 5

RouterA-1(config-telephony)# auto-reg-ephone

RouterA-1(config-telephony)# auto assign 1 to 5

RouterA-1(config-telephony)# ip source-address 172.16.10.1 port 2000


Paso 5

Configure el grupo de números de directorio en cada enrutador Cada sitio tendrá un

grupo único de números de directorio (extensión) para cada teléfono. En el equipo físico

es posible tener planes de marcado superpuestos (los mismos números de extensión

duplicados en ambos sitios) y luego usar un prefijo especial para marcar entre sitios,

pero PT no lo admite. Tendremos que asegurarnos de que cada teléfono en la topología

tenga un número único. Los números en el sitio A comenzarán con 4xxx y en el sitio B

todos deberían comenzar con 5xxx. A continuación se muestra la configuración de uno

de los números de directorio en el sitio A. Cree suficientes números de directorio

(numerados correctamente) en cada sitio para admitir todos los dispositivos VoIP en ese

sitio.

RouterA-1(config)# ephone-dn 1

RouterA-1(config-ephone-dn)# number 4001


Imagen 13 Configuración pasos 4 y 5 en RouterB-2

Paso 6

Configurar las interfaces del switch Puertos troncales: Configure un enlace troncal

802.1Q desde FastEthernet 0/1 en cada conmutador al enrutador. Puertos de acceso

Todos los puertos restantes en cada conmutador deben configurarse como puertos de

acceso en la VLAN DE DATOS y deben tener PortFast habilitado. Todos los puertos

deben cerrarse por razones de seguridad a menos que tengan un dispositivo conectado.

Ingrese esta configuración como lo haría normalmente en los conmutadores en ambos

sitios. Recuerde que hay accesos directos para configurar múltiples interfaces en un

conmutador de la misma manera. 11 Debido a que queremos tener nuestros teléfonos IP


en una VLAN diferente a nuestras PC, necesitamos realizar una configuración especial

en todos los puertos del conmutador de acceso para convertirlos en dos troncales VLAN

cuando los teléfonos IP son identificados por CDP. Deje los puertos en acceso de modo

de puerto de conmutación pero agregue una segunda VLAN especial para el tráfico de

voz

SwitchA-1(config-if-range)# switchport voice vlan 10

En el sitio A también necesitamos proporcionar energía a los teléfonos IP usando PoE:

SwitchA-1(config-if-range)# power inline auto

Imagen 14 Activación alimentación PoE SwitchA-1

Paso 7

En este punto, debe tener una configuración suficiente para que las comunicaciones

dentro de cada sitio funcionen, por lo que este es un buen lugar para detenerse y probar

su trabajo. Lo primero que debe verificar es asegurarse de que todos sus dispositivos

tengan direcciones IP en las subredes apropiadas. Tenga en cuenta que después de

habilitar todos los puertos, todos los dispositivos tardarán un tiempo en intentar solicitar

una dirección DHCP nuevamente, por lo que si no ve las direcciones de inmediato,


espere un par de minutos y vuelva a verificar. Puede verificar fácilmente las direcciones

de teléfonos IP y PC colocando el mouse sobre el dispositivo en PT y verificando las

direcciones IP y de puerta de enlace enumeradas. Puede verificar aún más la

conectividad haciendo ping a una de las interfaces en el enrutador en el mismo sitio

desde cada PC Una vez que sus teléfonos IP tengan direcciones IP, deben comunicarse

automáticamente con el software CUCME que se ejecuta en el enrutador (utilizando la

dirección de la opción 150), registrarse y obtener un número de extensión. Puede

verificar el número de extensión de cada teléfono IP colocando el mouse sobre el

teléfono y buscando un número de línea o abriendo el teléfono y verificando en la

esquina superior derecha de la pantalla en la pestaña GUI. Tenga en cuenta que el

Adaptador de teléfono analógico (ATA) en el sitio B no utiliza la opción 150 de DHCP

para encontrar el servidor CUCME. Deberá ingresar la dirección correcta del servidor en

la pestaña Configuración de ATA antes de que el teléfono analógico reciba un número

de extensión El otro teléfono debe indicar que está sonando y el número de la extensión

que está llamando debe aparecer en la pantalla. Haga clic en el receptor de este teléfono

para responder la llamada. La pantalla ahora debería mostrar que los teléfonos están 12

conectados. Si mira hacia la parte superior derecha de cada teléfono (puede que tenga

que desplazarse hacia la derecha) debería ver los botones Do, Re, Mi. Presionar uno de

estos simula hablar en el teléfono. Si presiona uno, debería ver un mensaje encima del

teléfono al que está conectado, como Jugar "Hacer”... por un corto tiempo después de

presionarlo. Esto indica que la conexión entre los teléfonos funciona correctamente
Paso 8

Configurar llamadas sitio a sitio Para habilitar la marcación de sitio a sitio, debemos

hacer que cada uno de los dos sistemas CUCME conozca al otro para que puedan

facilitar la conexión entre teléfonos. Aunque los sistemas CUCME administran la

conexión, no se requiere que el tráfico de voz fluya a través de ellos (aunque sí lo hace

en esta topología cuando se realiza una llamada de sitio a sitio). Debido a esto, lo

primero que debemos hacer es asegurarnos de que todos los dispositivos en cada sitio

puedan llegar a todos los dispositivos en el otro sitio. Agregue las rutas habilitadas a

cada enrutador para habilitar el enrutamiento entre los sitios. La mejor manera de

hacerlo es con una ruta de resumen única /16 en cada uno de los enrutadores para

resumir manualmente las direcciones encontradas en el otro sitio Una vez que tenga

instaladas las rutas apropiadas y las haya probado haciendo ping exitosamente desde la

PC en un sitio a la PC en el otro sitio, necesitamos configurar el enrutamiento de

llamadas VoIP entre sitios. Este enlace está hecho por lo que se llama un dial-peer que

identifica extensiones de destino específicas y las dirige a otro servidor CUCME de la

misma manera que una tabla de enrutamiento funciona para el tráfico IP. También

debemos identificar qué números de extensión dirigir al otro servidor, algo hecho con un

patrón de destino. Examine la configuración de dial-peer dada para el RouterA-1 a

continuación y luego ingrésela en el RouterA-1.

RouterA-1(config)# dial-peer voice 1 voip

RouterA-1(config-dial-peer)# destination-pattern 5...


RouterA-1(config-dial-peer)# session target ipv4:10.0.0.2

Esto identificará todas las extensiones que comienzan con un 5 seguido de otros tres

dígitos y las dirigirá al servidor CUCME que se ejecuta en el RouterB-1. Realice los

cambios apropiados a esta configuración y luego aplíquela al RouterB-1 para permitir

que los dispositivos VoIP en el sitio B también llamen al sitio A. Pruebe su

configuración llamando del sitio A al sitio B y del sitio B al sitio A.

Imagen 15 Habilitación marcado sitio a sitio.

Pruebas

Imagen 16 Llamada exitosa entre el teléfono 4002 y 4001 de la sección A.


Imagen 17 Llamada exitosa entre los teléfonos B2 y el teléfono análogo de la sección B.

Imagen 18 Llamada exitosa entre dos teléfonos de la sección A y la sección B.


Imagen 19 Ping exitoso entra dos computadores de la sección A y la sección B

Conclusiones
Realizar este tipo de laboratorios nos permite comprender la configuración y

funcionamiento de los dispositivos utilizados para realizar una comunicación VoIP. Es

importante tener claro el direccionamiento y las interfaces presentes en el diseño para

poder realizar una configuración acorde a los requerimientos de la red a simular.

Bibliografía.
[1] Watkins, K., & LabsTM, M. (2009). Las vulnerabilidades de VoIP.

Leal, M. A. J., de la Cruz Gámez, E., Díaz, M. W. N., Hernández, M. J. M., Bravo, I., & Santos,

A. B. DISEÑO Y RESTRUCTURACIÓN DE REDES VIRTUALES EN LA PLATAFORMA

“CUCM” DE TELEFONÍA VoIP.

Ayala Hurtado, O. L., & Garces, R. E. (2020). DISEÑO DE HERRAMIENTAS PARA LA AYUDA

EN EL AREA DE APRENDIZAJE DE LA ASIGNATURA DE VOIP CON CISCO EN LAS

UNIDADES TECNOLOGICAS DE SANTANDER.

Bolaños, W. A., Rivas, R. E., & Mendoza, R. A. (2012). Laboratorio de voz sobre IP

(VOIP) y su implementación en las redes avanzadas utilizando código abierto.

También podría gustarte