P. 1
Manual Millenium 3

Manual Millenium 3

|Views: 2.773|Likes:
Publicado porSantiago Birds

More info:

Published by: Santiago Birds on Jun 07, 2012
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

10/10/2014

pdf

text

original

Manual Crouzet Millenium 3 (1ª parte

)
Jorge A. Escalera M.
Elaborado con fines didácticos, sin afán de lucro, y exclusivamente para la materia programación del controlador lógico que se imparte en el CETIS 50, México, D.F.

CETIS 50
Mariano Matamoros Guridi SEP . 02/04/2012

Manual Crouzet Millenium 3

(1ª parte) 2012

Introducción
El material presentado en este documento es la conversión original del manual de ayuda que acompaña el programa. La idea es que pueda visualizarse en cualquier equipo de cualquier generación y de esta manera pueda ser vigente aún. Disfruta ahora de esta nueva experiencia.

Presentación de la herramienta de programación
Lenguajes utilizados El módulo lógico propone dos lenguajes de programación: Lenguaje LD: lenguaje de contactos Lenguaje FBD: diagrama de bloques de función (Functional Block Diagram) Estos lenguajes ponen en funcionamiento lo siguiente: Bloques de función predefinidos: temporizaciones contadores progresivos Funciones específicas: gestión del tiempo cadena de caracteres Comunicación... Lenguaje de contactos El lenguaje de contactos (LD) es un lenguaje gráfico. Permite la transcripción de esquemas de relés y se adapta al procesamiento combinatorio. Proporciona los símbolos gráficos básicos: contactos, bobinas, bloques. La ejecución de los cálculos específicos es posible en el interior de los bloques de operaciones. Ejemplo de programa en lenguaje de contactos:

Prof. J. A. Escalera M.

Página 2

Manual Crouzet Millenium 3

(1ª parte) 2012

Modo FBD El modo FBD permite una programación gráfica basada en la utilización de bloques funcionales predefinidos. Presenta una amplia gama de funciones básicas: temporizador, contador progresivo, lógico... Ejemplo de programa en lenguaje FBD:

El modo FBD permite una programación gráfica basada en la utilización de bloques funcionales predefinidos.

Prof. J. A. Escalera M.

Página 3

Forzar las entradas/salidas para comprobar el comportamiento del programa en condiciones especiales. Escalera M. Las diferentes ventanas se actualizan de forma cíclica.Manual Crouzet Millenium 3 (1ª parte) 2012 Presenta una amplia gama de funciones básicas: temporizador. Página 4 . el programa se ejecuta en el controlador y la herramienta de programación se conecta al controlador (conexión PC controlador). Modos de funcionamiento Existen varios modos de funcionamiento para la herramienta de programación: Modo de edición El modo de edición sirve para desarrollar los programas en modo FBD. el programa se ejecuta en modo local directamente en la herramienta de programación (simulada en el PC). cada acción en el gráfico (cambio de estado de una entrada. etc. contador progresivo. A. Modo de simulación En modo de simulación. J. forzado de una salida) actualiza las ventanas de simulación. lógica. Corresponde al desarrollo de la aplicación. es posible: Visualizar los estados de las salidas y los parámetros de los bloques de función del programa correspondiente a la hoja de cableado de la ventana de supervisión. Modo de monitorización En modo de monitorización. En los modos de simulación y monitorización. En este modo. Prof.

J. si fuese necesario. A. La posibilidad o no de conectar extensiones. Resultado: la lista de los controladores correspondientes aparece en la zona Seleccionar el tipo de controlador que se desea programar. Si el controlador admite extensiones. Resultado: pueden darse las posibilidades siguientes en este paso: Si el controlador no admite extensiones. Esta función muestra un conjunto de tres pantallas: La primera pantalla permite seleccionar el tipo de controlador.Manual Crouzet Millenium 3 (1ª parte) 2012 Creación o modificación de configuración de una aplicación Introducción Esta fase es importante porque determina la configuración futura del entorno de trabajo. pasar directamente al paso 6. así como el lenguaje de programación. esto conlleva el cierre de la aplicación en curso y la creación de una nueva aplicación (programa de aplicación). Descripción El menú:Archivo ® Nuevo y el menú:Controlador ® Elegir el tipo de controlador permiten elegir o modificar el tipo de controlador y/o las extensiones. seleccionar la categoría activando la casilla correspondiente. FBD o LD (la opción LD no se propone para las extensiones de tipo analógico). En la zona Seleccionar la categoría del controlador. Creación de una aplicación Procedimiento de creación de una aplicación: Paso 1 2 Acción Seleccionar el menú Archivo ® Nuevo. 3 Seleccionar el controlador haciendo clic en la línea correspondiente. Los controladores se reagrupan en categorías correspondientes a estos elementos: El número de entradas/salidas. y validar pulsando el botón Siguiente >. Resultado: aparece la ventana Selección del controlador. Escalera M. Página 5 . La presencia o ausencia de visualizador. La segunda permite agregar una extensión. Si el usuario modifica también el lenguaje de programación de una aplicación abierta en modo de edición. aparecerán dos zonas nuevas en la ventana: Prof. La tercera permite elegir el lenguaje de programación.

A. Se puede eliminar la extensión de la lista Extensiones seleccionadas utilizando el botón Suprimir. así como un conjunto específico de funciones FBD y Macro que incluye la barra de funciones. Los nombres del controlador y de las extensiones se muestran encima de la hoja de cableado. Seleccionar las extensiones: muestra las extensiones compatibles. Para una aplicación en modo FBD: A cada tipo de controlador (+ posibles extensiones) le corresponde un fondo de plano visualizado en la ventana Edición con las entradas/salidas específicas al tipo elegido sobre el contorno. La ventana de edición aparece con una hoja de cableado en blanco. Modificar los parámetros para obtener la configuración deseada. 5 6 7 Modificación de la configuración de una aplicación Procedimiento de modificación de la configuración de una aplicación: Paso 1 2 Acción Hacer clic en el menú :Controlador ® Seleccionar el tipo de controlador. Para elegir el tipo de programación. Validar la configuración con el botón Siguiente>. Escalera M.. entonces es posible añadir otra extensión. Nota: la extensión XE10 24VDC es una extensión extensible. Si se elige esta extensión. Los nombres del módulo y de las extensiones se muestran debajo de la hoja de cableado. Para una aplicación en modo LD A cada tipo de módulo (+ posibles extensiones) le corresponde un conjunto y un número específico de funciones LD en la barra de funciones. elegir el tipo de extensiones que se desean agregar a la lista Extensiones compatibles. Hacer clic en el botón Siguiente> para validar. Resultado: aparece la ventana de recapitulación. Las funciones que no sean compatibles con el controlador seleccionado y las macros que contengan una función no compatible con el controlador seleccionado aparecerán en gris oscuro en la barra de funciones. J. 4 En la zona Seleccionar las extensiones. . Resultado: aparece la zona de selección del tipo de programación.Manual Crouzet Millenium 3 (1ª parte) 2012 Selección actual: resume las selecciones efectuadas en los pasos 2 y 3. Para: Página 6 Prof. haciendo doble clic en la línea correspondiente o utilizando el botón Agregar. Resultado: la extensión seleccionada aparece en la lista Extensiones seleccionadas. es necesario hacer clic sobre el diseño asociado..

Modificar el tipo de programación: hacer clic en la figura que representa el tipo de programación deseado. Dirección MAC : Del inglés "Media Access Control". Pantalla LCD: pantalla situada en la caja de varios controladores que.Manual Crouzet Millenium 3 (1ª parte) 2012 Modificar el tipo de controlador: hacer clic una vez el botón Anterior. A. Tras el fallo de un equipo. asegurar que el equipo es funcionalmente compatible con el anterior. Agregar. el sistema (incluido el equipo) puede : proporcionar al equipo la misma dirección IP que la anterior. y efectuar el mismo procedimiento que para la creación de una aplicación desde el paso 2. Controlador modular o extensible: controlador al que pueden conectarse de forma lateral las cajas inteligentes adicionales de comunicación (Modbus) o de entradas/salidas. Se utiliza para proporcionar al usuario el mismo nivel de servicio que el disponible actualmente en otros buses de campo. J. etc. Página 7 . Escalera M. Es asignada por el constructor del equipo.) Aplicación: programa de aplicación. modificar o suprimir una extensión: efectuar el mismo procedimiento que para la creación de una aplicación desde el paso 4. cuando el equipo de sustitución esté físicamente conectado a la red. BDF: Diagrama de bloques de función (Functional Block Diagram). Inicio con la herramienta de programación Glosario (términos utilizados) Descripción La definición de los términos actuales tiene como objetivo facilitar la comprensión de la ayuda. restaurar los parámetros de aplicación del equipo para que se reinicie en el mismo Prof. mediante teclas.. control de acceso a los medios. parametrización. Resultado: la hoja de cableado se muestra en pantalla. supervisión. 3 Validar las modificaciones haciendo clic en el botón Siguiente. etc. CA: Corriente alterna (230 CA. permite utilizar el controlador de forma autónoma (control. Dirección material de una tarjeta o de una red periférica codificada con 6 bytes y única en el mundo. FDR : El servicio FDR (Faulty Device Replacement) forma parte de la estrategia de puesta en marcha Transparent Ready. 24 CA). denominadas extensiones.

Puerta de enlace : Equipo que conecta las redes cuya arquitectura es diferente y funcionan en la misma capa de aplicación. los datos y los parámetros modificados en el controlador. sus bloques de funciones internas y por sus conexiones de entrada y salida. sus enlaces. Página 8 . Este software garantiza el funcionamiento del controlador. Se caracteriza por su número. Contiene las columnas correspondientes a los contactos y una columna correspondiente a las bobinas de una aplicación en modo LD. Monitorización: acción que permite comprobar. su nombre. Programa: véase Aplicación. SFC: (Sequential Function Chart). LD: Ladder Diagram. Macro : Una MACRO es un reagrupamiento de los bloques de funciones. Modo de programación similar a GRAFCET. J. del esquema FBD a la pestaïa MACRO de la barra de funciones. Estos botones y su contenido se guardan en el contexto de la herramienta ClsM3 para editar nuevos FBD. Este término puede hacer referencia a un encaminador. Pestaña personalizable de la barra de funciones: botón de la barra de funciones en la que el usuario de la herramienta puede agrupar un conjunto de funciones o macros según le convenga mediante el método de arrastrar y soltar. Esquema: diseño del programa en la ventana de programa. Hoja de cableado : área de trabajo de la ventana Edición: Contiene los slots de entrada y de salida de una aplicación en modo BDF. Arrastrar y colocar (Drag/Drop): operación que consiste en seleccionar un elemento con el botón izquierdo del ratón. Interfaz hombre-máquina de la herramienta : interfaz hombre-máquina de la herramienta de programación que se ejecuta en el PC. Pestaña de la barra de funciones: botón de la barra de funciones que muestra un conjunto de funciones o macros. mediante el mótodo de arrastrar y soltar. mediante la herramienta del PC (modo conectado) o en la pantalla LCD del controlador. A. Se guarda en el contexto de la herramienta ClsM3 para editar nuevos FBD. Gráfico: diseño del programa en la ventana Edición (a veces denominado esquema).Manual Crouzet Millenium 3 (1ª parte) 2012 contexto que antes del fallo. Escalera M. Software del controlador : el software almacenado en la memoria del controlador. MEI : La interfaz MEI (Modbus Encapsulated Interface) es un mecanismo de encapsulación de solicitudes de servicios y de métodos de invocación y sus respuestas en una trama Modbus. Menú contextual : menú que aparece haciendo clic en el botón derecho del ratón. Prof. mantener pulsado el ratón mientras se arrastra el elemento y soltar para colocar el elemento en la ubicación deseada en la pantalla. Macro archivada: MACRO que se traslada.

Prof. Escalera M. J.Manual Crouzet Millenium 3 (1ª parte) 2012 Supervisión: este término hace referencia a la ventana de interfaz hombre-máquina de la herramienta en la que se visualizan los datos y los parámetros del programa verificado durante una fase de simulación o monitorización. DIG: Digital. Ficha de estado (SFC) en modo BDF. Página 9 . ANA (analógica). A. Tipos de conexiones : DIG (digital).

La presencia o ausencia de visualizador. seleccionar la categoría activando la casilla correspondiente. J. Resultado: pueden darse las posibilidades siguientes en este paso: Si el controlador no admite extensiones. A. Creación de una aplicación Procedimiento de creación de una aplicación: Paso 1 2 Acción Seleccionar el menú Archivo ® Nuevo. La posibilidad o no de conectar extensiones.Manual Crouzet Millenium 3 (1ª parte) 2012 Creación o modificación de configuración de una aplicación Introducción Esta fase es importante porque determina la configuración futura del entorno de trabajo. así como el lenguaje de programación. si fuese necesario. Si el usuario modifica también el lenguaje de programación de una aplicación abierta en modo de edición. La tercera permite elegir el lenguaje de programación. FBD o LD (la opción LD no se propone para las extensiones de tipo analógico). Escalera M. pasar directamente al paso 6. Resultado: la lista de los controladores correspondientes aparece en la zona Seleccionar el tipo de controlador que se desea programar. Los controladores se reagrupan en categorías correspondientes a estos elementos: El número de entradas/salidas. Descripción El menú:Archivo ® Nuevo y el menú:Controlador ® Elegir el tipo de controlador permiten elegir o modificar el tipo de controlador y/o las extensiones. La segunda permite agregar una extensión. 3 Seleccionar el controlador haciendo clic en la línea correspondiente. y validar pulsando el botón Siguiente >. Página 10 . Resultado: aparece la ventana Selección del controlador. En la zona Seleccionar la categoría del controlador. Esta función muestra un conjunto de tres pantallas: La primera pantalla permite seleccionar el tipo de controlador. esto conlleva el cierre de la aplicación en curso y la creación de una nueva aplicación (programa de aplicación). Prof.

así como un conjunto específico de funciones FBD y Macro que incluye la barra de funciones. Se puede eliminar la extensión de la lista Extensiones seleccionadas utilizando el botón Suprimir. . Si se elige esta extensión. Para una aplicación en modo FBD: A cada tipo de controlador (+ posibles extensiones) le corresponde un fondo de plano visualizado en la ventana Edición con las entradas/salidas específicas al tipo elegido sobre el contorno. Nota: la extensión XE10 24VDC es una extensión extensible. 5 6 7 Modificación de la configuración de una aplicación Procedimiento de modificación de la configuración de una aplicación: Paso 1 Acción Hacer clic en el menú :Controlador ® Seleccionar el tipo de controlador. Página 11 Prof. Resultado: aparece la zona de selección del tipo de programación. A. es necesario hacer clic sobre el diseño asociado. Para elegir el tipo de programación. haciendo doble clic en la línea correspondiente o utilizando el botón Agregar. Validar la configuración con el botón Siguiente>. aparecerán dos zonas nuevas en la ventana: Selección actual: resume las selecciones efectuadas en los pasos 2 y 3.. La ventana de edición aparece con una hoja de cableado en blanco. entonces es posible añadir otra extensión. Resultado: aparece la ventana de recapitulación. Hacer clic en el botón Siguiente> para validar.Manual Crouzet Millenium 3 (1ª parte) 2012 Si el controlador admite extensiones. Los nombres del controlador y de las extensiones se muestran encima de la hoja de cableado.. Resultado: la extensión seleccionada aparece en la lista Extensiones seleccionadas. J. 4 En la zona Seleccionar las extensiones. Seleccionar las extensiones: muestra las extensiones compatibles. elegir el tipo de extensiones que se desean agregar a la lista Extensiones compatibles. Escalera M. Los nombres del módulo y de las extensiones se muestran debajo de la hoja de cableado. Para una aplicación en modo LD A cada tipo de módulo (+ posibles extensiones) le corresponde un conjunto y un número específico de funciones LD en la barra de funciones. Las funciones que no sean compatibles con el controlador seleccionado y las macros que contengan una función no compatible con el controlador seleccionado aparecerán en gris oscuro en la barra de funciones.

Para: Modificar el tipo de controlador: hacer clic una vez el botón Anterior. A. el cuadro de diálogo muestra la lista de las variables disponibles: El número del elemento. Prof. y efectuar el mismo procedimiento que para la creación de una aplicación desde el paso 2. Creación de una aplicación LD Introducción de un elemento La introducción de los elementos sigue las reglas que se detallan a continuación: Contacto : en todas las columnas excepto en las dos últimas. Resultado: la hoja de cableado se muestra en pantalla. 3 Programar en escalera.Manual Crouzet Millenium 3 2 (1ª parte) 2012 Modificar los parámetros para obtener la configuración deseada. Modificar el tipo de programación: hacer clic en la figura que representa el tipo de programación deseado. modificar o suprimir una extensión: efectuar el mismo procedimiento que para la creación de una aplicación desde el paso 4. Escalera M. La etiqueta del elemento. J. Cuando el ratón pasa sobre alguno de los elementos. Página 12 . Procedimiento de introducción: Paso Descripción 1 Seleccionar el tipo de elemento deseado en la barra de herramientas: Ilustración La lista de los elementos disponibles se visualiza en la parte inferior de la pantalla. Bobina: en la penúltima columna (la última está reservada para los comentarios). Validar las modificaciones haciendo clic en el botón Siguiente. Agregar.

Conectar los elementos de la hoja de cableado haciendo clic en los vínculos punteados que los separan. Prof. 2 3 4 5 (1ª parte) 2012 Seleccionar el elemento deseado en el cuadro de diálogo colocando encima el ratón. bastará con: Seguir el procedimiento de introducción de un elemento. a continuación. Supresión de un elemento Para eliminar un elemento. Introducir el comentario cuando sea necesario haciendo clic en la zona de comentario.Manual Crouzet Millenium 3 El comentario asociado. A. Sustitución de un vínculo por un contacto Para reemplazar un vínculo por un contacto. Ctrl+X. Supresión de un enlace Para eliminar los vínculos entre elementos. Hacer clic con el botón derecho del ratón/Eliminar. Procedimiento de introducción: Paso Descripción 1 Seleccionar el segmento que se desea transformar colocando encima el ratón. J. seleccione el elemento y. Página 13 . pulse una de estas teclas del teclado: Supr. Ilustración 3 4 Soltar el botón del ratón: se crea el segmento. Escalera M. Hacer clic con el botón izquierdo del ratón. Introducción de un vínculo La introducción de un vínculo se efectúa exclusivamente en las celdas que poseen líneas punteadas. 2 Hacer clic con el botón izquierdo del ratón: el segmento validado se vuelve rojo. basta con clic de nuevo sobre el vínculo. Soltar el botón del ratón encima de la celda seleccionada. Tecla de retroceso.

. Escalera M. es necesario completar los parámetros de las funciones de automatismo configurables: Salidas DIG Memorias auxiliares Relojes Temporizadores Contadores Contador rápido Comparadores de contadores Textos Una vez introducida la función de automatismo en la hoja de cableado. (1ª parte) 2012 Nota: Esta operación sólo será posible en las celdas reservadas a los contactos. haciendo clic en el botón. Comentarios: comentarios asociados. Acceso mediante el modo Parametrización El modo Parametrización incluye una lista de todas las funciones de automatismo que poseen parámetros utilizados en la aplicación. Página 14 . Acceso directo Una vez introducida la función de automatismo en la hoja de cableado. Parámetros de funciones de automatismo Descripción Al introducir un esquema de comando.Manual Crouzet Millenium 3 Colocar el contacto sobre el segmento que se desea modificar. La interfaz general permite visualizar la información completa: Nº: Número de la función Prof. haga doble clic encima para abrir la ventana de parámetros correspondiente. Se puede acceder a este modo en la ventana de edición. A. Esta ventana se compone de dos fichas: Parametrización: son los parámetros específicos asociados a la variable. J. haga doble clic encima para abrir la ventana de parámetros correspondiente.

. J. el día de la semana (D/S).. (1ª parte) 2012 Label: identificación del bloque de función en el esquema de cableado. El cuadro de comando Bloques funcionales. .. Comentario: comentarios asociados a la función. Copia de seguridad en caso de corte de red: indica si se selecciona la opción Copia de seguridad en caso de corte de red. A. . La ventana de supervisión. Verificación remota del panel frontal) de la herramienta. haciendo clic con el botón derecho en el bloque de función. Parámetros el valor que se va a alcanzar de un contador progresivo. MONITORIZACIÓN.. contador.. Parámetros en modo MARCHA En modo MARCHA (SIMULACIÓN. se puede modificar de forma dinámica de los parámetros si están en Modificación permitida por: El menú PARÁMETRO del panel frontal. Escalera M. Modificación permitida: si se autoriza o no se autoriza la modificación de los parámetros de la función a partir del panel frontal del controlador. los parámetros ON/OFF Prof. Posición: posición en la hoja de cableado: Ilustración: Es posible configurar los distintos parámetros haciendo doble clic en la línea deseada. Lista de las manipulaciones autorizadas Funciones de automatismo Modificaciones autorizadas Contador Valor de preselección Temporizador Las duraciones de temporización Reloj La banda. Página 15 . En la hoja de edición.Manual Crouzet Millenium 3 Función: temporizador.

Página 16 . Mediante los menús : hacer clic en Edición ® Eliminar línea. Escalera M. seleccionar la línea (o una celda) y utilizar uno de los métodos siguientes : Mediante el teclado : pulsar la tecla Supr o Retroceso o Ctrl + X. Nota: También se pueden utilizar los comandos Cortar. Copiar partes de programa Descripción Se pueden copiar partes enteras del programa: Paso Descripción 1 Seleccionar los elementos que se desean copiar. 3 Colocarse en la zona de destino. A. J.Manual Crouzet Millenium 3 Inserción/eliminación de líneas de programa (1ª parte) 2012 Inserción de líneas Seleccionar la línea que se desea desplazar hacia abajo o una de sus celdas y utilizar los métodos siguientes : Mediante el teclado : pulsar la tecla Ins Mediante el ratón : hacer clic con el botón derecho/insertar una línea en el número de la línea que se desea desplazar hacia abajo. Mediante los menús : hacer clic en Edición ® Insertar una línea. Mediante el ratón : hacer clic con el botón derecho/eliminar la línea en el número de la línea que se desea eliminar. 4 Hacer clic con el botón derecho/pegar para pegar los elementos contenidos en el portapapeles (CTRL+ V). Copiar y Pegar del menú Edición. 2 Hacer clic con el botón derecho/copiar para copiar los elementos en el portapapeles (CTRL+ C). Prof. Eliminación de líneas Para eliminar una línea (o una celda).

Página 17 . De este modo. Ilustración Cuando el programa detecta un problema eventual. un símbolo de ojo pasa de azul a rojo en la parte superior de la ventana de edición. cargarse o ejecutarse en el controlador. J. Descripción del error. Sin embargo.Manual Crouzet Millenium 3 Control de la coherencia del programa (1ª parte) 2012 Descripción Durante la introducción del programa. pero que pueden justificarse sin problemas en determinadas aplicaciones. la banda Control de coherencia se pone en rojo y entonces será posible visualizar un cuadro de diálogo haciendo clic encima La ventana de coherencia del programa proporciona la información siguiente: Número del error. Al hacer doble clic en el error en la ventana. la herramienta de programación controla permanentemente la coherencia del programa: Línea incompleta. . A. Prof.). Escalera M. se resalta el lugar del problema en la hoja de cableado. Valor de Preset sin definir. la red LD siempre puede simularse. en caso de que se detecten anomalías de cableado (cableado vacío. etc. Entrada Reset RX desconectada. Localización del error: línea y columna. es posible desarrollarla y depurarla de forma progresiva. Se trata de avisos que proporcionan información al usuario sobre los procedimientos de cableado especiales. restablecimiento de una función no conectada.

Al pasar de MARCHA a PARO.Manual Crouzet Millenium 3 (1ª parte) 2012 Estos avisos se refieren generalmente a los procedimientos de cableado incompletos. los contactos activos se visualizan en rojo en la Vista de programa. Únicamente los contactos permanecen en modo de forzado permanente (resaltados en rojo). Los contactos y bobinas pueden mostrarse en color NARANJA si están ACTIVOS pero no reciben alimentación. Página 18 . Una bobina no conectada permanece inactiva. J. a los parámetros cuyo valor predeterminado no se modifica y a algunas configuraciones especiales de Reloj (cuya salida permanece en ON de forma constante). se podrá realizar un proceso de depuración progresivo. el programa siempre puede simularse o ejecutarse. a la falta de cableado de determinadas entradas (por ejemplo. restablecimiento de función . En modo MARCHA se simulan los elementos siguientes : Hoja de cableado: visualización de forma dinámica (en rojo) de los diferentes elementos activos del programa Comando de las entradas Comando de los relés auxiliares Comando de las salidas Comando de las teclas A/B Función de automatismo Relojes Los contactos en salida de las funciones de automatismo en el esquema de cableado pueden forzarse para comprobar el comportamiento del programa en condiciones especiales. ). Ilustración: En el modo MARCHA. De este modo. Nota: Incluso si el símbolo de ojo está en rojo. los valores actuales de las funciones de automatismo vuelven a pasar a cero.. Depuración de una aplicación LD desde la herramienta de programación Simulación de una aplicación Descripción El modo de simulación permite ejecutar el programa directamente en la herramienta de software (en modo local). En modo PARO. Escalera M. se pueden colocar los forzados por impulso o permanentes para preparar el modo MARCHA. Prof. A. durante la depuración de la aplicación.

no es posible llevar a cabo ninguna acción en esta entrada hasta que no se ejecute un comando de liberación. Escalera M. A partir de ese momento.Manual Crouzet Millenium 3 (1ª parte) 2012 (Consulte Depuración de una aplicación sin necesidad de cargarla en el controlador: simulación). en este caso. Desde la hoja de cableado Posibles acciones : Forzado permanente : clic con el botón izquierdo del ratón en la entrada deseada. A. Liberar todo : clic con el botón derecho del ratón. Forzado por impulso : clic con el botón derecho del ratón. Ilustración : entrada I2 de paso Posibles acciones : Forzado permanente : clic con el botón izquierdo del ratón. Página 19 . Simulación de los relés auxiliares Desde el cuadro de comando Bobinas El icono permite visualizar u ocultar el cuadro de comando de las bobinas. la entrada está bloqueada (aparece resaltada en color rojo) en el estado deseado : ON u OFF. J. Forzado por impulso : clic con el botón derecho del ratón en la entrada deseada. Simulación de las entradas DIG Desde el cuadro de comando Entradas DIG El icono permite visualizar u ocultar el cuadro de comando de las entradas. Ilustración : bobina M2 activa Posibles acciones: Forzado por impulso : clic con el botón derecho o izquierdo del ratón. Liberar : clic con el botón derecho del ratón. Forzado mantenido : clic con el botón derecho del ratón. Desde la hoja de cableado Posibles acciones : Forzado permanente : clic con el botón izquierdo del ratón en la bobina deseada. Prof. Forzado por impulso : clic con el botón derecho del ratón.

Forzado por impulso : clic con el botón derecho del ratón. Ilustración : salida Q2 activa Posibles acciones : Forzado permanente : clic con el botón derecho o izquierdo del ratón. la bobina está bloqueada (aparece resaltada en color rojo) en el estado deseado : ON u OFF. Ilustración: Posibles acciones: Forzado por impulso : clic con el botón derecho o izquierdo del ratón. Página 20 . Liberar : clic con el botón derecho del ratón. en este caso. en este caso. J. la salida está bloqueada (aparece resaltada en color rojo) en el estado deseado: ON u OFF. Liberar : clic con el botón derecho del ratón. Escalera M. Forzado mantenido : clic con el botón derecho del ratón. A partir de ese momento. se enciende la bombilla correspondiente. Esta bombilla permanece encendida cuando se simula un corte de alimentación. Simulación de las salidas DIG Desde el cuadro de comando Salidas DIG El icono permite visualizar u ocultar el cuadro de comando de las salidas. no es posible llevar a cabo ninguna acción en esta bobina hasta que no se ejecute un comando de liberación. Prof. Desde la hoja de cableado Posibles acciones : Forzado permanente : clic con el botón izquierdo del ratón en la salida deseada. Si se activa una salida Q en el modo de simulación. A. no es posible llevar a cabo ninguna acción en esta salida hasta que no se ejecute un comando de liberación. Simulación de las teclas A/B Desde el cuadro de comando Teclas A/B El icono permite visualizar u ocultar el cuadro de comando de las teclas A/B.Manual Crouzet Millenium 3 (1ª parte) 2012 Forzado mantenido : clic con el botón derecho del ratón. A partir de ese momento. Liberar todo : clic con el botón derecho del ratón. Liberar todo : clic con el botón derecho del ratón.

Prof. Resultado: se abre la ventana de parámetro de la función. Escalera M. A. Cómo modificar los parámetros de funciones Durante la simulación. Forzado por impulso : clic con el botón derecho del ratón. la tecla está bloqueada (aparece resaltada en color rojo) en el estado deseado : ON u OFF. mediante los siguientes pasos : Paso 1 Pulsar el botón . en este caso. A partir de ese momento. Liberar : clic con el botón derecho del ratón. Haga clic en Aceptar Monitorización de una aplicación Descripción La función de monitorización permite ejecutar el programa en el módulo lógico (modo conectado) y visualizar su desarrollo en la herramienta de software (mediante un enlace serie). Resultado: Se visualiza el índice de funciones.Manual Crouzet Millenium 3 (1ª parte) 2012 Desde la hoja de cableado Posibles acciones : Forzado permanente : clic con el botón izquierdo del ratón en la tecla deseada. J. no es posible llevar a cabo ninguna acción en esta tecla hasta que no se ejecute un comando de liberación. Página 21 . Modifique uno o varios parámetros de la función. Ilustración: Acción 2 3 4 Hacer doble clic en la línea e la función. Forzado mantenido : clic con el botón derecho del ratón. se pueden visualizar y después modificar los parámetros de una función. Liberar todo : clic con el botón derecho del ratón.

Nota: Es necesario tener la misma aplicación en el PC y en el controlador. Al pasar de MARCHA a PARO. Se pueden forzar algunos estados desde la herramienta y visualizar todos los estados internos del programa (un máximo de diez salidas de bloques de función de forma simultánea).Manual Crouzet Millenium 3 (1ª parte) 2012 El estado de los diferentes elementos de la aplicación: entradas/salidas y parámetros. o a través del iconoM. Ilustración En modo MARCHA se visualizan en rojo los contactos activos: Los contactos y bobinas pueden mostrarse en color NARANJA si están ACTIVOS pero no reciben alimentación. los valores actuales de las funciones de automatismo vuelven a pasar a cero. Escalera M. se actualiza en cada ciclo del programa. Página 22 . A. Pueden presentarse los casos siguientes: Está abierta una aplicación en la herramienta: la versión existente en el controlador se compara con la de la herramienta: Prof. (Consulte Supervisión y modificación de una aplicación que se ejecuta en el controlador mediante la herramienta de programación: monitorización). J. Acceso al modo de monitorización Es posible acceder a la monitorización a través del menú:Modo ® Monitorización.

Hacer clic en Aceptar 2 3 Cómo efectuar un forzado por impulso En el modo monitorización. Escalera M.Manual Crouzet Millenium 3 (1ª parte) 2012 Si la aplicación de la herramienta es idéntica a la del controlador. es necesario sincronizar las versiones transfiriendo el programa del PC al controlador o del controlador al PC. No existe ninguna aplicación abierta en la herramienta: en este caso. Para la hoja de cableado: Hacer clic con el botón izquierdo del ratón en el contacto correspondiente a la entrada. la tecla o el relé auxiliar en el que se debe realizar el forzado. la salida. una entrada. la salida. Modifique uno o varios parámetros de la función. Resultado: se abre la ventana de parámetro de la función. J. La pantalla de supervisión se visualiza desde el final de la transferencia. en la tabla de síntesis de funciones o en la ventana de supervisión). . (Esta operación puede efectuarse en la ventana de edición. haciendo clic en el botón: Para las entradas: Para los relés auxiliares: Para las salidas: Para las teclas A/B: Haga clic con el botón derecho o el izquierdo del ratón en el botón correspondiente a la entrada. Página 23 Prof. la tecla o el relé auxiliar en el que se debe realizar el forzado. una tecla A o B o un relé auxiliar mediante los siguientes pasos : Método Por medio del cuadro de comando Acción(es) Visualice el cuadro de comando correspondiente. una salida. se pueden modificar los parámetros de una función en la venta Edición. la herramienta propone dirigir al PC la aplicación en progreso de ejecución en el controlador. Cómo modificar los parámetros de una función Durante la monitorización. A. se puede realizar un forzado por impulso en un contacto. se inicia el modo de monitorización. Paso 1 Acción Hacer doble clic en el símbolo que representa la función. En caso contrario.

A. Escalera M. J. se puede realizar un forzado de manera permanente en un contacto. Página 24 . mediante los siguientes pasos : Paso 1 2 3 Acción Haga clic con el botón derecho del ratón en el contacto. Hacer clic en Liberar.Manual Crouzet Millenium 3 (1ª parte) 2012 Cómo efectuar un forzado permanente En el modo Monitorización. En el menú contextual. Resultado: El vínculo permanece en el estado seleccionado hasta liberar. Seleccione el estado en el que debe realizarse el forzado en el vínculo.... Prof. Hacer clic en la hoja de cableado con el botón derecho del ratón.. . seleccione Forzado mantenido.lleve a cabo los siguientes pasos :   Todos los contactos   Hacer clic en el contacto con el botón derecho del ratón. Hacer clic en Liberar todo. desde la hoja de cableado. Cómo liberar los forzados El (o los) vínculo(s) forzados y las entradas forzadas pueden liberarse de la siguiente manera: Para liberar Un contacto.

La figura siguiente presenta la estructura de una función: 4 Comentar cada función Ejemplo: Prof. Ejemplo Conteo de coche Programación diaria 3 Realizar cada función teniendo en cuenta algunos elementos: Los datos de entradas. los datos de salidas y los parámetros de ajuste (umbral). Escalera M. Ejemplo Presencia de coche Captador de fin de recorrido Comando de accionador 2 Indicar las funciones de automatismo que se desean realizar. Página 25 . J.Manual Crouzet Millenium 3 Consejos de estructuración de los programas LD (1ª parte) 2012 Generalidades Es importante respetar algunas reglas básicas para que el programa desarrollado en LD sea legible. Procedimiento En la tabla siguiente se describen las fases de realización del programa LD: Fase 1 Descripción Indicar las Entradas/salidas e introducir los comentarios asociados. A.

contadores progresivos y bloque de texto. Esta presentación se dirige a las personas familiarizadas con la utilización de herramientas de software de programación que se encuentran normalmente en el medio del automatismo. Verificar las funciones de REINICIO de las temporizaciones. el área de trabajo se compone de una hoja de cableado sobre la que se colocan las distintas funciones de automatismo. Una salida Set deberá estar acompañada por una salida REINICIO. A. Buena visibilidad global de la aplicación. deberá estar activada una salida en un único lugar en el programa. Creación de la aplicación mediante la función de arrastrar y soltar de las funciones de automatismo. Utilización de ventanas de parámetros. J. Bajo esta forma.Manual Crouzet Millenium 3 (1ª parte) 2012 5 Comprobar cada función mediante la herramienta de simulación. Escalera M. Página 26 . Acceso A la Vista programa se puede acceder mediante el botón . Descripción La figura siguiente muestra un ejemplo de cableado en Vista programa. Vista programa Presentación La utilización de la herramienta en modo Vista programa permite una presentación del software de la programación: Utilización de barras de herramientas. : Prof. En general.

4 : Conexión prediseñada Hacer clic con el ratón sobre las conexiones prediseñadas horizontales y/o verticales para trazar una conexión. verde: una entrada (o acción) hacia la columna de bobina. Objetivo Acción(es) Página 27 Prof. J. 2 : tabla de un tipo de función Utilización Haga clic sobre un tipo de función para hacer aparecer la tabla de funciones disponibles. Muestra las funciones disponibles Poner directamente los comentarios para cada función: en el columna Comentario. lugar de la hoja de cableado donde se puede dejar la función: Comentario asociado a la función. A. 3 : símbolo. Representa una función en $/$Símbolo escalera o en $/$Símbolo eléctrico según la elección realizada en el menú Visualización. visualizar u ocultar los comentarios? La tabla siguiente describe las posibilidades de añadido y visualización de los comentarios. Escalera M. . ¿Cómo añadir. Lista de sus salidas (o estados).Manual Crouzet Millenium 3 (1ª parte) 2012 Los elementos se describen en la tabla siguiente: Elemento Descripción 1 : barra de Reagrupa los tipos de funciones de funciones automatismo disponibles. Lista de sus entradas (o El color en primera línea indica el acciones). Hacer doble clic sobre el símbolo para abrir la ventana de parametrización. Arrastrar las funciones desde la tabla a la hoja de cableado. blanco: una salida (o estado) hacia una columna de contacto. Permite efectuar una conexión sobre la hoja de cableado.

. tipo de temporizador. .. Vista parámetros Descripción La Vista parámetros incluye una lista de todas las funciones de automatismo que poseen parámetros utilizados en la aplicación. Prof. Modificar: indica si está autorizada o no la modificación de los parámetros a partir del panel frontal del controlador.. Hacer clic en Aceptar. A. La interfaz general permite visualizar la información completa: Función: temporizador. Preselección: el valor que se va a alcanzar de un contador progresivo. .. Comentario: comentarios asociados a la función. Escalera M.Manual Crouzet Millenium 3 Añadir un comentario (1ª parte) 2012 Hacer doble clic sobre el símbolo en la hoja de cableado... . Visualizar los comentarios Ocultar los comentarios Hacer clic en el menú :Visualización ® Comentarios ® Todos Hacer clic en el menú :Visualización ® Comentarios ® Ninguno Resultado: cada comentario se sustituye por un pequeño sobre . . Posición: posición en la hoja de cableado. . Página 28 . Seleccionar la pestaña Comentario en la ventana de parametrización. Introducir el texto. contador. Tipo: tipo de contador progresivo. J. Label: identificación del bloque de función.

con el fin de obtener una buena visibilidad de la aplicación. Las funciones de automatismo que se pueden configurar son las siguientes:  Relojes    Temporizadores Contadores Textos Acceso A la Vista parámetros se puede acceder mediante el botón Vista comentarios . Este modo se aplica a:  Entradas DIG      Teclas A/B Salidas DIG Relés auxiliares Temporizadores Contadores progresivos Prof. Página 29 .Manual Crouzet Millenium 3 Ilustración: (1ª parte) 2012 Es posible configurar los distintos parámetros haciendo doble clic en la línea deseada. A. Es importante identificar correctamente cada entrada/salida mediante un comentario explícito. Escalera M. Descripción La Vista comentarios permite obtener una visión global de las entradas/salidas utilizadas en la aplicación. J.

Prof. Escalera M. Nota: debido a razones de visualización e impresión. Ilustración: Los comentarios se mostrarán debajo del contacto o de la bobina durante la visualización del programa en la configuración siguiente: El comentario está integrado en la red debajo del elemento gráfico asociado (contacto o bobina). Página 30 . se puede visualizar únicamente los bloques utilizados con ayuda del menú desplegable que aparece en la zona de edición. J. A. se recomienda no sobrepasar los 25 caracteres.Manual Crouzet Millenium 3       Contador rápido Comparadores de contadores progresivos Relojes Bloques de texto Retroiluminación de la pantalla LCD Verano invierno (1ª parte) 2012 En la ventana.

Escalera M. Introducción/modificación de los comentarios Para introducir o modificar los comentarios. Fin de la 1ª parte. Página 31 . Prof. A. introducir el texto y validar. hacer doble clic en la zona del comentario. J.Manual Crouzet Millenium 3 Ilustración: (1ª parte) 2012 Acceso A la Vista comentarios se puede acceder mediante el botón .

You're Reading a Free Preview

Descarga
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->