P. 1
Comandos Turbo Pascal

Comandos Turbo Pascal

|Views: 298|Likes:
Publicado porXander Muñoz

More info:

Published by: Xander Muñoz on Feb 03, 2012
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as DOCX, PDF, TXT or read online from Scribd
See more
See less

05/03/2015

pdf

text

original

2.1.

Utilizando el teclado
Al momento de escribir nuestro programa, el teclado será el principal medio para el ingreso de texto. Algunas de las principales combinaciones de teclas para mover el cursor a través de la pantalla del editor, son las siguientes: Movimiento Teclas Carácter a la izquierda Carácter a la derecha Palabra a la izquierda Ctrl+ Palabra a la derecha Ctrl+ Línea abajo Línea arriba Pantalla abajo AvPág Pantalla arriba RePág Principio de línea Inicio Final de línea Fin Principio de la ventana Ctrl+Inicio Final de la ventana Ctrl+Fin Principio del programa Ctrl+RePág Final del programa Ctrl+AvPág Indentación Tab
Tabla 1 - Combinación de teclas para movimiento del cursor

También se puede utilizar el teclado para realizar otra serie de operaciones como borrar caracteres, abrir archivos, etc. Los comandos más importantes que se pueden ejecutar a través del teclado se muestran a continuación: Comando Teclas Borrar un carácter a la izquierda del cursor Retroceso Borrar un carácter a la derecha del cursor Suprimir Borrar la palabra a la izquierda del cursor Ctrl+T Insertar una línea Ctrl+N Borrar una línea Ctrl+Y Borrar desde el cursor hasta el final de la línea Ctrl+Q+Y Activar la barra de menús F10 Abrir un fichero F3 Guardar un fichero F2
Tabla 2 - Combinación de teclas para otros comandos

Además de caracteres, palabras, líneas, ventanas y programas, en TP podemos hablar de bloques. Un bloque es cualquier cantidad de texto (desde un simple carácter hasta cientos de líneas) que el usuario haya marcado como bloque. Para marcar un bloque hay que indicar el principio y final del mismo. En una ventana sólo puede existir un único bloque en un momento determinado. Los comandos utilizados para bloques se detallan a continuación. Comando Teclas Marcar un bloque
Mayús+ , , , Ctrl+K+B (inicio de bloque) Ctrl+K+K (fin de bloque)

Ir al principio del bloque Ctrl+Q+B Ir al final del bloque Ctrl9Q+K Copiar un bloque Ctrl+Insert, Mayús+Insert

se pasa el control a este procedimiento y también lo ejecuta sentencia a sentencia. Program reset (Ctrl+F2) Detiene la sesión de depuración actual y devuelve el control al usuario. Comandos para bloques 2. 2. Cuando encuentra un procedimiento o función. sentencia a sentencia.2. El menú Compile contiene las opciones para la compilación y ejecución de programas. Instituto Superior de Formación Docente Nº 6012 .PAS). Trace into (F7) Ejecuta el programa. ó con errores. la cual sólo ejecuta las sentencias del procedimiento actual. sentencia a sentencia. los cuales deberán ser corregidos antes de volver a ser compilados sin errores para poder ejecutar el programa obtenido. incluyendo la traza de los procedimientos procedimientos y funciones. lo ejecuta como si fuera una única sentencia.0 Autor: Lic. es necesario compilarlo para obtener un programa objeto que pueda ser ejecutado por la computadora. es decir. Step over (F8) Ejecuta el programa. compilando ese archivo y otros archivos modificados utilizándoos en el programa. Build . Mayús+Insert Borrar un bloque Ctrl+Supr Ocultar/Visualizar un bloque Ctrl+K+H Tabla 3. Si el programa fuente ha sido modificado desde la última compilación. Gustavo Daniel Reyes 7 de 10 Compile (ALT+F9) Compila el archivo de la ventana de edición activa. Esta es la diferencia que tiene con la opción Step Over. el programa está listo para ser ejecutado. Make (F9) Constituye una versión ejecutable del archivo del programa principal. TP vuelve a compilarlo automáticamente antes de ejecutarlo. Durante la compilación.2. desde la línea de comandos.4. en cuyo caso el programa está listo para ser ejecutado. Si se encuentra con un procedimiento o función lo salta. Go to cursor (F4) Ejecuta el programa desde donde se encuentre en ese momento hasta la posición actual del cursor. Salta Cátedra: Programación II (PII) Carrera: Tecnicatura Superior en Análisis de Sistemas con Orientación en Redes Informáticas Apunte de cátedra Unidad 2: El Compilador de Turbo Pascal 7. Menú Compile (Alt+C) Una vez escrito el programa fuente (archivo . Parameters« Especifica los parámetros que se pasan al programa cuando se ejecuta el entorno integrado de desarrollo.5.El Carril. El menú Run permite el control sobre la ejecución de programas. El proceso de compilación puede acabar satisfactoriamente. es decir. TP muestra una ventana con el estado del proceso. Menú Run (Alt+R) Después de que el proceso de compilación haya terminado con éxito. paso a paso. en la ventana de edición activa. en la ventana de edición activa. Run (Ctrl+F9) Ejecuta el programa activo.Mover un bloque Ctrl+Supr.

se muestran las expresiones con sus valores actuales. Breakpoints. Evaluate/modify.. Register Abre la ventana Register. pero recompila archivos fuentes del programa. Destination Memory Especifica si la versión ejecutable de un programa se almacena en memoria o en disco. los errores sintácticos son fáciles de corregir pero no pasa lo mismo con los errores semánticos... Un punto de interrupción permite detener un programa en ejecución exactamente en la línea en la que se insertó. la condición a evaluar y la pasada en la que debe parar el programa.. cuyo código fuente se encuentra en archivos múltiples. permite la modificación de ese valor. Output Muestra la ventana de salida (Output)....0 . Call stack (Ctrl+F3) Abre una ventana que contiene una lista de procedimientos y funciones actualmente llamadas en el programa que se está ejecutando.+F7) Inserta una expresión de observación a la ventana Watch. Clear primary file Borra el nombre principal del archivo. Menú Debug (Alt+D) A menudo. que utiliza la pantalla completa para visualizar salidas programas. El cuadro de diálogo de puntos de ruptura muestra todos los puntos de ruptura insertados. Permite insertar. se escriben programas que se compilan sin error (no existen errores sintácticos) pero al ejecutarlos el resultado no es el esperado (se producen errores semánticos). En esta ventana.. Se pueden insertar puntos de ruptura dependiendo de una determinada condición. Añade un punto de ruptura en un cuadro de diálogo. si es posible.. Cuando esta ventana está activa. Para localizar estos errores. sin tener en cuenta si han sido modificados o no modificados. en la línea en la que se encuentran. Normalmente. Add watch. de modo que las órdenes Build o Make actúan sobre el archivo en la ventana de edición. (Ctrl+F4) Permite evaluar el nombre de una variable o expresión.. la cual permite comprobar la salida del programa que estamos ejecutando.El Carril. modificar o borrar puntos de interrupción2 (breakpoints). Muestra una ventana con información del archivo activo. muestra su valor y. podemos utilizar las herramientas que proporciona TP para depurar programas incluidas en el menú Debug. (ctrl. Especifica el archivo principal de un programa. se pueden insertar/borrar expresiones pulsando la tecla Insert/Supr. Es una pausa intencional y controlada durante la ejecución de un programa. 2. Primary File. Watch Muestra una ventana que permiten el control sobre las vistas de variables y expresiones de la ventana Watch. User screen (Alt+F5) Abre la pantalla de usuario. Add Breakpoint. haciendo activa..6..2. que está siendo compilado actualmente. 2 Breakpoint: punto de interrupción.. Information.Hace lo mismo que Make. punto de ruptura o parada dinámica. Salta Cátedra: Programación II (PII) Carrera: Tecnicatura Superior en Análisis de Sistemas con Orientación en Redes Informáticas Apunte de cátedra Unidad 2: El Compilador de Turbo Pascal 7. Instituto Superior de Formación Docente Nº 6012 .

Go to previous (Alt+F7) Salta al mensaje anterior la ventana Messages... Instituto Superior de Formación Docente Nº 6012 . que se utiliza para detectar patrones en archivos. Salta Cátedra: Programación II (PII) Carrera: Tecnicatura Superior en Análisis de Sistemas con Orientación en Redes Informáticas Apunte de cátedra Unidad 2: El Compilador de Turbo Pascal 7. Permite indicar a TP en que directorios debe buscar para encontrar los archivos que necesita en la compilación.... Menú Tools (Alt+T) Permite acceder a diferentes programas auxiliares. Messages Abre la ventana de mensajes (Messages). Menú Options (Alt+O) El Menú Options contiene comandos que permiten modificar el entorno de trabajo y cambiar las opciones de configuración que TP inicializa por defecto. enlazado (linkeado) y ejecución de programas. Especifica las opciones relativas al depurador integrador. . Gustavo Daniel Reyes 8 de 10 2. Environment Esta opción contiene un submenú en el que es posible cambiar las preferencias del usuario (tamaño de la ventana. que se pueden utilizar en el trabajo diario..0 Autor: Lic..). Grep (Shift+F2) Invoca la utilidad Grep3. añade o borra herramientas de programas.. Especifica los tamaños de memoria por defecto de un programa. Compiler. Especificar opciones de compilación.. Abre un archivo con información de parámetros.2. Go to next (Alft+F8) Salta al siguiente mensaje la ventana Messages. las opciones del ratón o los colores para la ventana de edición. tipo UNIX.. las opciones de la ventana de edición. escrita originalmente para ser usada con el sistema operativo Unix.TP.. Open. de modo que pueda inspeccionar salidas de programas. Save as. guardado automático de ficheros.. Linker.El Carril. en lugar de hacerlo en el archivo por defecto TURBO. 2.. Memory sizes. Guarda los parámetros de configuración en el archivo especificado.2. Gustavo Daniel Reyes 9 de 10 Save Todas las opciones que han sido modificadas en una sesión de trabajo (incluidas las opciones de búsqueda y el destino del archivo ejecutable) se restauran cuando se vuelve a ejecutar TP.8... Especifica las opciones relativas al proceso de enlace.. Debugger.TP. Tools.. Guarda los parámetros de configuración modificados en el archivo TURBO. Directories. 3 Utilidad de la línea de comandos.Autor: Lic.7. Edita..

You're Reading a Free Preview

Descarga
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->