Está en la página 1de 3

c 


  

c  
  

  


 
 

  
..

Programa; área

Entorno: BASE, ALTURA, AREA son número enteros

Algoritmo:

escribir Introduzca la base y la altura

leer BASE, ALTURA

calcular AREA = BASE * ALTURA

escribir El área del rectángulo es AREA

Finprograma

c  
  
 

  
 





Programa: SumaProducto

Entorno: NOTA1,NOTA2,SUMA,PRODUCTO son números enteros

Algoritmo:

escribir Introduzca las notas

leer NOTA1,NOTA2

calcular SUMA = NOTA1 + NOTA2

calcular PRODUCTO = NOTA1 * NOTA2

escribir La suma de las dos notas es: SUMA

escribir El producto de las dos notas es : PRODUCTO

Finprograma
c  
  

  

 
 .

Programa: ComparaNúmeros

Entorno: NUMERO es un número entero

Algoritmo:

Escribir Introduzca un número

leer NUMERO

SI NUMERO>0 ENTONCES

escribir El número introducido es positivo

SI NO

SI NUMERO<0 ENTONCES

escribir El número introducido es negativo

SI NO

escribir El número es cero

FINSI

FINSI

Finprograma

?
?


 
 



   
    

ALGORITMO lee_tres_vertices
ENTRADA: las coordenadas (x,y) de tres puntos
SALIDA: las coordenadas (x,y) de los tres puntos movidos 3 puntos hacia la derecha.
VARIABLES: i:entera
x,y: real
INICIO
PARA i=1 HASTA 3 CON INCREMENTO +1
ESCRIBE "Abscisa del punto número ", i
LEER x
ESCRIBE "Ordenada del punto número ", i
LEER Y
ESCRIBE "El punto es (" x+3","y")"
FIN_PARA
FIN
El programa equivalente a este algoritmo se muestra a continuación. Como podemos apreciar en un
programa en Pascal es importantísimo no olvidar detalles de sintaxis. Por ejemplo cada sentencia
termina en punto y coma. De cualquier forma es inmediato apreciar los simples cambios existentes.

program lee_tres_vertices;
var x,y:real;
i:integer;
begin
for i:=1 to 3 do
begin
write ('Abscisa del punto número ',i); readln(x);
write ('Ordenada del punto número ',i); readln(y);
writeln (' El punto es (',x+3,',',y,')');
end;
end;
?
m  
    
      
  
    

?
programa suma_divisibles
variables natural : divisor, suma, contador, número

inicio programa
divisor leer Introduce el divisor:
suma 0
contador 0
para número desde 1 hasta 1000 hacer
si divisor divide a número entonces
suma suma + número
contador contador + 1
fin si
si contador = 10 entonces
interrumpir
fin si
fin para

escribir La suma es , suma

fin programa
?