Está en la página 1de 5

PRINCIPIOS DE ALGORITMOS

EJERCICIOS SEMANA 9

1. Ingrese el nombre del trabajador, la cantidad de horas trabajadas y el valor de la hora


normal. Muestre la cantidad de horas extras y el pago del trabajador. Tenga en cuenta que
el valor de la hora extra es 50% más que el valor de la hora normal y que el trabajo es de
lunes a sábado.

Proceso sin_titulo
Definir NT COMO CARACTER
DEFINIR VHN, HT, HE, PT COMO ENTERO
ESCRIBIR "INGRESE EL NOMBRE DEL TRABAJADOR"
LEER NT
ESCRIBIR "INGRESE EL VALOR DE HORA NORMAL"
LEER VHN
ESCRIBIR "INGRESE EL VALOR DE HORAS TRABAJADAS"
LEER HT

SI HT>48 ENTONCES
HE<- HT-48
SINO
HE<- 0
FinSi

PT<- HT*VHN+HE*VHN*1.5

ESCRIBIR "NOMBRE DEL TRABAJADOR=" NT


ESCRIBIR "VALOR DE HORAS EXTRAS=" HE
ESCRIBIR "PAGO TOTAL DEL TRABAJADOR=" PT

FinProceso
2. Ingrese un numero natural de dos cifras y muestre el mensaje “Es capicúa” o “No es capicúa”
según sea el caso.

Proceso sin_titulo
DEFINIR A, B COMO ENTERO
ESCRIBIR "INGRESE PRIMER DIGITO"
LEER A
ESCRIBIR "INGRESE SEGUNDO DIGITO"
LEER B
SI A=B ENTONCES
ESCRIBIR "EL NUMERO ES CAPICUA"
SiNo
ESCRIBIR "EL NUMERO NO ES CAPICUA"
FinSi

FinProceso
3. Calcular el pago semanal de un trabajador. Los datos a ingresar son: total de horas trabajadas y
el pago por hora. Si el total de horas trabajadas es mayor a 40 la diferencia se considera como
horas extras y se paga un 50% más que una hora normal. Si el sueldo bruto es mayor a s/. 500.00,
se descuenta un 10% en caso contrario el descuento es 0.

Proceso sin_titulo
DEFINIR THT COMO ENTERO
DEFINIR PHN, SB, PS, DSC, PSCD COMO REAL
DEFINIR HE COMO ENTERO
ESCRIBIR "INGRESE TOTAL DE HORAS TRABAJADAS"
LEER THT
ESCRIBIR "INGRESE EL PAGO POR HORA"
LEER PHN
SB<-THT*PHN
SI THT>40 Entonces
HE<- THT-40
SiNo
HE<-0
FinSi
SI SB>500 Entonces
DSC<- SB*0.1
SiNo
DSC<-0
FinSi
PS<- SB+HE*PHN*1.5
PSCD <- PS-DSC
Escribir "Valor de descuento: " DSC
Escribir "Valor de pago extra: " HE
Escribir "Valor de pago normal: " SB
Escribir "Valor de pago semanal: " PS
Escribir "Valor de pago semanal con dsc: " PSCD

FinProceso
4. Hacer un seudocódigo que imprima el nombre de un artículo, clave, precio original y su precio
con descuento. El descuento lo hace en base a la clave, si la clave es 1 el descuento es del 10% y si
la clave es 2 el descuento es del 20% (solo existen dos claves).

Proceso sin_titulo
DEFINIR NP COMO CARACTER
DEFINIR C COMO ENTERO
DEFINIR PO, PCDSC COMO REAL
ESCRIBIR "ELIJA LA CLAVE DEL PRODUCTO (1 O 2)"
LEER C
ESCRIBIR "INGRESE EL PRECIO ORIGINAL"
LEER PO
SI C=1 Entonces
DSC<- PO-(PO*0.1)
ESCRIBIR "NOMBRE DEL ARTICULO =" 1
ESCRIBIR "PRECIO ORIGINAL=" PO
ESCRIBIR "PRECIO CON DESCUENTO=" DSC
SiNo
DSC<- PO-(PO*0.2)
ESCRIBIR "NOMBRE DEL ARTICULO=" 2
ESCRIBIR "PRECIO ORIGINAL=" PO
ESCRIBIR "PRECIO CON DESCUENTO=" DSC
FinSi
FinProceso

5. Escriba un seudocódigo que calcule el importe a pagar por un vehículo al circular por una
autopista. El vehículo puede ser una bicicleta, una moto, un coche, o un camión. Para definir el
conjunto vehículos utilizaremos un tipo enumerado. El importe se calculará según los siguientes
datos:
Un importe fijo de 100 soles para las bicicletas, Las motos y los carros pagarán 30 soles por Km.
Los camiones pagarán 30 soles por Km más 25 soles por Toneladas, La presentación en pantalla
de la solución, será de la forma siguiente:
1. bicicleta
2. moto
3. carro
4. camión
5. salir
6. Determinar la cantidad de dinero que recibirá un trabajador por concepto de las horas extras
trabajadas en una empresa, sabiendo que cuando las horas de trabajo exceden de 40, el resto se
consideran horas extras y que estas se pagan al doble de una hora normal cuando no exceden de
8; si las horas extras exceden de 8 se pagan las primeras 8 al doble de lo que se pagan las horas
normales y el resto al triple