Está en la página 1de 7

TALLER DE PROGRAMACION DE COMPUTADORES

JESUS ALFONSO HERNANDEZ SAUMETH

Cd. 2012215034

Programa: ING. CIVIL

Semestre # 3

PROF. ROBERTO MAL VILLALOBOS

UNIVERSIDAD DEL MAGDALENA

SANTAMARTA / octubre de 2013

1. Construya un algoritmo que determine el valor final de un conjunto de productos los cuales no se conoce la cantidad luego de aplicarles el iva del 16%, se debe determinar tambin la suma total de todos los productos ingresados luego de calcularles el IVA. Ejemplo: Si fuesen tres productos y el primero costara 1000 el segundo 2000 y el tercero 3000 el algoritmo debera determinar. El producto nmero 1 tiene un valor final de 1160. EL producto Numero 2 tiene un valor final de 2320. El producto Numero 3 tiene un valor final de 3480. La suma de los productos es igual a 6960.

funcion_principal real valor, valorf, suma, iva, tot; entero band, opcion, c ; band=1; suma=0; c=0; mientras ( band==1 ) hacer imprimir( " ingrese valor del producto " ); leer( valor ); iva=valor*0.16; valorf=iva+valor; suma=suma+valorf; c=c+1; imprimir( " el producto numero ", c, " tiene un valor final de ", valorf, "," );

imprimir( " ingrese 1 si desea seguir o\n " ); imprimir( " cualquier otro numero si desea terminar\n " ); leer(opcion); si(opcion==1)entonces band=1; si_no band=2; fin_si fin_mientras imprimir( " la suma de los productos es igual a ", suma ); fin_principal

2. Disee un algoritmo que permita calcular el permetro de un nmero indeterminado de rombos, el permetro del rombo=4L siendo L la dimensin de sus lados, el algoritmo terminara cuando el usuario as lo indique ingresando la opcin salir. Se debe imprimir el rea de cada uno de los rombos y se debe indicar cuantos de los rombos tienen permetros superiores a 15.

funcion_principal real perim, lad, area ; entero band, c, pesp ; caracter opcion, s, S, n ; band=1; c=0;

mientras( band==1 )hacer imprimir( " ingrese la dimension del lado del rombo " ); leer(lad); perim=4*lad; area=lad*lad; si(perim>15)entonces c=c+1; si_no c=c+0; fin_si imprimir( " el perimetro del rombo es ", perim, " y\n " ); imprimir( " el area es ", area ); imprimir( " si desea continuar, ingrese: c\n " ); imprimir( " si desea salir, ingrese: s\n " ); leer(opcion); si(opcion=='s' || opcion=='S')entonces band=0; si_no band=1; fin_si fin_mientras imprimir( " hay ", c, " rombos con perimetro mayor a 15\n " ); fin_principal

3. Construir un algoritmo que determine la divisin de dos nmeros sin utilizar la operacin divisin, solo realizarlos a travs de sumas y restas. Por ejemplo 15 entre 5 seria 15-5=10 10-5=5 5-5=0 Se realizaron tres restas es decir el resultado de dividir 15 entre 5 es 3.

funcion_principal real n1, n2, cont, divi, result ; imprimir( "Ingrese el Dividendo " ); leer(n1); imprimir( "Ingrese Divisor " ); leer(n2); cont=0; divi=n1/n2; result=0; mientras( cont<divi )hacer result=n1-n2; cont=cont+1; n1=result;

fin_mientras imprimir( " el resultado es: ", cont ); fin_principal

4. Construir un algoritmo que permita generar los N primeros trminos de la serie 1 3 2 4 3 5 4 6 5, la serie inicia con 1 luego se le suman 2 y despus se le resta 1, as sucesivamente hasta culminar el nmero de trminos de la serie.

funcion_principal entero n, c, ser, s, ban ; imprimir( " ingrese la cantidad de numeros que desea conocer de la serie " ); leer(n); si(n>=1)entonces ser=1; c=0; s=1; ban=0; mientras ( c<n ) hacer imprimir( " ", ser ); si(ban==0)entonces ser=ser+2; ban=1; si_no ser=ser - 1;

ban=0; fin_si c=c+1; fin_mientras si_no imprimir( " solo numeros mayores o iguales a 1 " ); fin_si fin_principal