Está en la página 1de 144

CAT5501 – Configuración Avanzada de Routers

Implementación de EIGRP
Unidad de Aprendizaje N°1
Implementación de IGP avanzado sobre IPv4 e IPv6

Experiencia 2:
Implementación de EIGRP.
Objetivos

• Describir los fundamentos de EIGRP.


• Planear e implementar enrutamiento EIGRP
• Configurar y verificar enrutamento EIGRP
• Configurar y verificar autenticación EIGRP
• Describir y configurar mecanismos de
optimización EIGRP
• Configurar EIGRP para IPv6
• Configuración de EIGRP nombrado
Implementación de EIGRP.

PARTE 1. INTRODUCCIÓN
Parte 1. Introducción
Capacidades y Atributos de EIGRP
• EIGRP es un protocolo vector-distancia
propietario de Cisco con características de
estado enlace
Parte 1. Introducción
Capacidades y Atributos de EIGRP
• Incluye las siguientes características:
– Rápida convergencia
– Actualizaciones parciales
– Soporte para múltiples capas de red
– Uso de comunicación unicast y multicast
– Soporte de VLSM
Parte 1. Introducción
Capacidades y Atributos de EIGRP
• Incluye las siguientes características:
– Conectividad independiente a través de todos los
protocolos de la capa de enlace y sus topologías
– Por defecto, realiza sumarización automática
sobre la red limítrofe mayor (puede ser
deshabililtada) pero puede ser configurada para
sumarizar sobre las interfaces
Parte 1. Introducción
Terminología
• Tabla de vecinos
• Tabla de topología
• Tabla de enrutamiento
• Distancia informada (AD)
• Distancia factible (FD)
• Sucesor y Sucesor Factible (FS)
• Rutas pasivas vs rutas activas
Parte 1. Introducción
Tablas EIGRP
• Tabla de Vecinos
– Contiene las direcciones e interfaces de los
vecinos EIGRP y las interfaces a través de las
cuales pueden ser alcabzados.
• Tabla de Topologías
– Contiene todos los destinos informador por los
routers vecinos.
• Tabla de Enrutamiento
– Contiene las rutas sucesoras EIGRP
Parte 1. Introducción
AD vs FD
• Distancia Informada(AD)
– La Distancia Informada (AD), también llamada la
Distancia Reportada , es el costo entre el router
del siguiente salto y el destino.
• Distancia Factible (FD)
– La Distancia Factible (FD) es el costo entre el
router local y el router del siguiente salto más la
AD del router del siguiente salto a la red de
destino.
Parte 1. Introducción
Sucesor y Sucesor Factible
• Sucesor
– Un sucesor es un router vecino que tiene un
camino de menor costo a un destino (menor FD) y
que garantiza que no es parte de un loop de
enrutamiento.
– Las rutas sucesoras son entregadas a la tabla de
enrutamiento para ser usadas para el envío de
paquetes
– Múltiples sucesores pueden existir si tienen la
misma FD.
Parte 1. Introducción
Sucesor y Sucesor Factible
• Sucesor Factible (FS)
– Un sucesor factible es un vecino que está cercano al
destino, pero no es la ruta con menor costo.
– Un sucesor factible asegura una topología libre de loops
porque debe tener una AD menor que la FD de la ruta
sucesora actual.
– El sucesor factible es seleccionado al mismo tiempo que el
sucesor, pero se mantiene en la tabla de topología como
respaldo de la ruta sucesora.
– La tabla de topologías puede mantener mútiples rutas
sucesoras para un mismo destino.
Parte 1. Introducción
Rutas Pasivas vs Rutas Activas
• Ruta Pasiva
– Una ruta es considerada pasiva cuando el router
no realiza un recalculo sobre dicha ruta.
– PASIVO es el estado estable y operacional.
• Ruta Activa
– Una ruta es activa cuando se está recalculando su
estado dentro de EIGRP.
Parte 1. Introducción
Claves de la Tecnología EIGRP
• Reliable Transport Protocol (RTP)
– EIGRP no puede usar los servicios de UDP o TCP
debido a que las redes IPX y Appletalk no usan el
conjunto de protocolos TCP/IP.
– Reliable Transport Protocol (RTP) es el único
protocolo de la capa de transporte para la entrega
y recepción de paquetes EIGRP.
Parte 1. Introducción
Claves de la Tecnología EIGRP
• Reliable Transport Protocol (RTP)
– RTP es similar a TCP, pero es propietario de Cisco.
– RTP emtrega un servicio confiable o no confiable,
de acuerdo a la situación.
– Los paquetes confiables (Update, Query, Reply)
requieren un conocimiento explícito, mientras que
los paquetes no-confiables (Hello, ACK) no lo
requieren.
Parte 1. Introducción
Claves de la Tecnología EIGRP
• Descubrimiento y Recuperación de Vecinos
– Los routers EIGRP establecen relaciones activas
con sus vecinos.
– Las adyacencias son establecidas usando
pequeños paquetes de saludo los cuales son
enviados cada 5 ó 60 segundos.
• Si un vecino pierde 3 paquetes Hello en forma
consecutiva, entonces el router lo considera inválido.
• Este tiempo es por defecto 15 segundos o 180
segundos.
Parte 1. Introducción
Claves de la Tecnología EIGRP
• Descubrimiento y
Recuperación de
Vecinos
Parte 1. Introducción
Claves de la Tecnología EIGRP
• Módulos Dependientes del Protocolo (PDMs)
– Varios protocolos enrutados son soportados
mediante PDMs.
• Permiten la independencia de los protocolos
enrutados.
• Las PDM son modulares, escalables y adaltables.
• EIGRP se puede adaptar a un nuevo protocolo enrutado
o uno mejorado.
• Los PDMs protegen a EIGRP de una profunda revisión.
Parte 1. Introducción
Claves de la Tecnología EIGRP
• Módulos Dependientes del Protocolo (PDMs)
• Cada PDM es responsable de todas las funciones
relacionadas con un protocolo enrutado específico.
Parte 1. Introducción
Claves de la Tecnología EIGRP
• Módulos Dependientes del Protocolo (PDMs)

EIGRP mantiene tablas


individuales para cada
protocolo enrutado.
Parte 1. Introducción
Claves de la Tecnología EIGRP
• Máquina de Estado Finito DUAL
– DUAL usa las tablas de topologías y de vecinos
para calcular la información de enrutamiento.
– Cuando un enlace falla, DUAl busca un sucesor
factible en las tablas de vecinos y de topologías.
– Compara todas las rutas informadas por los
vecinos usando una métrica compuesta para cada
ruta.
– La ruta de menor costo es insertada en la tabla de
enrutamiento.
Parte 1. Introducción
Claves de la Tecnología EIGRP
• Paquete EIGRP
Frame Payload
Frame Header IP EIGRP CRC
Protocol Number
EIGRP Message
Header (EIGRP = 88) Header

En la LAN, el paquete
La cabecera EIGRP El EIGRP
EIGRP es encapsulado en
La IP de destino es fijada en la IP identifica el tipo de message
una trama Ethernet con
multicast 224.0.0.10 y el campo paquete EIGRP y el consiste en el
una dirección MAC de
de protocol EIGRP es 88. número de Sistema Tipo / Valor /
destino Multicast :
Autónomo. TLV.
01-00-5E-00-00-0A
Implementación de EIGRP.

PARTE 2. ESTABLECIENDO
RELACIONES DE VECINDAD EIGRP
Parte 2. Estableciendo Relaciones de Vecindad EIGRP
Cabecera EIGRP
• EIGRP usa 5 tipos de paquetes para mantener
varias tablas y establecer complejas relaciones
con los routers vecinos:
– Hello (saludo)
– Acknowledgment (reconocimiento)
– Update (actualización)
– Query (petición)
– Reply (respuesta)
Parte 2. Estableciendo Relaciones de Vecindad EIGRP
Paquete EIGRP
Parte 2. Estableciendo Relaciones de Vecindad EIGRP
Paquete de Saludo EIGRP
• EIGRP depende de los paquetes de saludo
para descubrir, verificar y recuperar routers
vecinos.
• Los paquetes Hello EIGRP son multicast hacia
224.0.0.10.
• Los paquetes hello son siempre enviados de
forma no confiable, por lo que no requieren
reconocimiento.
Parte 2. Estableciendo Relaciones de Vecindad EIGRP
Paquete de Saludo EIGRP
Parte 2. Estableciendo Relaciones de Vecindad EIGRP
Paquete de Saludo EIGRP
• Los paquetes Hello son enviado en intervalos
fijos y configurables, llamado Hello interval.
– Los timers Hello/Hold no necesitan coincidir.
– Para reiniciar el intervalo de saludo: no ip hello-
interval eigrp as#
Parte 2. Estableciendo Relaciones de Vecindad EIGRP
Paquete de Saludo EIGRP
• El intervalo Hello depende del ancho de banda
de la interfaz.
– Interfaces Rápidas= 5 seconds
• Intervalo por defecto en enlaces seriales point-to-point,
circuitos multipoint con un ancho de banda mayor que
T1 y LANs.
– Interfaces Lentas = 60 seconds
• Intervalo por defecto en circuitos WAN menores a T1.
Parte 2. Estableciendo Relaciones de Vecindad EIGRP
Paquete de Saludo EIGRP
• Con los Hellos escuchados, el router crea una
tabla de vecinos los hellos que siguen llegando
mantienen la tabla.
• El Holdtime es la cantidad máxima de tiempo
que se espera desde un vecino que no ha
enviado Hellos.
– Tres veces el intervalo de saludo:
• Ancho de Banda Bajo (3 x 60 sec.) = 180 segundos
• Ancho de Banda Alto (3 x 5 sec.) = 15 segundos
Parte 2. Estableciendo Relaciones de Vecindad EIGRP
Paquete de Saludo EIGRP
Parte 2. Estableciendo Relaciones de Vecindad EIGRP
Paquetes de Reconocimiento (ACK)
• Son usados para indicar la recepción de
cualquier paquete EIGRP durante el
intercambio confiable.
• Los paquetes reconocidos son:
– Dataless Hello packets.
– Unicast.
Parte 2. Estableciendo Relaciones de Vecindad EIGRP
Paquetes de Actualización
• Después de que el router local descubre un nuevo
vecino, se envían paquetes de actualización a dicho
vecino.
• Los paquetes de actualización son también usados
cuando un router detecta un cambio de topología.
– El router envía un paquete de actualización multicast a
todos sus vecinos, informando del cambio.
• Todos los paquetes de actualización son enviados en
forma confiable.
Parte 2. Estableciendo Relaciones de Vecindad EIGRP
Paquetes de Actualización
Parte 2. Estableciendo Relaciones de Vecindad EIGRP
Paquetes de Consulta y Respuesta
• Los paquetes de consulta y respuesta son
enviados cuando un destino no tiene un
sucesor factible.
• Ambos tipos de paquetes son enviados en
forma confiable.
• Un paquete de Consulta se envía por Multicast
a otro router EIGRP durante el proceso de
recálculo de rutas.
– El paquete de consulta es siempre multicast.
Parte 2. Estableciendo Relaciones de Vecindad EIGRP
Paquetes de Consulta y Respuesta
• Un paquete de respuesta es usado para
responder a una consulta para instruir al
origen de no recalcular la ruta porque existe
un sucesor factible.
• El paquete de respuesta es siempre unicast.
Parte 2. Estableciendo Relaciones de Vecindad EIGRP
Paquetes de Consulta y Respuesta
Parte 2. Estableciendo Relaciones de Vecindad EIGRP
Tipos de Paquetes
Tipo de paquete Uso

Hello Usado para descubrir otros routers EIGRP en la red

Usado para reconocer la recepción de cualquier


Acknowledgement
paquete EIGRP.

Reúne información de enrutamiento para conocer


Update
destinos.

Usado para obtener información específica desde


Query
un router vecino.

Reply Usado para responder a una petición (Query)


Implementación de EIGRP.

PARTE 3. CONSTRUCCIÓN DE
TABLAS EIGRP
Parte 3. Construcción de Tablas EIGRP
Descubrimiento Inicial de Rutas
Parte 3. Construcción de Tablas EIGRP
Operaciones EIGRP
• EIGRP selecciona una ruta primaria (sucesor) y
una ruta de respaldo (sucesor factible) y las
ubica en la tabla de topología.
• La ruta primaria (sucesor) se mueve entonces
a la tabla de enrutamiento.
Parte 3. Construcción de Tablas EIGRP
Operaciones EIGRP

Tabla de vecinos IP EIGRP Lista de routers EIGRP vecinos que sean


Dirección IP Interface de salida del router local adyacentes y la interfaz local de salida hacia cada
Vecino hacia el vecino uno de ellos

Tabla de Topología IP EIGRP Lista de todas las rutas aprendidas desde cada
vecino EIGRP y las rutas sucesoras identificadas y
Destino 1 FD / AD a través de cada vecino
las rutas sucesoras factibles

Tabla de Enrutamiento IP Lista de la mejor ruta (sucesora) desde la tabla de


topologías EIGRP y desde otros procesos de
Destino 1 Mejor ruta
enrutamiento
Parte 3. Construcción de Tablas EIGRP
Ejemplos de Tablas EIGRP
Parte 3. Construcción de Tablas EIGRP
Tablas de Vecinos EIGRP
SRTT (Smooth Round Trip Timer) and RTO (Retransmit Interval) are used by RTP to
manage reliable EIGRP packets.
SRTT indicates how long it takes for this neighbor to respond to reliable packets.
RTO indicates how long to wait before retransmitting if no ACK is received.

R1# show ip eigrp neighbors


IP-EIGRP neighbors for process 100
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 192.168.1.102 Se0/0/1 11 00:07:22 10 2280 0 5
R1#

Neighbor’s IP The sequence


address Queue count
Amount of time number of the
should always be
since this neighbor last update,
Local interface zero otherwise
Lists the order in was added to the query, or reply
receiving EIGRP there’s congestion
which a peering neighbor table. packet that was
Hello packets. on the link.
session was received from
established with the this neighbor.
specified neighbor,
starting with 0. Seconds remaining before declaring neighbor
down.
The current hold time and is reset to the
maximum hold time whenever a Hello packet is
received.
Parte 3. Construcción de Tablas EIGRP
Tablas de Topología EIGRP
Destination network. Number of Feasible distance (FD) to
successors the successor

R1# show ip eigrp topology


IP-EIGRP Topology Table for AS(100)/ID(192.168.1.101)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 172.17.0.0/16, 1 successors, FD is 40514560
via 192.168.1.102 (40514560/28160), Serial0/0/1
R1#

Indicates if the Next-hop address Advertised Outbound interface to


Feasible
route is in passive for successor. distance (AD) reach the network.
distance (FD) to
or active state. from the
the successor
successor
Parte 3. Construcción de Tablas EIGRP
Tablas de Enrutamiento EIGRP
Local router exit
Time indicating the interface to
EIGRP Destination Next-hop address to
Administrative Feasible last update packet destination
route network reach the network
distance distance received network

R1# show ip route


<output omitted>
Gateway of last resort is not set
D 172.17.0.0/16 [90/40514560] via 192.168.1.102, 00:02:22, Serial0/0/1
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
D 172.16.0.0/16 is a summary, 00:31:31, Null0
C 172.16.1.0/24 is directly connected, FastEthernet0/0
R1#

Summary route automatically created as the result of


the default classful behavior of EIGRP.
Parte 3. Construcción de Tablas EIGRP
Distancia Administrativa EIGRP

Rutas sumarizadas
manualmente

Rutas distribuidas en EIGRP


Parte 3. Construcción de Tablas EIGRP
Cálculo de Métrica EIGRP
• EIGRP usa una métrica compuesta que se basa
en los siguientes parámetros:
– Ancho de Banda
– Retardo
– Confiabilidad
– Carga
• Solamente el Ancho de Banda y el retardo son
usados por defecto.
Parte 3. Construcción de Tablas EIGRP
Ancho de Banda EIGRP
• EIGRP usa el ancho de banda más lento en su
cálculo de métrica.
– Ancho de Banda Calculado = BW referencia / BW
más lento(kbps)
• El valor del ancho de banda puede no reflejar
el acho de banda físico de la interface.
– Por ejemplo, la mayoría de las interfaces seriales
usan un ancho de banda por defecto de 1.544
Mbps pero no es correctamente reflejado en el
ancho de banda real de la interface.
Parte 3. Construcción de Tablas EIGRP
Ancho de Banda EIGRP
• Debido a que EIGRP y OSPF usan el ancho de
banda por defecto en sus cálculos de métrica,
un valor correcto de BW es muy importante
para la exactitud de la información de
enrutamiento.
– Si el ancho de banda real difiere del ancho de
banda por defecto, entonces debe ser modificado.
• Para modificar el valor de ancho de banda,
usar el comando bandwidth en la interface
Parte 3. Construcción de Tablas EIGRP
Retardo EIGRP
• El retardo es la medida del tiempo que le
toma a un paquete atravesar una ruta.
– EIGRP usa la suma acumulativa de todas las
interfaces salientes.
• Retardo Calculado = Suma los retardos de interface / 10
• El retardo (DLY) es un valor estático basado en
el tipo de enlace al cual la interface es
conectada y se expresa en microsegundos.
Parte 3. Construcción de Tablas EIGRP
Retardo EIGRP
Parte 3. Construcción de Tablas EIGRP
Otras Métricas EIGRP
• Confiabilidad (no es una métrica EIGRP por
defecto) es una medida de la probabilidad de
que un enlace falle.
– Se mide en forma dinámica y se expresa como una
fracción de 255.
– Un alto valor en la fracción implica una alta
confiabilidad
Parte 3. Construcción de Tablas EIGRP
Otras Métricas EIGRP
• Carga (no es una métrica por defecto EIGRP)
refleja la cantidad de tráfico que esta usando
el enlace
– El número es determinado dinámicamente y es
expresado como una fracción de 255
– Una fracción baja indica una baja carga sobre el
enlace
Parte 3. Construcción de Tablas EIGRP
Cálculo de Métrica Compuesta EIGRP
• La fórmula de métrica compuesta EIGRP
consiste es valores K1 hasta K5, conocidos
como pesos de las métricas EIGRP.
– Por defecto, solo K1 (bandwidth) y K3 (delay) son
1.
– K2 (load), K4 (reliability), y K5 (MTU) son 0.
• Los valores K pueden ser cambiados con el
comando:
Router(config-router)# metric weights tos k1 k2 k3 k4 k5
Parte 3. Construcción de Tablas EIGRP
Cálculo de Métrica Compuesta EIGRP
Parte 3. Construcción de Tablas EIGRP
Ejemplo de Cálculo de Métrica EIGRP

Ancho de Banda más bajo


Mas la suma de los retardos
Parte 3. Construcción de Tablas EIGRP
Ejemplo de Cálculo de BW EIGRP
Parte 3. Construcción de Tablas EIGRP
Ejemplo de Cálculo de DLY EIGRP
• Delay = 20,000 / 10 + (100 / 10) * 256 = 514560
Parte 3. Construcción de Tablas EIGRP
Ejemplo de Cálculo de Métrica EIGRP
• Métrica EIGRP = 2499840 + 514560 = 3014400
Implementación de EIGRP.

PARTE 4. CONFIGURACIÓN Y
VERIFICACIÓN DE EIGRP
Parte 4. Configuración y Verificación de EIGRP
Habilitación de Enrutamiento EIGRP
• Definir EIGRP como el protocolo de
enrutamiento IP
Router(config)#router eigrp autonomous-system-id

• Para intercambiar actualizaciones de


enrutamiento, los routers EIGRP deben tener
el mismo ID de Sistema Autónomo.
Parte 4. Configuración y Verificación de EIGRP
Identificar Redes EIGRP
• Definir las redes EIGRP para informar a los
routers vecinos. E
Router(config-router)#network red [mask]

• El parámetro network puede ser una red, una


subred, o una dirección de una interface
directamente conectada.
Parte 4. Configuración y Verificación de EIGRP
Identificar Redes EIGRP
• MASK es una máscara wildcard (inverse mask)
usada para determinar como se interpretan
las direcciones.
– La máscara tiene bits wildcard, donde 0 es un
acierto y 1 es “no importa”.
– Por ejemplo, 0.0.255.255 indica un acierto a los
primeros dos octetos.
Parte 4. Configuración y Verificación de EIGRP
Identificar Redes EIGRP
• Desde la versión IOS 12.0(4)T, dicho
argumento puede ser configurado usando bits
wildcard o una máscara de subred normal.
• Por ejemplo, ambos formatos pueden ser
usados para la red 10.10.10.0:
– network 10.10.10.0 0.0.0.3
o
– network 10.10.10.0 255.255.255.252
Parte 4. Configuración y Verificación de EIGRP
Definir el Ancho de Banda de la Interface
• Definir el ancho de banda de la interface
(opcional).
Router(config-if)#bandwidth kilobits

• El parámetro kilobits indica el ancho de banda


ingresado en kbps.
– Por ejemplo, para fijar el ancho de banda en
512000 bps, usar el comando bandwidth 512.
Parte 4. Configuración y Verificación de EIGRP
Habilitar/Deshabilitar Sumarización
• Por defecto, EIGRP sumariza automáticamente
subredes.
Router(config)#auto-summary

• Esto hace que EIGRP se comporte como un


protocolo de enrutamiento con clase y
sumarice subredes en los límited de la subred.
• La sumarización automática puede ser
deshabilitada con el comando no auto-
summary
Parte 4. Configuración y Verificación de EIGRP
Comandos de Verificación EIGRP
Comando Descripción
Verifica la información de enrutamiento del
SHOW IP PROTOCOLS
router
SHOW IP EIGRP NEIGHBORS Lista los routers adyacentes que ejecutan EIGRP
SHOW IP EIGRP TOPOLOGY Muestra la tabla de topología
Muestra las rutas aprendidas por EIGRP en la
SHOW IP ROUTE EIGRP
tabla de enrutamiento
SHOW IP EIGRP INTERFACES Muestra las interfaces EIGRP configuradas
SHOW IP EIGRP TRAFFIC Verifica el tráfico de información EIGRP
Rastrea la transmisión y recepción de paquetes
DEBUG EIGRP PACKETS
EIGRP
Parte 4. Configuración y Verificación de EIGRP
Interfaces Pasivas EIGRP
• Previenen las actualizaciones EIGRP hacia una
interfaz específica del router.
Router(config-router)#passive-interface tipo [default]

• Deja una interface en particular o todas las


interfaces del router como pasivas.
• La opción default fija todas las interfaces del
router como pasivas.
Parte 4. Configuración y Verificación de EIGRP
Interfaces Pasivas EIGRP
• Para EIGRP, el comando:
– Previene que se establezcan relaciones de
vecindad.
– Las actualizaciones de enrutamiento desde un
vecino son ignoradas.
– Permite que subredes en una interfaz pasiva sean
informadas en EIGRP
Parte 4. Configuración y Verificación de EIGRP
Propagando una Ruta por Defecto
• Para propagar una ruta por defecto en EIGRP,
se debe usar el comando en configuración
global:
– ip default-network network-number.

O
– ip route 0.0.0.0 0.0.0.0 next-hop | interface.

• Una vez configurado, la ruta por defecto


puede ser propagada en el AS EIGRP.
Parte 4. Configuración y Verificación de EIGRP
Propagando una Ruta por Defecto
• Configura a un router para informar una red
como gateway de último recurso:
Router(config)#ip default-network network

• Los otros routers usan su dirección de


siguiente salto para informar la red como su
ruta por defecto.
Parte 4. Configuración y Verificación de EIGRP
Propagando una Ruta por Defecto
• No existe un parámetro para especificar la máscara
de subred, por lo tanto el comando puede ser usado
solamente para informar redes con clase.
• La red especificada debe ser alcanzable antes de ser
configurada.
• Si la red especificada es alcanzable a través de:
– EIGRP, entonces la ruta por defecto es propagada
automáticamente a otros routers EIGRP dentro del AS.
– Una ruta estática, entonces la ruta estática debe ser
redistribuida en EIGRP.
Parte 4. Configuración y Verificación de EIGRP
Sumarización de Rutas EIGRP
• EIGRP sumariza automáticamente a la red limítrofe mayor por
defecto.
– Debido al comando de configuración pre-configurado auto-
summary.
– En la mayoría de los casos, la auto-sumarización es una buena
herramienta y mantiene las tablas tan compactas como sea posible.
• A veces no es una buena práctica cuando existen redes
discontinuas.
• Típicamente, para que el enrutamiento trabaje
apropiadamente, se debe deshabilitar con el comando no
auto-summary.
Parte 4. Configuración y Verificación de EIGRP
Deshabilitando Resumen Automático
EIGRP AS 100

 EIGRP Update: Connected to 10.0.0.0 /8


10.10.10.0 /24 192.168.1.96 /30 10.20.20.0 /24

R1 R2

R1(config)# router eigrp 100


R1(config-router)# no auto-summary
R1(config-router)#
*Jul 26 22:14:07.183: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 192.168.1.102
(Serial0/0/0) is resync: summary configured
R1(config-router)# end
R1# show ip protocols
Routing Protocol is "eigrp 100“
<output omitted>
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
10.10.10.0/24
192.168.1.96/27
<output omitted>
Parte 4. Configuración y Verificación de EIGRP
Sumarización en una Interface
• Los primeros protocolos vector distancia eran
incapaces de de crear rutas sumarizadas que
no fueran límites con clase o /8, /16/ o /24.
• Para suplir esta deficiencia, EIGRP agrega el
comando de configuración de interface ip
summary-address eigrp.
– El comando es usado para crear una o mas rutas
sumarizadas dentro de una red en cualquier
límite.
Parte 4. Configuración y Verificación de EIGRP
Sumarización en una Interface
• Las rutas sumarizadas EIGRP tienen una
distancia administrativa de 5.
– Las rutas EIGRP estándar reciben una distancia
administrativa de 90.
– Las rutas EIGRP externas reciben una distancia
administrativa de 170.
Parte 4. Configuración y Verificación de EIGRP
IP SUMMARY-ADDRESS EIGRP
• Crea manualmente una ruta resumida en un
límite arbitrario.
ip summary-address eigrp as-number address mask [admin-distance]

Parámetro Descripción

as-number Se identifica el número AS de EIGRP.

address La dirección IP que será informada como ruta sumarizada.


No necesita estar cuadrada a una dirección Clase A, B o C.

mask La máscara IP usada para crear la dirección sumarizada.

admin-distance (Opcional) Distancia Administrativa. Un valor desde 0 a


255.
Implementación de EIGRP.

PARTE 5. OPTIMIZACIÓN DEL


COMPORTAMIENTO DE EIGRP
Parte 5. Optimización del Comportamiento de EIGRP
Balanceo de Carga EIGRP
• Las rutas con una métrica igual a la mínima
métrica son instaladas en la tabla de
enrutamiento.
– Referido como balanceo de cargas de igual costo.
– Todos los protocolos de enrutamiento en los
routers Cisco pueden desarrollar balanceo de
cargas de igual costo.
Parte 5. Optimización del Comportamiento de EIGRP
Balanceo de Carga EIGRP
• El comando maximum-paths maximum-path
puede ser usado para permitir hasta 6 rutas
de igual costo.
– Por defecto es 1
– Fijando la opción maximum-path en 1 deshabilita
el balanceo de cargas.
Parte 5. Optimización del Comportamiento de EIGRP
Balanceo de Carga EIGRP

Advertised Distance (AD)

R1(config)# router eigrp 100


R1(config-router)# network 172.16.1.0 0.0.0.255 R1 Topology Table
R1(config-router)# network 192.168.1.0
R1(config-router)# network 192.168.2.0 Network Neighbor AD FD
R1(config-router)# network 192.168.3.0 R2 20 40
172.16.2.0/24
R1(config-router)# network 192.168.4.0
R1(config-router)# maximum–paths 3 R3 20 40
R1(config-router)#
R4 20 40
R5 20 40
Parte 5. Optimización del Comportamiento de EIGRP
Balanceo de Carga EIGRP de Distinto Costo
• EIGRP puede también balancear tráfico a
través de múltiples rutas que tienen diferentes
métricas.
– Definido como balanceo de cargas de distinto
costo.
Parte 5. Optimización del Comportamiento de EIGRP
Balanceo de Carga EIGRP de Distinto Costo
• El grado en el cual EIGRP desarrolla balanceo de
cargas es controlado con el comando variance
multiplier.
– El multiplicador es un valor entre 1 y 128, usado para
balancear cargas.
– Por defecto es 1, el cual significa balanceo de cargas de
igual costo.
– Fijando un valor de variancia mayor que 1, permite a
EIGRP instalar múltiples rutas libres de bucles con costos
distintos en la tabla de enrutamiento.
Parte 5. Optimización del Comportamiento de EIGRP
Balanceo de Carga EIGRP de Distinto Costo
• El grado en el cual EIGRP desarrolla balanceo
de cargas es controlado con el comando
variance multiplier.
– EIGRP siempre instala los sucesores (la mejor ruta)
en la tabla de enrutamiento.
– La variancia permite a los sucesores factibles (y
solo a los sucesores factibles) ser potenciales
candidatos para ser instalados en la tabla de
enrutamiento.
Parte 5. Optimización del Comportamiento de EIGRP
Balanceo de Carga EIGRP de Distinto Costo

Advertised Distance (AD)

R1(config)# router eigrp 100 R1 Topology Table


R1(config-router)# variance 2 Network Neighbor AD FD
R1(config-router)#
172.16.2.0/24 R2 10 30
R3 10 20
R4 25 45
R5 10 50
Parte 5. Optimización del Comportamiento de EIGRP
BW EIGRP usado en Enlaces WAN
• EIGRP opera eficientemente en ambientes WAN y es
escalable en enlaces point-to-point y enlaces NBMA
multipoint y point-to-point.
• Sin embargo, la configuración por defecto de
conexiones WAN puede no ser la óptima si no se
tiene un sólido entendimiento del funcionamiento de
EIGRP, agregado con el conocimiento de las
velocidades de enlace para lograr una configuración
eficiente, confiable y escalable.
Parte 5. Optimización del Comportamiento de EIGRP
BW EIGRP usado en Enlaces WAN
• Existen dos comandos que al ser configurados
mejoran la operación de EIGRP:
– bandwidth
– ip percent-bandwidth
Parte 5. Optimización del Comportamiento de EIGRP
EIGRP IP BANDWIDTH-PERCENT
• Por defecto, EIGRP usa el 50% del ancho de
banda de la interface para intercambiar
información de enrutamiento.
• El comando ip bandwidth-percent eigrp puede
ser configurado para controlar la cantidad de
ancho de banda disponible para EIGRP.
– Esto no es lo mismo que el comando bandwidth.
– Sin embargo, este comando depende del valor
configurado mediante el comando bandwidth.
Parte 5. Optimización del Comportamiento de EIGRP
EIGRP IP BANDWIDTH-PERCENT
• Configurar la cantidad de ancho de banda
disponible para EIGRP.
ip bandwidth-percent eigrp as-number percent

• El as-number es el número de Sistema.


• El parámetro percent es el porcentaje de
ancho de banda configurado
• El valor de porcentaje no debe ser mayor a
100.
Parte 5. Optimización del Comportamiento de EIGRP
Factores que Influyen en la Escalabilidad
• Cantidad de información de enrutamiento
intercambiada entre routers compañeros: sin la
sumarización de ruta adecuada puede ser excesivo.
• Cantidad de routers que deben ser involucrados
cuando se produce un cambio de topología.
• Profundidad de la topología: la cantidad de saltos
que la información debe realizar para alcanzar todos
los routers.
• Cantidad de caminos alternativos a través de la red.
Parte 5. Optimización del Comportamiento de EIGRP
Proceso de Petición EIGRP
• Las solicitudes son enviadas cuando un router se ha caído y no
existe una ruta del sucesor factible disponible.
• La ruta perdida está ahora es estado activo.
• Las solicitudes son enviadas a todos los routers vecinos en
todas las interfaces excepto la interface del sucesor.
• Si el vecino no posee su información de rutas perdidas, las
consultas son enviadas a sus vecinos.
• Si un router tiene una ruta alternativa, responde a la consulta;
esto detiene las consultas.
Parte 5. Optimización del Comportamiento de EIGRP
Sobrecarga de las solicitudes EIGRP
• En redes extensas las solicitudes EIGRP
pueden exigir muchos recursos
Parte 5. Optimización del Comportamiento de EIGRP
Sobrecarga de las solicitudes EIGRP
• Existen varias soluciones para optimizar el
proceso de propagación de solicitudes y
limitar la cantidad de cara EIGRP innecesaria
sobre los enlaces, incluyendo:
– Sumarización
– Redistribución
– Características de enrutamiento EIGRP stub .
Parte 5. Optimización del Comportamiento de EIGRP
Stuck-in-Active
• Si un router no recibe una respuesta a todas
las solicitudes salientes dentro del tiempo por
defecto de 3 minutos (180 segundos), el
router entra es un estado de Stuck-in-Active
(SIA).
Parte 5. Optimización del Comportamiento de EIGRP
Stuck-in-Active
• Razones comunes para SIA:
– Un router está demasiado ocupado para
responder a las solicitudes.
– Un router no puede encontrar memoria para
procesar la solicitud.
– El circuito entre los dos routers no es confiable.
– El router tienen enlaces unidireccionales.
Parte 5. Optimización del Comportamiento de EIGRP
Stuck-in-Active
• Soluciones a SIA:
– Rediseñar la red para limitar el rango de
solicitudes mediante sumarización de rutas y el
comando ip summary-address eigrp.
– Configurar los routers remotos como routers
EIGRP stub.
Parte 5. Optimización del Comportamiento de EIGRP
Solución Stuck-in-Active: Sumarización
• Diseños de red simplistas puede hacer difícil la
sumarización.
• La sumarización manual sobre los routers
dentro de lo posible para soportar diseños de
red jerárquicos..
• Mientras más redes se sumaricen, menor
deberá ser la cantidad de solicitudes que
deban ser enviadas.
Parte 5. Optimización del Comportamiento de EIGRP
Solución Stuck-in-Active: Sumarización
Parte 5. Optimización del Comportamiento de EIGRP
Solución Stuck-in-Active: Sumarización
Parte 5. Optimización del Comportamiento de EIGRP
Solución Stuck-in-Active: Sumarización
• Este diseño de red es mejor debido a que las
direcciones de subred desde redes
individuales mayores son localizadas dentro
de cada nube, permitiendo que mediante el
uso del comando ip summary-address eigrp
sean inyectadas dentro del núcleo.
• Como valor agregado, las rutas sumarizadas
actúan como limítrofes para las solicitudes
generadas por cambios de topologías.
Parte 5. Optimización del Comportamiento de EIGRP
Solución Stuck-in-Active: Redes STUB
• La característica de red EIGRP stub:
– Permite mayor estabilidad en la red
– Reduce la utilización de recursos
– Simplifica la configuración del router remoto
(spoke)
Parte 5. Optimización del Comportamiento de EIGRP
Enrutamiento EIGRP Stub
• El enrutamiento Stub es comúnmente usado
en topologías hub-and-spoke.
• El router Stub envía paquetes de información
especial a todos los routers vecinos para
reportar su estado como router stb.
• Solo los routers remotos son configurados
como stubs.
Parte 5. Optimización del Comportamiento de EIGRP
Enrutamiento EIGRP Stub
• Configurar un router como router stub.
eigrp stub [receive-only | connected | static | summary | redistributed]

Parameter Description
Restricts the router from sharing any of its routes with any other router within an
receive-only EIGRP AS.
Keyword cannot be combined with any other keyword.
Permits the EIGRP stub routing feature to send connected routes.
connected
This option is enabled by default and is the most widely practical stub option.
Permits the EIGRP stub routing feature to send static routes.
static
Redistributing static routes with the redistribute static command is still necessary.
Permits the EIGRP stub routing feature to send automatically summarized and / or
summary manually summarized routes.
This option is enabled by default.
Permits the EIGRP stub routing feature to send redistributed routes.
redistributed
Redistributing routes with the redistribute command is still necessary.
Parte 5. Optimización del Comportamiento de EIGRP
Enrutamiento EIGRP Stub
• Si stub connected está
configurado:
– B anunciará 10.1.2.0/24
hacia A.
– B no anunciará 10.1.2.0/23,
10.1.3.0/23, or 10.1.4.0/24.
• Si stub summary está
configurado:
– B informará 10.1.2.0/23
hacia A.
– B no anunciará 10.1.2.0/24,
10.1.3.0/24, or 10.1.4.0/24.
Parte 5. Optimización del Comportamiento de EIGRP
Enrutamiento EIGRP Stub
• Si stub static es
configurado:
– B informará 10.1.4.0/24
hacia A.
– B no anunciará 10.1.2.0/24,
10.1.2.0/23, or 10.1.3.0/24.
• Si stub receive-only es
configurado:
– B no informará nada a A, por
lo que A necesitará tener
una ruta estática hacia las
redes detrás de B para
alcanzarlas.
Parte 5. Optimización del Comportamiento de EIGRP
Gracefull Shutdown
• Mejora la convergencia de
la red
• Antes la caída de una red,
se debe esperar el HOLD
TIMER
• Ante un cambio de
topología mayor, el router
informa mediante un
mensaje de adiós
Implementación de EIGRP.

PARTE 6. CONFIGURACIÓN DE
EIGRP PARA IPV6
Parte 6. configuración de EIGRP para IPv6
Enrutamiento IPv6
• Para IPv6, son soportados los siguientes
protocolos
– Enrutamiento Estático
– RIPng
– OSPFv3
– IS-IS
– Multiprotocol BGP versión 4
• Para cada protocolo de enrutamiento anterior,
se debe usar ipv6 unicast-routing
Parte 6. configuración de EIGRP para IPv6
EIGRP para IPv6
• EIGRP para IPv6 es un protocolo de enrutamiento
Vector-Distancia
– Su configuración y operación es similar a EIGRP para IPv4
• Los siguientes puntos se mantienen de EIGRP para
IPv4
– Usa el mismo número de protocolo
– Mantiene una tabla de topologías y usa peticiones
(QUERIES) si no se encuentra disponible un sucesor
factible
– Usa DUAL para calcular las rutas sucesoras
Parte 6. configuración de EIGRP para IPv6
EIGRP para IPv6
• A diferencia de EIGRP para IPv4:
– Es usado para enrutar prefijos IPv6
– Requiere de un ID de router de 32 bits
– Se configura en una interface
– Se usa direccionamiento de Link-Local para
establecer adyacencias con los vecinos
– Su estado por defecto es SHUTDOWN
– No sumariza automáticamente
Parte 6. configuración de EIGRP para IPv6
Pasos para Configurar EIGRP en IPv6
• Completar la estrategia de red en EIGRP
• Habilitar enrutamiento unicast IPv6 mediante el
comando ipv6 unicast-routing
• Ingresar al modo de configuración EIGRP y asignar un
ID de router (opcional)
• Habilitar EIGRP para IPv6 en la interface usando el
comando ipv6 eigrp
• Configurar EIGRP para IPv6 en las interfaces
• Configurar aspectos específicos de EIGRP en el modo
de configuración de enrutamiento
Parte 6. configuración de EIGRP para IPv6
Habilitar EIGRP en IPv6
• Configurar los parámetros del proceso EIGRP
para IPv6
Router(config)#ipv6 router eigrp as-number

• El comando crea un proceso de enrutamiento


EIGRP para IPv6
• El as-number identifica el sistema autónomo
EIGRP en el que participa la interface
Parte 6. configuración de EIGRP para IPv6
Definir el Router-ID
• Definir el ID de router
Router(config-rtr)#eigrp router-id [ip-address]

• El IP-ADDRESS es un número en formato IPv4


– El ID de router debe ser único en cada router
Parte 6. configuración de EIGRP para IPv6
Habilitar EIGRP para IPv6 en una Interface
• Habilitar el proceso EIGRP para IPv6 en una
interface
Router(config-if)#ipv6 eigrp [as-number]

• El AS-NUMBER identifica el sistema autónomo


EIGRP en el cual la interface participa
Parte 6. configuración de EIGRP para IPv6
Sumarizar rutas IPv6
• Configurar un conjunto de rutas sumarizadas
en una interface
Router(config-if)#ipv6 summary-address eigrp [as-
number] [dirección IPv6] [admin-distance]

• El comando funciona igual que en IPv4


Implementación de EIGRP.

PARTE 7. INTRODUCCIÓN A LA
CONFIGURACIÓN DE EIGRP
NOMBRADO
Parte 7. Introducción a la Configuración de EIGRP Nombrado
Introducción
• La configuración de EIGRP en una topología
simple es una tarea sencilla si todos sus
parámetros se encuentran por defecto
• Sin embargo, consideremos un router que
necesita una instancia para IPv4 y otra para
IPv6
• Además, debemos configurar los timers por
defecto, las opciones de variance , direcciones
sumarizadas y un ID de router
Parte 7. Introducción a la Configuración de EIGRP Nombrado
Introducción
• Con lo anterior, la configuración de EIGRP se
torna un desafío y debemos ir hacia atrás y
adelante entre los diferentes modos de
configuración
• EIGRP nombrado consolida todos los
comandos bajo una sola estructura jerárquica.
• Con esto, no solo se simplifica la
configuración, sino que el proceso de
recuperación es más fácil
Parte 7. Introducción a la Configuración de EIGRP Nombrado
Introducción
Parte 7. Introducción a la Configuración de EIGRP Nombrado
La Estructura Jerárquica de Named EIGRP
• Su configuración es diferente de EIGRP tradicional,
pero compatibles
• Mientras que tradicionalmente los Routers EIGRP
forman adyacencias con otros Routers EIGRP, EIGRP
nombrado consiste en una estructura jerárquica de
tres modos de configuración primarios
– Address-Family
– Address-Family-Interface
– Address-Family-Topology
Parte 7. Introducción a la Configuración de EIGRP Nombrado
Modos de Configuración de Named EIGRP
Modo de Configuración Descripción
Address-Family Los comandos de configuración normal son usados bajo
este modo.
En este punto se implementan los ID de router, las redes
y las configuraciones de EIGRP Stub. Se pueden crear
múltiples Address-family (IPv4 e IPv6)
Address-Family-Interface Los comandos ingresados bajo este modo de
configuración son los de EIGRP clásico, como los timers y
configuraciones de interfaces pasivas
Address-Family-Topology Los comandos que tienen directo impacto en la tabla de
topología EIGRP se ingresan en este modo, por ejemplo,
los comandos de redistribución
Parte 7. Introducción a la Configuración de EIGRP Nombrado
Pasos para EIGRP Nombrado
• Paso 1.
– Configurar una instancia virtual de EIGRP
nombrado usando el comando de configuración
global router eigrp [nombre instancia
virtual]
– Bajo esta sola instancia virtual se deben configurar
todas las ADDRESS-FAMILY
Parte 7. Introducción a la Configuración de EIGRP Nombrado
Pasos para EIGRP Nombrado
• Paso 2.
– Especificar una ADDRESS-FAMILY con un número
de Sistema Autónomo usando el comando
address-family [ipv4|ipv6] [AS]
• Paso 3.
– Configurar los parámetros generales de EIGRP
dentro de la ADDRESS-FAMILY.
– Ejemplos de comandos usados en este modo son:
metric, network, eigrp stub y eigrp
router-id
Parte 7. Introducción a la Configuración de EIGRP Nombrado
Pasos para EIGRP Nombrado
• Paso 4. (Opcional)
– Ingresar al modo de configuración ADDRESS-
FAMILY-INTERFACE, con el comando af-
interface [default|interface-id].
– Si se especifica la opción DEFAULT, los comandos
ingresados en este modo de configuración se
aplican a todas las interfaces, a menos que sea
configurado un comando específico en una
interface
Parte 7. Introducción a la Configuración de EIGRP Nombrado
Pasos para EIGRP Nombrado
• Paso 4. (Opcional)
– Ejemplos de comandos usados en este modo de
configuración son:
• authentication
• bandwidth-percent
• hello-interval
• hold-time
• passive-interface
• split-horizon
Parte 7. Introducción a la Configuración de EIGRP Nombrado
Pasos para EIGRP Nombrado
• Paso 5 (Opcional)
– Ingresar al modo ADDRESS-FAMILY-TOPOLOGY,
saliendo (EXIT) del modo ADDRESS-FAMILY-
INTERFACE con el comando topology base.
– Ejemplos de comandos en este modo son:
• auto-summary
• maximun-path
• redistribute
• variance
Parte 7. Introducción a la Configuración de EIGRP Nombrado
Comparación EIGRP vs EIGRP Nombrado
• Si una red no tiene algún requerimiento EIGRP
específico, como balanceo de carga o
sumarización, muchos administradores de red
configurarán EIGRP en el modo clásico,
haciendo que todas las interfaces participen
en el proceso
Parte 7. Introducción a la Configuración de EIGRP Nombrado
Comparación EIGRP vs EIGRP Nombrado

!Router R1 Configuration
R1#conf term
R1(config)#router eigrp 1 Configuración de
R1(config-router)#network 0.0.0.0
!Router R2 Configuration EIGRP usando el
R2#conf term método clásico
R2(config)#router eigrp 1
R2(config-router)#network 0.0.0.0
Parte 7. Introducción a la Configuración de EIGRP Nombrado
Comparación EIGRP vs EIGRP Nombrado

!R1 Router Configuration


R1#conf term Configuración de
R1(config)#router eigrp R1DEMO EIGRP nombrado
R1(config-router)#address-family ipv4 autonomous-system 1
R1(config-router-af)#network 0.0.0.0
!R2 Router Configuration
R2#conf term
R2(config)#router eigrp R2DEMO
R2(config-router)#address-family ipv4 autonomous-system 1
R2(config-router-af)#network 0.0.0.0
Parte 7. Introducción a la Configuración de EIGRP Nombrado
Comparación EIGRP vs EIGRP Nombrado
• Para este ejemplo, incluso la configuración de
EIGRP nombrado parece ser un poco más
compleja que EIGRP clásico. Sin embargo, los
beneficios de EIGRP nombrado son más
evidentes cuando los patrones de
configuración se vuelven más complejos
Parte 7. Introducción a la Configuración de EIGRP Nombrado
Comparación EIGRP vs EIGRP Nombrado
• Por ejemplo, considerar el esquema siguiente. Se
desea usar EIGRP clásico para configurar los
siguientes parámetros en R1 y R2
– Todas las interfaces participan en EIGRP AS 1 para IPv4
– Todas las interfaces participan en EIGRP AS 2 para IPv6
– La opción de VARIANCE debe estar en 2 para ambos
routers
– El intervalo HELLO sebe ser fijado en 2 segundos para
EIGRP AS 1 para IPv4
– El intervalo HOLD debe ser fijado en 10 segundos para
EIGRP AS 1 para IPv4
Parte 7. Introducción a la Configuración de EIGRP Nombrado
Comparación EIGRP vs EIGRP Nombrado
Parte 7. Introducción a la Configuración de EIGRP Nombrado
Configuración EIGRP Clásico
!Router R1 Configuration ipv6 router eigrp 2
interface FastEthernet0/0 variance 2
ip address 172.16.1.1 255.255.255.0 !Router R2 Configuration
ipv6 address 2001::1/64 interface FastEthernet0/0
ipv6 eigrp 2 ip address 192.168.1.1 255.255.255.0
! ipv6 address 2003::1/64
interface Serial1/0 ipv6 eigrp 2
ip address 10.1.1.1 255.255.255.252 !
ip hello-interval eigrp 1 2 interface Serial1/0
ip hold-time eigrp 1 10 ip address 10.1.1.2 255.255.255.252
ipv6 address 2002::1/64 ip hello-interval eigrp 1 2
ipv6 eigrp 2 ip hold-time eigrp 1 10
! ipv6 address 2002::2/64
router eigrp 1 ipv6 eigrp 2
variance 2 !
network 0.0.0.0 router eigrp 1
passive-interface default variance 2
no passive-interface Serial1/0 network 0.0.0.0
! passive-interface default
no passive-interface Serial1/0
!
ipv6 router eigrp 2
variance 2
Parte 7. Introducción a la Configuración de EIGRP Nombrado
Configuración EIGRP Nombrado (R1)
!Router R1 Configuration
router eigrp R1DEMO
!
address-family ipv4 unicast autonomous-system 1
!
af-interface default
hello-interval 2
hold-time 10
passive-interface
exit-af-interface
!
af-interface Serial1/0
no passive-interface
exit-af-interface
!
topology base
variance 2
exit-af-topology
network 0.0.0.0
exit-address-family
Parte 7. Introducción a la Configuración de EIGRP Nombrado
Configuración EIGRP Nombrado (R1)
!
address-family ipv6 unicast autonomous-system 2
!
topology base
variance 2
exit-af-topology
exit-address-family
Parte 7. Introducción a la Configuración de EIGRP Nombrado
Configuración EIGRP Nombrado (R2)
!Router R2 Configuration
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ipv6 address 2003::1/64
!
interface Serial1/0
ip address 10.1.1.2 255.255.255.252
ipv6 address 2002::2/64
!
router eigrp R2DEMO
!
address-family ipv4 unicast autonomous-system 1
!
af-interface default
hello-interval 2
hold-time 10
passive-interface
exit-af-interface
!
Parte 7. Introducción a la Configuración de EIGRP Nombrado
Configuración EIGRP Nombrado (R2)
af-interface Serial1/0
no passive-interface
exit-af-interface
!
topology base
variance 2
exit-af-topology
network 0.0.0.0
exit-address-family
!
address-family ipv6 unicast autonomous-system 2
!
topology base
variance 2
exit-af-topology
exit-address-family
Parte 7. Introducción a la Configuración de EIGRP Nombrado
Comparación EIGRP vs EIGRP Nombrado
• En el modo de configuración nombrado, cada
router tiene una sola instancia de EIGRP
virtual, y cada instancia incluye dos ADDRESS-
FAMILY, una para IPv4 y otra para IPv6
• Además, cada uno de los comandos
necesarios son organizados lógicamente bajo
el modo de configuración adecuado en la
jerarquía de EIGRP nombrado
Parte 7. Introducción a la Configuración de EIGRP Nombrado
Verificación de EIGRP Nombrado
• Aunque EIGRP nombrado es distintos a EIGRP
clásico, los comandos de verificación siguen
siendo los mismos
– show ip protocols
– show ip eigrp interfaces
– show ip eigrp interfaces detail s0/0
– show ipv6 protocols
Parte 7. Introducción a la Configuración de EIGRP Nombrado
Verificación de EIGRP Nombrado
R1#show ip protocols
Routing Protocol is "eigrp 1"
*** IP Routing is NSF aware ***
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP-IPv4 VR(R1DEMO) Address-Family Protocol for AS(1)
Metric weight K1=1, K2=0, K3=1, K4=0, K5=0 K6=0
Metric rib-scale 128
Metric version 64bit
NSF-aware route hold timer is 240
Router-ID: 172.16.1.1
Topology : 0 (base)
Active Timer: 3 min
Distance: internal 90 external 170
Maximum path: 4
Maximum hopcount 100
Maximum metric variance 2
Total Prefix Count: 3
Total Redist Count: 0
Automatic Summarization: disabled
Maximum path: 4
Routing for Networks:
0.0.0.0
Passive Interface(s):
FastEthernet0/0
Routing Information Sources:
Gateway Distance Last Update
10.1.1.2 90 01:18:03
Distance: internal 90 external 170
Parte 7. Introducción a la Configuración de EIGRP Nombrado
Verificación de EIGRP Nombrado
R1#show ip eigrp interfaces
EIGRP-IPv4 VR(R1DEMO) Address-Family Interfaces for AS(1)
Xmit Queue PeerQ Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable Un/Reliable SRTT Un/Reliable Flow Timer Routes
Se1/0 1 0/0 0/0 81 0/16 352 0

R1#show ip eigrp interfaces detail s1/0


EIGRP-IPv4 VR(R1DEMO) Address-Family Interfaces for AS(1)
Xmit Queue PeerQ Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable Un/Reliable SRTT Un/Reliable Flow Timer Routes
Se1/0 1 0/0 0/0 81 0/16 352 0
Hello-interval is 2, Hold-time is 10
Split-horizon is enabled
Next xmit serial <none>
Packetized sent/expedited: 2/0
Hello's sent/expedited: 2980/2
Un/reliable mcasts: 0/0 Un/reliable ucasts: 3/3
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 0
Retransmissions sent: 0 Out-of-sequence rcvd: 0
Topology-ids on interface - 0
Authentication mode is not set
Parte 7. Introducción a la Configuración de EIGRP Nombrado
Verificación de EIGRP Nombrado
R1#show ipv6 protocols
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "ND"
IPv6 Routing Protocol is "eigrp 2"
EIGRP-IPv6 VR(R1DEMO) Address-Family Protocol for AS(2)
Metric weight K1=1, K2=0, K3=1, K4=0, K5=0 K6=0
Metric rib-scale 128
Metric version 64bit
NSF-aware route hold timer is 240
Router-ID: 172.16.1.1
Topology : 0 (base)
Active Timer: 3 min
Distance: internal 90 external 170
Maximum path: 16
Maximum hopcount 100
Maximum metric variance 2
Total Prefix Count: 3
Total Redist Count: 0
Interfaces:
FastEthernet0/0
Serial1/0
Redistribution:
None
Resumen

• En este capítulo revisamos


– Los conceptos generales del protocolo de
enrutamento EIGRP
– La implementación de EIGRP para IPv4 e IPv6
– Los conceptos y configuración básicas de EIGRP
nombrado
– Se ha comparado EIGRP Clásico versus EIGRP
Nombrado

También podría gustarte