Está en la página 1de 105

Protocolo de Protocolo RIP

enrutamiento Protocolo OSPFv2

 Introducción
Protocolo de  Formato de RIPv1
 Formato de RIPv2
Enrutamiento  Caso de estudio
RIPv1/RIPv2  Configuración
Propiedad intelectual de Daniel Díaz @ 2014

 Redistribución
Profesor Daniel Díaz Ataucuri
Profesor Titular de Telecomunicaciones
Universidad Nacional de Ingeniería

ddiaz@inictel-uni.edu.pe
Universidad Nacional Mayor de San Marcos

http://www.danieldiaza.com
ddiaz@inictel-uni.edu.pe
ddiaz1610@gmail.com

Lima, Enero–
INSTITUTO NACIONAL DE INVESTIGACION Diciembre
Y CAPACITACION de 2014
DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

INTRODUCCIÓN AL
PROTOCOLO RIP
Propiedad intelectual de Daniel Díaz @ 2014

RFC 1058 Routing Information Protocol, Junio 1988


RFC 1723 RIP version 2, Noviembre 1994

ddiaz@inictel-uni.edu.pe
RFC 2453 RIP version 2, Noviembre 1998

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

INTRODUCCION AL PROTOCOLO RIP


RIP presenta dos versiones: RIPv1 y RIPv2
►RIPv1  Es un protocolo de enrutamiento con clase.
►RIPv2  Es un protocolo de enrutamiento sin clase.

RIP utiliza el algoritmo Vector Distancia.


Propiedad intelectual de Daniel Díaz @ 2014

RIP utiliza como métrica el número de saltos.


►Máximo número de saltos en un trayecto (path) es 15.
Mayores a 15 saltos es inalcanzable.

ddiaz@inictel-uni.edu.pe
RIP difunde su tabla de enrutamiento completa a
cada router vecino en intervalos de 30 segundos
► Dirección MAC=FF FF FF FF FF FF

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

RIPv1 – vs – RIPv2
RIPv1 envía sus actualizaciones en broadcast:
255.255.255.255
RIPv2 envía sus actualizaciones en multicast:
224.0.0.9
RIPv2 permite autenticación: texto plano o
Propiedad intelectual de Daniel Díaz @ 2014

cifrado MD5.
RIPv1 y RIPv2 se encapsulan en UDP.

ddiaz@inictel-uni.edu.pe
►En puerto utilizado es el 520.

RIP es capaz de equilibrar las cargas hasta en seis rutas de


igual costos, siendo cuatro rutas la cantidad por defecto.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

TEMPORIZACION DEL PROTOCOLO RIP


RIP emplea temporizadores para mejorar su
rendimiento.
►Routing-update timer  Inicialmente 30 seg.
Intervalo entre las actualizaciones de tabla de enrutamiento.
►Route-timeout timer  ó Hold down en 180 seg.
Cada entrada tiene un route-timeout asociado.
Propiedad intelectual de Daniel Díaz @ 2014

Cuando expira, la ruta es señalada como inválida y la métrica se


configura con 16; pero no es borrada de la tabla de enrutamiento.
►Route-flush timer  Inicialmente en 240 seg

ddiaz@inictel-uni.edu.pe
Cuando expira el route-timeout, se borrará la entrada de la
tabla de enrutamiento cuando expira el route-flush timer.

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

ACTUALIZACIONES SINCRONIZADAS
Cuando los routers envían actualizaciones al mismo
tiempo, se puede producir colisiones, retardos y
gran consumo de ancho de banda.
►El envío de actualizaciones al mismo tiempo se denomina
sincronización de actualizaciones.
►RIP puede experimentar problemas ya que envía actualizaciones
Propiedad intelectual de Daniel Díaz @ 2014

periódicas.
Cual es la solución.
►Para evitar la sincronización de actualizaciones, se considera una

ddiaz@inictel-uni.edu.pe
variable RIP_JITTER (usado por el IOS de cisco); cuyo valor
fluctúa entre 0% a 15%.
De este modo el intervalo de actualización varía entre 25 a
30 seg. en lugar de los 30 seg.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

FORMATO DEL
PROTOCOLO RIP
Propiedad intelectual de Daniel Díaz @ 2014

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

FORMATO DEL PROTOCOLO RIPv1


RIPv1 Comando: Indica si el paquete
0 8 16 31

Comando Versión 00 00
RIP es de requerimiento o
Address Family
00 00
respuesta.
Identifier

Máximo 25 por
►Requerimiento (1) pregunta a un

paquete RIP
Dirección IP

00 00 00 00
router por el envío total o parcial
de su tabla de enrutamiento.
Propiedad intelectual de Daniel Díaz @ 2014

00 00 00 00

Métrica
►Respuesta (2) puede ser una
Address Family 00 00
actualización de enrutamiento
Dirección IP
no solicitada o en respuesta a

ddiaz@inictel-uni.edu.pe
00 00 00 00
un requerimiento.
00 00 00 00 Version: Indica versión del
Métrica
protocolo RIP. Está en 1.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

FORMATO DEL PROTOCOLO RIPv1


RIPv1 Address Family Identifier
0 8 16 31

Comando Versión 00 00
AFI.
Address Family
►Especifica la familia de dirección
00 00
Identifier usada. RIP está diseñado para

Máximo 25 por
paquete RIP
Dirección IP
llevar información de enrutamiento
00 00 00 00
de varios tipos de protocolos.
►AFI está en 2 para IP.
Propiedad intelectual de Daniel Díaz @ 2014

00 00 00 00

Métrica

Address Family 00 00 Dirección IP: Indica la


Dirección IP dirección IP de entrada.

ddiaz@inictel-uni.edu.pe
00 00 00 00
Métrica: Indica cuantos
00 00 00 00

Métrica
routers atraviesa RIP.
►El valor está entre 1 a 15.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

FORMATO DEL PROTOCOLO RIPv2


http://www.rfc-editor.org/rfc/pdfrfc/rfc2453.txt.pdf

Comando: Indica si el paquete 0 RIPv2


8 16 31
RIP es de requerimiento o Comando Versión 00 00
respuesta. Address Family
Route Tag
Identifier

Máximo 25 por
paquete RIP
Version: Indica la versión Dirección IP

Máscara de subred
del protocolo RIP.
Propiedad intelectual de Daniel Díaz @ 2014

Salto siguiente

Address Family Identifier Métrica

AFI. Address Family Route Tag

►Es similar al RIPv1, con una Dirección IP

ddiaz@inictel-uni.edu.pe
Máscara de subred
excepción
►Si el AFI de la primera entrada Salto siguiente

está en FFFFh, el resto de las Métrica

entradas contiene información de autenticación.


INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

FORMATO DEL PROTOCOLO RIPv2


http://www.rfc-editor.org/rfc/pdfrfc/rfc2453.txt.pdf

Route tag: Permite distinguir RIPv2


0 8 16 31
entre rutas internas Comando Versión 00 00
(reconocida por RIP) y rutas Address Family
Route Tag
Identifier
externas (por otros Dirección IP

Protocolos EGP). Máscara de subred


Propiedad intelectual de Daniel Díaz @ 2014

Salto siguiente
Dirección IP: Indica el prefijo Métrica

de red de entrada. Address Family Route Tag

Dirección IP
Máscara de Subred:

ddiaz@inictel-uni.edu.pe
Máscara de subred
Contiene la máscara de Salto siguiente
subred de entrada. Métrica

Métrica: Cuantos routers atraviesa RIP.


INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

ENCAPSULAMIENTO DEL PROTOCOLO RIPv2


0 8 16 31

Ver HLEN ToS Longitud Total

Identificador Indicador/Desplazam.
Protocolo
TTL Suma de Chequeo
11H = 17
Dirección IP de Origen
.
Dirección IP de Destino
Puerto de Origen Puerto de Destino
0208H = 520 0208H = 520
Propiedad intelectual de Daniel Díaz @ 2014

Longitud de Mensaje Suma de Chequeo


Dominio de
Comando Versión
enrutamiento
AFI Route Tag

ddiaz@inictel-uni.edu.pe
Dirección IP

Máscara de subred MAC MAC Tipo


Datos
Destino Origen 0800H
Salto siguiente

Métrica
Trama Ethernet

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

ANALISIS DEL PROTOCOLO RIPv1


Lo0:172.16.15.1/16

S0/1
R1 .42
S0/0
.221 Lo1:132.2.4.7/16

Paquetes RIPv1
S0/0 Fa0/0
Propiedad intelectual de Daniel Díaz @ 2014

40.5.5.28/30
10.2.2.220/30 .41 .29
Red
R3
S0/1
.62

S0/1
.222

ddiaz@inictel-uni.edu.pe
S0/0
R2 .61

RIP v1

Lo2:172.32.6.7/16

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

ANALISIS DEL PROTOCOLO RIPv1

0 8 16 31

02 01 00 00

Red 172.16.0.0 Métrica 2


Red 132.2.0.0 Métrica 1 Red 30.0.0.0 Métrica 1
Red 10.0.0.0 Métrica 2

00 02 00 00 00 02 00 00 00 02 00 00

0A 00 00 00 1E 00 00 00 AC 10 00 00

00 00 00 00 00 00 00 00 00 00 00 00

00 00 00 00 00 00 00 00 00 00 00 00
Propiedad intelectual de Daniel Díaz @ 2014

00 00 00 02 00 00 00 01 00 00 00 02

00 02 00 00 00 02 00 00 00 02 00 00
Red 20.0.0.0 Métrica 1

Red 172.32.0.0 Métrica 2


14 00 00 00 84 02 00 00 AC 20 00 00

00 00 00 00 00 00 00 00 00 00 00 00

ddiaz@inictel-uni.edu.pe
00 00 00 00 00 00 00 00 00 00 00 00

00 00 00 01 00 00 00 01 00 00 00 02

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

ANALISIS DEL PROTOCOLO RIPv2


Lo4:201.1.1.5/25

S0/0
.70 R5
S0/1
Lo3:210.7.1.8/32 .6

Paquetes RIPv2
Fa0/1
40.5.5.28/30 S0/1
.30
Propiedad intelectual de Daniel Díaz @ 2014

.69 70.8.8.4/30
Red R4
S0/0
.205

S0/0
.5

ddiaz@inictel-uni.edu.pe
S0/1 R6
.206
RIP v2

Lo5:192.168.1.9/26

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

ANALISIS DEL PROTOCOLO RIPv2

0 8 16 31

02 02 00 00

Red 201.1.1.0 Métrica 2


Red 50.6.6.68 Métrica 1

Red 70.8.8.4 Métrica 2


00 02 00 00 00 02 00 00 00 02 00 00

32 06 06 44 46 08 08 04 C9 01 01 00

FF FF FF FC FF FF FF FC FF FF FF 80

00 00 00 00 00 00 00 00 00 00 00 00
Propiedad intelectual de Daniel Díaz @ 2014

00 00 00 01 00 00 00 02 00 00 00 02
Red 192.168.1.0 Métrica 2
Red 60.7.7.204 Métrica 1

00 02 00 00 00 02 00 00 00 02 00 00

Red 210.7.1.8 Métrica 1


3C 07 07 CC C0 A8 01 00 D8 07 01 08

FF FF FF FC FF FF FF C0 FF FF FF FF

ddiaz@inictel-uni.edu.pe
00 00 00 00 00 00 00 00 00 00 00 00

00 00 00 01 00 00 00 02 00 00 00 01

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

CONFIGURACIÓN DE
PROTOCOLO
RIPv1/RIPv2
Propiedad intelectual de Daniel Díaz @ 2014

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

CONFIGURACION BASICA
Configurar RIPv1:
►Activar el protocolo RIPv1:
router rip
►Anunciar redes:
network <dirección de red>
Propiedad intelectual de Daniel Díaz @ 2014

Configurar RIPv2 en R4
►Activar el protocolo RIPv2:
router rip
►Especificar la versión 2:

ddiaz@inictel-uni.edu.pe
version 2
►Anunciar redes:
network <dirección de red>

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

EJEMPLO DE CONFIGURACIÓN RIPv2


200.1.1.64/26

PC2 .66

Fa2/0
Rb Rc .65
Fa1/0 Fa1/1
.2 .5 40.1.2.4/30 .6 .10
200.1.1.0/26 .18 200.1.1.128/26
PC1 Ra .1 .9 Re PC3
Propiedad intelectual de Daniel Díaz @ 2014

.1 Fa2/0
.2 .13 .130
Fa2/0 .22 .129
.17
.14 .21

.193

ddiaz@inictel-uni.edu.pe
Rd
Fa2/0

.194 PC4

200.1.1.192/26
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

EJEMPLO DE CONFIGURACIÓN RIPv2


Tablas de enrutamiento inicial:
►Router Ra

Ra#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
Propiedad intelectual de Daniel Díaz @ 2014

E1 - OSPF external type 1, E2 - OSPF external type 2


i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

ddiaz@inictel-uni.edu.pe
200.1.1.0/26 is subnetted, 1 subnets
C 200.1.1.0 is directly connected, FastEthernet2/0
40.0.0.0/30 is subnetted, 2 subnets
C 40.1.2.12 is directly connected, FastEthernet1/1
C 40.1.2.0 is directly connected, FastEthernet1/0
Ra#
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

EJEMPLO DE CONFIGURACIÓN RIPv2


Tablas de enrutamiento inicial:
►Router Rb

Rb#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
Propiedad intelectual de Daniel Díaz @ 2014

E1 - OSPF external type 1, E2 - OSPF external type 2


i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Para borrar la tabla de
Gateway of last resort is not set enrutamiento:

ddiaz@inictel-uni.edu.pe
40.0.0.0/30 is subnetted, 3 subnets Rb#clear ip route *
C 40.1.2.0 is directly connected, FastEthernet1/1
C 40.1.2.4 is directly connected, FastEthernet1/0
C 40.1.2.16 is directly connected, FastEthernet2/0
Rb#

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

EJEMPLO DE CONFIGURACIÓN RIPv2


Tablas de enrutamiento inicial:
►Router Rc

Rc#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
Propiedad intelectual de Daniel Díaz @ 2014

E1 - OSPF external type 1, E2 - OSPF external type 2


i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

ddiaz@inictel-uni.edu.pe
200.1.1.0/26 is subnetted, 1 subnets
C 200.1.1.64 is directly connected, FastEthernet2/0
40.0.0.0/30 is subnetted, 2 subnets
C 40.1.2.8 is directly connected, FastEthernet1/0
C 40.1.2.4 is directly connected, FastEthernet1/1
Rc#
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

EJEMPLO DE CONFIGURACIÓN RIPv2


Tablas de enrutamiento inicial:
►Router Rd

Rd#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
Propiedad intelectual de Daniel Díaz @ 2014

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2


ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

ddiaz@inictel-uni.edu.pe
200.1.1.0/26 is subnetted, 1 subnets
C 200.1.1.192 is directly connected, FastEthernet2/0
40.0.0.0/30 is subnetted, 3 subnets
C 40.1.2.12 is directly connected, FastEthernet1/0
C 40.1.2.16 is directly connected, FastEthernet2/1
C 40.1.2.20 is directly connected, FastEthernet1/1
Rd#
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

EJEMPLO DE CONFIGURACIÓN RIPv2


Tablas de enrutamiento inicial:
►Router Re

Re#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
Propiedad intelectual de Daniel Díaz @ 2014

E1 - OSPF external type 1, E2 - OSPF external type 2


i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

ddiaz@inictel-uni.edu.pe
200.1.1.0/26 is subnetted, 1 subnets
C 200.1.1.128 is directly connected, FastEthernet2/0
40.0.0.0/30 is subnetted, 2 subnets
C 40.1.2.8 is directly connected, FastEthernet1/1
C 40.1.2.20 is directly connected, FastEthernet1/0
Re#
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

EJEMPLO DE CONFIGURACIÓN RIPv2


Configurando RIPv2: Routers Ra y Rb
Ra>
Ra>enable
Ra#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Ra(config)#router rip
Ra(config-router)#version 2
Ra(config-router)#network 200.1.1.0
Ra(config-router)#network 40.0.0.0
Ra(config-router)#exit
Propiedad intelectual de Daniel Díaz @ 2014

Ra(config)#

Rb>
Rb>enable
Rb#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.

ddiaz@inictel-uni.edu.pe
Rb(config)#router rip
Rb(config-router)#version 2
Rb(config-router)#network 40.0.0.0
Rb(config-router)#exit
Rb(config)#

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

EJEMPLO DE CONFIGURACIÓN RIPv2


Configurando RIPv2: Routers Rc y Rd
Rc>
Rc>enable
Rc#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Rc(config)#router rip
Rc(config-router)#version 2
Rc(config-router)#network 200.1.1.0
Rc(config-router)#network 40.0.0.0
Rc(config-router)#exit
Propiedad intelectual de Daniel Díaz @ 2014

Rc(config)#

Rd>
Rd>enable
Rd#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.

ddiaz@inictel-uni.edu.pe
Rd(config)#router rip
Rd(config-router)#version 2
Rd(config-router)#network 200.1.1.0
Rd(config-router)#network 40.0.0.0
Rd(config-router)#exit
Rd(config)#

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

EJEMPLO DE CONFIGURACIÓN RIPv2


Configurando RIPv2: Router Re
Re>
Re>enable
Re#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Re(config)#router rip
Re(config-router)#version 2
Re(config-router)#network 200.1.1.0
Re(config-router)#network 40.0.0.0
Re(config-router)#exit
Propiedad intelectual de Daniel Díaz @ 2014

Re(config)#

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

UN DETALLE: “SUMMARY”
Desde Ra como llega a 200.1.1.64/26
Ra# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type
2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route Salto siguiente
40.1.2.14
Gateway of last resort is not set
Propiedad intelectual de Daniel Díaz @ 2014

200.1.1.0/24 is variably subnetted, 2 subnets, 2 masks


Aquí se ve a las redes
C 200.1.1.0/26 is directly connected, FastEthernet2/0
200.1.1.64, 200.1.1.128
R 200.1.1.0/24 [120/1] via 40.1.2.14, 00:00:25, FastEthernet1/1
y 200.1.1.192 como si
40.0.0.0/30 is subnetted, 6 subnets
fuera la red 200.1.1.0
R 40.1.2.8 [120/2] via 40.1.2.14, 00:00:25, FastEthernet1/1
[120/2] via 40.1.2.2, 00:00:11, FastEthernet1/0

ddiaz@inictel-uni.edu.pe
C 40.1.2.12 is directly connected, FastEthernet1/1
C 40.1.2.0 is directly connected, FastEthernet1/0
R 40.1.2.4 [120/1] via 40.1.2.2, 00:00:11, FastEthernet1/0
R 40.1.2.16 [120/1] via 40.1.2.14, 00:00:25, FastEthernet1/1
[120/1] via 40.1.2.2, 00:00:11, FastEthernet1/0
R 40.1.2.20 [120/1] via 40.1.2.14, 00:00:25, FastEthernet1/1 Ra#clear ip route *
Ra# Borra la tabla de enrutamiento.

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

UN DETALLE: “SUMMARY”
Desde Rd como llega a 200.1.1.0/26
Rd#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type
2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route Salto siguiente
40.1.2.13
Gateway of last resort is not set
Propiedad intelectual de Daniel Díaz @ 2014

200.1.1.0/24 is variably subnetted, 2 subnets, 2 masks


C 200.1.1.192/26 is directly connected, FastEthernet2/0
R 200.1.1.0/24 [120/1] via 40.1.2.22, 00:00:05, FastEthernet1/1 Aquí se ve a las redes
[120/1] via 40.1.2.13, 00:00:10, FastEthernet1/0 200.1.1.0, 200.1.1.64, POSIBLE
40.0.0.0/30 is subnetted, 6 subnets y 200.1.1.128 como si BUCLE!!
R 40.1.2.8 [120/1] via 40.1.2.22, 00:00:05, FastEthernet1/1 fuera la red 200.1.1.0

ddiaz@inictel-uni.edu.pe
C 40.1.2.12 is directly connected, FastEthernet1/0
R 40.1.2.0 [120/1] via 40.1.2.18, 00:00:22, FastEthernet2/1
[120/1] via 40.1.2.13, 00:00:10, FastEthernet1/0
R 40.1.2.4 [120/1] via 40.1.2.18, 00:00:22, FastEthernet2/1
C 40.1.2.16 is directly connected, FastEthernet2/1
C 40.1.2.20 is directly connected, FastEthernet1/1
Rd#

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

SOLUCIÓN: DESACTIVAR “SUMMARY”


Ra>enable
Ra#configure terminal
Enter configuration commands, one per line. End with NTL/Z.
Ra(config)#router rip
Ra(config-router)#no auto-summary
Ra(config-router)#exit Rd>enable
Ra(config)# Rd#configure terminal
Enter configuration commands, one per line. End with NTL/Z.
Rd(config)#router rip
Rd(config-router)#no auto-summary
Rb>enable
Rd(config-router)#exit
Rb#configure terminal
Rd(config)#
Enter configuration commands, one per line. End with NTL/Z.
Rb(config)#router rip
Propiedad intelectual de Daniel Díaz @ 2014

Rb(config-router)#no auto-summary
Rb(config-router)#exit Re>enable
Rb(config)# Re#configure terminal
Enter configuration commands, one per line. End with NTL/Z.
Re(config)#router rip
Re(config-router)#no auto-summary
Rc>enable Re(config-router)#exit

ddiaz@inictel-uni.edu.pe
Rc#configure terminal Re(config)#
Enter configuration commands, one per line. End with NTL/Z.
Rc(config)#router rip
Rc(config-router)#no auto-summary
Rc(config-router)#exit
Rc(config)#

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

ANALIZANDO NUEVAMENTE Ra”


Desde Ra como llega a 200.1.1.64/26
Ra#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set


Propiedad intelectual de Daniel Díaz @ 2014

200.1.1.0/24 is variably subnetted, 5 subnets, 2 masks Aquí se ve a las redes


R 200.1.1.192/26 [120/1] via 40.1.2.14, 00:00:00, FastEthernet1/1 200.1.1.64, 200.1.1.128
R 200.1.1.128/26 [120/2] via 40.1.2.14, 00:00:00, FastEthernet1/1 y 200.1.1.192 de manera
R 200.1.1.64/26 [120/2] via 40.1.2.2, 00:00:10, FastEthernet1/0 independiente!!!!.
C 200.1.1.0/26 is directly connected, FastEthernet2/0
R 200.1.1.0/24 [120/2] via 40.1.2.14, 00:00:00, FastEthernet1/1
40.0.0.0/30 is subnetted, 6 subnets

ddiaz@inictel-uni.edu.pe
R 40.1.2.8 [120/2] via 40.1.2.14, 00:00:00, FastEthernet1/1
[120/2] via 40.1.2.2, 00:00:10, FastEthernet1/0
C 40.1.2.12 is directly connected, FastEthernet1/1
C 40.1.2.0 is directly connected, FastEthernet1/0
R 40.1.2.4 [120/1] via 40.1.2.2, 00:00:10, FastEthernet1/0
R 40.1.2.16 [120/1] via 40.1.2.14, 00:00:00, FastEthernet1/1
[120/1] via 40.1.2.2, 00:00:10, FastEthernet1/0
R 40.1.2.20 [120/1] via 40.1.2.14, 00:00:06, FastEthernet1/1
Ra#
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

ANALIZANDO TABLAS DE ENRUTAMIENTO


Tabla de enrutamiento del Rb:
Rb# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set


Propiedad intelectual de Daniel Díaz @ 2014

200.1.1.0/26 is subnetted, 4 subnets


R 200.1.1.192 [120/1] via 40.1.2.17, 00:00:14, FastEthernet2/0 La redes LAN están
R 200.1.1.128 [120/2] via 40.1.2.17, 00:00:14, FastEthernet2/0 detalladas.
[120/2] via 40.1.2.6, 00:00:10, FastEthernet1/0 Se observa el balanceo de
R 200.1.1.64 [120/1] via 40.1.2.6, 00:00:10, FastEthernet1/0 carga hacia: 200.1.1.128
R 200.1.1.0 [120/1] via 40.1.2.1, 00:00:12, FastEthernet1/1
40.0.0.0/30 is subnetted, 6 subnets

ddiaz@inictel-uni.edu.pe
R 40.1.2.8 [120/1] via 40.1.2.6, 00:00:10, FastEthernet1/0
R 40.1.2.12 [120/1] via 40.1.2.17, 00:00:14, FastEthernet2/0
[120/1] via 40.1.2.1, 00:00:12, FastEthernet1/1
C 40.1.2.0 is directly connected, FastEthernet1/1
C 40.1.2.4 is directly connected, FastEthernet1/0
C 40.1.2.16 is directly connected, FastEthernet2/0
R 40.1.2.20 [120/1] via 40.1.2.17, 00:00:17, FastEthernet2/0
Rb#

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

ANALIZANDO TABLAS DE ENRUTAMIENTO


Tabla de enrutamiento del Rc:
Rc#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set


Propiedad intelectual de Daniel Díaz @ 2014

200.1.1.0/26 is subnetted, 4 subnets


R 200.1.1.192 [120/2] via 40.1.2.9, 00:00:12, FastEthernet1/0 La redes LAN están
[120/2] via 40.1.2.5, 00:00:24, FastEthernet1/1 detalladas.
R 200.1.1.128 [120/1] via 40.1.2.9, 00:00:12, FastEthernet1/0 Se observa el balanceo de
C 200.1.1.64 is directly connected, FastEthernet2/0 carga hacia: 200.1.1.192
R 200.1.1.0 [120/2] via 40.1.2.5, 00:00:24, FastEthernet1/1
40.0.0.0/30 is subnetted, 6 subnets

ddiaz@inictel-uni.edu.pe
C 40.1.2.8 is directly connected, FastEthernet1/0
R 40.1.2.12 [120/2] via 40.1.2.9, 00:00:12, FastEthernet1/0
[120/2] via 40.1.2.5, 00:00:24, FastEthernet1/1
R 40.1.2.0 [120/1] via 40.1.2.5, 00:00:24, FastEthernet1/1
C 40.1.2.4 is directly connected, FastEthernet1/1
R 40.1.2.16 [120/1] via 40.1.2.5, 00:00:24, FastEthernet1/1
R 40.1.2.20 [120/1] via 40.1.2.9, 00:00:13, FastEthernet1/0
Rc#

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

ANALIZANDO TABLAS DE ENRUTAMIENTO


Tabla de enrutamiento del Rd:
Rd#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set


Propiedad intelectual de Daniel Díaz @ 2014

200.1.1.0/26 is subnetted, 4 subnets


C 200.1.1.192 is directly connected, FastEthernet2/0
R 200.1.1.128 [120/1] via 40.1.2.22, 00:00:00, FastEthernet1/1 La redes LAN están
R 200.1.1.64 [120/2] via 40.1.2.22, 00:00:00, FastEthernet1/1 detalladas.
[120/2] via 40.1.2.18, 00:00:00, FastEthernet2/1 Se observa el balanceo de
R 200.1.1.0 [120/1] via 40.1.2.13, 00:00:24, FastEthernet1/0 carga hacia: 200.1.1.64
40.0.0.0/30 is subnetted, 6 subnets

ddiaz@inictel-uni.edu.pe
R 40.1.2.8 [120/1] via 40.1.2.22, 00:00:00, FastEthernet1/1
C 40.1.2.12 is directly connected, FastEthernet1/0
R 40.1.2.0 [120/1] via 40.1.2.18, 00:00:00, FastEthernet2/1
[120/1] via 40.1.2.13, 00:00:24, FastEthernet1/0
R 40.1.2.4 [120/1] via 40.1.2.18, 00:00:00, FastEthernet2/1
C 40.1.2.16 is directly connected, FastEthernet2/1
C 40.1.2.20 is directly connected, FastEthernet1/1
Rd#

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

ANALIZANDO TABLAS DE ENRUTAMIENTO


Tabla de enrutamiento del Re:
Re#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set


Propiedad intelectual de Daniel Díaz @ 2014

200.1.1.0/26 is subnetted, 4 subnets


R 200.1.1.192 [120/1] via 40.1.2.21, 00:00:22, FastEthernet1/0
C 200.1.1.128 is directly connected, FastEthernet2/0 La redes LAN están
R 200.1.1.64 [120/1] via 40.1.2.10, 00:00:27, FastEthernet1/1 detalladas.
R 200.1.1.0 [120/2] via 40.1.2.21, 00:00:22, FastEthernet1/0
40.0.0.0/30 is subnetted, 6 subnets
C 40.1.2.8 is directly connected, FastEthernet1/1

ddiaz@inictel-uni.edu.pe
R 40.1.2.12 [120/1] via 40.1.2.21, 00:00:22, FastEthernet1/0
R 40.1.2.0 [120/2] via 40.1.2.21, 00:00:22, FastEthernet1/0
[120/2] via 40.1.2.10, 00:00:27, FastEthernet1/1
show ip protocols
R
R
40.1.2.4 [120/1] via 40.1.2.10, 00:00:27, FastEthernet1/1
40.1.2.16 [120/1] via 40.1.2.21, 00:00:22, FastEthernet1/0
►Muestra el protocolo de
C
Re#
40.1.2.20 is directly connected, FastEthernet1/0 enrutamiento configurado
y sus parámetros.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

INTERFAZ PASIVA
Envío
Servidor
Se debe anunciar la red 200.1.1.4/24
actualizaciones?

200.1.1.0 donde está el S0/0


Fa0/0
.1

.221
servidor, para que sea R1
S0/1
.42

accedido externamente. S0/0

22.2.2.220/30
.41

No se debe enviar al servidor R3


S0/1
Propiedad intelectual de Daniel Díaz @ 2014

actualizaciones. Para que?? .62

S0/0
R1(config)# router rip S0/1
.61

R1(config-router)# version 2 .222 R2

R1(config-router)# network 200.1.1.0

ddiaz@inictel-uni.edu.pe
R1(config-router)# network 22.2.2.220
R1(config-router)# network 20.3.3.40
R1(config-router)# passive-interface fastethernet 0/0
R1(config-router)# exit
R1#debug ip rip ; permite ver
R1(config)#
actualizaciones según se genere.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

PROPAGACIÓN DE RUTA POR DEFECTO


200.2.2.0/24 R1 50.5.5.0/30 R2
.9
.2 .1 .1 .2 50.5.5.8/30
PC1 210.10.10.0/24
.10 60.6.6.0/30
.1 .2 .1 .2

PC2 .13
R5 R6 PC3
.2 .1 .5 .6
.14
200.2.3.0/24 R3 50.5.5.4/30 R4
Propiedad intelectual de Daniel Díaz @ 2014

R5#show ip route
R4#show
R3#showip route
ip route
50.0.0.0/30 is R1#show
R2#showsubnetted,
ip route
ip4 subnets
route
50.0.0.0/30
50.0.0.0/30 is subnetted,
is subnetted,4 subnets
4 subnets
R 50.5.5.0 [120/1]
50.0.0.0/30via 50.5.5.9,
is
50.0.0.0/30 00:00:01,
subnetted,
is FastEthernet0/1
400:00:22,
subnetted, subnets
4 subnets
R R50.5.5.0 [120/2]
50.5.5.0 via
[120/3] 50.5.5.13,
via 50.5.5.6, FastEthernet0/1
00:00:09, FastEthernet0/1
R 50.5.5.4
C [120/1]
C via
50.5.5.0 50.5.5.14,
is
50.5.5.0 directly
is 00:00:24,
connected,
directly FastEthernet0/0
FastEthernet0/0
connected, FastEthernet0/1
C C50.5.5.4 is directly connected, FastEthernet0/0
C R50.5.5.4
50.5.5.8
R R50.5.5.8
is directly
R
is connected,
50.5.5.4 directly
[120/2]
50.5.5.4
[120/1] via
connected,
[120/3]
50.5.5.13, via
FastEthernet0/1
FastEthernet0/1
via 50.5.5.10, 00:00:06,
50.5.5.2,
00:00:22, FastEthernet0/1
00:00:11, FastEthernet0/1
FastEthernet0/1
C 50.5.5.12
C 50.5.5.8 [120/2]
isRdirectly
50.5.5.8 via
connected,
is directly50.5.5.6, 00:00:09,
FastEthernet0/0
connected, FastEthernet0/1
FastEthernet0/1

ddiaz@inictel-uni.edu.pe
C R50.5.5.12
50.5.5.12 50.5.5.8
is directly
[120/1] [120/1]
connected,
via viaFastEthernet0/1
50.5.5.6, 50.5.5.2,
00:00:09,00:00:11, FastEthernet0/1
FastEthernet0/1
R 210.10.10.0/24 [120/1]
R R50.5.5.12 via
50.5.5.12 60.6.6.2,
[120/1] 00:00:08,
via 50.5.5.10,
[120/2] FastEthernet1/0
00:00:06,
via 50.5.5.2, FastEthernet0/1
00:00:11, FastEthernet0/1
R 210.10.10.0/24
R 210.10.10.0/24 [120/2] via
[120/3] 50.5.5.13,
via 50.5.5.6,00:00:22, FastEthernet0/1
00:00:09, FastEthernet0/1
R 200.2.2.0/24
R [120/2]
R via
210.10.10.0/24 50.5.5.9,
210.10.10.0/24 [120/2] 00:00:01,
via
[120/3] FastEthernet0/1
50.5.5.10,
via 00:00:06,
50.5.5.2, FastEthernet0/1
00:00:11, FastEthernet0/1
R 200.2.2.0/24
R 200.2.2.0/24 [120/3] via
[120/4] 50.5.5.13,
via 50.5.5.6, 00:00:22, FastEthernet0/1
00:00:09, FastEthernet0/1
R 200.2.3.0/24
R [120/2]
200.2.2.0/24 via
C 200.2.2.0/24 50.5.5.14,
[120/1] 00:00:24,
via 50.5.5.1,
is connected,
directly FastEthernet0/0
00:00:14,
connected, FastEthernet0/0
FastEthernet0/0
R 200.2.3.0/24
C 200.2.3.0/24 [120/1] via 50.5.5.5,
is directly 00:00:17, FastEthernet0/0
FastEthernet0/0
60.0.0.0/30
R is 200.2.3.0/24
subnetted,
R[120/1] 1
200.2.3.0/24 subnets
[120/3] via
[120/4] 50.5.5.10,
via 00:00:06,
50.5.5.2, FastEthernet0/1
00:00:11, FastEthernet0/1
R 60.0.0.0/8
R 60.0.0.0/8 via 50.5.5.13,
[120/2] via 50.5.5.6,00:00:22, FastEthernet0/1
00:00:09, FastEthernet0/1
C 60.6.6.0
R is 60.0.0.0/8
directly connected,
[120/1] FastEthernet1/0
via 50.5.5.10, 00:00:06, FastEthernet0/1
R 60.0.0.0/8 [120/2] via 50.5.5.2, 00:00:11, FastEthernet0/1
R4# R3#
R5# R2# R1#
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

PROPAGACIÓN DE RUTA POR DEFECTO


200.2.2.0/24 R1 50.5.5.0/30 R2
.9
.2 .1 .1 .2 50.5.5.8/30
PC1 210.10.10.0/24
RIP .10 60.6.6.0/30
.1 .2 .1 .2

PC2 .13
R5 R6 PC3
.2 .1 .5 .6
.14
200.2.3.0/24 R3 50.5.5.4/30 R4
Propiedad intelectual de Daniel Díaz @ 2014

Redes

ddiaz@inictel-uni.edu.pe
anunciadas

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

PROPAGACIÓN DE RUTA POR DEFECTO


default-information originate
►Permite que el router propague la ruta estática por defecto, en las
actualizaciones RIP.
200.2.2.0/24
R1 50.5.5.0/30 R2
.9
.2 .1 .1 .2 50.5.5.8/30 210.10.10.0/24
PC1
Propiedad intelectual de Daniel Díaz @ 2014

.10 60.6.6.0/30
.1 .2 .1 .2
.13
R5 R6 PC3
.2 .1 .5 .6
.14

ddiaz@inictel-uni.edu.pe
200.2.3.0/24 R3 50.5.5.4/30 R4
PC2
R5#configure terminal
R5(config)#router rip
R5(config-router)#default-information originate
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

PROPAGACIÓN DE RUTA POR DEFECTO


200.2.2.0/24 R1 50.5.5.0/30 R2
.9
.2 .1 .1 .2 50.5.5.8/30
PC1 210.10.10.0/24
.10 60.6.6.0/30
.1 .2 .1 .2

PC2 .13
R5 R6 PC3
.2 .1 .5 .6 Desde RI, R2, R3, R4 y R6 se podrá ir a cualquier
.14 red, debido que sus tablas tiene la red 0.0.0.0
200.2.3.0/24 R3 50.5.5.4/30 R4
R2#show ip route
Propiedad intelectual de Daniel Díaz @ 2014

R1#show
R4#showip route
R3#showip routeip route
50.0.0.0/30 is
50.0.0.0/30 subnetted,
50.0.0.0/30
is 4 subnets
subnetted,
is R6#show
subnetted,
4 subnets ipsubnets
4 subnets route
C C50.5.5.0 is 50.0.0.0/30
directly is subnetted,
connected, 4
FastEthernet0/0
R50.5.5.0
R 50.5.5.0
is50.5.5.0
directly
[120/2] connected,
via 50.5.5.13,
[120/3] via FastEthernet0/1
00:00:02,
50.5.5.6, FastEthernet0/1
00:00:00, FastEthernet0/1
R R50.5.5.4 [120/2]
C50.5.5.4
50.5.5.4 via
[120/3]
is 50.5.5.10,
directly
via R 00:00:05,
50.0.0.0/8
50.5.5.2,
connected, FastEthernet0/1
00:00:24,[120/1] via
FastEthernet0/0 60.6.6.1,
FastEthernet0/1 00:00:04, FastEthernet0/1
C R50.5.5.8 Cis 50.5.5.4
directly is directly
connected, connected,
FastEthernet0/1 FastEthernet0/1
R50.5.5.8
R 50.5.5.8
[120/1]
[120/1]
50.5.5.8 via C 50.5.5.13,
[120/2] 210.10.10.0/24
50.5.5.2,
via via 00:00:24, is directly
00:00:02,
50.5.5.6, connected, FastEthernet0/0
FastEthernet0/1
FastEthernet0/1
00:00:00, FastEthernet0/1
R R50.5.5.12 [120/1]
C50.5.5.12
50.5.5.12 via
[120/2] 50.5.5.10,
is directly
via 00:00:05,
R connected,
200.2.2.0/24
50.5.5.2, 00:00:24, FastEthernet0/1
[120/3] via FastEthernet0/1
FastEthernet0/1 60.6.6.1, 00:00:04, FastEthernet0/1
FastEthernet0/1

ddiaz@inictel-uni.edu.pe
R
R 210.10.10.0/24 50.5.5.12
[120/2] via[120/1] via
50.5.5.10, 50.5.5.6,
00:00:05, 00:00:00,
FastEthernet0/1
R 210.10.10.0/24
R 210.10.10.0/24
R [120/3]
210.10.10.0/24 R[120/3]
[120/2]
via 200.2.3.0/24
50.5.5.2,
via 50.5.5.13,
via [120/3]
00:00:24, via FastEthernet0/1
00:00:02,
50.5.5.6, 60.6.6.1,
FastEthernet0/1
00:00:00, 00:00:04, FastEthernet0/1
FastEthernet0/1
R 200.2.2.0/24
C 200.2.2.0/24 [120/1]
R 200.2.2.0/24 via
is directly50.5.5.1,
[120/3] 00:00:04,
60.0.0.0/30
connected,
via 50.5.5.13, FastEthernet0/0
is00:00:02,
subnetted,
FastEthernet0/0 1 subnets
FastEthernet0/1
R 200.2.3.0/24R 200.2.2.0/24
[120/3] via [120/4]
50.5.5.10, via 50.5.5.6,
00:00:05, 00:00:00,
FastEthernet0/1FastEthernet0/1
R 200.2.3.0/24
R 200.2.3.0/24
C [120/4]
200.2.3.0/24[120/1]
via
isC via 60.6.6.0
50.5.5.2,
50.5.5.5,
directly is
00:00:24,directly
00:00:02,
connected, connected,
FastEthernet0/1 FastEthernet0/1
FastEthernet0/0
FastEthernet0/0
R 60.0.0.0/8
R 60.0.0.0/8[120/1]
R 60.0.0.0/8 via
[120/2] 50.5.5.10,
[120/1]
via 00:00:05,
R*50.5.5.13,
0.0.0.0/0
50.5.5.2,
via FastEthernet0/1
[120/1]
00:00:24,
00:00:02, via 60.6.6.1,
FastEthernet0/1 00:00:04, FastEthernet0/1
FastEthernet0/1
R* R*
0.0.0.0/0 R 60.0.0.0/8
[120/1] via [120/2]
50.5.5.10, via 50.5.5.6,
00:00:05, 00:00:00,
FastEthernet0/1 FastEthernet0/1
R*
0.0.0.0/0
0.0.0.0/0
R* [120/2]
[120/1]
0.0.0.0/0 via R6#
50.5.5.2,
via
[120/2] 50.5.5.13,
via Observar
00:00:24,
00:00:02,
50.5.5.6, que R5FastEthernet0/1
falta adicionar: no- auto-summary
FastEthernet0/1
FastEthernet0/1
00:00:00,
R2# R1# R4# De allí que aparezca en R1, R2, R3 y R4: 60.0.0.0/8
R3#
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

PROPAGACIÓN DE RUTA POR DEFECTO


200.2.2.0/24 R1 50.5.5.0/30 R2
.9
.2 .1 .1 .2 50.5.5.8/30
PC1 210.10.10.0/24
RIP .10 60.6.6.0/30
.1 .2 .1 .2

PC2 .13
R5 R6 PC3
.2 .1 .5 .6
.14
200.2.3.0/24 R3 50.5.5.4/30 R4
Propiedad intelectual de Daniel Díaz @ 2014

Ruta por Redes


defecto

ddiaz@inictel-uni.edu.pe
anunciadas

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

PROPAGACIÓN DE RUTA POR DEFECTO


200.2.2.0/24 R1 50.5.5.0/30 R2 Habilitado con RIPv2
.9
.2 .1 .1 .2 50.5.5.8/30
PC1 210.10.10.0/24
.10 60.6.6.0/30
.1 .2 .1 .2

PC2 .13
R5 R6 PC3
.2 .1 .5 .6 .5 Enrutamiento
.14 estático
200.2.3.0/24 R3 50.5.5.4/30 R4 60.6.6.4/30
.6
.1 .2
Propiedad intelectual de Daniel Díaz @ 2014

R7 PC4
220.20.20.0/24
R5#configure terminal
R5(config)#router rip
R7(config)#ip route 0.0.0.0 0.0.0.0 60.6.6.5
R5(config-router)#default-information originate

►De R1 a R6 tienen la

ddiaz@inictel-uni.edu.pe
R5#configure terminal
R5(config)#ip route 220.20.20.0 255.255.255.0 60.6.6.6
ruta por defecto
R5(config)#exit ►“Todos” saben llegar a
R5
►Cuando se llegue a R5, la tabla estática indicará 220.20.20.0
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

REDISTRIBUCIÓN ESTÁTICA (1)


200.1.1.0/25
ip route 0.0.0.0 0.0.0.0 21.2.2.5
.2 PCb
215.5.5.0/24
R3.5 20.1.1.4/30 .6
R4
.1 Fa0/0
.1 Fa0/0
Fa0/1 .9
PCa .22 R7
.2 .6

Fa0/0 .2 .21
.1 .10
.1 .2 .5
.18 .9 R6
Propiedad intelectual de Daniel Díaz @ 2014

Fa0/1

21.2.2.0/30
Fa0/0

.13
R1
R2
.14 .17
.10
R8

ddiaz@inictel-uni.edu.pe
ip route 0.0.0.0 0.0.0.0 21.2.2.2
R5 .129 Fa0/0
ip route 200.1.1.0 255.255.255.128 21.2.2.6
ip route 200.1.1.128 255.255.255.128 21.2.2.10

ip route 215.5.5.0 255.255.255.0 21.2.2.1 .130


ip route 0.0.0.0 0.0.0.0 21.2.2.9
PCc
200.1.1.128/25
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

REDISTRIBUCIÓN ESTÁTICA (2)


200.1.1.0/25
R7#show ip route .2 PCb
215.5.5.0/24
C R3.5is directly
21.2.2.4 R4FastEthernet0/1
connected,
20.1.1.4/30 .6
.1
200.1.1.0/25 is subnetted, 1 subnets.9
Fa0/0
.1 Fa0/0
Fa0/1
PCa C .22
200.1.1.0 is directly connected, FastEthernet0/0 R7
.2 .6
S* 0.0.0.0/0 [1/0] via 21.2.2.5
R7#
Fa0/0 .2 .21
.1 .10
.1 .2 .5
.18 .9 R6
Propiedad intelectual de Daniel Díaz @ 2014

Fa0/1

21.2.2.0/30
Fa0/0

.13
R1 ip route
R1#show
R2
C .14 .17
21.2.2.0 is directly connected, FastEthernet0/1
.10
C 215.5.5.0/24 is directly connected, FastEthernet0/0
R8#show ip route
R8

ddiaz@inictel-uni.edu.pe
S* 0.0.0.0/0 [1/0] via 21.2.2.2
R1# C
R5
21.2.2.8 is directly connected, FastEthernet0/1 .129 Fa0/0
200.1.1.0/25 is subnetted, 1 subnets
C 200.1.1.128 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 [1/0] via 21.2.2.9 .130
R8# PCc
200.1.1.128/25
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

REDISTRIBUCIÓN ESTÁTICA (3)


200.1.1.0/25
R2#show ip route
.2 PCb
215.5.5.0/24 R3#show ip route
R 21.2.2.4
R4#show [120/2] R3
ip route via 20.1.1.22, 00:00:27,
.5 20.1.1.4/30 .6
R4FastEthernet1/1
R [120/2].1[120/2]
21.2.2.4 via 20.1.1.14, 00:00:11,
via 20.1.1.6, FastEthernet1/0
00:00:14,
Fa0/0 FastEthernet0/1 .1 Fa0/0
R5#show ip route Fa0/1 .9
PCa C R 21.2.2.0 is directly
R 21.2.2.0 [120/1]
21.2.2.4 connected,
[120/1] via via
20.1.1.2, FastEthernet0/0
.22
00:00:10,
20.1.1.10, FastEthernet0/0
00:00:16, FastEthernet0/1 R7
.2 R R 21.2.2.8 R6#show
[120/2] ip
via route
20.1.1.22, 00:00:27, FastEthernet1/1
R 21.2.2.8 [120/2]
21.2.2.0 [120/1] via via
20.1.1.6, 00:00:14,
20.1.1.21, FastEthernet0/1
00:00:07, FastEthernet1/0 .6
R C 21.2.2.4
21.2.2.4 [120/1]
is via
directly 20.1.1.18,
connected,00:00:15, FastEthernet0/0
FastEthernet1/0
R R[120/2]
20.0.0.0/30
R
viasubnetted,
is
21.2.2.8
21.2.2.0
20.1.1.14,
[120/1]
21.2.2.0 [120/1]
[120/2]
00:00:11,
via6via
subnets
20.1.1.10, FastEthernet1/0
00:00:16,
20.1.1.13,
via 20.1.1.17, FastEthernet0/1
00:00:26,
00:00:02,FastEthernet0/1
FastEthernet0/1
20.0.0.0/30
R is
20.1.1.20 subnetted,
20.0.0.0/30 [120/1]
is[120/2] 6
via subnets
subnetted, 20.1.1.6, 00:00:14,
620.1.1.18, FastEthernet0/1
subnets00:00:12,
Fa0/0 R 21.2.2.8 [120/1]via via20.1.1.9, 00:00:15, FastEthernet0/0
FastEthernet0/0
.1 C C .2
20.1.1.20 .21
is directly
[120/1]
20.1.1.20 via
is is connected,
20.1.1.2,
directly FastEthernet1/1
00:00:10,
connected, .10
FastEthernet0/0
FastEthernet1/0
.1 R R 20.1.1.16 C20.0.0.0/30
.2 20.1.1.16 21.2.2.8 subnetted,
is directly 6 subnets
connected, FastEthernet1/1.5
[120/1]
R R 20.1.1.16 [120/2]via via
[120/1]20.1.1.14,
20.1.1.6,
via 00:00:11, FastEthernet1/0
00:00:14,
20.1.1.10, FastEthernet0/1
00:00:16, FastEthernet0/1
.9 R6
20.1.1.20
20.0.0.0/30 [120/1] via
is subnetted, 20.1.1.13, 00:00:26,
6 subnets .18 FastEthernet0/1
Propiedad intelectual de Daniel Díaz @ 2014

Fa0/1

21.2.2.0/30
Fa0/0

R 20.1.1.4
C C R [120/1]
.13
[120/2]
20.1.1.4 isvia
via 20.1.1.22,
20.1.1.2,
directly 00:00:27,
00:00:10,
connected, FastEthernet1/1
FastEthernet0/0
FastEthernet0/0
20.1.1.16
20.1.1.20 is directly
[120/1] connected,
via 20.1.1.9,FastEthernet0/0
00:00:12, FastEthernet0/0
R1 [120/1]
C R 20.1.1.4 via
is
20.1.1.0
R C 20.1.1.4
20.1.1.1,
directly
[120/1]
20.1.1.16[120/2] via00:00:07,
connected,
20.1.1.21, FastEthernet0/1
FastEthernet0/1
via 20.1.1.18,
is directly 00:00:07, FastEthernet1/0
00:00:15,
connected, FastEthernet0/0
FastEthernet0/1
R220.1.1.0
C C 20.1.1.0 is directly
is
R is[120/1] [120/2]
20.1.1.4
connected,
directlyvia connected,
20.1.1.5,
via
[120/1]
FastEthernet0/1
20.1.1.13,
via
FastEthernet0/0
00:00:10,
20.1.1.9, FastEthernet0/0
00:00:26, FastEthernet0/1
00:00:12, FastEthernet0/0
C R 20.1.1.12
20.1.1.12
R R R directly
20.1.1.12[120/1]
[120/1]via .14
connected, .17
20.1.1.2,
via FastEthernet1/0
00:00:10, FastEthernet0/0
20.1.1.0
20.1.1.0 [120/1]
[120/2] via20.1.1.21,
20.1.1.13,
via 00:00:07,
00:00:26,
20.1.1.17, FastEthernet1/0
00:00:02,FastEthernet0/1
FastEthernet0/1.10
R R 20.1.1.8 [120/1]
C 20.1.1.8 [120/1]
20.1.1.8 isvia 20.1.1.22,
via
directly 20.1.1.6, 00:00:00,
connected, FastEthernet1/1
00:00:14, FastEthernet0/1
FastEthernet0/1
C 20.1.1.12 is directly
[120/2] connected,
via 20.1.1.9, FastEthernet0/1
00:00:12, FastEthernet0/0
S R3#
215.5.5.0/24 [1/0] via 21.2.2.1 R8

ddiaz@inictel-uni.edu.pe
R4#
R2#
R R 20.1.1.820.1.1.12[120/1][120/1]R5
via 20.1.1.18, 00:00:15,
via 20.1.1.17, FastEthernet0/0
00:00:02, FastEthernet0/1
.129 Fa0/0
R5#C 20.1.1.8 is directly connected, FastEthernet0/0
No se indica 200.1.1.0/25 is subnetted, 2 subnets
como llegar a S 200.1.1.128 [1/0] via 21.2.2.10
todas las LAN S 200.1.1.0 [1/0] via 21.2.2.6 .130
R6# PCc
200.1.1.128/25
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

REDISTRIBUCIÓN ESTÁTICA (4)

Observar que no
se anuncia las LAN
Propiedad intelectual de Daniel Díaz @ 2014

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

REDISTRIBUCIÓN ESTÁTICA (5)


200.1.1.0/25
.2 PCb
215.5.5.0/24
R3.5 20.1.1.4/30 .6
R4
.1 Fa0/0
.1 Fa0/0
Fa0/1 .9
PCa .22 R7
.2 .6

Fa0/0 .2 .21
.1 .10
.1 .2 .5
.18 .9 R6
Propiedad intelectual de Daniel Díaz @ 2014

Fa0/1

21.2.2.0/30
Fa0/0

.13
R1
R2
.14 .17
.10
R8

ddiaz@inictel-uni.edu.pe
R5(config)#router rip R5
R5(config-router)#redistribute static .129 Fa0/0
R5(config)#router rip
R5(config-router)#redistribute static
.130
PCc
200.1.1.128/25
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

REDISTRIBUCIÓN ESTÁTICA (6)


R2#show ip route
R 21.2.2.4 [120/2] via 20.1.1.22, 00:00:12, FastEthernet1/1
R3#show ip route
[120/2] via 20.1.1.14, 00:00:08, FastEthernet1/0
R R4#show
21.2.2.4ip[120/2]
route via 20.1.1.6, 00:00:00, FastEthernet0/1
C 21.2.2.0 is directly connected, FastEthernet0/0
R R 21.2.2.0 [120/1]
21.2.2.4 via via
[120/1] 20.1.1.2, 00:00:17,
20.1.1.10, FastEthernet0/0
00:00:20, FastEthernet0/1
R R5#show
21.2.2.8 [120/2] ip viaroute
20.1.1.22, 00:00:12, FastEthernet1/1
R R 21.2.2.8 [120/2]
21.2.2.0 via via
[120/1] 20.1.1.6, 00:00:00,
20.1.1.21, FastEthernet0/1
00:00:00, FastEthernet1/0
R R6#show
[120/2] 21.2.2.4 [120/1]
ip
via 20.1.1.14, route via 20.1.1.18,
00:00:08, 00:00:07, FastEthernet0/0
FastEthernet1/0
20.0.0.0/30
R 21.2.2.8is subnetted,
[120/1] via6 20.1.1.10,
subnets 00:00:20, FastEthernet0/1
R isCsubnetted,
20.0.0.0/30 21.2.2.0 [120/1]
21.2.2.4 via 20.1.1.13,
is directly
6 subnets 00:00:12,
connected, FastEthernet0/1
FastEthernet1/0
R 20.1.1.20
20.0.0.0/30 [120/1] via 20.1.1.6,
is subnetted, 00:00:00, FastEthernet0/1
6 subnets
C R isRdirectly
20.1.1.20 21.2.2.8 [120/1]
21.2.2.0 viaFastEthernet1/1
[120/2]
connected, 20.1.1.18, 00:00:07,
via 20.1.1.17, FastEthernet0/0
00:00:23, FastEthernet0/1
C [120/1] via
20.1.1.20 20.1.1.2,
is directly 00:00:17,FastEthernet1/0
connected, FastEthernet0/0
R 20.1.1.16 20.0.0.0/30 is
[120/1] via [120/2] subnetted,
20.1.1.14, 6 subnets
via00:00:08,
20.1.1.9, 00:00:15, FastEthernet0/0
FastEthernet1/0
R R 20.1.1.16
20.1.1.16[120/2] via via
[120/1] 20.1.1.6, 00:00:00,
20.1.1.10, FastEthernet0/1
00:00:20, FastEthernet0/1
R R [120/1]
20.1.1.4 C 20.1.1.20
21.2.2.8 [120/1]
via 20.1.1.22, via
is directly 20.1.1.13,
connected,
00:00:12, 00:00:12, FastEthernet0/1
FastEthernet1/1
FastEthernet1/1
C [120/2]isvia
20.1.1.4 20.1.1.2,
directly 00:00:17,
connected, FastEthernet0/0
FastEthernet0/0
C
[120/1] 20.1.1.16
20.0.0.0/30
via 20.1.1.1, is directly
is connected,
subnetted,
00:00:23, FastEthernet0/0
6 subnets
FastEthernet0/1
C R 20.1.1.4 is directly
20.1.1.0 [120/1]connected,
via 20.1.1.21, FastEthernet0/1
00:00:00, FastEthernet1/0
Propiedad intelectual de Daniel Díaz @ 2014

C R is Rdirectly
20.1.1.0 20.1.1.4 [120/2]
20.1.1.20
connected, via
[120/1] 20.1.1.18, 00:00:07,
via 20.1.1.9,
FastEthernet0/1 FastEthernet0/0
00:00:15, FastEthernet0/0
C 20.1.1.0[120/1]
is directlyvia connected, FastEthernet0/0
20.1.1.5, 00:00:14, FastEthernet0/0
C 20.1.1.12 isCdirectly [120/2]
20.1.1.16 via
connected,is 20.1.1.13,
directly 00:00:12,FastEthernet0/1
connected,
FastEthernet1/0 FastEthernet0/1
R R 20.1.1.12
20.1.1.12[120/1] via via
[120/1] 20.1.1.2, 00:00:17,
20.1.1.21, FastEthernet0/0
00:00:00, FastEthernet1/0
R R [120/1]
20.1.1.8 R 20.1.1.0 [120/1]
20.1.1.4
via 20.1.1.22, via00:00:14,
[120/1] 20.1.1.13, 00:00:12,
via 20.1.1.9, FastEthernet0/1
00:00:15,
FastEthernet1/1 FastEthernet0/0
R C 20.1.1.8 [120/1]
20.1.1.8 via 20.1.1.6,
is directly connected,00:00:00, FastEthernet0/1
FastEthernet0/1
C is
200.1.1.0/25 R 20.1.1.12
20.1.1.0
subnetted, is2directly
[120/2] connected,
subnets FastEthernet0/1
via 20.1.1.17, 00:00:23, FastEthernet0/1
200.1.1.0/25
200.1.1.0/25 is subnetted,
is subnetted, 2 subnets
2 subnets
R R
200.1.1.128 20.1.1.8
[120/2] via [120/1]
[120/2] via 20.1.1.18,
20.1.1.22, 20.1.1.9,
00:00:15, 00:00:07,
00:00:15, FastEthernet0/0
FastEthernet0/0
FastEthernet1/1
R R 200.1.1.128
200.1.1.128 [120/2]
[120/1]via via20.1.1.6, 00:00:02,
20.1.1.10, FastEthernet0/1
00:00:22, FastEthernet0/1
200.1.1.0/25 is subnetted, 2 subnets

ddiaz@inictel-uni.edu.pe
R via20.1.1.12
[120/2] 20.1.1.14, [120/1] via
00:00:11, 20.1.1.17, 00:00:23, FastEthernet0/1
FastEthernet1/0
R R 200.1.1.0
200.1.1.0[120/2] via via
[120/1] 20.1.1.6, 00:00:03,
20.1.1.10, FastEthernet0/1
00:00:22, FastEthernet0/1
R R [120/2]
200.1.1.0 C 200.1.1.128
20.1.1.8 [120/1]
is directly
via 20.1.1.22, viaconnected,
20.1.1.18,
00:00:17, 00:00:09, FastEthernet0/0
FastEthernet0/0
FastEthernet1/1 Si se indica
R R215.5.5.0/24
215.5.5.0/24 [120/1]
[120/1]via via
20.1.1.2, 00:00:21,
20.1.1.21, FastEthernet0/0
00:00:02, FastEthernet1/0
R
[120/2] 200.1.1.0
200.1.1.0/25
via [120/1]
20.1.1.14, via 20.1.1.18,
is00:00:12,
subnetted, 00:00:09, FastEthernet0/0
2 subnets
FastEthernet1/0 como llegar
R3#R4#
R 215.5.5.0/24
S 215.5.5.0/24 S[1/0] 200.1.1.128 [120/1]
via 21.2.2.1 viavia
[1/0] 20.1.1.13,
21.2.2.1000:00:15, FastEthernet0/1 a las LAN
R2# R5#S 200.1.1.0 [1/0] via 21.2.2.6
R 215.5.5.0/24 [120/2] via 20.1.1.17, 00:00:26, FastEthernet0/1
[120/2] via 20.1.1.9, 00:00:18, FastEthernet0/0
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

REDISTRIBUCIÓN ESTÁTICA (7)

Observar que SI
se anuncia las LAN,
debido a la
redistribución
Propiedad intelectual de Daniel Díaz @ 2014

ddiaz@inictel-uni.edu.pe
Porque no se observa el
anuncio de la LAN
215.5.5.0/24 ?

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


EJERCICIO:
Protocolo de
enrutamiento
IMPLEMENTAR
Protocolo RIP
Protocolo OSPFv2
TABLA DE NAT
Activar servidor DHCP.
192.168.1.2  210.1.1.2 Cuando una de las PC solicite
UNI 192.168.1.3  210.1.1.3 una dirección IP dinámica,
ésta se asignará en el rango:
192.168.1.4 210.1.1.4
192.168.1.64
PC1 192.168.1.63 210.1.1.14
192.168.1.254
192.168.1.0/24 192.168.1.64 210.1.1.15 Nota: Considere las interfaces que estime conveniente
192.168.1.254 Nota: En un enlace WAN, asigne la dirección IP adecuada
R5 a cada interfaz dentro del rango establecido

PUCP
R1
R3 R6
R8 PCb
RIPv2
UNMSM

VLSM 4
Propiedad intelectual de Daniel Díaz @ 2014

VLSM 5

110.2.3.0/24

PC2
192.168.1.0/24 VLSM 3

R4 Enlace WAN

ddiaz@inictel-uni.edu.pe
R7
192.168.1.2  220.2.2.2
192.168.1.3  220.2.2.3 Activar servidor DHCP.
60.50.40.0/24
R2 Cuando una de las PC solicite
192.168.1.4 220.2.2.4 una dirección IP dinámica,
192.168.1.63 2202.2.14 ésta se asignará en el rango:
192.168.1.64
192.168.1.64 220.2.2.15 192.168.1.254
192.168.1.254
INSTITUTO NACIONALTABLA DE NAT
DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

BIBLIOGRAFIA
RFC 2453 RIP version 2
Noviembre de 1998.
http://www.ietf.org/rfc/rfc1058.txt
Routing Information Protocol, Autor CISCO
http://www.cisco.com/univercd/cc/td/doc/cisintwk/ito_doc/rip.pdf
RFC 1058 Routing Information Protocol
Propiedad intelectual de Daniel Díaz @ 2014

Junio de 1988.
http://www.ietf.org/rfc/rfc1058.txt
RFC 2082 MD5 Authentication

ddiaz@inictel-uni.edu.pe
http://www.ietf.org/rfc/rfc2082.txt

Routing Information Protocol, Autor CISCO


http://www.cisco.com/univercd/cc/td/doc/cisintwk/ito_doc/rip.pdf
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

 Introducción
Protocolo de  Formato de OSPFv2
Enrutamiento  Caso de estudio
 Configuración
OSPFv2  Redistribución estática
Propiedad intelectual de Daniel Díaz @ 2014

 Redistribución con RIP

Profesor Daniel Díaz Ataucuri


Profesor Titular de Telecomunicaciones
Universidad Nacional de Ingeniería

ddiaz@inictel-uni.edu.pe
Universidad Nacional Mayor de San Marcos

http://www.danieldiaza.com
ddiaz@inictel-uni.edu.pe
ddiaz1610@gmail.com

Lima, Enero–
INSTITUTO NACIONAL DE INVESTIGACION Diciembre
Y CAPACITACION de 2014
DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

CONFIGURACIÓN DE
PROTOCOLO
OSPFv2
Propiedad intelectual de Daniel Díaz @ 2014

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

ASPECTO BÁSICO DEL PROTOCOLO OSPF


Definido por la
IETF en la RFC
2328, de Abril-98.
► Se encapsula en IP
con protocolo=59h.
► Se define 05 tipos
Propiedad intelectual de Daniel Díaz @ 2014

de paquetes o mensajes.
► Lectura obligada.

Características más importante:

ddiaz@inictel-uni.edu.pe
► Velocidad de convergencia. ► Mejor uso del ancho de
► Soporte de VLSM. banda.
► Grandes redes IP: Áreas. ► Se define “costos”.
Enrutamiento jerárquico.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

ASPECTO BÁSICO DEL PROTOCOLO OSPF


TIPO DE MESAJES OSPF FUNCIÓN
Hello Es utilizado por un nodo para conocer los
nodos adyacentes que soportan OSPF.
DataBase Description (DBD) Incluye una lista abreviada de la base de datos
de estado de enlace del router emisor.
Link State Request (LSR) Los routers receptores solicitan información
adicional acerca de una entrada en la DBD
Propiedad intelectual de Daniel Díaz @ 2014

enviando un paquete LSR.


Link State Update (LSU) Se genera como respuesta al paquete LSR y se
usa para responder las LSR y para anunciar
nueva información.

ddiaz@inictel-uni.edu.pe
Link State Ack (LSA) Cuando un router recibe un paquete LSU,
responde enviando un paquete LSA para
confirmar la recepción de LSU.

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

CARACTERÍSTICAS DEL PROTOCOLO OSPF


Los routers vecinos deben conocerse entre si.
►Se hace uso del paquete HELLO. HELLO

►Se envía periódicamente a la Dirección IP 224.0.0.5

dirección multicast IP 224.0.0.5


►Direcc. MAC multicast: 01-00-5E-00-00-05
La clave de OSPF es el intercambio de estados.
Propiedad intelectual de Daniel Díaz @ 2014

Router
El estado de enlace es la descripción Crea una base Llamado también
Base de datos de
de una interfaz y de su relación con los de datos Estado de Enlace
routers vecinos: dirección IP, máscara topológicas

ddiaz@inictel-uni.edu.pe
de subred, tipo de red conectada, etc.

OSPF origina que cada routers conozca de manera


completa toda la red de su área.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

REDES DE ÁREA ÚNICA


SISTEMA AUTÓNOMO

AREA 0
Propiedad intelectual de Daniel Díaz @ 2014

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

REDES MULTIAREAS
SISTEMA AUTÓNOMO
Propiedad intelectual de Daniel Díaz @ 2014

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

OBSERVACIONES AL ESTADO DE ENLACE


Los routers con estado de enlace requieren más
memoria y potencia de procesamiento, que un
router con vector-distancia.

Al inicio del proceso se debe inundar la red con mensaje


LSA, puede degradar la red.
Propiedad intelectual de Daniel Díaz @ 2014

Para reducir la base de datos topológica es necesario


dividir la red en áreas.

ddiaz@inictel-uni.edu.pe
► El Área 0 es denominada también Área Backbone y en ella se
conectan las demás áreas.

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

FORMATO DEL
PROTOCOLO
OSPFv2
Propiedad intelectual de Daniel Díaz @ 2014

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

FORMATO DEL PROTOCOLO OSPF


0 8 16 31

Campo Versión: Ver HLEN


HLEN ToS Longitud Total

Cabecera IPv4
► Indica la versión del protocolo Identificador Indicador/Desplazam.
Protocolo
OSPF, Versión 2. TTL
TTL
59H = 89
Suma
Suma de
de Chequeo
Chequeo

Campo Tipo: Dirección


Dirección IP
IP de
de Origen
Origen

Dirección IP
Dirección IP de
de Destino
Destino
Indica el tipo de mensaje que
Longitud del
encapsula OSPF. Versión Tipo
paquete
Propiedad intelectual de Daniel Díaz @ 2014

► Tipo 1: Hello ID del Router

► Tipo 2: DataBase Description-DBD ID del Área

Protocolo OSPF
► Tipo 3: Link-State Request-LSR Suma de Chequeo Tipo de Autenticación

ddiaz@inictel-uni.edu.pe
► Tipo 4: Link-State Update-LSU Autenticación
Autenticación

► Tipo 5: Link-State
Acknowledgement-LSA Formato del tipo de
Paquete OSPF

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

FORMATO DEL PROTOCOLO OSPF


0 8 16 31

Campo Longitud del paquete: Ver HLEN ToS Longitud Total

Cabecera IPv4
► Indica longitud del paquete OSPF, Identificador Indicador/Desplazam.
Protocolo
incluyendo la cabecera OSPF. TTL
59H = 89
Suma de Chequeo

Campo ID del Router: Dirección IP de Origen

Dirección IP de Destino
► Indica el ID del router que
Longitud del
originó en paquete OSPF. Versión Tipo
paquete
Propiedad intelectual de Daniel Díaz @ 2014

Normalmente cada router ID del Router

escoge como ID la IP mayor ID del Área

Protocolo OSPF
entre las IP activas y la Suma de Chequeo Tipo de Autenticación

loopback si esta está activa.

ddiaz@inictel-uni.edu.pe
Autenticación
Campo ID del Área:
► Indica el área en el que se originó Formato del tipo de
Paquete OSPF
el paquete OSPF.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

FORMATO DEL PROTOCOLO OSPF


0 8 16 31

Campo Suma de Chequeo: Ver HLEN ToS Longitud Total

Cabecera IPv4
► Verifica todo el contenido del paquete OSPF,
Identificador Indicador/Desplazam.

excluyendo el campo de autenticación. TTL Protocolo


59H = 89
Suma de Chequeo

Campo Tipo de Autenticación: Dirección IP de Origen

► Indica el tipo de autenticación a usar Dirección IP de Destino

en el paquete. Se configura por áreas. Versión Tipo


Longitud del
paquete
Propiedad intelectual de Daniel Díaz @ 2014

La RFC 2328 define dos tipos de ID del Router


autenticación: ID del Área
- 0  Ninguna
Protocolo OSPF
Suma de Chequeo Tipo de Autenticación
- 1  Password de 64 bits, texto.

ddiaz@inictel-uni.edu.pe
- 2  Autenticación MD5. Autenticación

Campo Autenticación:
► Campo de 64 bits, contiene la Formato del tipo de
Paquete OSPF
información de autenticación.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

ANÁLISIS DEL
PROTOCOLO
OSPFv2
Propiedad intelectual de Daniel Díaz @ 2014

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

FORMATO DEL PAQUETE HELLO


(Pag. 193 de la RFC 2328)
0 8 16 31

Longitud del
Paquetes Hello son paquetes
Versión Tipo=1
paquete OSPF tipo 1.
Protocolo OSPF

ID del Router
► Son enviados periódicamente a
ID del Área
todas las interfaces (incluyendo
Suma de Chequeo Tipo de Autenticación
los loopback) para definir/mantener
Autenticación
los vecinos. Elige el DR/DBR
Propiedad intelectual de Daniel Díaz @ 2014

► En segmentos multiacceso y punto


Máscara a punto, el mensaje HELLO se
Protocolo HELLO

Prioridad
Intervalo de Hello Opción
de Router
envían cada 10seg (IP 224.0.0.5)
► En segmentos multiacceso sin

ddiaz@inictel-uni.edu.pe
Intervalo de Dead Router

Router Designado (DR) broadcast-NBMA,es cada 30seg.


Router Designado de Reserva (BDR) ► En segmentos multiacceso y
Lista de vecino punto a punto, si no llega un
un mensaje HELLO en 40 seg. se considera el router vecino caído .
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

FORMATO DEL PAQUETE HELLO


Propiedad intelectual de Daniel Díaz @ 2014

ddiaz@inictel-uni.edu.pe
En la figura, R1, R2 y R3 están conectados a
través de enlaces punto a punto. Por lo
tanto, no ocurre la elección de DR/BDR.

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

FORMATO DEL PAQUETE HELLO


(Pag. 193 de la RFC 2328)

Máscara
Campo Máscara.
► Es la máscara de la red asociada
Protocolo HELLO

Prioridad
Intervalo de Hello Opción
de Router
Intervalo de Dead Router
con la interfaz emisora.
Router Designado (DR) Campo Intervalo de Hello.
Router Designado de Reserva (BDR) ► Define la frecuencia en seg. con
Lista de vecinos que un router envía un paquete Hello.
Propiedad intelectual de Daniel Díaz @ 2014

Campo de Opción:
DN O DC L NP MC E No
usado

ddiaz@inictel-uni.edu.pe
Campo Prioridad de Router:
► Usado para la elección de un router DR o BDR
► Si este campo está en 0, el router nunca será seleccionado como
DR o BDR. Por defecto este campo está en 1.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

FORMATO DEL PAQUETE HELLO


(Pag. 193 de la RFC 2328)

Máscara
Campo Intervalo Dead
Protocolo HELLO

Intervalo de Hello Opción


Prioridad
de Router
Router.
Intervalo de Dead Router
► Número en segundos antes de
Router Designado (DR)
declarar caído. Por default es
Router Designado de Reserva (BDR)
cuatro (04) veces del campo
Lista de vecinos
Intervalo de Hello.
Propiedad intelectual de Daniel Díaz @ 2014

Campo de Router Designado (DR):


► Identifica a un router dentro de un sistema autónomo.
Es la dirección IP más alta de sus interfaces.

ddiaz@inictel-uni.edu.pe
Es utilizado para seleccionar el router DR.
Campo de Router Designado de Respaldo (BDR):
► Selecciona el router BDR (cuando no escucha LSA desde el DR)
Lista de vecinos
► Enumera la ID del router OSPF de los routers vecinos.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

FORMATO DEL PAQUETE HELLO


0 8 16 31
IP
4 5 C0 00 4C
Cabecera IPv4

04 D3 00 00 OSPF

Hello
01 59H 00 BD

D0 03 03 01 Versión 2 Máscara 255.255.255.0


E0 00 00 05 Tipo 1 (Hello) Intervalo de Hello 10 seg.
Longitud 2C=44 Prioridad de router 1
02 01 00 2C
ID Router 72.72.72.34 Intervalo Dead Router 40 seg.
Propiedad intelectual de Daniel Díaz @ 2014

48 48 48 22 ID Area 0.0.0.2 Router DR 208.3.3.1


00 00 00 02 Suma de Chequeo 892D Router BDR 0.0.0.0
Protocolo OSPF

89 2D 00 00
FF FF FF 00

Protocolo HELLO

ddiaz@inictel-uni.edu.pe
00 00 00 00
00 0A 12 01
00 00 00 00
00 00 00 28

D0 03 03 01

00 00 00 00

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

CONFIGURACIÓN DE
PROTOCOLO
OSPFv2
Propiedad intelectual de Daniel Díaz @ 2014

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

ASPECTOS DE CONFIGURACIÓN (1/7)


Configuración OSPF:
Router# configure terminal
Router(config)# router ospf process-ID
Router(config-router)# network dirección_de_red wildcard
area area_ID
Router(config-router)# exit
Propiedad intelectual de Daniel Díaz @ 2014

Router(config)# R1# configure terminal


R1(config)# router ospf 1
R1(config-router)# network 10.2.3.4 0.0.0.3 area 1
R1(config-router)# network 20.1.71.8 0.0.0.3 area 2
Área 0 R1(config-router)# network 40.1.0.4 0.0.0.3 area 0

ddiaz@inictel-uni.edu.pe
R1(config-router)# network 40.1.0.8 0.0.0.3 area 0
R1(config)#
R1
Área 1 Área 2

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

ASPECTOS DE CONFIGURACIÓN (2/7)


Definición de Identificador de Router (ID-Router):
► Al iniciarse el proceso OSPF en un router, el IOS utiliza
la dirección IP activa local más alta como ID del router.
► Si no existe una interfaz activa, el proceso OSPF no se
iniciará.
► Para asegurar la estabilidad del proceso OSPF, es necesario
Propiedad intelectual de Daniel Díaz @ 2014

que el router tenga una interfaz activa en todo momento.


► La interfaz loopback es importante para este objetivo.
En un router con más de una interfaz loopback,
la dirección más alta será el ID-Router.

ddiaz@inictel-uni.edu.pe
Selección del Router Designado (DR):
► La interfaz con mayor prioridad permitira el router sea DR.
► Ante iguales prioridades se selecciona el de mayor ID-Router.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

ASPECTOS DE CONFIGURACIÓN (3/7)


Configuración de prioridad en una interfaz:
Router(config)# interface serial 0/0/0
Router(config-if)# ip priority número_de_prioridad

Un valor de prioridad puede variar de 0 a 255.


Propiedad intelectual de Daniel Díaz @ 2014

Valor 0 de prioridad imposibilita al router que sea


elegido DR.

En resumen sobre selección de DR y BDR:

ddiaz@inictel-uni.edu.pe
► Mayor prioridad  Router DR.
► Segundo valor de prioridad  Router BDR.
► Routers con igual prioridad  Será DR el mayor ID-Router
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2
LAN UNMSM
LAN UNI RED MULTIAREA 212.2.2.0/26
212.2.2.64/26
.... ....
R5

AREA 1 .2 .5 R6 AREA 2
.1
.65 R3 .1 .6
.13 R1 R8 .13 Rc
Ra .14 .2 AREA 0 .14

.22
.9 .2

Costo 1
.1
.17
20.1.1.16/30 .1

20.1.1.20/30
Costo 2
.9 .9

.21
Propiedad intelectual de Daniel Díaz @ 2014

.10
.18

.14 20.1.1.12/30 .13


Costo 3 .6 .10
.10 .6 40.4.4.16/30
30.3.3.16/30
.5
R4 R7 .18
.5 Rd
Rb .17 .18 .17

ddiaz@inictel-uni.edu.pe
.129 R2 R9 .193

Sistema Autónomo
.... ....
212.2.2.128/26 212.2.2.192/26
LAN UNFV LAN INICTEL-UNI
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2
LAN UNMSM
LAN UNI RED MULTIAREA 212.2.2.0/26
212.2.2.64/26
.... ....
R5
Rc>enable
AREA 1 Rc#configute .2 terminal
.5 R6 AREA 2
Rc(config)#ip route 0.0.0.0 0.0.0.0 40.4.4.14 .1
.65 R3 .1 .6
.13 R1 R8 .13 Rc
Ra .14 .2 AREA 0 .14

.22
.9 .2

Costo 1
.1
.17
20.1.1.16/30 .1

20.1.1.20/30
Ra>enable
Costo 2
.9 .9
Ra#configute terminal
Ra(config)#ip route 0.0.0.0 0.0.0.0 30.3.3.14

.21
Propiedad intelectual de Daniel Díaz @ 2014

.10
.18

.14 20.1.1.12/30 .13


Costo 3 .6 .10
.10 .6 40.4.4.16/30
30.3.3.16/30
.5
R4 R7 .18
Rd>enable .5 Rd
Rb .17 .18 .17

ddiaz@inictel-uni.edu.pe
.129 R2 Rd#configute terminal .193
R9
Rd(config)#ip route 0.0.0.0 0.0.0.0 40.4.4.18

Rb>enable Sistema Autónomo


.... Rb#configute terminal
Rb(config)#ip route 0.0.0.0 0.0.0.0 30.3.3.18
....
212.2.2.128/26 212.2.2.192/26
LAN UNFV LAN INICTEL-UNI
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2
LAN UNMSM
LAN UNI RED MULTIAREA 212.2.2.0/26
Ra>enable
212.2.2.64/26
Ra#configute terminal
.... ....
Ra(config)#router ospf 1 R5
Ra(config-router)#network 30.3.3.12 0.0.0.3 area 1
Ra(config-router)#network 30.3.3.8 0.0.0.3 area 1 R6
AREA 1 30.3.3.0 0.0.0.3
Ra(config-router)#network
.2 .5
area 1
AREA 2
.1
.65 Ra(config-router)#exit R3 .1 .6 Rc
.13 R1 R8 .13
Ra .14 .2 AREA 0 .14

.22
.9 .2

Costo 1
.1
.17
20.1.1.16/30 .1

20.1.1.20/30
Costo 2
.9 .9

.21
Propiedad intelectual de Daniel Díaz @ 2014

.10
.18

.14 20.1.1.12/30 .13


Costo 3 .6 .10
.10 .6 40.4.4.16/30
30.3.3.16/30
.5
R4 R7 .18
.5 Rd
Rb .17 .18 .17

ddiaz@inictel-uni.edu.pe
.129 R2 R9 .193

Sistema Autónomo
.... ....
212.2.2.128/26 212.2.2.192/26
LAN UNFV LAN INICTEL-UNI
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2
LAN UNMSM
LAN UNI RED MULTIAREA 212.2.2.0/26
212.2.2.64/26
.... ....
R5

AREA 1 .2 .5 R6 AREA 2
.1
.65 R3 .1 .6
.13 R1 R8 .13 Rc
Ra .14 .2 AREA 0 .14

.22
.9 .2

Costo 1
.1
.17
20.1.1.16/30 .1

20.1.1.20/30
Costo 2
.9 .9

.21
Propiedad intelectual de Daniel Díaz @ 2014

.10
.18

.14 20.1.1.12/30 .13


Costo 3 .6 .10
.10 .6 40.4.4.16/30
30.3.3.16/30
.5
R4 R7 .18
.5 Rd
Rb .17 .18 .17

ddiaz@inictel-uni.edu.pe
.129 R2 R9 .193

Sistema Autónomo
.... ....
212.2.2.128/26 212.2.2.192/26
LAN UNFV LAN INICTEL-UNI
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

ANÁLISIS DE LA RED MULTIAREA

R5

AREA 1 .2 .5 AREA 2
R3 R6
PCa .1 .6 PCc
R1 AREA 0 R8
.65 .2 .9 .2 .65

Costo 1
.1
.17

.1
20.1.1.16/30

.22
20.1.1.20/30
Costo 2
.9 .9 220.2.2.64/26
Propiedad intelectual de Daniel Díaz @ 2014

210.1.1.64/26

.21
.10
.18

.14 20.1.1.12/30 .13


210.1.1.128/26 .10 .6 Costo 3 .6 .10 220.2.2.0/26
.129 .5 R4 R7 .1

ddiaz@inictel-uni.edu.pe
.5

PCb R2 R9 PCd

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

CONFIGURACIÓN DE ROUTER CON OSPF


Propiedad intelectual de Daniel Díaz @ 2014

R2>enable
R2#configute terminal
R2(config)#router ospf 1
R2(config-router)#network 30.3.3.4 0.0.0.3 area 1
R2(config-router)#network 30.3.3.8 0.0.0.3 area 1

ddiaz@inictel-uni.edu.pe
R1>enable
R1#configute terminal R2(config-router)#network 210.1.1.128 0.0.0.63 area 1
R1(config)#router ospf 1 R2(config-router)#exit
R1(config-router)#network 30.3.3.0 0.0.0.3 area 1
R1(config-router)#network 30.3.3.8 0.0.0.3 area 1
R1(config-router)#network 210.1.1.64 0.0.0.63 area 1
R1(config-router)#exit
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

CONFIGURACIÓN DE ROUTER CON OSPF


Propiedad intelectual de Daniel Díaz @ 2014

R7>enable
R7#configute terminal
R7(config)#router ospf 1
R7(config-router)#network 20.1.1.8 0.0.0.3 area 0
R7(config-router)#network 20.1.1.12 0.0.0.3 area 0

ddiaz@inictel-uni.edu.pe
R4>enable
R4#configute terminal R7(config-router)#network 20.1.1.20 0.0.0.3 area 0
R4(config)#router ospf 1 R7(config-router)#network 40.4.4.4 0.0.0.3 area 2
R4(config-router)#network 20.1.1.12 0.0.0.3 area 0 R7(config-router)#exit
R4(config-router)#network 20.1.1.16 0.0.0.3 area 0
R4(config-router)#network 30.3.3.4 0.0.0.3 area 1 Los demás router se configuran
R4(config-router)#exit de manera similar.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

COSTOS OSPF POR DEFAULT

fa2/0
Propiedad intelectual de Daniel Díaz @ 2014

►Por default, OSPF asigna costo


R1>enable
asociado al ancho de banda: R1#configute terminal
R1(config)#interface fastethernet 2/0

ddiaz@inictel-uni.edu.pe
costo= 108/(Ancho de banda) R1(config-if)#bandwidth 100 000
Expresado en 1000

►Se puede usar el comando bandwidth


para cambiar el denominador de la fórmula
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

CONFIGURACIÓN DE COSTOS OSPF

fa2/0
Propiedad intelectual de Daniel Díaz @ 2014

R1>enable Los demás router se configuran


R1#configute terminal de manera similar.
R1(config)#interface fastethernet 1/1
R1(config-if)#ip ospf cost 5 ►Para observar el costo de una interfaz:
R1(config-router)#exit show ip ospf interface fastethernet 1/1

ddiaz@inictel-uni.edu.pe
R1(config)#interface fastethernet 2/0 R1#show ip ospf interface fastethernet 1/1
R1(config-if)#ip ospf cost 1 FastEthernet1/1 is up, line protocol is up
R1(config-router)#exit Internet Address 30.3.3.1/30, Area 1
Process ID 1, Router ID 210.1.1.65, Network Type BROADCAST, Cost: 5
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 210.1.1.65, Interface address 30.3.3.1

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

COMANDO debug ip ospf events


R3#debug ip ospf events Se desactiva:
OSPF events debugging is on R#no debug ip ospf events
R3#
*Jan 14 10:45:30.079: OSPF: Rcv hello from 40.4.4.6 area 0 from FastEthernet2/1 20.1.1.10
*Jan 14 10:45:30.083: OSPF: End of hello processing
R3#
*Jan 14 10:45:31.567: OSPF: Send hello to 224.0.0.5 area 1 on FastEthernet1/0 from 30.3.3.2
*Jan 14 10:45:31.571: OSPF: Send hello to 224.0.0.5 area 0 on FastEthernet2/0 from 20.1.1.1
*Jan 14 10:45:31.575: OSPF: Send hello to 224.0.0.5 area 0 on FastEthernet1/1 from 20.1.1.17
*Jan 14 10:45:31.579: OSPF: Send hello to 224.0.0.5 area 0 on FastEthernet2/1 from 20.1.1.9
*Jan 14 10:45:31.779: OSPF: Rcv hello from 210.1.1.65 area 1 from FastEthernet1/0 30.3.3.1
Propiedad intelectual de Daniel Díaz @ 2014

*Jan 14 10:45:31.783: OSPF: End of hello processing


R3#
*Jan 14 10:45:35.991: OSPF: Rcv hello from 20.1.1.5 area 0 from FastEthernet2/0 20.1.1.2
*Jan 14 10:45:35.995: OSPF: End of hello processing
R3#
*Jan 14 10:45:38.487: OSPF: Rcv hello from 30.3.3.6 area 0 from FastEthernet1/1 20.1.1.18
*Jan 14 10:45:38.491: OSPF: End of hello processing

ddiaz@inictel-uni.edu.pe
R3#
*Jan 14 10:45:40.083: OSPF: Rcv hello from 40.4.4.6 area 0 from FastEthernet2/1 20.1.1.10
*Jan 14 10:45:40.087: OSPF: End of hello processing
R3#
*Jan 14 10:45:41.571: OSPF: Send hello to 224.0.0.5 area 1 on FastEthernet1/0 from 30.3.3.2
*Jan 14 10:45:41.575: OSPF: Send hello to 224.0.0.5 area 0 on FastEthernet2/0 from 20.1.1.1

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

ANALISIS DE PATH PCb a PCc


Propiedad intelectual de Daniel Díaz @ 2014

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

ANALISIS DE PATH PCc a PCb


Propiedad intelectual de Daniel Díaz @ 2014

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

TABLA DE ENRUTAMIENTO DE R2
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Costos totales
Gateway of last resort is not set

220.2.2.0/26 is subnetted, 2 subnets


O IA 220.2.2.64 [110/14] via 30.3.3.9, 00:34:37, FastEthernet1/0
O IA 220.2.2.0 [110/13] via 30.3.3.9, 00:34:37, FastEthernet1/0
20.0.0.0/30 is subnetted, 6 subnets

► Costo total O IA 20.1.1.20 [110/12] via 30.3.3.9, 00:34:37, FastEthernet1/0


Propiedad intelectual de Daniel Díaz @ 2014

O IA 20.1.1.16 [110/8] via 30.3.3.9, 00:34:32, FastEthernet1/0


O IA 20.1.1.4 [110/16] via 30.3.3.9, 00:34:46, FastEthernet1/0
desde R2 hasta O IA 20.1.1.0 [110/12] via 30.3.3.9, 00:34:39, FastEthernet1/0
O IA 20.1.1.12 [110/11] via 30.3.3.9, 00:34:37, FastEthernet1/0
la red O IA 20.1.1.8 [110/13] via 30.3.3.9, 00:34:32, FastEthernet1/0
40.0.0.0/30 is subnetted, 3 subnets
220.2.2.64 O IA 40.4.4.8 [110/13] via 30.3.3.9, 00:34:37, FastEthernet1/0
O IA 40.4.4.0 [110/13] via 30.3.3.9, 00:34:37, FastEthernet1/0

ddiaz@inictel-uni.edu.pe
es 14. O IA 40.4.4.4 [110/12] via 30.3.3.9, 00:34:41, FastEthernet1/0
210.1.1.0/26 is subnetted, 2 subnets
C 210.1.1.128 is directly connected, FastEthernet2/0
O 210.1.1.64 [110/2] via 30.3.3.9, 00:34:50, FastEthernet1/0
30.0.0.0/30 is subnetted, 3 subnets
C 30.3.3.8 is directly connected, FastEthernet1/0
C 30.3.3.4 is directly connected, FastEthernet1/1
O 30.3.3.0 [110/6] via 30.3.3.9, 00:34:50, FastEthernet1/0
R2#
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

NUEVO ESCENARIO DE ANÁLISIS


Área 1

Lo_0: 131.4.5.33/28 Lo_2: 190.1.7.73/29


Lo_1: 131.4.6.163/27 Lo_3: 190.1.9.130/25
205.2.83.128/25 Lo_1
Fa0/0
Lo_0
10.2.2.36/30 R6
S0/0/0
Lo_3

S0/0/1
Lo_2
Lo_10: 10.41.52.3/24 Lo_13: 204.6.21.36/24
Lo_11: 10.41.68.19/24 Lo_14: 204.9.80.94/24
Lo_12: 51.5.6.6/24
Fa0/0 Fa0/1
Propiedad intelectual de Daniel Díaz @ 2014

Área 0 R1 Área 3
Lo_6
Lo_4 Lo_8
Lo_5
Fa0/1 Fa0/0
R2 R3
Lo_12 10.52.177.56/30 Lo_13
Lo_10 S0/0/1 S0/0/0
Fa0/0 Fa0/1
R4 R5
S0/0/0 Área 2 S0/0/1

ddiaz@inictel-uni.edu.pe
Lo_7 Lo_9
Fa0/0 Fa0/0
Lo_4: 210.7.2.31/24
Lo_11 Lo_5: 210.8.8.19/24 Lo_14
Lo_6: 55.0.4.3/17
Lo_7: 55.0.190.90//17
Lo_8: 140.1.160.3/21
200.4.5.0/24 Lo_9: 140.1.170.7/21 210.7.9.0/24
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

OBTENCION DE ROUTER-ID

En el router R1
R1#show ip ospf
Routing Process "ospf 1" with ID 210.8.8.19

En el router R2
Propiedad intelectual de Daniel Díaz @ 2014

R2#show ip ospf
Routing Process "ospf 3" with ID 55.0.190.90

ddiaz@inictel-uni.edu.pe
En el router R3
R3#show ip ospf
Routing Process "ospf 3" with ID 140.1.170.7

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

OBTENCION DE ROUTER-ID

En el router R4
R4#show ip ospf
Routing Process "ospf 1" with ID 10.41.68.19

En el router R5
Propiedad intelectual de Daniel Díaz @ 2014

R5#show ip ospf
Routing Process "ospf 3" with ID 204.9.80.94

ddiaz@inictel-uni.edu.pe
En el router R6
R6#show ip ospf
Routing Process "ospf 3" with ID 131.4.6.163

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

USANDO show ip ospf neighbor

En el router R1
R1#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
131.4.6.163 0 FULL/ - 00:00:33 10.2.2.37 Serial0/0/1
55.0.190.90 1 FULL/BDR 00:00:38 10.52.177.62 FastEthernet0/0
140.1.170.7 1 FULL/BDR 00:00:33 10.52.177.53 FastEthernet0/1
R1#
Propiedad intelectual de Daniel Díaz @ 2014

En el router R3
R3#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface

ddiaz@inictel-uni.edu.pe
55.0.190.90 1 FULL/BDR 00:00:39 10.52.177.57 GigabitEthernet0/1
210.8.8.19 1 FULL/DR 00:00:34 10.52.177.54 GigabitEthernet0/0
204.9.80.94 0 FULL/ - 00:00:31 10.1.1.30 Serial0/0/0
R3#
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

ESTABLECIENDO ENLACE VIRTUAL


Área 1

Lo_0: 131.4.5.33/28 Lo_2: 190.1.7.73/29


Lo_1: 131.4.6.163/27 Lo_3: 190.1.9.130/25
205.2.83.128/25 Lo_1
Fa0/0
Lo_0
10.2.2.36/30 R6
S0/0/0
Lo_3

S0/0/1
Lo_2
Lo_10: 10.41.52.3/24 Lo_13: 204.6.21.36/24
Lo_11: 10.41.68.19/24 Lo_14: 204.9.80.94/24
Lo_12: 51.5.6.6/24
Fa0/0 Fa0/1
Propiedad intelectual de Daniel Díaz @ 2014

Área 0 R1 Área 3
Lo_6
Lo_4 Lo_8
Lo_5
Fa0/1 Fa0/0
R2 R3
Lo_12 10.52.177.56/30 Lo_13
Lo_10 S0/0/1 S0/0/0
R4 Fa0/0 virtual-link Fa0/1
R5
S0/0/0 Área 2 S0/0/1

ddiaz@inictel-uni.edu.pe
Lo_7 Lo_9
Fa0/0 Fa0/0
Lo_4: 210.7.2.31/24
Lo_11 Lo_5: 210.8.8.19/24 Lo_14
Lo_6: 55.0.4.3/17
Lo_7: 55.0.190.90//17
Lo_8: 140.1.160.3/21
200.4.5.0/24 Lo_9: 140.1.170.7/21 210.7.9.0/24
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

OBSERVANDO LA TABLA DE RUTEO EN R5

Observar que un loopback siempre se anuncia


Propiedad intelectual de Daniel Díaz @ 2014

con una máscara 255.255.255.255

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

CONFIGURANDO VIRTUAL-LINK

Área 0 R1 Área 3
Lo_6
Lo_4 Lo_8
Lo_5
Fa0/1 Fa0/0
R2 R3
Lo_12 10.52.177.56/30 Lo_13
Lo_10 S0/0/1 S0/0/0
R4 Fa0/0 virtual-link Fa0/1
R5
S0/0/0 Área 2 S0/0/1

Lo_7 Lo_9
Fa0/0 Fa0/0
Propiedad intelectual de Daniel Díaz @ 2014

Lo_7: 55.0.190.90//17 Lo_9: 140.1.170.7/21


Lo_11 Lo_14

200.4.5.0/24 210.7.9.0/24

ddiaz@inictel-uni.edu.pe
R2>enable R3>enable
R2#configure terminal. R3#configure terminal.
R2(config)#router ospf 2 R3(config)#router ospf 3
R2(config-router)#area 2 virtual-link 140.1.170.7 R3(config-router)#area 2 virtual-link 55.0.190.90
R2(config-router)#exit R3(config-router)#exit
R2(config)# R3(config)#

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

OBSERVANDO LA TABLA DE RUTEO EN R5


Propiedad intelectual de Daniel Díaz @ 2014

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

OBSERVANDO LA TABLA DE RUTEO EN R6


Propiedad intelectual de Daniel Díaz @ 2014

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

CONFIGURANDO VIRTUAL-LINK
Área 1

205.2.83.128/25 Lo_1
Fa0/0
Lo_0
10.2.2.36/30 R6
S0/0/0
Lo_3

S0/0/1
Lo_2

R1>enable
Fa0/0 Fa0/1 R1#configure terminal
Propiedad intelectual de Daniel Díaz @ 2014

Área 0 R1 R1(config)#router ospf 1


Lo_6
Lo_4
Lo_5 R1(config-router)#area
Lo_8 2 virtual-link 55.0.190.90
Fa0/1 R1(config-router)#exit
Fa0/0
R2 R1(config)#
Lo_12 10.52.177.56/30
Lo_10 S0/0/1
Fa0/0 Fa0/1
R4
S0/0/0 Área 2

ddiaz@inictel-uni.edu.pe
R2>enable
Lo_7 R2#configure terminal
Fa0/0
Lo_5: 210.8.8.19/24 R2(config)#router ospf 2
Lo_11 R2(config-router)#area 2 virtual-link 210.8.8.19
R2(config-router)#exit
Lo_7: 55.0.190.90//17 R2(config)#
200.4.5.0/24
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

OBSERVANDO LA TABLA DE RUTEO EN R6


Propiedad intelectual de Daniel Díaz @ 2014

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

ANALIZANDO LOS VIRTUAL-LINK

R2#show ip ospf virtual-link


Propiedad intelectual de Daniel Díaz @ 2014

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

CONFIGURACIÓN DE
LOS PROTOCOLOS
RIPv2/OSPFv2
Propiedad intelectual de Daniel Díaz @ 2014

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

ANÁLISIS DE UNA RED OSPF/RIP

R5

AREA 1 .2 .5
RIPv2 AREA 2
R3 R6 RIPv2
PCa .1 .6 PCc
R1 AREA 0 R8
.65 .2 .9 .2 .65

Costo 1
.1
.17

.1
20.1.1.16/30

.22
20.1.1.20/30
Costo 2
.9 .9 220.2.2.64/26
Propiedad intelectual de Daniel Díaz @ 2014

210.1.1.64/26

.21
.10
.18

.14 20.1.1.12/30 .13


210.1.1.128/26 .10 .6 Costo 3 .6 .10 220.2.2.0/26
.129 .5 R4 R7 .1

ddiaz@inictel-uni.edu.pe
.5

PCb R9 PCd
R2

RIPv2 RIPv2
Revisión de redistribución RIP y OSPF en: OSPFv2
http://docwiki.cisco.com/wiki/Internetwork_Design_Guide_--_RIP_and_OSPF_Redistribution#RIP_and_OSPF_Redistribution
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

ANÁLISIS DE UNA RED OSPF/RIP


router ospf 1 router rip
redistribute rip subnets version 2
network 30.3.3.0 0.0.0.3 area 1 redistributeR5
ospf 1 match internal external 1 external 2
network 30.3.3.8 0.0.0.3 area 1 network 210.1.1.64
no auto-summary
AREA 1 .2 .5
RIPv2 AREA 2
R3 R6 RIPv2
PCa .1 .6 PCc
R1 AREA 0 R8
.65 .2 .9 .2 .65

Costo 1
.1
.17

.1
20.1.1.16/30

.22
20.1.1.20/30
Costo 2
.9 .9 220.2.2.64/26
Propiedad intelectual de Daniel Díaz @ 2014

210.1.1.64/26

.21
.10
.18

.14 20.1.1.12/30 .13


210.1.1.128/26 .10 .6 Costo 3 .6 .10 220.2.2.0/26
.129 .5 R4 R7 .1

ddiaz@inictel-uni.edu.pe
.5

PCbospf 1 R2
router router rip R9 PCd
redistribute rip subnets version 2
network 30.3.3.4 0.0.0.3 area 1 redistribute ospf 1 match internal external 1 external 2RIPv2
RIPv2
network 30.3.3.8 0.0.0.3 area 1 network 210.1.1.128
OSPFv2
no auto-summary
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

ANÁLISIS DE UNA RED OSPF/RIP


172.16. 0.0/16

RIPv2 .0.2 BW 100Mbps


.0.1
Ra
.198 .201
S1 S0
OSPFv2 AREA 0
Propiedad intelectual de Daniel Díaz @ 2014

BW 1544kbps
S0 .197 S1
.202
S1 S0

ddiaz@inictel-uni.edu.pe
.206
router ospf 1 .65 10.0.37.204/30
router rip
.205 .129
BW 100Mbps
BW 100Mbps
redistribute rip subnets version 2
.66 0.0.0.3 area 0
network 10.0.37.196 .130
redistribute ospf 1 match internal external 1 external 2
RIPv2
network 10.0.37.200 0.0.0.3 area 0 RIPv2
network 172.16.0.0
200.37.42.0/24 no auto-summary 200.37.51.0/24
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

TABLA DE ENRUTAMIENTO
Propiedad intelectual de Daniel Díaz @ 2014

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2

BIBLIOGRAFIA
RFC 1058 Routing Information Protocol
Junio de 1988.
http://www.ietf.org/rfc/rfc1058.txt

RFC 1723 RIP version 2, Noviembre de 1994


http://www.ietf.org/rfc/rfc1723.txt
Propiedad intelectual de Daniel Díaz @ 2014

RFC 2082 MD5 Authentication


http://www.ietf.org/rfc/rfc2082.txt

Routing Information Protocol, Autor CISCO

ddiaz@inictel-uni.edu.pe
http://www.cisco.com/univercd/cc/td/doc/cisintwk/ito_doc/rip.pdf

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo de Protocolo RIP
enrutamiento Protocolo OSPFv2
Propiedad intelectual de Daniel Díaz @ 2014

ddiaz@inictel-uni.edu.pe
MUCHAS GRACIAS

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI