Está en la página 1de 13

Matrices o arreglos

multidimensionales
POR
EDGAR FLORIANO

Pero que es? Una matriz es una estructura de datos. es decir. en las matrices. La diferencia con los arreglos está en que. un espacio de memoria que permite almacenar una colección de elementos. es usual dibujarla como lo ilustra la figura siguiente: . Conviene imaginar una matriz como una organización de celdas de memoria. Además. en cada una de las cuales se puede guardar un elemento de la colección. en filas y columnas. o más técnicamente. los elementos no están organizados linealmente sino que su organización es bidimensional. o casillas. todos del mismo tipo.

que contiene filas y columnas. .Una manera sencilla de entenderla es: Una matriz es una tabla ordenada. ejemplo una matriz de números.

También conocidos como arreglos en 2 dimensiones .

Como en una hoja de Excel En Pseint se utiliza dimensión arreglo[7.4] Columna Fila .

j Como Entero Dimensión alumno[2.Ejemplo 1 Escribir "Programa que permite hacer una matriz de 2x2 con los datos sumistrados “ Escribir "" definir i.2] Escribir "Ingrese datos que van en la primera fila primera columna" Leer alumno[1.2] Escribir "Ingrese datos que van en la segunda fila primera columna " Leer alumno[2.1] Escribir "Ingrese datos que van en la segunda fila segunda columna " Leer alumno[2. " .2]  .1]. " .1] Escribir "Ingrese datos que van en la primera fila segunda columna " Leer alumno[1. " alumno[1. " alumno[2.2] Escribir alumno[2.2] Escribir alumno[1.1].

pero usando ciclos" Escribir "" definir i.alumno[i.j Como Entero dimension alumno[2. Ejemplo 2: usando ciclos Algoritmo Matriz_12 Escribir "Programa que permite hacer una matriz 2x2 con los datos suministrados.alumno[i. j]. " Edad : ".j+1] Fin Para FinAlgoritmo .2] Para i<-1 Hasta 2 Con Paso 1 Hacer Para j<-1 Hasta 2 Con Paso 1 Hacer Escribir " Pimero digite el nombre y luego la edad" leer alumno[i. j]. Fin Para Fin Para Escribir "" Para i<-1 Hasta 2 Con Paso 1 Hacer j=1 Escribir " Nombre: ".

D I A G R A M A D E F L U J O .

Salida .

2] Nombre 2 Edad 2 alumno[2.1] alumno[2.Lo que se hace Nombre 1 Edad 1 alumno[1.1] alumno[1.2] .

". grado : ".j+3]  Fin Para  FinAlgoritmo .j Como Entero dimension alumno[3. Edad : ". Fin Para Escribir"" Escribir "continue" Fin Para Para i<-1 Hasta 3 Con Paso 1 Hacer j=1 Escribir " Nombre: ". luego grado y finalmente jornada" leer alumno[i.alumno[i. alumno[i.Ejemplo 3: matriz 3x4 Algoritmo Matriz_23 Escribir "Programa que permite hacer una matriz 3x4 con los datos suministrados.j].j+1]. ".luego edad.j].alumno[i. jornada: ". pero usando ciclos" Escribir "" definir i.4] Para i<-1 Hasta 3 Con Paso 1 Hacer Para j<-1 Hasta 4 Con Paso 1 Hacer Escribir "siga" Escribir " Primero digite el nombre . alumno[i. ".j+2].

.

3] alumno[1.La matriz Nombre 1 Edad 1 Grado 1 Jornada 1 alumno[1.4] Nombre 2 Edad 2 Grado 2 Jornada 2 alumno[2.1] alumno[2.3] alumno[2.2] alumno[3.2] alumno[1.4] Nombre 3 Edad 3 Grado 3 Jornada 3 alumno[3.3] alumno[3.1] alumno[3.2] alumno[2.4] .1] alumno[1.