Está en la página 1de 29

ENRUTAMIENTO RIP V2

(Protocolo Dinmico)

Es un protocolo de enrutamiento dinmico con lo


cual nos permite configurar las rutas con las que
se comunicaran los Router de forma dinmica y
sencilla.

ENRUTAMIENTO RIP V2
(Protocolo Dinmico)

RIP es un tipo de protocolo dinmico versin


distancia y tiene 2 versiones (RIP y RIPV2).
Esta
presentacin
tiene
como
objetivo
comprender el funcionamiento y configuracin
del protocolo de enrutamiento RIPv2.

Como trabaja RIP


El dispositivo enva su tabla de
enrutamiento a todos los vecinos
conectados cada 30 segundos.
Puede haber
actualizaciones
disparadas por eventos.
Por ejemplo: una interfaz cae si
el Timer expira antes de los 30
segundos

Escenario

CONFIGURACIN DE RIPv2
Se utiliz una topologa bsica y la
finalidad es que se pueda enrutar
trfico entre las redes.
192.168.1.0/24Sucursal A
192.168.2.0/24 Sucursal B
192.168.3.0/24 Sucursal C

Primero:
Definimos la estructura
que utilizaremos

Segundo:
Hacemos las conexiones
fsicas

Tercero:
Se configuraron los Host

HOST 1

HOST 2

HOST 3

Host 1

Host 2

Host 3

Cuarto:
Se deben levantar los servicios

Realizando la configuracin bsica de


los Routers.
Dicha configuracin se realiza en la
interfaz de comandos de cada Routers.

Router 1
1. Router>enable
2. Router#config terminal
3. Router(config)#hostname R1
4. R1(config)#interface serial 0/0/0
5. R1(config-if)#ip address 10.0.0.1 255.0.0.0
6. R1(config-if)#clock rate 56000
7. R1(config-if)#no shutdown
8. R1 (config-if)#exit
9. R1(config)#interface serial 0/0/1
10. R1(config-if)#ip address 11.0.0.1 255.0.0.0
11. R1(config-if)#clock rate 56000
12. R1(config-if)#no shutdown
13. R1(config-if)#exit
14. R1(config)#interface serial 0/1/0
15. R1(config-if)#ip address 12.0.0.1 255.0.0.0
16. R1(config-if)#clock rate 56000

Router 2
1.
2.
3.
4.
5.

Router>enable
Router#config terminal
Router(config)#hostname R2
R2(config)#interface fastethernet 0/0
R2(config-if)#ip address 192.168.1.1
255.255.255.0
6. R2(config-if)#no shutdown
7. RouterA(config-if)#exit
8. R2(config)#interface serial 0/0/0
9. R2(config-if)#ip address 10.0.0.2 255.0.0.0
10.R2(config-if)#no shutdown
11.R2(config-if)#exit

Router 3
1.
2.
3.
4.
5.

Router>enable
Router#config terminal
Router(config)#hostname 3
R3(config)#interface fastethernet 0/0
R3(config-if)#ip address 192.168.2.1
255.255.255.0
6. R3(config-if)#no shutdown
7. R3(config-if)#exit
8. R3(config)#interface serial 0/0/0
9. R3(config-if)#ip address 11.0.0.2 255.0.0.0
10.R3(config-if)#no shutdown
11.R3(config-if)#exit

Router 4
1.
2.
3.
4.
5.

Router>enable
Router#config terminal
Router(config)#hostname 4
R4 (config)#interface fastethernet 0/0
R4(config-if)#ip address 192.168.3.1
255.255.255.0
6. R4(config-if)#no shutdown
7. R4(config-if)#exit
8. RouterA(config)#interface serial 0/0/0
9. R4(config-if)#ip address 12.0.0.2 255.0.0.0
10.R4(config-if)#no shutdown
11.R4(config-if)#exit

Quinto:
Se debe realizar la
configuracin RIP
A cada Router se le debe hacer
las configuraciones RIP
Con el Comando Network se
publican las redes directamente
conectadas al Router.

Router 1

10.0.0.0

11.0.0.0

12.0.0.0

R1>enable
R1#config terminal
R1(config)# router rip
R1(config-router)# version 2
R1(config-router)# network 10.0.0.0
R1(config-router)# network 11.0.0.0
R1(config-router)# network 12.0.0.0
R1(config-router)# network 192.168.1.0
R1(config-router)# network 192.168.2.0

Router 2

R2>enable
R2#config terminal
R2(config)# router rip
R2(config-router)# version 2
R2(config-router)# network 10.0.0.0
R2(config-router)# network
192.168.1.0
R2(config-if)#exit

Router 3
R3>enable
R3#config terminal
R3(config)# router rip
R3(config-router)# version
2
R3(config-router)# network
11.0.0.0
R3(config-router)# network
192.168.2.0
R3(config-if)#exit

Router 3
R4>enable
R4#config terminal
R4(config)# router rip
R4(config-router)#
version 2
R4(config-router)#
network 12.0.0.0
R4(config-router)#
network 192.168.2.0
R4(config-if)#exit

Comprobacin de
Conectividad
Se utiliza el comando Show IP
Router en cada uno de los
Routers para verificar
conectividad y la configuracin
RIP

Router 1

R1>show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C
C
C
R
R
R

10.0.0.0/8 is directly connected, Serial0/0/0


11.0.0.0/8 is directly connected, Serial0/0/1
12.0.0.0/8 is directly connected, Serial0/1/0
192.168.1.0/24 [120/1] via 10.0.0.2, 00:00:21, Serial0/0/0
192.168.2.0/24 [120/1] via 11.0.0.2, 00:00:06, Serial0/0/1
192.168.3.0/24 [120/1] via 12.0.0.2, 00:00:21, Serial0/1/0

Lecturas del resultado anterior


La primer lectura dice que todo trafico con destino a las
redes
192.168.1.0, sern enviado por la interfaz serial 0/0/0 y fue
tomado mediante la publicacin RIP enviada por la interfaz
10.0.0.1 del Router 1
Segunda lectura dice que todo trafico con destino a las
redes
192.168.2.0, sern enviado por la interfaz serial 0/0/1 y fue
tomado mediante la publicacin RIP enviada por la interfaz
11.0.0.1 del Router 1
Tercer lectura dice que todo trafico con destino a las redes
192.168.3.0, sern enviado por la interfaz serial 0/0/1 y fue
tomado mediante la publicacin RIP enviada por la interfaz
12.0.0.1 del Router 1

Router 2
La lectura siguiente dice que todo trafico con destino a las redes
192.168.2.0, 192.168.3.0 , 11.0.0.0 y 12.0.0.0 sern enviado por la
interfaz serial 0/0/0 y fue tomado mediante la publicacin RIP enviada
por la interfaz 10.0.0.1 del Router 1

R2>show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C
R
R
C
R
R

10.0.0.0/8 is directly connected, Serial0/0/0


11.0.0.0/8 [120/1] via 10.0.0.1, 00:00:10, Serial0/0/0
12.0.0.0/8 [120/1] via 10.0.0.1, 00:00:10, Serial0/0/0
192.168.1.0/24 is directly connected, FastEthernet0/0
192.168.2.0/24 [120/2] via 10.0.0.1, 00:00:10, Serial0/0/0
192.168.3.0/24 [120/2] via 10.0.0.1, 00:00:10, Serial0/0/0

Router 3
La lectura siguiente dice que todo trafico con destino a las redes
192.168.3.0, 192.168.1.0 , 10.0.0.0 y 12.0.0.0 sern enviado por la
interfaz serial 0/0/0 y fue tomado mediante la publicacin RIP enviada
por la interfaz 11.0.0.1 del Router 1

R3>show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

R 10.0.0.0/8 [120/1] via 11.0.0.1, 00:00:17, Serial0/0/0


C 11.0.0.0/8 is directly connected, Serial0/0/0
R 12.0.0.0/8 [120/1] via 11.0.0.1, 00:00:17, Serial0/0/0
R 192.168.1.0/24 [120/2] via 11.0.0.1, 00:00:17, Serial0/0/0
C 192.168.2.0/24 is directly connected, FastEthernet0/0
R 192.168.3.0/24 [120/2] via 11.0.0.1, 00:00:17, Serial0/0/0
R3>

Router 4
La lectura siguiente dice que todo trafico con destino a las redes
192.168.1.0, 192.168.2.0 , 10.0.0.0 y 11.0.0.0 sern enviado por la
interfaz serial 0/0/0 y fue tomado mediante la publicacin RIP enviada
por la interfaz 12.0.0.1 del Router 1

R4>show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

R 10.0.0.0/8 [120/1] via 12.0.0.1, 00:00:17, Serial0/0/0


R 11.0.0.0/8 [120/1] via 12.0.0.1, 00:00:17, Serial0/0/0
C 12.0.0.0/8 is directly connected, Serial0/0/0
R 192.168.1.0/24 [120/2] via 12.0.0.1, 00:00:17, Serial0/0/0
R 192.168.2.0/24 [120/2] via 12.0.0.1, 00:00:17, Serial0/0/0
C 192.168.3.0/24 is directly connected, FastEthernet0/0
R4>

Comprobacin del
Ejercicio

A
I
C
A
R
G

O
P
S

S
R

T
A
U

I
C
EN