Está en la página 1de 22

Principios de Algoritmos

Agenda

Introduccin
Estructura Mientras
Ejemplo
Ejercicios

ESTRUCTURA MIENTRAS
La instruccin Mientras ejecuta una secuencia de instrucciones mientras se cumpla
una condicin

ESTRUCTURA PARA
MIENTRAS
Se repite una operacin mientras una condicin sea
verdadera.
Al dejar de serlo, se rompe el ciclo
Si la condicin nunca es falsa, se tiene un ciclo
infinito.

Combinacin de operaciones
bsicas
1
no
C
si
2

3
C: Condicin

IWI-131 - Tema 1
Algoritmos

Combinacin de operaciones
bsicas
Inicio
ejecutar 1
mientras se cumpla la condicin
ejecutar 2
fin mientras
ejecutar 3
fin

IWI-131 - Tema 1
Algoritmos

Combinacin de operaciones
bsicas
HASTA QUE
Se repite la ejecucin de una operacin hasta que se
cumpla una condicin.
La principal diferencia con MIENTRAS es que la
operacin se ejecuta al menos una vez.

IWI-131 - Tema 1
Algoritmos

Combinacin de operaciones
bsicas
1

no
C
si
3
C: Condicin

IWI-131 - Tema 1
Algoritmos

Combinacin de operaciones
bsicas
Inicio
ejecutar 1
repetir
ejecutar 2
hasta que se cumpla condicin
ejecutar 3
fin
IWI-131 - Tema 1
Algoritmos

Ejemplo 1
Realizar un pseudocdigo que sume los n
primeros nmeros (1, 2, 3, 4, ., n).
Proceso Suma_N
Definir n, total, i como Entero
Leer n
total 0
Para i 1 hasta n hacer
total total + i
FinPara
Escribir total
FinProceso
Pablo Romero

10

Usando PSeInt

Pablo Romero

11

Solucin

Pablo Romero

12

CONTADORES
CONTADOR
Un contador es una variable que se
incrementa o disminuye en un valor
constante. Un contador tiene la
siguiente forma:
contador contador + valor
constante
Algunos
ejemplos:
jj+2
ii1
carros carros

ACUMULADOR
ACUMULADOR
Un acumulador o totalizador es una variable
cuya misin es el almacenamiento de
cantidades variables de procesos sucesivos.
La diferencia con el contador radica en que
el incremento o disminucin del acumulador
es variable, la forma general de un
acumulador es la siguiente:
acumulador acumulador + valor
Algunos
variable
ejemplos:
acum acum +
i
suma suma +
algo

Acumulador
o
Contador?

Pablo Romero

15

Ejemplo 2
Leer el promedio de cada uno de los n alumnos del curso Principios
de Algoritmos. Mostrar cantidad de aprobados.
Proceso ContarAprobados
Definir n, prom, aprob, i como Entero
Leer n
aprob 0
Para i 1 hasta n hacer
Leer prom
Si prom >=12 entonces
aprob aprob + 1
FinSi
FinPara
Escribir aprob
FinProceso

Pablo Romero

16

Usando PSeInt

Pablo Romero

17

Ejecucin

Pablo Romero

18

Ejercicios
Elabore un pseudocdigo para cada caso:

Hallar total de n trminos: 1+3+5+7+..


Ingresar un numero entero n y mostrar todos los
mltiplos de 3 hasta n.
Mostrar al mayor de n enteros positivos.

Pablo Romero

19

Preguntas

Pablo Romero

20

Finalmente:
El conjunto de sentencias que se repiten siempre
que una condicin dada sea cierta es llamado
..
Una variable que se incrementa o disminuye
en un valor constante es un

Una variable cuya misin es el


almacenamiento de cantidades
variables de procesos sucesivos es
un ..
Pablo Romero

21

Identifique el contador y el acumulador

Cuntas veces se ejecutar la sentencia?


total total + i

Pablo Romero

22