Está en la página 1de 81

IS-IS

Intermediate System-to-Intermediate System

Rick Graziani
Cabrillo College
graziani@cabrillo.edu
Feb. 2004
Sources

• Sources used in creating this IS-IS presentation:


– Cisco Online curriculum, CCNP 1 version 3.0
• Not much as I figured you can read this yourself.
– IS-IS Network Design Solutions, Cisco Press
• Very Good Reference
– CCNP Self-Study (BSCI), Cisco Press
– Routing TCP/IP Volume I by Jeff Doyle

Rick Graziani graziani@cabrillo.edu 2


IS-IS versus OSPF

“IS-IS is exactly the same as OSPF only


completely different.”
IS-IS versus OSPF

• OSPF – discussed in CCNA and CCNP (Single Area and


Multi-Area)
• The following slides show terminology differences between
IS-IS and OSPF.
• Similar to the differences between Spanish and Italian.
• Suggestion: Put this on the board.

Rick Graziani graziani@cabrillo.edu 4


IS-IS versus OSPF - Terminology

IS-IS OSPF Comments


ES (End System) Host
IS (Intermediate System) Router
Circuit Link
SNPA (Subnetwork Point of Datalink Address
Attachment)
PDU (Protocol Data Unit) Packet
DIS (Designated DR (Designated
Intermediate System) Router)
N/A BDR
IIH (IS-to-IS Hello Packet) Hello packet

Rick Graziani graziani@cabrillo.edu 5


IS-IS versus OSPF - Terminology

IS-IS OSPF Comments


LSP (Link-State Packet) LSA (Link -State LSAs are actually
comparable to TLVs used in
Advertisement) LSPs.

CSNP (Complete Sequence DBD (Data Base


Number PDU or Packet) Description Packet)
PSNP (Partial Sequence LSAck or LSR (Link
Number PDU or Packet) State Request)
Routing Domain AS The term routing domain is
also used with OSPF.

Level 1 Area Area (non-


backbone)
Level 2 Area Backbone area IS-IS uses a backbone path
connected by contiguous L2
(Area 0) routers. There is no
backbone area in IS-IS

Rick Graziani graziani@cabrillo.edu 6


IS-IS versus OSPF – ISs (Routers)

IS-IS OSPF Comments


Level 1 IS (router) Internal Non- Internal, non-backbone
router in a Totally Stubby
backbone Router Area

Level 2 IS (router) Internal Backbone Any Level 2 router can


distribute externals into the
Router or ASBR domain. No special name.
(Cisco IOS allows Level 1
routers to distribute
externals.)

Level 1-2 IS (router) ABR


System ID Router ID The System ID is the key for
SPF calculations.
Sometimes the NET
address is thought of as the
Router ID.

AFI = 49 RFC 1918 AFI is part of the NSAP.

Addresses

Rick Graziani graziani@cabrillo.edu 7


IS-IS versus OSPF - Timers

Interface IS-IS OSPF


Point-to-Point Hello – 10 sec Hello – 10 sec
Holdtime – 30 sec Dead – 40 sec
Broadcast Hello – 10 sec Hello – 10 sec
Holdtime – 30 sec Dead – 40 sec
NBMA N/A Hello – 30 sec
Dead – 120 sec

Other IS-IS OSPF


LS Aging 1,200 sec or 20 min 3,600 sec or 60 min
(counts down) (counts up)
LS Refresh Every 15 min Every 30 min
NBMA N/A Hello – 30 sec
Dead – 120 sec
SPF Delay/Holdtime 5.5 sec / 10 sec 5 sec / 10 sec
Rick Graziani graziani@cabrillo.edu 8
History of IS-IS and OSPF

Just like the MacIntosh versus PC debate


History of IS-IS and OSPF
http://www.nanog.org
• 1985
– Originally called DECnet Phase V
• 1987
– IS-IS (from DEC) selected by ANSI as OSI intradomain protocol
(CLNP only)
• 1988
– NSFnet deployed, IGP based on early IS-IS draft
– OSPF work begins, loosely based on IS-IS mechanisms
– IP extensions to IS-IS defined
• 1989
– OSPF v.1 RFC published
– IS-IS becomes ISO proposed standard
– Public bickering ensues--OSPF and IS-IS are blessed as equals by
IETF, with OSPF somewhat more equal
– Private cooperation improves both protocols
• 1990
– Dual-mode IS-IS RFC published
Rick Graziani graziani@cabrillo.edu 10
History of IS-IS and OSPF
http://www.nanog.org
• 1991
– OSPF v.2 RFC published
– Cisco ships OSI-only IS-IS
• 1992
– Cisco ships dual IS-IS
– Lots of OSPF deployed, but very little IS-IS
• 1993
– Novell publishes NLSP (IPX IS-IS knockoff)
• 1994
– Large ISPs need an IGP; IS-IS is recommended due to recent
rewrite and OSPF field experience (and to lesser extent, NSF
CLNP mandate)
• 1995
– ISPs begin deployment of IS-IS, Cisco implementation firms up,
protocol starts to become popular in niche
Rick Graziani graziani@cabrillo.edu 11
History of IS-IS and OSPF
http://www.nanog.org
• 1996-1998
– IS-IS niche popularity continues to grow (some ISPs switch to it
from OSPF)
– IS-IS becomes barrier to entry for router vendors targeting large
ISPs
– Juniper and other vendors ship IS-IS capable routers
• 1999-2000
– Extensions continue for both protocols

Do you use IS-IS in your network (YES)?


Do you use OSPF (NO)?
Something else (leave blank).

Rick Graziani graziani@cabrillo.edu 12


Who uses IS-IS?

• IS-IS is popular amongst telcos and large ISPs (at least in U.S.).
– A Tier 1 carrier is a telco or ISP that is at the top of the
telecommunications peering and settlements food chain.
– Tier 1 operators typically have operations in more than one country
– Tier 1 operators own and operate their own physical networks, and
either own or part-own their international submarine cable links.

• Example of Tier 1 carriers (not necessarily IS-IS users):


• AT&T • NTT/Verio
• BBN/Genuity • Optus
• British Telecom (BT) • Qwest
• Cable & Wireless • Sprint
• Connect Internet Solutions • Telstra
• German Telekom • UUNET (owned by Worldcom,
• Global Crossing doing business as MCI)

Rick GrazianiLevel 3
graziani@cabrillo.edu
• Williams Communications 13
Introduction to IS-IS

Protocol
Routers
Areas
OSI: Two Network Services,
Two Network Protocols

• CMNS (Connection Mode Network Service) – Requires establishment of a path


between transport layer entites.
– CONP (Connection-Oriented Network Protocol) – OSI network layer
protocol that carries upper layer data over connection-oriented links.

• CLNS (Connectionless Network Service) – Performs datagram support, does


not require circuit to be established
– CLNP (Connectionless Network Protocol) – OSI network layer protocol that
carries upper layer data over connectionless links. (Similar to IP)
Rick Graziani graziani@cabrillo.edu 15
IS-IS Protocol Options

• IS-IS (ISO 10589)


– Dynamic link state routing protocol used in an ISO
CLNS environment.
• ISO-IGRP
– Cisco IOS offers proprietary routing protocol for CLNS.
– Based on IGRP, distance vector technology.
– Can be used for Level 3 Routing, between IS-IS
domains (next)
• Integrated IS-IS (RFC 1195)
– IS-IS for mixed ISO CLNS and IP environments.
– Either:
• Purely ISO
• Purely IP (CCNP 1)
• Both
Rick Graziani graziani@cabrillo.edu 16
OSI Routing Protocols: ES-IS and IS-IS

ISH ESH

ES-IS
• Analogous to Address Resolution Protocol (ARP) in IP
• Not technically a routing protocol
• Sometimes referred to as Level 0 routing.
• ESs (hosts) discover nearest IS (router) by listening to IS Hello (ISH) packets
• ISs (routers) know which hosts are on their subnetwork by listening to ES Hello
(ESH) packets.
• Not applicable for IP networks
Rick Graziani graziani@cabrillo.edu 17
OSI Routing Protocols: ES-IS and IS-IS

Boundary areas in
IS-IS exists on a link
between routers and
not on a router itself
as in OSPF.
These routers should
be entirely in Area 1
and Area 2.

IS-IS
• OSI distinguishes between Level 1, Level 2, and Level 3 routing.
• Level 1 Routing
– If DA is an ES on another subnetwork in the same area, the IS knows the
correct route and forwards packet appropriately.
• Level 2 Routing
– If DA is an ES on another area, the Level 1 IS sends the packet to the
nearest Level 2 IS.
• Level 3 Routing is between separate domains.
– Pure CLNS environment IDRP or ISO-IGRP can be used, in IP, BGP is
used.
Rick Graziani (Not applicable to CCNP)
graziani@cabrillo.edu 18
IS-IS Areas

IS-IS Routers:
• Level 1 IS (L1 IS, router)
– Analogous to OSPF Internal non-backbone router (Totally Stubby)
– Responsible for routing to ESs inside an area.
• Level 2 IS (L2 IS, router)
– Analogous to OSPF Internal Backbone router
– Responsible for routing between areas
• Level 1 and Level 2 IS (L1-L2 IS, router)
– Analogous to OSPF ABR router
– Participate in both L1 intra-area routing and L2 inter-area routing.
Rick Graziani graziani@cabrillo.edu 19
Level 1 Router

• Level 1 IS (L1 IS, router)


– Analogous to OSPF Internal non-backbone router (Totally Stubby)
– Responsible for routing to ESs inside an area.
• A contiguous group of Level 1 routers define an area.
• Level 1 routers maintain the Level 1 database for the area and exit
points to neighboring areas.

Rick Graziani graziani@cabrillo.edu 20


Level 2 Router

• Level 2 IS (L2 IS, router)


– Analogous to OSPF Internal Backbone router
– Responsible for routing between areas
• Also referred to as area routers.
• Interconnect the Level 1 areas
• Store separate database of only inter-area topology

Rick Graziani graziani@cabrillo.edu 21


Level 1 – Level 2
Router

• Level 1 and Level 2 IS (L1-L2 IS, router)


– Analogous to OSPF ABR router
– Participate in both L1 intra-area routing and L2 inter-area routing.
• Maintain both Level and Level 2 LSDB
• Support Level 1 function communicating with other Level 1 routers in
their area
– Inform other Level 1 routers that they are the exit point (default
route) from the area.
• Support Level 2 function communicating with the rest of the backbone
path.
Rick Graziani graziani@cabrillo.edu 22
IS-IS Backbone

• IS-IS does not share the concept of a backbone area 0 with OSPF.
• An IS-IS backbone can appear as a set of distinct areas
interconnected by a chain of Level 2 routers, weaving their way
through and between the Level 1 Areas.
• The IS-IS backbone (path) consists of a contiguous set of Level 1-2
and Level 2 routers.
• Where is the backbone (path)?

Rick Graziani graziani@cabrillo.edu 23


OSI Addressing

NSAP (Area, System ID, NSEL)


SNAP
OSI
Addressing

NSAP

• OSI network layer addressing is done through the NSAP (Network


Service Access Point) consisting of:
– OSI Address of the device
– Link to higher layer protocol
• A variety of NSAP formats exist, which we will not go into.
• Represented in hexadecimal (up to 40 hex digits)
• Cisco format: Area – System ID – NSEL (always 00 on ISs)
49.0001.2222.2222.2222.00
Rick Graziani graziani@cabrillo.edu 25
NSAPs

• Format of the Cisco NSAP address consists of three parts.


– Area address
– System ID
– NSAP selector byte

• Area address is a variable length field


• The system ID is the ES or IS identifier in an area, similar to the
OSPF router ID.
– The system ID has a fixed length of six bytes as engineered in the
Cisco IOS.
• The NSAP selector byte is a service identifier.
– Analogous
Rick Graziani graziani@cabrillo.eduto that of a port or socket in TCP/IP. 26
Do I have to know this, I am only routing IP?

• NSAP prefixes are required for CLNS routing, including IP only


networks.
• Even in IP only networks, IS-IS uses OSI addresses:
– Identify the router (IS)
– Build the topology table
– Build the SPF tree
– LSPs
– Hello and other PDUs
• NSAP addresses are required for CLNS routing.
Rick Graziani graziani@cabrillo.edu 27
NSAPs – Cisco Format

Area – System ID – NSEL


49.0001.2222.2222.2222.00
Area
• Addresses starting with 49 (AFI=49) are considered private IP address,
analogous to RFC 1918.
– Routed by IS-IS
– Should not be advertised to other CLNS networks (outside this IS-
IS domain)
• Additional 2 bytes (HODSP) added for the area ID
• All routers in the same are must have the same area address
Rick Graziani graziani@cabrillo.edu 28
NSAPs – Cisco Format

Area – System ID – NSEL


System ID 49.0001.2222.2222.2222.00
• OSI requires it must be the same number of bytes throughout the
domain.
• Cisco fixes the System ID at 6 bytes.
• Customary to use one of the following:
– MAC address from the router
– IP address of loopback interface
• 192.168.111.3 -> 192.168.111.003 -> 1921.6811.1003
• Each device (IS and ES) must have a unique System ID within the area.
(Recommended to make them unique within the domain.)
Rick Graziani graziani@cabrillo.edu 29
NSAPs – Cisco Format

Area – System ID – NSEL


49.0001.2222.2222.2222.00
NSEL (NSAP Selector)
• NSEL is a service identifier.
• Loosely equivalent to that of a port or socket in TCP/IP.
• Must be specified by a single byte preceded by a period (.)
• Not used in routing decisions.
NET
• When NSEL = 00, it identifies the device itself, the network level address.
• The NSAP with a NSEL = 00 is known as a Network Entity Title (NET)
• A NET is an NSAP with the NSEL set to (00)
Rick Graziani graziani@cabrillo.edu 30
NSAP (NETs)

Other Examples

Area – System ID – NSEL


49.0001.2222.2222.2222.00

Example 1: NSAP 47.0001.aaaa.bbbb.cccc.00


• Area ID is 47.0001
• System ID is aaaa.bbbb.cccc
• NSAP selector byte is 00
Example 2: NSAP 39.0f01.0002.0000.0c00.1111.00
• Area ID is 39.0f01.0002
• System ID is 0000.0c00.1111
• NSAP selector byte is 00
Rick Graziani graziani@cabrillo.edu 31
Configuring IS-IS
(so far)
SanJose1
Area
interface FastEthernet0/0 49.0001
ip address 172.16.0.1 255.255.255.0
ip router isis
isis priority 100
router isis
net 49.0001.1111.1111.1111.00

SanJose2
SanJose3
interface FastEthernet0/0
interface FastEthernet0/0
ip address 172.16.0.2 255.255.255.0
ip address 172.16.0.3 255.255.255.0
ip router isis
ip router isis
router isis
router isis
net 49.0001.2222.2222.2222.00
net 49.0001.3333.3333.3333.00
Area . System ID . NSEL

• ip router isis: IS-IS must be enabled on the interface


• IOS: Cisco IOS 12.2(12) with Enterprise Plus (16 MB Flash/48 MB RAM) or
Enter Plus IPSec56 (16 MB Flash/64 MB RAM)
• Note: IS-IS routing cannot be enabled on an interface until an IP address has
been configured on the interface.
Rick Graziani graziani@cabrillo.edu 32
SNPA (Subnetwork Point of Attachment)
and Circuits
IP address IP address
NSAP NSAP

MAC (SNPA) address SNPA address


• The router assigns a circuit ID of one octet to each interface on the router.
• In the case of point-to-point interfaces, this is the sole identifier for the circuit,
for example 03.
• In the case of LAN interfaces, the circuit ID is tagged to the end of the system
ID of the designated IS to form a 7-byte LAN ID.
– For example, 1921.6811.1001.03
• The SNPA is taken from the following:
– MAC address on a LAN interface
– Virtual Circuit ID for X.25 or ATM
– Data link connection identifier (DLCI) for Frame Relay
– High-Level Data Link Control (HDLC) for interfaces
Rick Graziani graziani@cabrillo.edu 33
Configuring IS-IS
(so far)
Area
49.0001

• To display both ES and IS neighbors.


• SNPA is the MAC address of the remote router.
– If serial, would show encapsulation, I.e. HDLC
• Cisco routers default to L1-L2 type routers.
• We will see how to change this in a moment.

Rick Graziani graziani@cabrillo.edu 34


IS-IS Adjacencies

Are we half way yet?


Network
Representation
Broadcast

Point-to-Point

• In OSI there are only two main types of physical links:


– Broadcast: Multiaccess media types, usually LANs
– Nonbroadcast: Point-to-Point, Multipoint, and dynamically
established links (WAN links)
• Thus, IS-IS supports only two media representations:
– Broadcast for LANs
– Point-to-Point for all other media
• IS-IS has no concept of an NBMA network.
– Recommended that point-to-point links be used for native ATM,
Frame Relay, or X.25
Rick Graziani graziani@cabrillo.edu 36
Hello Messages

• IS-IS uses Hello PDUs to establish adjacencies with other routers


(ISs) and ESs.
• IS-IS has three types of Hello PDUs:
– ESH, sent by ES to an IS
– ISH, sent by IS to an ES
– IIH, used between two ISs (CCNP 1)
• Hello Level 1 LAN
• Hello Level 2 LAN
• Hello Point-to-Point

Rick Graziani graziani@cabrillo.edu 37


Neighbors and
Adjacencies

• IS-IS discover neighbors and forms adjacencies using IS-IS Hello


PDUs.
• Transmitted every 10 seconds
• Can be changed using the interface command, is hello-interval
• Hold time defaults to 3 times the Hello time (30 seconds), before
declaring a neighbor dead.
– Changed using the interface command is hello-multiplier
– Default is 3

Rick Graziani graziani@cabrillo.edu 38


LAN Representation and Adjacencies

DIS

• Similar to the DR in OSPF…


• DIS (Designated IS) is elected to generate the LSP (Link State Packet,
ie. LSA) representing the virtual router connecting all attached routers
to a star-shaped topology
• For SPF, the whole network must look like a collection of nodes and
point-to-point links
– Multi-access networks are different
• LAN uses a virtual node called pseudonode.
Rick Graziani graziani@cabrillo.edu 39
LAN Representation and Adjacencies

DIS

• Election of DIS:
– Router with highest priority (Cisco default is 64)
– Router with highest MAC address
• No “BDR”
• No way to make a router ineligible from being DIS (no OSPF priority 0)
• New router (IS) can cause a new election, unlike OSPF
• Used as circuit ID for all routers on LAN.
• Periodically broadcasts CSNPs (OSPF DBD) every 10 seconds
• Each router on the LAN simulates an interface on the pseudonode.
Rick Graziani graziani@cabrillo.edu 40
Adjacencies

LAN
Adjacencies

• L1 routers form L1 adjacencies with L1 and L1-L2 routers in their area.


• L2 routers form L2 adjacencies with L2 and L1-L2 routers in their area
or another area.
• L1L2 routers form L1 and L2 adjacencies with each other in their area
or another area.
• L1 router does not form an adjacency with an L2 router
Rick Graziani graziani@cabrillo.edu 41
WAN
Adjacencies

• On point-to-point links the IIH PDUs are common to both


Level 1 and Level 2.
• Announce both their Level type and Area ID in the Hellos.
• Remember, separate LSDBs for different Levels.
• What are the adjacencies? L1? L2? L1L2? None?
Rick Graziani graziani@cabrillo.edu 42
WAN
Adjacencies

• What are the adjacencies? L1? L2? L1L2? None?

• The adjacencies also determine what type of routes the IS (router) will
have in its routing table.
– L1 – Intra-area routes (routes only within that area)
– L2 – Inter-area routes (routes from other areas)
– Or both
Rick Graziani graziani@cabrillo.edu 43
Adjacencies

• For an adjacency to be formed and maintained, routers must agree on:


– If they are both Level 1, them must be in the same area
– The System ID must be unique to each router.
– The Hello timers do not have to match.

Rick Graziani graziani@cabrillo.edu 44


Configuring IS-IS
(so far)
DIS
SanJose1
Area
interface FastEthernet0/0 49.0001
ip address 172.16.0.1 255.255.255.0
ip router isis
isis priority 100
router isis
net 49.0001.1111.1111.1111.00

SanJose2
SanJose3
interface FastEthernet0/0
interface FastEthernet0/0
ip address 172.16.0.2 255.255.255.0
ip address 172.16.0.3 255.255.255.0
ip router isis
ip router isis
router isis
router isis
net 49.0001.2222.2222.2222.00
net 49.0001.3333.3333.3333.00
Area . System ID . NSEL

• isis priority: Sets DIS priority on a LAN interface, default 64

Rick Graziani graziani@cabrillo.edu 45


IS-IS Link State Database
Synchronization
LSDB Synchronization and Update Process

LSP (LSA)
LSP (LSA) LSP (LSA)
X
PSNP (LSAck) PSNP (LSAck) PSNP
(LSAck)

• IS-IS LSDB is accomplished by using special PDUs, known as SNPs


(Sequence Number PDUs):
– CSNP (Complete Sequence Number PDU) – (OSPF: DBD)
• List of LSPs held by the router
– PSNP (Partial Sequence Number PDU) – (OSPF: LSAck/LSR)
• Acknowledge the receipt of a LSP
• Request a complete LSP for a missing entry
Rick Graziani graziani@cabrillo.edu 47
Update Process

• Point-to-Point networks:
– Once an LSP is sent, router sets a timer
(minimumLSPTransmissionInterval) of 5 seconds
– If PSNP not received, resends LSP.

Rick Graziani graziani@cabrillo.edu 48


Update
Process LSP 77
(LSA)
CSNP
PSNP (OSPF
(DBD)
LSR) goes to
DIS. PSNP
(LSR)
III. LSP 77 is
sent by DIS to PSNP
R1 (LSAck)

• On Broadcast networks:
– LSPs are not acknowledged by each receiving router.
– DIS periodically multicasts a CSNP (OSPF DBD) that describes
every LSP in LSDB.
• Default is every10 seconds
– L1 CSNPs are multicast to AllL1ISs
– L2 CSNPs are multicast to AllL2ISs
Rick Graziani graziani@cabrillo.edu 49
Decision Process

• Once the update process has built the LSDB, the Decision Process
uses the LSDB to calculate the SPF.
• Separate SPF for L1 routes and L2 routes.
• Four types of metrics:
1. Default – Cisco only supports this metric.
2. Delay
3. Expense
4. Error
• Each metric expressed as an integer between 0 and 63.
• Separate route is calculated for each metric.
• SPF must be run for each metric, for both L1 and L2 routes.
• Because of these and other reasons, Cisco only supports the Default.
Rick Graziani graziani@cabrillo.edu 50
Metric
• Cisco assigns a default metric of 10 to every interface regardless of
interface type.
• Left to the default, IS-IS metric becomes a simple measure of hop
count.
• Interface command isis metric changes the default value.
• The total cost of any route is a sum of the individual metrics of the
outgoing interfaces.
• This is known as the narrow metric, which uses 6 bits for the interface
metric and 10 bits for the total path metric.
• The maximum interface metric value is 63.
• The maximum total path metric value is 1023.
• Extended Metric
– Cisco IOS software addresses this issue with the support of a 24-
bit metric field for the interface and a 32 bit metric for the total path,
called the wide metric.
– Using the new metric style, link metrics now have a maximum value
of 16777215 (224 - 1) with a total path metric of 4261412864 (232 -
225).
Rick Graziani graziani@cabrillo.edu 51
Metrics
Odds and Ends
• Cisco’s IS-IS implementation will perform equal cost load balancing up
to six paths.
• Supports VLSM
• L1 routers calculate path to the nearest L2 router for inter-area
routing (OSPF: Totally Stubby Area)
– When an L2 or L1L2 router is attached to another area, the router
will advertise this fact
– The Decision Process in L1 routers will choose the metrically
closest L1L2 router as the default router.
– An L1 0.0.0.0/0 route will be entered into the routing table.
• IS-IS command - summary-address network mask is used to
configured summarization (Level 1, Level 2 or both).
– See summary-address command for more details.
• Level 2 routers are expected to know about all routes.
– ISIS command: default-information originate is used to
advertise a default route into the backbone path.
Rick Graziani graziani@cabrillo.edu 52
Odds and Ends

• L1L2 routers run two IS-IS processes, one for its L1 LSDB and another
for its L2 LSDB.
• Once an packet is accepted by a router the System ID and NSEL are
stripped.

Rick Graziani graziani@cabrillo.edu 53


Multi-Area IS-IS Example
Note: ip router isis command must be added not only to transit interfaces but
Levels
also to interfaces connected to stub networks whose IP addresses should be
advertised by IS-IS.
L1L2
SanJose1
interface Loopback0
ip address 192.168.10.1 255.255.255.252
ip router isis
interface FastEthernet0/0
ip address 172.16.0.1 255.255.255.0
ip router isis
interface Serial0/0 L1 L2
ip address 10.0.0.2 255.255.255.252
ip router isis
router isis
net 49.0001.1111.1111.1111.00 Phoenix
is-type level-1-2 interface Serial0/0
ip address 10.0.0.1 255.255.255.252
SanJose2 ip router isis
interface FastEthernet0/0 interface FastEthernet0/1
ip address 172.16.0.2 255.255.255.0 ip address 192.168.30.1 255.255.255.0
ip router isis ip router isis
interface FastEthernet0/1 router isis
ip address 192.168.20.1 255.255.255.0 net 49.0002.3333.3333.3333.00
ip router isis is-type level-2-only
router isis
net 49.0001.2222.2222.2222.00
is-type level-1 • is-type {level-1 | level-1-2
Rick Graziani graziani@cabrillo.edu | level-2-only} 55
show clns neigh
L1L2
• System ID – Cisco IOS uses
the hostname.
• SNPA is the MAC of the
remote router or HDLC on the
serial link.
L1 L2
• The Type is the is-type of the
remote router.
SanJose1#show clns neighbors
System Id Interface SNPA State Holdtime Type Protocol
SanJose2 Fa0/0 0003.6be9.d480 Up 26 L1 IS-IS
Phoenix Se0/0 *HDLC* Up 28 L2 IS-IS

SanJose2#show clns neighbors


System Id Interface SNPA State Holdtime Type Protocol
SanJose1 Fa0/0 0002.b9ee.5ee0 Up 4 L1 IS-IS

Phoenix#show clns neighbors


System Id Interface SNPA State Holdtime Type Protocol
SanJose1 Se0/0 *HDLC* Up 27 L2 IS-IS
Rick Graziani graziani@cabrillo.edu 56
show isis data
L1L2
• SanJose1 has a L1 LSDB and
a L2 LSDB.
• Email me if you want the
detail of this output or I can
add it to the presentation.
L1 L2
• Use detail option for
complete LSDB.
SanJose1#show isis database

IS-IS Level-1 Link State Database:


LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
SanJose1.00-00 * 0x00000005 0xDE15 916 1/0/0
SanJose1.01-00 * 0x00000003 0xBBFE 1165 0/0/0
SanJose2.00-00 0x00000006 0xBDFB 470 0/0/0
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
SanJose1.00-00 * 0x0000001B 0xAB48 914 0/0/0
SanJose1.01-00 * 0x0000001B 0x5526 480 0/0/0
Phoenix.00-00 0x0000001E 0xA3D3 912 0/0/0
Phoenix.01-00 0x00000002 0x54A6 826 0/0/0
Rick Graziani graziani@cabrillo.edu 57
show isis data
L1L2
• SanJose2 only has a L1
LSDB.
• Phoenix only has a L2 LSDB.

L1 L2
SanJose2#show isis database

IS-IS Level-1 Link State Database:


LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
SanJose1.00-00 0x00000005 0xDE15 907 1/0/0
SanJose1.01-00 0x00000003 0xBBFE 1155 0/0/0
SanJose2.00-00 * 0x00000006 0xBDFB 464 0/0/0

Phoenix#show isis database


IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
SanJose1.00-00 0x0000001B 0xAB48 893 0/0/0
SanJose1.01-00 0x0000001B 0x5526 459 0/0/0
SanJose2.00-00 0x00000024 0x2FD3 0 (932) 0/0/0
Phoenix.00-00 * 0x0000001E 0xA3D3 895 0/0/0
Phoenix.01-00 * 0x00000002 0x54A6 808 0/0/0
Rick Graziani graziani@cabrillo.edu 58
show ip route
L1L2
• Because SanJose1 is an
L1L2 router, it contains both:
 L1 routes for Area 49.0001
and
 L2 routes for the other L1 L2
area 49.0002.

SanJose1#show ip route
Gateway of last resort is not set

i L2 192.168.30.0/24 [115/20] via 10.0.0.1, Serial0/0


C 192.168.10.0/24 is directly connected, FastEthernet0/1
172.16.0.0/24 is subnetted, 1 subnets
C 172.16.0.0 is directly connected, FastEthernet0/0
i L1 192.168.20.0/24 [115/20] via 172.16.0.2, FastEthernet0/0
10.0.0.0/30 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, Serial0/0

Rick Graziani graziani@cabrillo.edu 59


show ip route
L1L2
• Because SanJose2 is only an
L1 router, it only contains:
 L1 routes for Area 49.0001
and
 The 0.0.0.0/0 default route L1 L2
sent by SanJose1.

SanJose2#show ip route

Gateway of last resort is 172.16.0.1 to network 0.0.0.0

i L1 192.168.10.0/24 [115/20] via 172.16.0.1, FastEthernet0/0


172.16.0.0/24 is subnetted, 1 subnets
C 172.16.0.0 is directly connected, FastEthernet0/0
C 192.168.20.0/24 is directly connected, FastEthernet0/1
10.0.0.0/30 is subnetted, 1 subnets
i L1 10.0.0.0 [115/20] via 172.16.0.1, FastEthernet0/0
i*L1 0.0.0.0/0 [115/10] via 172.16.0.1, FastEthernet0/0
Rick Graziani graziani@cabrillo.edu 60
show ip route
L1L2
• Because Phoenix is an L2
router, it contains:
 L2 routes which are L1
routes from Area 49.0001.
 No L1 routes from Area L1 L2
49.0002.

Phoenix#show ip route

Gateway of last resort is not set

C 192.168.30.0/24 is directly connected, FastEthernet0/1


i L2 192.168.10.0/24 [115/20] via 10.0.0.2, Serial0/0
172.16.0.0/24 is subnetted, 1 subnets
i L2 172.16.0.0 [115/20] via 10.0.0.2, Serial0/0
i L2 192.168.20.0/24 [115/30] via 10.0.0.2, Serial0/0
10.0.0.0/30 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, Serial0/0
Rick Graziani graziani@cabrillo.edu 61
Last Couple of things…

Sub-optimal Routing
Sub-optimal Routing

• Sub-optimal routing is not necessarily a disadvantage.


Rick Graziani graziani@cabrillo.edu 63
The IS-IS Routing Process,
Summarization and Additional
Notes

Additional information helpful to understand and some


of those little items they like to ask us about on
certification exams.
Terminology

• CLV (Code/Length/Value) and TLV (Type/Length/Value)


– Same thing, CLV is more of the OSI term.
– There are variable length fields in a PDU.
• Code or Type specifies the type of information.
• Length specifies the size of the Value field.
• Value is the information itself.
– Example CLV or TLV 128 defines the capability to carry IP
routes in IS-IS packets, in essence TLV 128 is Integrated
IS-IS.

Rick Graziani graziani@cabrillo.edu 65


IS-IS Routing Process

• IS-IS Routing Process is divided into four stages:


– Update
– Decision
– Forwarding
– Receive

Rick Graziani graziani@cabrillo.edu 66


IS-IS Routing Process: Update

The Update Process


• Routers can only forward data packets if they have an understanding
of the network topology.

• LSPs are generated and flooded throughout the network whenever:


– An adjacency comes up or down (example: a new router comes
online).
– An interface on a router changes state or is assigned a new metric.
– An IP route changes (example: because of redistribution)

Rick Graziani graziani@cabrillo.edu 67


IS-IS Routing Process: Update

Sending and Receiving an LSP

• Receiving an LSP
– If the LSP is already present in the database (LSDB), the router
(IS) acknowledges (PSNP) and ignores it.
• The router sends the duplicated LSP it its neighbors.
• Level 1 LSPs are flooded throughout the area
• Level 2 LSPs are sent across all L2 adjacencies.

Rick Graziani graziani@cabrillo.edu 68


IS-IS Routing Process: Update
Sending and Receiving an LSP:

• Propagating (sending) LSPs on a Point-to-Point Interface


– When an adjacency is established both routers send a CSNP
(OSPF DBD) summary of their LSDB.
– If the receiving router has any LSPs that were not present in the
CSNP it received, it sends a copy of the missing LSP to the other
router.

CSNP CSNP
You are
missing LSP 3
LSP 3 PSNP (Ack)

Rick Graziani graziani@cabrillo.edu 69


IS-IS Routing Process: Update

Sending and Receiving an LSP:


• Propagating (sending) LSPs on a Point-to-Point Interface
– Likewise, if the receiving router is missing any LSPs received in the
CSNP, the receiving router sends a PSNP (OSPF LSR) requesting
the full LSP to be sent.
– LSPs are acknowledges with a PSNP (OSPF LSAck)
– When the LSP is sent, the router sets a timer.
• If the acknolwedgement (PSNP) is not received within 5
seconds (Cisco default), the LSP is resent.
CSNP CSNP

PSNP 3
LSP 3
I am
PSNP (Ack) missing
LSP 3

Rick Graziani graziani@cabrillo.edu 70


IS-IS Routing Process: Update

Sending and Receiving an LSP:


• Propagating (sending) LSPs on a Broadcast Interface
– The DIS (OSPF DR) takes on much of the responsibility for
synchronizing the databases on behalf of the pseudonode.
– DIS has three tasks:
• Creating and maintaining adjacencies
• Creating and updating the pseudonode LSP
• Flooding the LSPs over the LAN.

Rick Graziani graziani@cabrillo.edu 71


IS-IS Routing Process: Update

Sending and Receiving an LSP:


• Propagating (sending) LSPs on a Broadcast Interface
– On receiving a CSNP the router compares it with its LSDB…
– If the receiving router has a newer version of the LSP then what
was sent in the CSNP, or if the CSNP did not contain one of its
LSPs, the router multicasts the LSP to all routers on the LAN.

CSNP
(DBD)
I have a LSP 88
newer version
of LSP 88

Receipt of LSP 88 is acknowledged by


all routers with a PSNP.
Rick Graziani graziani@cabrillo.edu 72
IS-IS Routing Process: Update
Sending and Receiving an LSP:
• Propagating (sending) LSPs on a Broadcast Interface
– On receiving a CSNP the router compares it with its LSDB…
– If the database is missing an LSP that was in the CSNP, it sends a
PSNP requesting the full LSP.
– The DIS sends the LSP.

LSP 77
(LSA)
CSNP
(DBD)
PSNP
(LSR)
PSNP
(LSAck)

Rick Graziani graziani@cabrillo.edu 73


IS-IS Routing Process: Update
• Determining if an LSP is valid:
– Receiving router uses three fields to help determine if the received LSP is
more recent than the one in its LSDB.
– Remaining Lifetime
• Used to age-out or delete LSPs
• Lifetime is set to 0 and flooded
• Receiving routers recognize this means the route is bad and deletes
the LSP from their LSDB, rerunning SPF algorithm, new SPT, new
routing table.
• Note: LSPs have a maximum age of 20 minutes in an IS-IS LSDB,
and are re-flooded (refreshed) every 15 minutes.
– Sequence Number
• First LSP starts with a sequence number of 1, with following LSPs
incremented by 1.
– Checksum
• If received LSP’s checksum does not computer correctly, the LSP is
flushed and the lifetime set to 0.
• The receiving router floods the LSP with the lifetime set to 0.
• When the originating router gets this LSP (lifetime = 0) it retransmits a
new LSP.
Rick Graziani graziani@cabrillo.edu 74
IS-IS Routing Process: Decision

• IS-IS Routing Process is divided into four stages:


– Update
– Decision
– Forwarding
– Receive

Rick Graziani graziani@cabrillo.edu 75


IS-IS Routing Process: Decision

• The Decision Process


– Uses Dijkstra’s algorithm to build a SPT (Shortest Path Tree)
– The SPT is used to create the forwarding table, also known as the
routing table.
– Several tables are used during this process:
• PATH table
– PATH table is the SPT during the construction of the LSDB
– Each candidate route is placed in the PATH table while the
metric is examined to determine if it is the shortest path to
the destination.
• TENT is the tentative database (a scratchpad) during this
process

Rick Graziani graziani@cabrillo.edu 76


IS-IS Routing Process: Decision

Determining the best route


• Criteria by which the lowest cost paths are selected and placed in the
forwarding database are:
– Cisco allows up to six equal-cost paths, four by default.
– Cisco only supports the default metric
– Internal paths are chosen before external paths outside the routing
domain, to prevent sub-optimal routes and routing loops.
– Level 1 paths within the area are “more attractive” than Level 2
paths outside the area, to prevent sub-optimal routes and routing
loops.
– Longest match or most specific address in IP ensures that the
closest router is chosen.
– ToS (Type of Service) in IP header is used, if configured.
– If there is no path, the forwarding database sends the packet to the
nearest Level 2 router, which is the default router.

Rick Graziani graziani@cabrillo.edu 77


IS-IS Routing Process: Forwarding

• IS-IS Routing Process is divided into four stages:


– Update
– Decision
– Forwarding
– Receive

Rick Graziani graziani@cabrillo.edu 78


IS-IS Routing Process:
Forwarding and Receiving
• Forwarding process
– After the SPT has been built the forwarding database can be
created.
– The forwarding table is the lookup table for the longest match.
– The forwarding table for IS-IS is more relevant to CLNS than to IP,
because the IP routing information is entered directly into the IP
routing table.

• Receive process
– If the frame is valid, the receive process passes user data and error
reports to the forwarding process.
– Whereas routing information: Hellos, LSPs, and SNPs are sent to
the update process.
– Receive process is primarily concerned with CLNS routing and not
IP.
Rick Graziani graziani@cabrillo.edu 79
Route Summarization
• Rules for IS-IS route summarization similar to that of OSPF
• Level 1-2 routers (L1L2)
– Similar to OSPF ABR
– Configured at the L1L2 router at the edge of an area.
– L1L2 routers can summarize the routes within their area to L1L2 or
L2 routers in another area.
– This is an efficient method of establishing prefix (network
addresses) routing into other areas.
• If one edge L1L2 router in an area is summarizing routes for that area,
other edge L1L2 routers in that area must also be summarizing routes.
– If other L1L2 routers are summarizing and one edge L1L2 router is
not summarizing, all traffic destined for that area will be sent to the
non-summarizing router because of longest match routing.
• Level 1 routes cannot be summarized within the area because it is not
permitted by IS-IS (Level 1 routers cannot summary routes).
• Level 2 routers can summarize at the area boundary.

Rick Graziani graziani@cabrillo.edu 80


IS-IS
Intermediate System-to-Intermediate System

Rick Graziani
Cabrillo College
graziani@cabrillo.edu
Feb. 2004