Está en la página 1de 11

PROGRAMACIÓN BÁSICA

______________________________________________________________________

PROGRAMACION BASICA
Docente: Ing. Wilson Polo
Asignatura: Televisión
Carrera: Producción
Nivel: Primero
Prerequisito: ninguno
Carga Horaria Semanal : 2Hs. 2 Créditos semanales
Fecha: 14 - 12 - 2008

OBJETIVOS
● Analiza e interpreta los problemas planteados
● Diseña e implementa manuales de resolución de algoritmos y sus
aplicaciones
● Usa elementos básicos y desarrolla estrategias de resolución

TEXTOS, REVISTAS, ENLACES DE REFERENCIA:


● Programación en C++.-Deitel/Deitel
● Pseudocódigos-Códigos.-Evelio Granizo Montalvo

RECURSOS DIDÁCTICOS:

● Aula
● Pizarrón de Tiza Líquida
● Audiovisual
● Laboratorio de Pcs

MODELO DE ENSEÑANZA PARA ESTOS CAPÍTULOS (Conductista)


Se enseñará utilizando infocus, luego se estímulará al estudiante para que ponga
atención entregándole una nota por su actuación y finalmente antes de iniciar una
nueva clase, se recordará la anterior.

EVALUACIÓN: Se evaluará de acuerdo al reglamento de la universidad. Además


se estimulará al estudiante por su participación en clase

CAPÍTULO 1

1. ALGORITMOS Y LOGICA DE PROGRAMACIÓN


1. SOFTWARE

CAPÍTULO 2

2. FUNDAMENTOS DE LA PROGRAMACIÓN
2.1. INTRODUCCIÓN
2.2. PROGRAMA
2.3. PSEUDOCÓDIGO
2.4. ESTRUCTURAS BÁSICAS DE CONTROL
2.4.1. Estructura secuencial
2.4.2. Estructuras condicionales
2.4.3. Estructuras repetitivas

Ing. Wilson Polo. Página 1 14/12/08


PROGRAMACIÓN BÁSICA
______________________________________________________________________

CAPITULO 1

1. ALGORITMOS Y LOGICA DE PROGRAMACIÓN

1.1. SOFTWARE

El software es un conjunto de programas que residen en la computadora y que permiten


trabajar con ella escribiendo documentos, realizando cálculos, creando diagramas, etc.
El software puede dividirse en dos grandes grupos:

 Sistema operativo
 Aplicaciones

 Sistema operativo.- Es el núcleo del software de la computadora. Es


indispensable para que se pueda manejar la computadora para realizar cualquier
tarea.
o Permite que el usuario realice operaciones básicas con la computadora
sin necesidad de programar.
o Permite que los programas que se ejecuten accedan a los recursos del
sistema, como la pantalla, los discos, la impresora, etc.

APLICACIONES

SISTEMA OPERATIVO

HARDWARE

 Aplicaciones.- Son programas que permiten realizar actividades concretas como


edición de documentos, cálculos, diseño, etc.

Ing. Wilson Polo. Página 2 14/12/08


PROGRAMACIÓN BÁSICA
______________________________________________________________________

CAPITULO 2

2. FUNDAMENTOS DE LA PROGRAMACIÓN

2.1. INTRODUCCIÓN

Cuando se habla de “Programación Informática”, se hace referencia al proceso


de planificar y desarrollar la resolución de un problema mediante una computadora. En
su sentido más simple, se trata de diseñar y codificar un programa que, al ejecutarse en
una computadora, resuelva un problema.

Programa

Problema Resultados

Datos de entrada

Figura 2.1. Resolución de un problema por computadora.

Programa

Obtener los Primos:


números primos 1,7,11,13,17

1,2,3,4,5,6,7,8,9,1
0,11,12,13,14,15,1
6,17, etc

Figura 2.2. Ejemplo de resultado de un problema.

Ing. Wilson Polo. Página 3 14/12/08


PROGRAMACIÓN BÁSICA
______________________________________________________________________
2.2. PROGRAMA

La resolución de un problema por computadora se reduce pues a construir un programa


que resuelva el problema planteado.

Un programa es una secuencia de instrucciones codificadas, que al ejecutarse en una


computadora realiza una serie de operaciones preestablecidas para resolver un
problema.

2.3. PSEUDOCÓDIGO

Es una mezcla de castellano y expresiones matemáticas que permiten describir de un


modo preciso un programa.

Reglas generales del pseudocódigo

1. Todo programa escrito en pseudocódigo comienza con la palabra “Inicio” y


termina con la palabra “Fin”.
2. Cada instrucción se debe escribir en una línea. Y deberá terminar con un punto
y coma.
3. Para su descripción se utilizan una serie de palabras reservadas y funciones,
tales como:
 Inicio/Fin
 Si/Entonces/Fin_Si (if)
 Si/Entonces/Si no/Fin_Si (if/else)
 Según/Fin_Según (switch)
 Mientras/Fin_Mientras (while)
 Repetir/Hasta/Fin_Repetir (do/while)
 Para/desde/hasta/incremento/Fin_Para (for)
 Leer (cin)
 Mostrar (cout)
4. Las palabras reservadas nunca terminarán con punto y coma.
5. Debe escribirse indentado (tabulando) para mostrar claramente las dependencias
de unas instrucciones del programa con respecto a otras.
6. Cada una de las estructuras que se encuentran en el programa tendrán una
palabra reservada para comenzar y una palabra reservada para terminar.
7. Los nombres para los datos o variables que elija el programador tratarán de
describir la acción que van a ejecutar. Además:
 Se escribirá preferentemente con minúsculas la primera letra y con
mayúsculas el comienzo de cada palabra. Por ejemplo nombreDeVariable .
 Los nombres de las variables no podrán comenzar con un número, ni con un
símbolo ( a excepción del guión bajo, por ejemplo _nombreDeVariable ).
 Las variables no podrán tener espacios en blanco.
11. Los mensajes deberán escribirse entre comillas dobles.

Ing. Wilson Polo. Página 4 14/12/08


PROGRAMACIÓN BÁSICA
______________________________________________________________________

2.4. ESTRUCTURAS BÁSICAS DE CONTROL

Existen tres estructuras básicas de control como son, la secuencial, condicional


y repetitiva.

2.4.1. Estructura secuencial

Es una secuencia de instrucciones que se tienen que ejecutar en orden y


secuencialmente para realizar una operación.

*************************************************
Por ejemplo, calcular la suma y el producto de dos números:
*************************************************
Lo primero que se debe hacer es leer dos números que serán ingresados a través
del teclado y que serán guardados en las variables que las llamaremos primerNumero y
segundoNumero. Después, los sumaremos, luego los multiplicaremos y, por último,
mostraremos los resultados en la pantalla de la computadora.

1. // Programa que suma y multiplica dos números


2. Inicio
3. Mostrar “Ingrese el primer número : ”;
4. Leer primerNumero;
5. Mostrar “Ingrese el segundo número : ”;
6. Leer segundoNumero;
7. suma = primerNumero + segundoNumero;
8. producto = primerNumero * segundoNumero;
9. Mostrar suma;
10. Mostrar producto;
11. Fin

La línea 1 es un comentario llamado de fin de línea cuyo contenido comienza


después del operador “ // ” y termina al final de la línea. Este comentario es ignorado
por el compilador.
En las líneas 2 y 11 se muestran el comienzo y el fin de la estructura secuencial.
En las líneas 3 y 5 se usa la palabra reservada “Mostrar” que es una función que
permite sacar en pantalla mensajes y resultados.

Ing. Wilson Polo. Página 5 14/12/08


PROGRAMACIÓN BÁSICA
______________________________________________________________________
En las líneas 4 y 6 se usa la palabra reservada “ Leer” que es una función que permite
el ingreso de datos al computador a través del teclado; estos datos son almacenados en
las variables primerNumero y segundoNumero.
En las líneas 7 y 8 se realizan las operaciones de suma y multiplicación
respectivamente. Los resultados son guardados en las variables suma y producto.
En las líneas 9 y 10 se usa la palabra reservada “Mostrar” que es una función que
permite sacar en pantalla los resultados de una operación.

2.4.2. Estructuras condicionales

Cuando se está construyendo un programa, es normal tener que seleccionar un


conjunto de instrucciones entre varias posibles, dependiendo de que se cumpla o no una
determinada condición. Esto constituye lo que se denomina estructura condicional, que
se divide en:
 Estructura condicional simple.
 Estructura condicional doble.
 Estructura condicional múltiple.

Estructura condicional simple.- En este tipo, si la condición se cumple, se ejecutan


una serie de acciones, pero si no se cumplen no se realiza ninguna acción.


Si Condición Entonces
Acción 1;
Acción 2;
………..;
Acción n;
Fin_Si

***************************************************************
Por ejemplo: Si un número ingresado por el teclado es mayor que 5, entonces
mostrarlo en la pantalla, caso contrario terminar.
***************************************************************
1. Inicio
2. Mostrar “Ingrese un número : ”;
3. Leer numero;
4. Si numero > 5 Entonces
5. Mostrar numero;
6. Mostrar “Ingrese un número : ”;
7. Leer numero;
8. Fin_Si
9. Fin

En las líneas 1 a la 9 se muestra el comienzo y el fin de una estructura secuencial.

Ing. Wilson Polo. Página 6 14/12/08


PROGRAMACIÓN BÁSICA
______________________________________________________________________
En la línea 2, se usa la función Mostrar que permite sacar en pantalla mensajes o
resultados.
En la línea 3, usando la función Leer se ingresa a través del teclado un número que es
almacenado por el computador en la variable llamada “numero”.
Desde la línea 4 hasta la 8 se realiza la estructura condicional simple. Si la condición es
cierta o se cumple, se ejecutan las acciones dentro de la estructura condicional (línea 5,
6 y 7); caso contrario (si la condición no se cumple) no se ejecutan las acciones y el
programa continuará con la siguiente instrucción (línea 9).

Estructura condicional doble.- En este tipo se ejecutará un bloque de instrucciones u


otro, dependiendo de que la condición sea cierta o falsa. El pseudocódigo de esta
variante es:


Si Condición Entonces
Acción 1;
Acción 2;
………..;
Acción n;
Si no
Acción 11;
Acción 22;
………..;
Acción nn;
Fin_Si

******************************************************
Ejemplo: Seleccionar y visualizar el mayor de dos números leídos.
******************************************************

1. Inicio
2. Leer primerNumero;
3. Leer segundoNumero;
4. Si primerNumero > segundoNumero Entonces
5. Mostrar “El mayor es ” primerNumero;
6. Si no
7. Mostrar “El mayor es ” segundoNumero;
8. Fin_Si
9. Fin

Desde la línea 1 hasta la 10 se realiza una estructura secuencial.


En la línea 2 y 3 se leen los números desde el teclado, y estos números son almacenados
en las variables primerNumero y segundoNumero.

Ing. Wilson Polo. Página 7 14/12/08


PROGRAMACIÓN BÁSICA
______________________________________________________________________
Desde la línea 4 hasta la 9, se ejecuta la estructura condicional doble. Si la
condición se cumple entonces se ejecuta la línea 6, luego pasa a la 9 y finalmente a la
10. En caso de ser falsa la condición, se ejecuta la línea 8, luego pasa a la 9 y finalmente
la 10.
En las líneas 6 y 8, la función Mostrar imprime en pantalla “El mayor es”, y el número.
El texto indicado por la función Mostrar se debe escribir entre comillas dobles.

Estructura condicional múltiple.- En este caso, dependiendo del valor que tome la
variable numérica que controla la condición , se ejecutará una de las n acciones
definidas en la estructura.
El pseudocódigo de esta variante es el siguiente:

….
Según Condición
=1 Acción_1;
=2 Acción_2;

=n Acción_n;
Fin_Según

**********************************************************************
Por ejemplo: Leer desde el teclado un valor numérico, denominado numCarta, asociado
a una carta de una baraja (del 1 al 12), y mostrar en pantalla el nombre de la carta
asociado a ese número.
**********************************************************************

1. Inicio
2. Leer numCarta;
3. Según numCarta
4. =1 Mostrar “As” ;
5. =2 Mostrar “Dos” ;
6. ………………
7. =12 Mostrar “Rey” ;
8. Fin_Según
9. Fin

Desde las líneas 3 a la 8 se desarrolla la estructura condicional múltiple.


Si en la línea 3, numCarta es igual a 1, entonces pasa a imprimir As, luego va a la línea
8 y finalmente a la 9.
Si en la línea 3, numCarta es igual a 2, entonces pasa a imprimir Dos, luego va a la línea
8 y finalmente a la 9.
Si en la línea 3, numCarta es igual a 12, entonces pasa a imprimir Rey, luego va a la
línea 8 y finalmente a la 9.

Ing. Wilson Polo. Página 8 14/12/08


PROGRAMACIÓN BÁSICA
______________________________________________________________________

2.4.3. Estructuras repetitivas

En un programa es normal tener que ejecutar repetidamente un conjunto de


instrucciones, dependiendo de que sea cierta o no una condición. Existen tres versiones:

 Estructura repetitiva tipo Mientras


 Estructura repetitiva tipo Hasta
 Estructura repetitiva tipo Para

Estructura repetitiva tipo Mientras.- En este tipo, el bloque de instrucciones se


repetirán mientras que la condición sea cierta. La condición se evalúa al comienzo de la
estructura. Esto implica que el bloque de instrucciones no se ejecutarán si la condición
es falsa.

El pseudocódigo de esta estructura es de la forma:

Inicio
….
Mientras Condición
Instrucción_1;
Instrucción_2;
…………
Instrucción_n;
Fin_Mientras
………..
Fin

*******************************************************************
Ejemplo: Leer un número desde el teclado, si el número es igual a -1 terminar, caso
contrario mostrar en pantalla el número ingresado.
********************************************************************

1. Inicio
2. ………..
3. Leer numIngresado;
4. Mientras numIngresado < > -1
5. Mostrar numIngresado;
6. Fin_Mientras
7. ………..
8. Fin

Ing. Wilson Polo. Página 9 14/12/08


PROGRAMACIÓN BÁSICA
______________________________________________________________________

En la línea 4 el símbolo < > significa diferente. En esta línea, si la condición es cierta se
ejecuta la línea 5, luego la 6, luego la 4 nuevamente y así hasta que la condición sea
falsa. Cuando esto sucede, ya no ingresa a la línea 5, sino que pasa a la línea 7 y
finalmente a la 8.

Estructura repetitiva tipo Hasta.- En este tipo el bloque de acciones se repetirá


mientras la condición sea cierta. Dicha condición se evalúa al final de la estructura. Esto
implica que el bloque de instrucciones se ejecutará al menos una vez.
La diferencia fundamental entre ambas estructuras repetitivas es que, en el
primer tipo, las acciones del bucle no se realizan nunca si la condición es falsa. Por el
contrario, las acciones del bucle en el segundo tipo, se realizarán al menos una vez, ya
que la condición se evalúa después de haber sido realizadas dichas acciones.
El pseudocódigo de esta estructura es:

…….
Repetir
Acción_1;
Acción_2;
…………
Acción_n;
Hasta Condición Fin_Repetir
……

**********************************************
Ejemplo: Visualizar la tabla de multiplicar del número 4
**********************************************

1. Inicio
2. Contador = 0;
3. Repetir
4. Contador = contador + 1;
5. tablaMultiplicar = contador * 4;
6. Mostrar “La tabla del 4 es : ” tablaMultiplicar;
7. Hasta contador <= 10 Fin_Repetir
8. Fin

En la línea 2, se inicializa la variable llamada contador en cero.


Desde la línea 3 hasta la 7, se desarrolla la estructura de repetición. Si la condición que
se evalúa al final del ciclo es cierta, otra vez se dirige a la línea 3 y continúa. Si la
condición es falsa, pasa a la línea 8.
En la línea 4, el contador se incrementa en 1 en cada pasada.

Ing. Wilson Polo. Página 10 14/12/08


PROGRAMACIÓN BÁSICA
______________________________________________________________________
Estructura repetitiva tipo Para.- El número de repeticiones del bucle es fijo o se
conoce de antemano, se debe utilizar una estructura tipo Para, en lugar de las anteriores.
La estructura Para indica que las acciones del bucle se realizarán un número
específico de veces y que la estructura controla automáticamente el número de
repeticiones. Para dicho control hay que definir dentro de la estructura una variable de
control, su valor inicial, su valor final y un incremento fijo.

El pseudocódigo de este tipo de estructura es el siguiente:

…..
Para variableControl desde V1 hasta V2, incremento V3
Acción_1;
Acción_2;
………
Acción_n;
Fin_Para

**********************************************************************
Ejemplo: Calcule la suma de los números comprendidos entre 1 y 100, ambos inclusive.
**********************************************************************

1. Inicio
2. Suma = 0;
3. Para numero desde 1 hasta 100, incremento =1
4. Suma = suma + numero;
5. Fin_Para
6. Mostrar suma;
7. Fin

Ing. Wilson Polo. Página 11 14/12/08