Está en la página 1de 5
FÓRMULAS Y FUNCIONES (III) Fórmulas de Lógicas Estas fórmulas manejan parámetros lógicos para generar los

FÓRMULAS Y FUNCIONES (III)

Fórmulas de Lógicas

Estas fórmulas manejan parámetros lógicos para generar los resultados, es decir proporciones verdaderas y falsas.

Las fórmulas más utilizadas son: =SI(), =O(), =Y().

FÓRMULA CONDICIONAL “=SI()”

Esta es una de las fórmulas más potentes de Excel. La sintaxis de esta función es:

=SI(condición lógica; respuesta verdadera; respuesta falso)

Es una función con tres argumentos separados por un punto y coma (;). El primero de los argumentos es una condición. Para crear condiciones se utilizan los símbolos relacionales de igualdad y comparación: =, <, >, <=, >=, <> (distinto de).

Si la condición se cumple, es decir, si es verdadera la condición, se ejecuta la expresión que tengamos en respuesta verdad y la respuesta falso en el caso en el que la condición sea falsa o no se cumpla.

Si es una función en la que queremos comparar o escribir texto, debe estar escrito entre “comillas”. Para escribir un espacio en blanco deben colocar lo siguiente “”.

Para comprender mejor su funcionamiento, veamos el siguiente ejemplo:

Necesitamos saber si la venta de un producto es buena o mala, para ello, determinamos que los productos con buenas ventas, son aquellos iguales o mayores que 40 unidades diarias; los productos con ventas inferiores a 40 unidades diarias se consideran malas.

40 unidades diarias; los productos con ventas inferiores a 40 unidades diarias se consideran malas. Profesor

Profesor Cruz Mariano

FÓRMULA CONDICIONAL “=Y()” La sintaxis de esta función es: =Y(Condición 1; Condición 2; …) Esta

FÓRMULA CONDICIONAL “=Y()”

La sintaxis de esta función es: =Y(Condición 1; Condición 2; …)

Esta función consta de dos o más argumentos, evalúa si los valores que se ingresaron son verdaderos o falsos, el resultado será verdadero si todos los argumentos son verdaderos o falso en caso de que alguno sea falso.

Está función es muy utilizada para determinar rangos de datos.

El siguiente ejemplo ilustrará mejor está función:

Necesitamos saber si un número está o no dentro de un rango entre 1 y 100, el resultado será VERDADERO si el número es mayor que 1 y menor que 100; el resultado es FALSO si el número está por fuera del rango.

resultado es FALSO si el número está por fuera del rango. FÓRMULA CONDICIONAL “=O()” La sintaxis

FÓRMULA CONDICIONAL “=O()”

La sintaxis de esta función es: =O(Condición 1; Condición 2; …)

Esta función consta de dos o más argumentos, evalúa si los valores que se ingresaron son verdaderos o falsos, el resultado será verdadero si alguno de los argumentos es verdadero o falso, en caso de que todos los argumentos sean falsos.

El siguiente ejemplo ilustra mejor esta función:

Una cooperativa necesita saber si es posible dar crédito a sus afiliados, para ello tiene en cuenta lo siguiente: se puede dar crédito al trabajador que adeude menos de $15000 o que tenga ahorrado en el fondo común más de $10000, en cualquier caso el resultado será VERDADERO y le será otorgado el crédito, pero en caso de que el trabajador adeude más de $15000 y tenga ahorrado menos de $10000, le será negado el crédito y el resultado será FALSO.

Profesor Cruz Mariano

ACTIVIDAD VISTA EN CLASES En el siguiente ejercicio se verán aplicadas las funciones de Búsqueda
ACTIVIDAD VISTA EN CLASES En el siguiente ejercicio se verán aplicadas las funciones de Búsqueda

ACTIVIDAD VISTA EN CLASES

En el siguiente ejercicio se verán aplicadas las funciones de Búsqueda Horizontal y Vertical y las funciones anteriormente vistas en esta lección…

Se cargará la siguiente tabla en Excel 2003 y se le aplicará el formato que presenta la misma.

2003 y se le aplicará el formato que presenta la misma. A continuación se calculara el

A continuación se calculara el promedio por medio de la fórmula SUMA y dividir de acuerdo a la cantidad de las notas cargadas…

la fórmula SUMA y dividir de acuerdo a la cantidad de las notas cargadas… =SUMA(E13;F13;G13)/3 Profesor
=SUMA(E13;F13;G13)/3
=SUMA(E13;F13;G13)/3

Profesor Cruz Mariano

Una vez calculado el promedio se pide agregar una función de Búsqueda por el DNI,

Una vez calculado el promedio se pide agregar una función de Búsqueda por el DNI, cabe aclarar que se eligió el DNI como búsqueda debido a que si lo hacemos por el Apellido podemos llegar a tener a dos personas con el mismo apellido, al realizar la búsqueda deberán mostrar el promedio, el apellido y el nombre.

deberán mostrar el promedio, el apellido y el nombre. =BUSCARV(K3;B3:H13;7;FALSO) =BUSCARV(K3;B3:D13;2;FALSO)
deberán mostrar el promedio, el apellido y el nombre. =BUSCARV(K3;B3:H13;7;FALSO) =BUSCARV(K3;B3:D13;2;FALSO)

=BUSCARV(K3;B3:H13;7;FALSO)

=BUSCARV(K3;B3:D13;2;FALSO)

=BUSCARV(K3;B3:D13;3;FALSO)

=BUSCARV(K3;B3:D13;2;FALSO) =BUSCARV(K3;B3:D13;3;FALSO) Una vez realizada las celdas de búsqueda pasaremos a crear
=BUSCARV(K3;B3:D13;2;FALSO) =BUSCARV(K3;B3:D13;3;FALSO) Una vez realizada las celdas de búsqueda pasaremos a crear
=BUSCARV(K3;B3:D13;2;FALSO) =BUSCARV(K3;B3:D13;3;FALSO) Una vez realizada las celdas de búsqueda pasaremos a crear

Una vez realizada las celdas de búsqueda pasaremos a crear mediante las funciones vistas en esta lección lo que llamamos Fórmulas compuestas o anidadas, las cuales serán explicadas en teoría en la siguiente lecciónLas fórmulas serán cargadas en las celda de Condición

Un profesor necesita que las notas de sus estudiantes sean cualitativas, teniendo un listado con notas cuantitativas, para ello tiene en cuenta lo siguiente:

Profesor Cruz Mariano

*Si la nota es menor a 6 (Seis) debe aparecer el texto “ LIBRE ”

*Si la nota es menor a 6 (Seis) debe aparecer el texto LIBRE.

*Si la nota es mayor igual a 6 (Seis) y menor a 8 (Ocho) debe decir REGULAR.

nota es mayor PROMOCION.

*Si

la

igual a

8

(Ocho) y

menor igual

a

10 (Diez)

debe

decir

=SI(H13<6;"LIBRE";SI(Y(H13>=6;H13<8);"REGULAR";SI(Y(H13>=8;H13<=10);"PROMOCION"
=SI(H13<6;"LIBRE";SI(Y(H13>=6;H13<8);"REGULAR";SI(Y(H13>=8;H13<=10);"PROMOCION"

Esa fórmula es la apropiada para colocar las condiciones expresadas en el ejercicio

A continuación se explicara parte por parte de la fórmula

=SI(H13<6;"LIBRE";SI(Y(H13>=6;H13<8);"REGULAR";SI(Y(H13>=8;H13<=10);"PROMOCION")))

Fórmula =Y(); está se encuentra dentro de la función
Fórmula =Y(); está se encuentra dentro de la función

Fórmula =Y(); está se encuentra dentro de la función =SI()

=Y(); está se encuentra dentro de la función =SI() Lo que debe dar como resultado si

Lo que debe dar como resultado si cumple la condición de la fórmula =Y()

Celda que contiene el promedio de los alumnos

Se llaman Fórmulas compuestas o anidadas debido a que como se ve en la fórmula podemos incorporar dentro de una fórmula otra fórmula másComo lo es en este caso

la fórmula =SI() contiene dentro a la fórmula =Y()

Profesor Cruz Mariano