Está en la página 1de 35

LABORATORIO DE INGENIERIA DE REDES Y SERVICIOS TELEMATICOS

Práctica de
Encaminamiento Dinámico
con OSPF
Curso 2004/2005

David Fernández
david@dit.upm.es
Dpcho: B-216

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 1
Practica Enc. Dinámico con OSPF

! !
" !
# ! ! $ %
&' !
( !
# ! )* &
! ! * +,- .+
$
&
! $ %&
* "' /
0 & & 1112 2 2 3

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 2
Escenario Práctica OSPF
Sucursal 2
192.168.85.64/26

.66 .65
0
.1
1 Sucursal 1
.198
Sucursal 3 192.168.85.0/26
.196/30
192.168.87.0/26 192.168.95
Sucursal 4 RRA2 .1 0 .2

19
.194
.1 0 .2

2.
.197 2 1

16
SRA 1

.98
1

5.
1

0
0 .206 0 .193

1
4/3
19

92
.66 .65 2.1 .202 .3 192.168.84.0/26 .2

.20

/3
68 Sede

0
.95 VLAN 111

.95
192.168.87.64/26 RRB2 .20
Regional A FA0/1 .1

68
0/3 192.168.12.0/28 192.168.12.16/28

2.1
1 .201 0

19
2 11
.205
0
Sede Regional B .162 S0/0
192 RRA1 E1 E1

0
.2 192.168.86.0/26 .
168

4/3
VLAN 121 .9 5
.16
RC1 RC2

. 16
.1 0/3
.3 FA0/1
RB2 0 1 2

.95
S0/0 E0 E0
S0/2 .161

68
SRB

0
Sucursal 5 .166

8/3
12

2.1
S0/3 S0/0 192.168.11.0/24 .1 .2

. 12
19
RRB1 VLAN 10

.95
.165 8 .130 .3
S0/1 .129 .4 .22

68
1 S0/0 FA0/1 E0 E0
0

2.1
.210
0

192 .133 .50


RC4
/3

.2 .1 7
RC3

19
.16
08

8.9 S0/1
RB1 5
.2

Sede Regional C 5.1 6


95

32/ E1 E1
192.168.89.0/26
RB3 30 .141
8.

RRC2
16

.209 S0/0 .134 19


2.

2 .1
SSC
19

192
1
SRC 68

0
.9 5

6/3
.168
Red
192.168.32.0/28 192.168.12.48/28
.213 2 0 .169 S0/2 9 .137 .14

. 13
.3 S0/3 S0/1 .142 0 /3
.2 VLAN 131 .95.1 0

.95
Sede Central
S0/1
.173
RB4

68
Troncal
68/3
19 192.168.88.0/26E0/1 .1 S0/0

2.1
2. S0/0
16 10
S0/2 S0/3

19
0

8. .138
95 .170
.2 13
1 .177 .181
Sucursal 6 2/
30
RRC1 19
2.1
68 0
/3
.95 80
1 .214 .17
2 /3 .9 5.1 Sede Regional F
68
0
0
192.168.95.1
76/30 19
2 .1 RRF1
.66 .65
.182 S0/0 SRF
Sede Regional D 16
192.168.89.64/26
E0/1

/30
.178S0/0
SRD
S0/0 .174
RRE1 .1 VLAN 161 .3
SRE Sucursal 12

.95.236
14 RRD1 15 .2
.3
E0/1
.1 .3
E0/1
.1
Sede 192.168.94.0/26 0
2

192.168
VLAN 141 VLAN 151
.2
Regional E RRF2 1 .237 .238 1
0
192.1

192.168.90.0/26 192.168.92.0/26 .2
Sucursal 7 0 0
RRE2 .233 .65 .66
.217 1
RRD2
68.9

.218 2 30 192.168.95.64/26
1 2 1 32/
5.21

.225 .229 5.2


0 .221 8.9
.16
6/30

.1 /30 192
.2 192.1 192 228 Sucursal 11
68.9 .168 95.
.97 5.22
0/30 .95.2 . 168.
192.168.91.0/26 24/3
0 192 .234
1
.222 Sucursal 9 Sucursal 10 0
1
.226 .230 .1 .2
0 1 1
.65 .66 192.168.95.0/26
0 0
.2 .1 .65 .66
192.168.91.64/26

Sucursal 8 192.168.93.0/26 192.168.93.64/26

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 3
Aspectos Prácticos

" !
# ! ' !

+ 4
56
+ 5 5 4 57
58 4
! 9 '
&
. !! : ! !
* !
! ;<56
! %%

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 4
Repaso del Protocolo OSPF

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 5
OSPF
$4 4% &% 6 6= 26
9 !
> 1 !>
& ,+%
; ! , ,!
$ ! ! 0-$? @
"
, "' .$ "
, ! A
! ! * )
"
. * ! !
$ *

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 6
Funcionamiento Básico OSPF (I)

.! , ,!
! ! #!
! ! '
* !
-
$ ! !
!
B A
4 B/4
138.4.3.0/24 .1
A
.1 C/2
138.4.4.0/24
C
.1
2 138.4.3.0/24
138.4.5.0/24 138.4.4.0/24
138.4.5.0/24
LSP generado por A

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 7
Ejemplo (I)
P1 P3 P4

P2 A 6 B 2 C
A B C P13
5
P12
2 1 2 G
G
1
D 2 E 4 FF
P5 D E P11

P6 P7 P8 P9 P10

A B C D E F G
B/6 A/6 B/2 A/2 B/1 C/2 C/5
D/2 C/2 F/2 E/2 D/2 E/4 F/1
P1 E/1 G/5 P5 F/4 G/1 P11
P2 P3 P4 P6 P7 P9 P12
P8 P10 P13

Base de Datos (RIB)

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 9
Ejemplo (II)
"! ! * !
B
. *
A
A B
B C
C
Destino Siguiente Coste
G
G P1 E 8
D
D E
E FF P2 E 8
P3 C 4
Nodo F P4 C 2
Destino Siguiente Coste P5 E 6
A E 8 P6 E 6
B C 4 P7 E 4
C C 2 P8 E 4
D E 6 P9 F 0
E E 4 P10 F 0
F F 0 P11 G 1
G G 1 P12 G 1
P13 G 1
© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 10
Paquetes OSPF
$ 9 ! =8

+ '

Tipo Nombre Funció


Función
1 Hello Descubrimiento y mantenimiento de
vecindades
2 Database Description Resumen contenido base de datos

3 Link State Request Solicitud de enví


envío
4 Link State Update Actualizació
Actualización de base de datos
5 Link State Ack Asentimiento

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 11
Paquete Link State Update
$ ! -$ !
! A ,,2
-
$C -
$. - B
$ .
-
$. *

+ -
$.
+ 5D & - B.
!
#
3 2
+ 6D E 1 B- B.
! -
.E2
! !- .E !
!
!2
+ D E 1 B$ -B
. !# !
" 4
! ) !" 2
,) :F7

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 12
Escalabilidad EE
GH A ") ! # '
! ,,I
J! !
EJ !
+ !9 J
!
! C K2
! " !
C 4
! !
& $ %
; 4 L6F

M
,&.&HC N.&!

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 13
Encaminamiento Jerárquico en OSPF (I)

! ! ! $ % ! *
$.
$ % !
, E+&.</&,.
! "
, E+,&</&,.
"
,!, $. ! !
! < ;>

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 14
Encaminamiento Jerárquico en OSPF (II)

$ . * .&,.$

AREA 1
SA AREA 3
Otros
AREA 0 SAs
(BACKBONE)
ABR
ABR
ASBR
AREA 2 Tipos de Routers:
ABR ASBR
ABR Interno
Frontera de Area
(ABR)
AREA 4
Backbone
Frontera de SA
Otros (ASBR)
SAs
© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 15
Routers Frontera de Área (ABR)

. ; & .;&
!" ! !
!" ! B
? -
$
$ ! !! *
!" ! B
. ! B ! ! !"
! ! B !
!"

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 16
Flujos de Información (I)

( !) "
- .;& ! !
! "
> -
$ 4 ! B ! !!

,) !
,) J ' ! ! . *
D &' * "' !
&
. ! * )

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 17
Flujos de Información (II)

( !) "

ABR ABR
AREA AREA
1.1.1.0/24 1.1.1.0/24
1.1.1.0/24 1.1.0.0/16
1.1.2.0/24
1.1.3.0/24
1.1.2.0/24 1.1.4.0/24 1.1.2.0/24
1.1.4.0/24 1.1.4.0/24
1.1.3.0/24 1.1.3.0/24

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 18
Flujos de Información (IV)
( ! "
- .;& ! ! *
' ! ! B
4 ! ! "

E J 2
D ,!.;& 4 2 2 2 3
D O ! !" ! .;&
& ! ! B
D - !
) !' ! ! !.;&
* 2
D O ! !" .;&

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 20
Configuración Básica de OSPF
GH A 4 ' '
$ %I
, ! #
* "
"
$*! ! " .;&
* !" ! B
?J! !
D
D J . *
HA !" !)
D & 4 .;&
D ! B
D !) ! B .$;&

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 21
Descripción de la Práctica y
Entorno

! E *
* $ % $
* $ % +,- .+
> * ! "

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 22
Topología de la Red

Internet
Sucursal
Sede Sede
Sucursal
Regional Central

Sucursal Red Troncal

Sucursal Sede
Regional

Sucursal
... Sede ...
Sede
Regional Regional
Sucursal
Sucursal

Sucursal Sucursal
Sucursal Sucursal

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 23
Resumen Requisitos

Número Host
Tecnología
Núm de por Total
Acceso
subredes subred
Sede Central Enlaces pto. a
1 8 100 800
(SC) pto.
Sedes
Enlaces pto. a
Regionales 8 4 50 1600
pto.
(SR)
Pto. a pto. (24)
Sucursales 29 1 50 1450
Frame Relay (5)
Oficinas
Comerciales 40 RDSI - 1 40
(OC)
TOTAL 3890

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 24
Diseño Plan de Numeración (I)

52 $ !
EJ ! ! P =8
- ' A J
4 7 !
$ ! & 65 P =586

192.168.64.0/19

11000011 00000001 010 00000 00000000


Prefijo libre

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 25
Diseño Plan de Numeración (II)

62 * $ & !
! 6
! F !F

!
LF !
8
68PF56 !
- " !
# "
255.255.254.0 (/23)

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 26
Diseño Plan de Numeración (III)

62 *
192.168.64.0/23 libre
! " 6FF26FF26F:2 192.168.66.0/23 libre
= 8 2 192.168.68.0/23 SRA
192.168.70.0/23 SRB
.
192.168.72.0/23 SRC
! 192.168.74.0/23 SRD
192.168.76.0/23 SRE
192.168.78.0/23 SRF
192.168.64.0/19
192.168.80.0/23 SRG
192.168.82.0/23 SRH
192.168.84.0/23 libre
192.168.86.0/23 libre
192.168.88.0/23 libre
192.168.90.0/23 libre
192.168.92.0/23 libre
192.168.94.0/23 libre

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 27
Diseño Plan de Numeración (IV)

2 $ *
$ ! ! $& F
7
C!
#! " 6FF26FF26FF2586 367
! =
76
192.168.68.0/26 SRA
192.168.64.0/23 libre 192.168.68.64/26 SRA
192.168.66.0/23 libre 192.168.68.128/26 SRA
192.168.68.0/23 SRA 192.168.68.192/26 SRA
192.168.69.0/26 Sucursal 1
192.168.70.0/23 SRB 192.168.69.64/26 Sucursal 2
192.168.64.0/19 192.168.72.0/23 SRC 192.168.69.128/26 libre
192.168.74.0/23 SRD 192.168.69.192/26 libre
192.168.76.0/23 SRE
192.168.78.0/23 SRF
….
© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 28
Diseño Plan de Numeración (V)

:2 $ !
C! # ! 36
586257=27:2 36 @ 586257=2772 36 P
586257=27:2 366
E 5
Q
192.168.64.0/25 SC1
192.168.64.128/25 SC2
192.168.65.0/25 SC3
192.168.65.128/25 SC4
192.168.64.0/22
192.168.66.0/25 SC5
192.168.66.128/25 SC6
192.168.67.0/25 SC7
192.168.67.128/25 SC8

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 29
Diseño Plan de Numeración (VI)

F2 &
$ ! ! %&
! &$
& ! !
C!# !
! ! 586257=28:2 36
" 367
192.168.94.0/26 SPFR1
192.168.94.64/26 SPFR2
192.168.94.128/26 SPFR3
192.168.94.192/26 SPFR4
192.168.94.0/23
192.168.95.0/26 SPFR5
192.168.95.64/26 OCs
192.168.95.128/26 Enlaces p2p
192.168.95.192/26 Enlaces p2p

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 30
Configuración OSPF en CISCO (I)

router ospf 109


i0 router-id 0.0.0.1
network 131.0.0.0 0.255.255.255 area 0

interface ethernet 0
ip address 131.108.20.5 255.255.255.0
interface ethernet 1
i1 ip address 131.109.10.5 255.255.255.0

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 31
Configuración OSPF en CISCO (II)

router ospf 109


i0 router-id 0.0.0.1
network 131.108.20.0 0.0.0.255 area 0
network 131.109.10.0 0.0.0.255 area 1

interface ethernet 0
ip address 131.108.20.5 255.255.255.0

i1 interface ethernet 1
ip address 131.109.10.5 255.255.255.0

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 32
Configuración OSPF en CISCO (III)

!
" #

router ospf 109


i0 router-id 0.0.0.1
network 131.108.20.0 0.0.0.255 area 0
network 131.109.1.0 0.0.0.255 area 1
area 1 range 131.109.0.0/21

interface ethernet 0
ip address 131.108.20.5 255.255.255.0
i1
interface ethernet 1
ip address 131.109.1.5 255.255.255.0

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 33
Configuración OSPF en TELDAT

, !

R :
S $ %
$ % S ,E.;-, $ %
$ % S $,+ E+,&%. , % !

0 ? !&" * &
+,- .+ 4 331112! 2 2 2 3L! 3 3 <
! 24

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 34
Escenario Práctica OSPF
Sucursal 2
192.168.85.64/26

.66 .65
0
.1
1 Sucursal 1
.198
Sucursal 3 192.168.85.0/26
.196/30
192.168.87.0/26 192.168.95
Sucursal 4 RRA2 .1 0 .2

19
11
.194
.1 0 .2

2.
.197 2 1

16
1

.98
1

5.
1

0
0 .206 0 .193

1
4/3
19

92
.66 .65 2.1 .202 .3 192.168.84.0/26 .2

.20

/3
68 Sede

0
.95 VLAN 111

.95
192.168.87.64/26 RRB2 .20
Regional A FA0/1 .1

68
0/3 192.168.12.0/28 192.168.12.16/28

2.1
1 .201 0

19
2 11
.205
0
Sede Regional B .162 S0/0
192 RRA1 E1 E1

0
.2 192.168.86.0/26 .
168

4/3
VLAN 121 .9 5
.16
RC1 RC2

. 16
.1 0/3
.3 FA0/1
RB2 0 1 2

.95
S0/0 E0 E0
S0/2 .161

68
SRB

0
Sucursal 5 .166

8/3
12

2.1
S0/3 S0/0 192.168.11.0/24 .1 .2

. 12
19
RRB1 VLAN 10

.95
.165 8 .130 .3
S0/1 .129 .4 .22

68
1 S0/0 FA0/1 E0 E0
0

2.1
.210
0

192 .133 .50


RC4
/3

.2 .1 7
RC3

19
.16
08

8.9 S0/1
RB1 5
.2

Sede Regional C 5.1 6


95

32/ E1 E1
192.168.89.0/26
RB3 30 .141
8.

RRC2
16

.209 S0/0 .134 19


2.

2 .1
SC
19

192
1
SRC 68

0
.9 5

6/3
.168
Red
192.168.32.0/28 192.168.12.48/28
.213 2 0 .169 S0/2 9 .137 .14

. 13
.3 S0/3 S0/1 .142 0 /3
.2 VLAN 131 .95.1 0

.95
Sede Central
S0/1
.173
RB4

68
Troncal
68/3
19 192.168.88.0/26E0/1 .1 S0/0

2.1
2. S0/0
16 10
S0/2 S0/3

19
0

8. .138
95 .170
.2 13
1 .177 .181
Sucursal 6 2/
30
RRC1 19
2.1
68 0
/3
.95 80
1 .214 .17
2 /3 .9 5.1 Sede Regional F
68
0
0
192.168.95.1
76/30 19
2 .1 RRF1
.66 .65
.182 S0/0 SRF
Sede Regional D 16
192.168.89.64/26
E0/1

/30
.178S0/0
SRD
S0/0 .174
RRE1 .1 VLAN 161 .3
SRE Sucursal 12

.95.236
14 RRD1 15 .2
.3
E0/1
.1 .3
E0/1
.1
Sede 192.168.94.0/26 0
2

192.168
VLAN 141 VLAN 151
.2
Regional E RRF2 1 .237 .238 1
0
192.1

192.168.90.0/26 192.168.92.0/26 .2
Sucursal 7 0 0
RRE2 .233 .65 .66
.217 1
RRD2
68.9

.218 2 30 192.168.95.64/26
1 2 1 32/
5.21

.225 .229 5.2


0 .221 8.9
.16
6/30

.1 /30 192
.2 192.1 192 228 Sucursal 11
68.9 .168 95.
.97 5.22
0/30 .95.2 . 168.
192.168.91.0/26 24/3
0 192 .234
1
.222 Sucursal 9 Sucursal 10 0
1
.226 .230 .1 .2
0 1 1
.65 .66 192.168.95.0/26
0 0
.2 .1 .65 .66
192.168.91.64/26

Sucursal 8 192.168.93.0/26 192.168.93.64/26

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 35
Guión de la Práctica
5 * $ !
* ! -
.E ! 2 2

6 * !& $ %/ O
+ ! "
E 4 *

' $ % ,4 !
9 !
: * !& $ % ?J! ! /
C " $ & !
" )
* 4 ! !"

© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 36
Trabajo Previo

, !! E *
+ ! ,
& ! !
& ! $&
& . ! $&
& !; B
- ! !9
J !2
E ! ! ! !
! 2

$
$ # %& % ' #
! (
(
© 2005, DIT-
DIT-UPM Prá
Práctica de Encaminamiento Diná
Dinámico con OSPF 37