Está en la página 1de 14

Basic Cisco 2811 Configuration

Tom Atlas 2 posts since Dec 19, 2009

Hello All! I just got a Cisco 2811 Router to replace a residential Linksys (WRT300N) router. I attached a switch to the router, and have the SDM installed. Basically, I would like to know if there is any basic configuration file that just does the following basic tasks:

1) Is DHCP enabled (FastEthernet0/1) 2) Connects to my Time Warner internet box (Dynamic IP via. DHCP) (FastEthernet0/0)

I tried to use the SDM to get this to work, however what keeps happening is that it will not get an IP from my ISP. When I plug my other Linksys router in it gets an IP, starts DHCP and works great. I know without any doubt that the Cisco rouer is WAY better, I just dont know how to use it yet. I dont mind starting from scratch at all, so a full config file is perfectly fine. I understand (at the surface) how the config file works.

I currently have FastEthernet0/0 as the WAN (outside) and FastEthernet0/1 as LAN (inside). Everything is wired, I just need a config file to get me going. I am working on my CCNA which is largly the reason I got the router in the first place. I have Googled this (not a total n00b) however I am not exactly what to search for. If there is an existing thread to help, that would be greatly appreciated as well.

Thanks for any replies!

Tom
Tags: configuration, ip_routing, 2800_routers, routers

Reza Sharifi 517 posts since

Postings may contain unverified user-created content and change frequently. The content is provided as-is and is not warrantied by Cisco. 1

Basic Cisco 2811 Configuration

Jul 2, 2008 1. Re: Basic Cisco 2811 Configuration Dec 19, 2009 10:18 PM

Hi Tom,

Login to the router and type config t interface FastEthernet0/0 ip address dhcp

The router will get an IP address form your service provider

for your other interfcae (0/1): config t interface FastEthernet0/1 ip address 10.1.1.1 255.255.255.0 (this is an example, use the ip addess range that you are using for your PCs, printer, etc at home.

If you want to use DHCP addressing for your devices at home, then you would need to define an IP DHCP pool and sepcify ip dhcp pool LAN network 10.1.1.0 255.255.255.0 default-router 10.1.1.1 dns-server (DNS servers supplied by the ISP)

You will also need a default route tward your sevice provide

Postings may contain unverified user-created content and change frequently. The content is provided as-is and is not warrantied by Cisco. 2

Basic Cisco 2811 Configuration

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 HTH Reza

Tom Atlas 2 posts since Dec 19, 2009 2. Re: Basic Cisco 2811 Configuration Dec 22, 2009 3:32 PM

Thanks Reza! Actually what I did was turn off the router ,and when it booted up again, it reverted back to the default configuration. I just didn't save the running config to the boot config. However, when I started to re-config it, I just did the simple steps, and now it works partially.

I currently have it plugged into my linksys router which is connected to my Time Warner cable box. What I want to do next is plug it into my cable box, to make it the top router. I tried this, but when I did so, I was not assigned an IP by my ISP (same as before). I tries a crossover cable as well and that did not work. In the SDM, I did a Test Connection and it said that I didn't have an IP. I checked my Linksys Router settings and it said it was simply set up for DHCP as is my Cisco router. I am a bit confused on this one. I posted my config below.

Thanks for any replies!

Postings may contain unverified user-created content and change frequently. The content is provided as-is and is not warrantied by Cisco. 3

Basic Cisco 2811 Configuration

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname {!REMOVED FOR SECURITY!}

boot-start-marker

boot-end-marker

logging buffered 51200 warnings

enable secret 5 {!REMOVED FOR SECURITY!}

no aaa new-model

Postings may contain unverified user-created content and change frequently. The content is provided as-is and is not warrantied by Cisco. 4

Basic Cisco 2811 Configuration

resource policy

ip subnet-zero

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.0.31 10.10.0.254

ip dhcp excluded-address 10.10.0.1

ip dhcp pool sdm-pool1

network 10.10.0.0 255.255.255.0

domain-name {!REMOVED FOR SECURITY!}

default-router 10.10.0.1

Postings may contain unverified user-created content and change frequently. The content is provided as-is and is not warrantied by Cisco. 5

Basic Cisco 2811 Configuration

dns-server 208.67.222.222 208.67.220.220

ip dhcp pool sdm-pool

ip dhcp pool {!REMOVED FOR SECURITY!}

host 10.10.1.2 255.255.255.0

hardware-address {!REMOVED FOR SECURITY!}

client-name {!REMOVED FOR SECURITY!}

ip domain name {!REMOVED FOR SECURITY!}

voice-card 0

no dspfarm

Postings may contain unverified user-created content and change frequently. The content is provided as-is and is not warrantied by Cisco. 6

Basic Cisco 2811 Configuration

crypto pki trustpoint TP-self-signed-{!REMOVED FOR SECURITY!}

enrollment selfsigned

Postings may contain unverified user-created content and change frequently. The content is provided as-is and is not warrantied by Cisco. 7

Basic Cisco 2811 Configuration

subject-name cn=IOS-Self-Signed-Certificate-{!REMOVED FOR SECURITY!}

revocation-check none

rsakeypair TP-self-signed-{!REMOVED FOR SECURITY!}

crypto pki certificate chain TP-self-signed-{!REMOVED FOR SECURITY!}

certificate self-signed 01

{!REMOVED FOR SECURITY!}

quit

username root privilege 15 secret 5 {!REMOVED FOR SECURITY!}

Postings may contain unverified user-created content and change frequently. The content is provided as-is and is not warrantied by Cisco. 8

Basic Cisco 2811 Configuration

interface FastEthernet0/0

description $ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$$ETH-WAN$

ip address dhcp client-id FastEthernet0/0 hostname {!REMOVED FOR SECURITY!}

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

interface FastEthernet0/1

description $ETH-LAN$

ip address 10.10.0.1 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

Postings may contain unverified user-created content and change frequently. The content is provided as-is and is not warrantied by Cisco. 9

Basic Cisco 2811 Configuration

speed auto

ip classless

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 1 interface FastEthernet0/0 overload

access-list 1 remark INSIDE_IF=FastEthernet0/1

access-list 1 remark SDM_ACL Category=2

access-list 1 permit 10.10.0.0 0.0.0.255

Postings may contain unverified user-created content and change frequently. The content is provided as-is and is not warrantied by Cisco. 10

Basic Cisco 2811 Configuration

control-plane

banner login ^C

-----------------------------------------------------------------------

Postings may contain unverified user-created content and change frequently. The content is provided as-is and is not warrantied by Cisco. 11

Basic Cisco 2811 Configuration

Cisco Router and Security Device Manager (SDM) is installed on this device.

This feature requires the one-time use of the username "cisco"

with the password "cisco". The default username and password have a privilege level of 15.

Please change these publicly known initial credentials using SDM or the IOS CLI.

Here are the Cisco IOS commands.

username <myuser> privilege 15 secret 0 <mypassword>

no username cisco

Replace <myuser> and <mypassword> with the username and password you want to use.

For more information about SDM please follow the instructions in the QUICK START

GUIDE for your router or go to http://www.cisco.com/go/sdm

-----------------------------------------------------------------------

Postings may contain unverified user-created content and change frequently. The content is provided as-is and is not warrantied by Cisco. 12

Basic Cisco 2811 Configuration

^C

line con 0

login local

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet ssh

line vty 5 15

privilege level 15

login local

transport input telnet ssh

scheduler allocate 20000 1000

Postings may contain unverified user-created content and change frequently. The content is provided as-is and is not warrantied by Cisco. 13

Basic Cisco 2811 Configuration

end

remaker 45 posts since Sep 13, 2000 3. Re: Basic Cisco 2811 Configuration Dec 22, 2009 4:16 PM

The cable company is locked on to the MAC address of your Linksys. When you replace the Linksys, you need to wait for the old MAC address to time out or otherwise trick the cable company into recognizing the new MAC address of the 2811. Most consumer routers have a "Clone MAC address" function for this purpose.

Some people report that powering off the cable modem for 2 to 5 minutes while switching the routers will do the job. So, turn of fthe cable modem for a few minutes while swapping the routers, and then see if it works out.

Postings may contain unverified user-created content and change frequently. The content is provided as-is and is not warrantied by Cisco. 14

También podría gustarte