Está en la página 1de 6

Integrantes:

GILMER DANIEL VILLAR ROJAS – U21210483


JHON LARRY VELEZMORO SOZA - U20202548
FRANCISCO ROLGER QUEZADA CHIHUALA - U20229835

1. Escribir un algoritmo que permita ingresar un número “n” de estudiantes (se cumple
que: 10<=n<=20), cada uno de los cuáles cursa 4 materias. Para cada alumno se ingresa el
nombre y sus calificaciones. Escriba un algoritmo para calcular el promedio de cada
estudiante luego de ingresar sus notas.
Algoritmo ejercicio01
Definir nombre Como Texto
Definir nota1, nota2, nota3, nota4, promedio Como Real
Definir n Como Entero

//Contador para el numero de alumno


Definir i Como Entero

Repetir
Escribir "Ingrese numero de estudiantes (entre 10 y 20)"
Leer n

si n < 10 o n >20 Entonces


Escribir "***Error, Ingrese un valor entre 10 y 20***"
Escribir ""
FinSi

Hasta Que n>=10 y n<=20

Escribir "*******************************************"
Escribir "*** Se van a ingresar ", n , " Alumnos ***"
Escribir "*******************************************"

//Inicializamos el contador
i <- 1

Mientras i<=n Hacer


Escribir "Ingrese nombre del alumno ", i
Leer nombre

//Pedimos las notas y nos aseguramos que sean valoes entre 0 y 20


Repetir
Escribir "Ingrese nota de la materia 1"
Leer nota1

si nota1 < 0 o nota1 >20 Entonces


Escribir "Ingrese nota entre 0 y 20"
FinSi

Hasta Que nota1>=0 Y nota1 <=20

Repetir
Escribir "Ingrese nota de la materia 2"
Leer nota2
si nota2 < 0 o nota1 >20 Entonces
Escribir "Ingrese nota entre 0 y 20"
FinSi

Hasta Que nota2>=0 Y nota2 <=20

Repetir
Escribir "Ingrese nota de la materia 3"
Leer nota3

si nota3 < 0 o nota1 >20 Entonces


Escribir "Ingrese nota entre 0 y 20"
FinSi

Hasta Que nota3>=0 Y nota3 <=20

Repetir
Escribir "Ingrese nota de la materia 4"
Leer nota4

si nota4 < 0 o nota1 >20 Entonces


Escribir "Ingrese nota entre 0 y 20"
FinSi

Hasta Que nota4>=0 Y nota4 <=20

promedio<- (nota1 + nota2 + nota3 + nota4)/4

Escribir nombre, " su promedio es:", promedio

//Para que no aparesca todo Junto


Escribir "*******************************************"

//Incrementamos el contador
i<- i +1

Fin Mientras

Escribir "Fin"

FinAlgoritmo
2. Escribir un algoritmo que permita crear una matriz MxN donde el usuario ingresa los
valores de M (filas) y N (columnas). Todos los elementos se rellenan con el símbolo *

Algoritmo Ejercicio02
Definir m, n, j, i Como Entero
Definir fila Como Texto

Repetir
Escribir "Ingrese el numero de filas"
Leer m
Hasta Que m>0

Repetir
Escribir "Ingrese el numero de columnas"
Leer n
Hasta Que n>0

Escribir "Primera forma con Para (", m, " x ",n,")"


Escribir ""

Para j<-m Hasta 1 Con Paso -1 Hacer

fila <-""
Para i<-n Hasta 1 Con Paso -1 Hacer
fila<- fila + "*"
Fin Para

Escribir fila
FinPara

Escribir ""
Escribir "Segunda forma con Mientras (", m, " x ",n,")"
Escribir ""

j<-1

Mientras j <= m Hacer


fila <-""
i<-1
Mientras i<=n Hacer
fila<- fila + "*"
i <- i +1
FinMientras

Escribir fila
j <- j+1
FinMientras

FinAlgoritmo

También podría gustarte