Está en la página 1de 7

Lab MPLS-VPN đơn giản

Sơ đồ mạng

Các bước cấu hình


Cấu hình cơ bản, yêu cầu:
■ IP address cho các interface theo như sơ đồ mạng.

P1#sh run | be 0/0


interface FastEthernet0/0
description connected to router A
ip address 10.0.0.2 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet0/1
description connected to router C
ip address 10.0.0.9 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface Loopback0
ip address 3.3.3.3 255.255.255.128
ip ospf network point-to-point
end

P2#sh run
interface FastEthernet0/0
description To PE1
ip address 10.0.0.6 255.255.255.252
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
description To PE2
ip address 10.0.0.13 255.255.255.252
duplex auto
speed auto
mpls ip
!

PE1#sh run | be 0/0


interface FastEthernet0/0
description To P1
ip address 10.0.0.1 255.255.255.252
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
description To P2
ip address 10.0.0.5 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
description To CE1
ip vrf forwarding VPN_ONE
ip address 10.0.255.1 255.255.255.252
duplex auto
speed auto
!
...

■ Routing IGP (trong lab này dùng OSPF) trên các router core (P1, P2, PE1, PE2),
các router core quảng bá ra subnet của interface loopback, và các connected
subnet.
P1#sh run | sec ospf
router ospf 1
log-adjacency-changes
network 3.3.3.0 0.0.0.127 area 0
network 10.0.0.0 0.255.255.255 area 0
P2#sh run | sec ospf
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 1.1.1.0 0.0.0.127 area 0
network 10.0.0.0 0.255.255.255 area 0

PE1#sh run | sec ospf


ip ospf network point-to-point
router ospf 1
log-adjacency-changes
network 2.2.2.0 0.0.0.127 area 0
network 10.0.0.0 0.0.0.255 area 0

PE2#sh run | sec ospf


ip ospf network point-to-point
router ospf 1
log-adjacency-changes
network 4.4.4.0 0.0.0.127 area 0
network 10.0.0.0 0.255.255.255 area 0

■ enable mpls ip trên các interface router core, chọn giao thức phân phối nhãn
LDP
Nhập vào lệnh mpls ip tạimode config interface trên các interface liên quan

■ Trên các CE, trỏ default route tới các PE

Test: Các router PE học đầy đủ và đúng route trong mạng core. Các router PE ping
thông tới các interface loopback của nhau

Tạo bảng VRF trên PEs cho các VPN, gán các interface kết nối với khách hàng vào
VRF tương ứng
■ Mỗi khách hàng (VPN) cần có bảng định tuyến riêng, tách biệt với nhau, do đó,
trên các PEs, cần tạo bảng VRF cho từng khách hàng. Để tạo VRF, cần có cấu
hình 3 thông tin:
● Tên VRF
● RD: thông tin sẽ được prepend vào gói tin trước khi chuyển đi
● Import & export Route target:
Export target là thông tin được gán vào gói tin, để identify VRF instance.
Import target dùng trên từng VRF table, để lọc các bản tin VPNv4
incoming.
● Giá trị RD và RT được dùng theo dạng AS:nn.
ip vrf VPN_ONE
rd 65001:1
route-target export 65001:1
route-target import 65001:1
■ Gán interface vào bảng VRF: dùng lệnh ip vrf forwarding vrf-name
PE1#sh run int f1/0
!
interface FastEthernet1/0
description To CE1
ip vrf forwarding VPN_ONE
ip address 10.0.255.1 255.255.255.252
duplex auto
speed auto
end

Chú ý: khi gán một interface vào VRF, cấu hình IP address của interface đó
sẽ bị mất, cần cần cấu hình lại IP address của nó.
- Một interface chỉ có thể nằm trong một bảng định tuyến, do đó, khi gán vào
bảng VRF, ta sẽ ko thể thấy route của interface đó trong bảng định tuyến
thông thường

Kích hoạt MP-BGP giữa các PE


Để kích hoạt MP-BGP, ta cần làm các bước sau:
■ Cấu hình BGP thông thường
PE1#sh run | sec bgp
router bgp 65001
bgp router-id 2.2.2.2
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 65001
neighbor 4.4.4.4 update-source Loopback0
!

Test kết quả


Khai thêm khách hàng VPN mới
Step 1: Cấu hình thêm VRF cho khách hàng, sau đó, gán interface kết nối trực tiếp
với khách hàng vào VRF vừa tạo. Ở đây, vrf được tạo là VPN_TWO.
Chú ý, khi gán interface vào VRF, nó sẽ không còn nằm trong bảng định tuyến chính
(thông thường ) nữa, mà nằm trong bảng VRF, IP cấu hinh cũ sẽ bị mất đi, và cần phải
được cấu hình lại.
PE1(config)#ip vrf VPN_TWO
PE1(config-vrf)#rd 65001:2
PE1(config-vrf)#route-target both 65001:2
PE1(config-vrf)#description CUS2

PE1(config-if)#ip vrf forwarding VPN_TWO


% Interface FastEthernet1/1 IP address 10.0.255.1 removed due to enabling VRF VPN_TWO

Đến đây, route của interface f1/1 không con nằm trong bảng định tuyến chính nữa:
PE1#sh ip route

PE1#sh ip route vrf VPN_TWO
Gateway of last resort is not set

10.0.0.0/30 is subnetted, 1 subnets


C 10.0.255.0 is directly connected, FastEthernet1/1

Trên PE1, để ping tới B1, không thể dùng lệnh ping thông thường nữa, mà phải:
PE1#ping vrf VPN_TWO 10.0.255.2

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 10.0.255.2, timeout is 2 seconds:
.!!!!

Cấu hình tương tự ở site B trên router PE2.


Step2: Enable MP-BGP giữa các PE
Ở bước này, các route của khách hàng đã được đưa vào bảng VRF của PE kết nối trực
tiếp, nhưng chưa được quảng bá giữa các PE khác. Để làm điều này, sử dụng MP-BGP
trao đổi các route VPNv4 trong mạng MPLS.
PE2(config-router)# address-family ipv4 vrf cus2
redistribute connected
no synchronization
exit-address-family
Test kết quả
Kiểm tra bảng định tuyến trên VRF dành cho VPN:
PE1#show ip route vrf VPN_TWO
Routing Table: VPN_TWO
...
10.0.0.0/30 is subnetted, 2 subnets
B 10.0.255.4 [200/0] via 4.4.4.4, 00:07:00
C 10.0.255.0 is directly connected, FastEthernet1/1

DONE, route 10.0.255.4 từ site B đã được quảng bá sang PE1 thông qua BGP.

Cấu hình định tuyến OSPF giữa PE-CE


Tạo thêm subnets cho các router khách hàng (dùng loopback interface)
Tạo OSPF process riếng biệt cho từng VRF.
PE2(config)# router ospf 2 vrf cus2
Chú ý, nếu đã có tiến trình OSPF đang chạy, sẽ nhận được thông báo như sau:
OSPF process 1 already exists and is attached to Default-IP-Routing-Table
router ospf 2 vrf cus2
log-adjacency-changes
redistribute bgp 65001 subnets
network 10.0.0.0 0.255.255.255 area 0

a. Quảng bá các route BGP vào miên OSPF


PE2(config-router)#redistribute bgp 65001 subnets

Một số chú ý khi redistribute route vào miền OSPF:


„ External routes cannot be summarized.
„ External routes are flooded across all OSPF areas.
„ External routes could use a different metric type that is not comparable to OSPF cost.
„ External routes are not inserted in stub areas or not-so-stubby areas (NSSAs).
„ Internal routes are always preferred over external routes, regardless of their cost.
Quảng bá các route OSPF vào miền MP-BGP
PE1(config)#router bgp 65001
PE1(config-router-af)#redistribute ospf 2
PE1(config-router)#address-family ipv4 vrf VPN_TWO

Nhận được log sau:


PE1(config-router-af)#
*May 25 15:04:11.990: BGP: Applying map to find origin for 10.0.255.0/30
*May 25 15:04:11.998: vpn: bgp_vpnv4_bnetinit: 65001:2:10.1.2.1/32
*May 25 15:04:11.998: BGP: Applying map to find origin for 10.1.2.1/32
*May 25 15:04:12.010: vpn: bgp_vpnv4_alloc_tag route_tag_change for VPN_TWO:10.1.2.
1/255.255.255.255
*May 25 15:04:12.010: vpn: tag_vpn_find_route_tags: 65001:2:10.1.2.1
*May 25 15:04:12.014: vpn: intag=22, outtag=unknown, outtag owner=BGP
*May 25 15:04:12.018: vpn: bgp_vpnv4_bnetinit: 65001:2:10.1.3.1/32
*May 25 15:04:12.018: BGP: Applying map to find origin for 10.1.3.1/32
*May 25 15:04:12.022: vpn: bgp_vpnv4_alloc_tag route_tag_change for VPN_TWO:10.1.3.
1/255.255.255.255
*May 25 15:04:12.026: vpn: tag_vpn_find_route_tags: 65001:2:10.1.3.1
*May 25 15:04:12.030: vpn: intag=23, outtag=unknown, outtag owner=BGP
*May 25 15:04:12.034: vpn: bgp_vpnv4_bnetinit: 65001:2:10.1.0.1/32
*May 25 15:04:12.034: BGP: Applying map to find origin for 10.1.0.1/32
*May 25 15:04:12.038: vpn: bgp_vpnv4_alloc_tag route_tag_change for VPN_TWO:10.1.0.
1/255.255.255.255
*May 25 15:04:12.042: vpn: tag_vpn_find_route_tags: 65001:2:10.1.0.1
*May 25 15:04:12.046: vpn: intag=24, outtag=unknown, outtag owner=BGP
*May 25 15:04:12.046: vpn: bgp_vpnv4_bnetinit: 65001:2:10.1.1.1/32
*May 25 15:04:12.050: BGP: Applying map to find origin for 10.1.1.1/32
*May 25 15:04:12.054: vpn: bgp_vpnv4_alloc_tag route_tag_change for VPN_TWO:10.1.1.
1/255.255.255.255
*May 25 15:04:12.058: vpn: tag_vpn_find_route_tags: 65001:2:10.1.1.1
*May 25 15:04:12.058: vpn: intag=25, outtag=unknown, outtag owner=BGP
*May 25 15:04:12.086: BGP: Applying map to find origin for 10.0.255.0/30