Está en la página 1de 40

Instituto Nacional de Aprendizaje

Curso: Enrutamiento

Manual de Comandos para


Enrutamiento

Responsable:
Hellen Arguedas Porras

Profesor:
Erick González Quesada

Alajuela
Mayo, 2010
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

Índice

CAPITULO 1: Introducción ........................................................................................................ 4


Objetivo general .............................................................................................................................. 5
Objetivos específicos ....................................................................................................................... 5
Antecedentes .................................................................................................................................. 5
Justificación ..................................................................................................................................... 5
CAPÍTULO 2: Manual de Comandos de Enrutamiento.................................................... 6
La interfaz de línea de comandos (CLI) de un router ................................................ 6
Comandos del Modo Usuario ................................................................................................ 7
Comandos del Modo Privilegiado ........................................................................................ 8
Comandos de verificación (SHOW) ................................................................................ 9
Memorias ............................................................................................................................... 10
Respaldos de la memoria del Router .......................................................................... 11
Comandos del Modo de Configuración ........................................................................... 12
Comando para cambiar el nombre del router ......................................................... 12
Comandos de interfaces .................................................................................................. 12
Contraseñas .......................................................................................................................... 13
Enrutamiento estático ....................................................................................................... 13
Rutas por defecto (default route) ................................................................................ 14
Vector – Distancia RIP ...................................................................................................... 14
Estado de enlace – OSPF ................................................................................................. 14
Hibrido – EIGRP ................................................................................................................... 14
Vlan’s (Redes LAN virtuales) .......................................................................................... 15
CDP (Cisco Discovery Protocol) ..................................................................................... 17
Balanceo de cargas entre varias rutas ....................................................................... 18
DHCP ....................................................................................................................................... 19
Listas de Acceso ACL ............................................................................................................. 20
Estabished ................................................................................................................................. 20
Access Class (Restricción de líneas vty) ........................................................................ 21
CAPITULO 4: Curso Redes WAN ........................................................................................... 22

Página 2 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

Frame Relay .............................................................................................................................. 22


Características ........................................................................................................................... 22
Terminología de Frame Relay.................................................................................................... 22
Laboratorio Frame Relay – Punto a Punto ................................................................................ 23
Convertir Router a Switch Frame-Relay (ppp) ............................................................ 26
NAT (Network address Traslation) ................................................................................... 27
PAT (Port address Traslation) ............................................................................................ 28
Red digital de Servicios Integrados (RDSI o ISDN) .................................................. 29
DDR Legado .............................................................................................................................. 30
Backup RDSI............................................................................................................................. 32
CAPÍTULO 3: Conclusiones ..................................................................................................... 33
CAPÍTULO 4: Bibliografía ......................................................................................................... 34
CAPÍTULO 5: Anexos ................................................................................................................. 35
Modelo OSI ................................................................................................................................ 35
Tipos de cables ........................................................................................................................ 35
Protocolos TCP-UDP y sus puertos .................................................................................. 35
Ejemplos de Listas de Acceso Estándar ......................................................................... 38
Ejemplos de Listas de Acceso Extendidas ..................................................................... 39
Tabla de Subneteo ................................................................................................................. 39

Página 3 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

CAPITULO 1: Introducción

Dada la importancia de la seguridad informática hoy en día, se hace indispensable


contar con todo lo necesario para poder hacer una correcta administración de los
equipos de la red, esto para garantizar la seguridad a los usuarios y que estos de una
buena manera se sientan protegidos y confiados de que están interactuando de forma
segura con sus equipos en la red así como de disponer de todos los servicios
necesarios para poder realizar sus labores.

El presente manual de comandos de configuración de un router ha sido elaborado con


la finalidad de recopilar toda la información necesaria para la correcta configuración de
los equipos que conforman una red completa, con el fin de poder contar con una
herramienta que nos permita guiarnos desde las configuraciones más básicas hasta las
más complejas para así poder satisfacer las necesidades de los usuarios.

La información que contiene este manual, fue producto de la investigación, recopilación


de la información de los docentes durante el periodo de lecciones y practicas realizadas
en clase. Es responsabilidad de cada alumno, la implementación, seguimiento y
actualización de dicho manual para preservar la utilidad de esta herramienta tan
importante.

Página 4 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

Objetivo general
Crear un manual de comandos para enrutamiento de manera que contribuya en
obtener una herramienta de consulta permanente que permita más investigación y
conociendo acerca de los laboratorios realizados en clase para la configuración de
Router y Switches.

Objetivos específicos
 Investigar acerca de las características básicas y más importantes a la hora de
configurar un Router o un Switch.
 Conocer un poco de historia acerca de las redes computacionales.
 Investigar un poco más de la estructura y funcionamiento de los protocolos
vistos y desarrollados en clase.
 Desarrollar un manual con base sólida de comandos en un manual comprensible
para el usuario.

Antecedentes
Este manual, es la recopilación de todas las clases del curso de Enrutamiento del
Instituto Nacional de aprendizaje.

Además de la investigación para reforzar el conocimiento adquirido en la clase, en


medios como libros e internet.

Justificación
Se desarrollo este manual dado que se requiere de una herramienta con la cual contar
con toda la variedad de comandos disponibles para la configuración de los equipos de
una red. Dado la importancia de la seguridad informática hoy en día, se hace necesario
contar con una administración de calidad, para que los usuarios y la información
trasmitida esté protegida y se pueda disponer de todos los servicios necesarios para
poder realizar sus procesos y labores.

Página 5 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

CAPÍTULO 2: Manual de Comandos de Enrutamiento

La interfaz de línea de comandos (CLI) de un router

Con este tema podemos mostrar cómo trabaja un router a la hora de trabajar con la
entrega de datos en las redes que estén formadas por routers.

Desde aquí podemos registrarnos con la contraseña de usuario, si lo deseamos, o


aplicar la contraseña en el modo privilegiado.

Además, podemos conocer los comandos básicos y más importantes a la hora de


configurar un router y las verificaciones de sintaxis.

Como se representa en el dibujo que a continuación se muestra, tenemos tres modos


de ingreso al Router: Modo Usuario (router>), Modo Privilegiado (router#) y Modo de
Configuración (router(config)#). Este último se divide en varios submodos, como lo
son: Contraseñas, Interface (router(config-if)#), Subinterface (router(config-subif)#),
Protocolos (ej. router(config-dhcp)#), entre otros.

Página 6 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

Comandos del Modo Usuario

En el modo Usuario podemos realizar tareas comunes, como verificar el estado. Desde
este modo no podemos cambiar la configuración de router.

Con la tecla ? nos aparece una lista con todos los comandos que se utilizan en este
modo.

Comando Descripción
Connect Abre la conexión de la terminal
Disable Apaga los comandos de privilegiado
Enable Enciende los comandos del modo privilegiado
Exit Salida del EXEC
Logout Salida del EXEC
Ping Envía mensajes de consola
Resume Reanuda una conexión activa de red
Show Muestra la información del sistema en ejecución
Ssh Abrir una conexión segura de cliente shell
telnet Abrir una conexión Telnet
terminal Establece los parámetros de terminal de línea
traceroute Traza la ruta del destino

Página 7 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

Comandos del Modo Privilegiado

Dentro del Modo Privilegiado podemos realizar tareas comunes y cambiar la


configuración del router.

Para acceder a este modo de comandos, primero debemos activarlo, en el indicador >
escribimos ENABLE y nos va a quedar en el modo Router#.

Con la tecla ? nos aparece una lista con todos los comandos que se utilizan en este
modo.

Comando Descripción
Auto Nivel de automatización EXEC
Clear Reinicia funciones
Clock Administra el sistema del reloj
Configure Ingresa a la configuración de Modo
Connect Abre la conexión de la terminal
Copy Copia de un archivo a otro
Debug Funciones de depuración
Delete Elimina un archivo
Dir Lista de archivos en el Sistema de Archivos
Disable Apaga los comandos de privilegiado
Disconnect Desconecta una red de conexión existente
Enable Enciende comando de privilegiado
Erase Borra un Sistema de Archivos
Exit Salida del EXEC
Logout Salida del EXEC
Mkdir Crear un nuevo directorio
More Muestra los contenidos de un archivo
No Deshabilita de depuración de información
Ping Envía mensajes de consola
Reload Detiene y hace un arranque en frío
Resume Reanuda una conexión de red activa
Rmdir Remueve un directorio existente
Setup Ejecuta la instalación de comandos de instalación
Show Muestra el sistema de configuración en ejecución
Ssh Abrir una conexión segura de cliente Shell
Telnet Abre una conexión Telnet
Terminal Establezce los parámetros de terminal de línea
Traceroute Traza la ruta del destino
Undebug Deshabilita funciones de depuración
Vlan Configura parámetros de VLAN
Write Escribe la ejecución de configuración a la memoria, red o terminal

Página 8 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

Comandos de verificación (SHOW)

Show running-config: muestra el archivo de configuración actual que se encuentra


en memoria RAM.
Show interface: despliega todas las estadísticas en las interfaces en el router. Para
ver las estadísticas específicas para una interface utilice el comando Show interface
seguido de la interfaz que desea observar y el puerto. Ej. Router#Show interface
serial 0/1
Show controlers serial: se puede observar información referente al hardware de las
interfaces. Por ejemplo, se puede conocer cuál es el DCE y cuál es el DTE.
Show clock: muestra la hora del router.
Show users: despliega una lista de los usuarios que están conectados al router.
Show host: despliega una lista de los host y sus direcciones.
Show flash: despliega información sobre la flash y el IOS que está utilizando.
Show versión: despliega información del router tal como el registro de información en
curso, además sirve para verificar la memoria RAM.
Memoria total = memoria principal + memoria comparativa
Show ARP: despliega la tabla ARP del router.
Show protocol: despliega información específica y global del estado de cualquier
protocolo de capa 3 configurado.
Show startup-config: despliega el archivo de configuración almacenado en NVRAM.
Show ip interface brief: despliega una tabla con lista de protocolos por interfaz.
Show ip route: despliega las rutas conocidas por el router.
Show history: Despliega la sesion del historial de comando.
Show access-lists: despliega todas las Listas de Acceso.
Show cdp: despliega la información de CDP.
Show class-map: Muestra los Class Map del QoS.
Show crypto: Muestra el modulo de encriptación
Show debugging: Despliega el estado de cada opción de depuración.
Show dhcp: Muestra el estado del DHCP
Show file: Despliega la información de Sistema de Archivos.
Show frame-relay: Despliega la información del Frame-Relay.
Show ipv6: Muestra la información del IPv6.
Show logging: Muestra el contenido del buffer de registro.
Show login: Muestra configuraciones de pantalla del Secure Login y el Estado.

Página 9 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

Show mac-address-table: muestra las tablas de reenvío de la MAC.


Show ntp: Muestra el tiempo del protocolo de la red.
Show parser: Muestra los comandos del analizado.
Show policy-map: Despliega el QoS Policy Map.
Show privilege: Muestra el nivel privilegiado actual.
Show processes: muestra las estadísticas de proceso activas.
Show queue: Muestra el contenido de la cola.
Show queueing: Despliega la cola de configuración.
Show secure: Muestra la configuración de la imagen y la configuración del archivo.
Show sessions: Información sobre las conexiones de TELNET.
Show snmp: Muestra estadísitcas de SNMP.
Show spanning-tree: Muestra el mapa de la topología de árbol.
Show ssh: Muestra el estado de la conexión del SSH.
Show storm-control: Muestra el control de configuración.
Show tcp: Muestra el estado de las conexiones de TCP.
Show tech-support: Despliega información del sistema para Tech-Support
Show terminal: Despliega la configuración de parámetros de la terminal.
Show vlan-switch: Muestra el estado de la VTP VLAN.
Show vtp: Despliega la configuración de la base de datos del VLAN.

Memorias

Memoria de acceso aleatorio (RAM)

 Almacena las tablas de enrutamiento.


 Proporciona memoria de ejecución para el archivo de configuración de un
router.
 El contenido de la RAM se pierde cuando el router se apaga o se reinicia.

Memoria no volátil de acceso aleatorio (NVRAM)

 Almacena el archivo de configuración de inicio.


 Copia de seguridad de un router
 El contenido de la NVRAM no se pierde cuando el router se apaga o se reincia.
 Startup-config

Página 10 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

Memoria Flash

 Memoria ROM borrable y repogramable


 Contiene la imagen del sistema operativo.
 Sistema operativo I.O.S. (System Operative Internetwork)

Respaldos de la memoria del Router

RAM NVRAM tftp


Running-Config Startup-Config tftp
Copy running-config Startup-config

Copy running-config Tftp

Running-config Copy tftp

Startup-config Copy tftp

Pasos a la hora de copiar

1. Deshabilitar firewall
2. Deshabilitar el router
3. Copy running-config tftp
ó
Copy startup-config tftp
4. Dirección o nombre host remote> 192.168.1.2 (IP Máquina)
5. Destination filename> [router-config ] (Nombre del archivo)
6. !!!!!! [kbps] (Si esta leyenda no aparece, no copio nada en el destino)

Página 11 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

Comandos del Modo de Configuración

Dentro del Modo de Configuración podemos realizar todas las configuraciones del
router.

Para acceder a este modo de comandos, primero debemos activarlo, en el indicador #


y escribir CONFIGURE TERMINAL. De esta manera ingresamos a la Modo
router(config)#.

Con la tecla ? nos aparece una lista con todos los comandos que se utilizan en este
modo.

A continuación se detallan algunos comandos importantes para la configuración del


router.

Comando para cambiar el nombre del router

Comando Descripción
Este comando nos da la posibilidad de poder
Router(Config)#hostname NOMBRE
nombrar al router

Comandos de interfaces

Comando de Interfaces Descripción


Estos comandos nos permiten
Router(config)#interface serial 0/1/0
ingresar a una interface deseada. En
Router(config)#interface loopback NUMERO
este caso nombramos tres: serial,
Router(Config)#interface fastethernet 0/0
loopback y fastethernet.
Este comando es un ejemplo de una
Router(Config)#interface fastethernet 0/0.10
subinterface
Comando que se utilize para indicar
Router(Config-if)#ip address IP MSK cuál es el número de ip y la máscara
que va a tener esa interface
Dentro de las interfaces se deben
Router(Config-if)#no shutdown
configurar algunos comandos tales
Router(Config)#clock rate 56000
como encender la interface, el reloj
Expo(config-if)#bandwidth 56
de tráfico y ancho de banda.

Página 12 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

Contraseñas

Contraseñas Consola

Router(Config)#line console 0
Router(Config-line)#password contraseña
Router(Config-line)#login

Contraseña líneas V+y

Router(Config)#line V+y 0 4
Router(Config)#password contraseña
Router(Config)#login

Enable password

Router(Config)#enable password contraseña

Enable secret (encriptado)

Router(Config)#enable secret contraseña

Cifrado de contraseñas

Router(Config)#service password-encryptation

Enrutamiento estático

Router#ip route dirección de red destino MSK red destino IP siguiente salto y tipo
de interfaz saliente

Ej. R2=ip route 192.168.1.0 255.255.255.0 200.100.50.1


Distancia administrativa DA = <0-255> interfaz saliente = 0 IP siguiente salto = 1

Página 13 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

Rutas por defecto (default route)

Ip route red destino MSK Interface siguiente salto interface saliente


0.0.0.0 0.0.0.0 S 0/0
Ej. R1=ip route 0.0.0.0 0.0.0.0 200.100.50.2

Vector – Distancia RIP

Se envían la tabla completa periódicamente aproximadamente cada 30 segundos o


cuando haya un cambio. El router no conoce toda la red, sólo sabe de su vecino.
Se dice que convergen cuando dos protocolos están levantados.

R1(Config)#router rip
R1(Config-router)network IP DE RED

Estado de enlace – OSPF

No envía la tabla de enrutamiento, sino cada vez que hay un cambio. Él si conoce toda
la red.

R1(Config)#router OSPF 1-1024 (#proceso)


R1(Config-router)network IP DE RED METAMÁSCARA

Hibrido – EIGRP

Se envía la tabla constantemente a cada uno de los routers pero con toda la topología.

R1(Config)#router EIGRP 200


R1(Config-router)network IP DE RED

Classful -> MSK default


Classless -> MSK variables

Página 14 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

Es importante tomar en cuenta que se debe redistribuir las redes en los routers cuando
son diferentes clases de enrutamientos dinámicos. Utilizando el siguiente comando:
Router1(config-router)#redistribute ENRUTAMIENTO DINÁMICO
Ej.
Router1(config)#router ospf 1
Router1(config-router)#redistribute Rip

Vlan’s (Redes LAN virtuales)

Configuración de Vlan’s para Switch D-LINK (Des-30106)

Comandos Parámetros
Create vlan <vlan_name32> {tag<vlanID 1-4094>}
Delete vlan <vlan_name32>
Config vlan <vlan_name32>{[add|tagget|untagged|delete]<portlist>}
Show vlan {<vlan_name32>}

Página 15 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

Configuración de Vlan’s para SW-CISCO

Nombre y ID

Switch(config)#vlan ID
Switch(config-vlan)#name nombre

Troncal

Switch(config)#interface f 0/1
Switch(config-if)#switchport mode trunk

Para asignar puertos

Switch(config)#interface range f 0/1 – f 0/5


Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan ID

Asignar Vla’s a la diferentes troncales

Switch(config)#inteface f 0/1
Switch(config-if)#switchport trunk allowed vlan ID, ID…

D-LINK CISCO
Verticales Tagged Trunk
Planos Untagged Access

Configuración de las VLAN’s en el router

La interface f 0/0 no lleva dirección ip. La que lleva ip son las interfaces seriales.
Ej Router(config)#interface f 0/0
Router(config)#no shutdown
Router(config)#interface f 0/0.10
Router(config-subif)#encpsulation dot1q (estandar) o ISL(cisco) ID Vlan
Router(config-subif)#ip address IP MSK

Página 16 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

Comandos para Vlan’s

Comandos Descripción
Muestra la información de la configuración de
Show vlan
la Vlan
Reinicia todo el sistema del Switch para
Reset system (para borrar vlan’s)
borrar todo la configuración previa.

CDP (Cisco Discovery Protocol)

Información básica / Preparación

CDP detecta y muestra información acerca de los dispositivos cisco directamente


conectados incluyendo routers y switches. Se ejecuta en la capa de enlace de datos
del modelo OSI (Capa 2). No hay conflictos con la capa tres.
CDP se inicia automáticamente, cuando se arranca un dispositivo de sistema. Se
puede habilitar en forma global en comandos CDP Run y en interfaces por medio del
comando CDP enable. Con el comando Show CDP interface, se recopila la
información que el CDP utiliza para la transmisión de tramas de descubrimiento y
publicaciones.

Página 17 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

Comandos:
Comando Descripción
Show cdp neighbors Muestra los equipos que se encuntra más cercanos.
Muestra los equipos que se encuntra más cercanos
Show cdp neighbors detail
detallados.

Balanceo de cargas entre varias rutas

Balanceo de cargas por paquete

Ambas interfaces seriales deben usar conmutación de procesos. La conmutación de


procesos obliga al router a buscar la red de destino de cada paquete enrutado en la
tabla de enrutamiento.
En cambio la conmutación rápida, que es el valor por defecto, almacena los resultados
de la búsqueda inicial en un caché de alta velocidad y usa la información para enrutar
los paquetes al mismo destino.

Designación F 0/0 S0 S1 IP S 0 IP S 1 MSK


Router 1 192.168.14.1 DCE DTE 192.168.15.1 192.168.13.1 255.255.255.0
Router 2 192.168.16.1 DTE DCE 192.168.15.2 192.168.13.2 255.255.255.0

Comandos:
 Habilite la conmutación de procesos en ambas interfaces seriales mediante el
comando.
#no ip route-cache
 Verificar #show ip interface
 Observe el proceso de selección de ruta mediante el commando
#debug ip packet en el router GAD
 Envíe 30 paquetes ping através de la red desde el host conectado en BHM hasta
el host conectado en GAD.
#ping 192.168.16.2 –n 30
 Verificar balanceo de cargas por destino

Página 18 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

#ip router-cache
 Use el comando show ip interface para verificar que se haya habilitado la
conmutación rápida.

Nota:
La tabla de enrutamiento se consulta sólo una vez por destino, por lo tanto, todos los
paquetes que forman parte de una cadena de paquetes a un host específicos seguirán
el mismo camino, la ruta alternativa sólo se utilizará cuando va segundo destino
obligue otra consulta de la tabla o cuando se venza la entrada del caché.

DHCP

Comando Descripción
DHCP Discover Para ubicar servidores DHCP disponibles.
DHCP Offer Repuesta del servidor a un paquete. DHCP discover que
contienen los parámetros iniciales.
DHCP Request Solicitudes varias del cliente, por ejemplo para extender la
concesión.
DHCP Pack Respuesta del servidor que contiene los parámetros y la dirección
IP del cliente.
DHCP Nack Respuesta del servidor para indicarle al cliente que su concesión
ha vencido o si el cliente una configuración de red errónea.
DHCP decline El cliente le anuncia al servidor que la IP ya está en uso.
DHCP Release El cliente libera su IP
DHCP Inform El cliente solicita parámetros iniciales, ya tiene su IP.

Comandos:
Router(config)#service DHCP ->Ejecuta el servicio (para el simulador no se usa)
Router(config)#ip DHCP-excluded address IP INICIAL IP FINAL (Le damos un rango de
ip a excluir de direccionamiento – ambos inclusivos)
Router(config)#ip DHCP pool nombre del pool (le damos un nombre al ámbito del
direccionamiento)
Router(config)#network IP(RED) MSK (le damos el ámbito de red.
Router(config-DHCP)#default-rourter IP de default Gateway (Señalamos la ip que
vamos a indicarle a los host como puerta de enlace)
Router(config-DHCP)#lease #días (tiempo de alquiler que le damos al IP a la host, va
de 1 a 365 días –no es un comando obligatorio).

Página 19 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

Listas de Acceso ACL

Aplicar la ACL a una interface


Router(config-if)# {protocol} access-group [access-list-number]

ACL Estándar
Router(config)# Access-list # ACL(1-99) {permit/deny} ip fuente wildcard (0 Compara, 1 Ignora)
Wildcard -> Compara bit a bit
Sumarizar -> buscar un equivalente que le permita hacer un modelo de lo que me están pidiendo
(lógica del usuario).
Comandos:
Router(config)# interface f0/0
Router(config-if)# ip access-group # ACL {in/out}

ACL Extendida
Router(config)# Access-list # ACL(100-199) {permit/deny} protocol IP Fuente wildcard
___ Puerto fuente ip destino wildcard __________ Puerto destino opción
gt -------------------------------------------------- mayor que
dt -------------------------------------------------- menor que
eq -------------------------------------------------- igual que
neg ------------------------------------------------ diferente que
range ---------------------------------------------- rango

{0 -1023} -> Puertos Asignados


{1024 -65335} -> Puertos No Asignados

Estabished

La opción estabished indica que solo pasaran paquetes TCP con los flag ACK (Acuse de Recibo) o
RST (Recibo) activados, es decir, que no permitirá pasar ningún comienzo de conexión con el flag
SyN=1 ACK=0 de inicio de sesión ICP.

Página 20 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

Forzamos que el establecimiento de la conexión se realice en el sentido contrario donde está


establecida la lista de acceso.

Origen Destino

Access Class (Restricción de líneas vty)

Para restringir las conexiones entrantes y salientes entre un vty particular (en un dispositivo de
Cisco) y las direcciones en una lista de acceso, se utiliza Access class de comandos en modo de
configuración. Para eliminar las restricciones de acceso, utilice el no al comando.
Solamente la 3.0 puede entrar con telnet.
Comandos:
R1(config)#access-list 10 permit 192.168.3.0 0.0.0.255
R1(config)#line vty 04
R1(config-if)#access class 10 in

Página 21 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

CAPITULO 4: Curso Redes WAN

Frame Relay

Características

 La conmutación se da por paquetes (no importa por donde vaya, siempre llega)
 Utiliza CIR (Protocolo de ancho de banda)

Terminología de Frame Relay

Velocidad de Acceso Local: Velocidad del puerto hacia la nube de FR.

DLCI (Identificador de conexión de enlace de datos): es un número que identifica el circuito lógico
entre los dispositivos de origen y destino. El Switch FR asigna los DLCI’s entre cada par de routers
para crear un PVC (Private Virtual Circuit).

LMI: es el encargado de administrar la conexión y mantener el estado entre los dispositivos.

Tipos de LMI:

 Cisco
 Ansi
 Q933A

Velocidad de información suscrita (CIR): es la velocidad garantizada en bps, que el proveedor de


servicios (ISP) se compromete a proporcional.

Ráfaga suscrita (BC): es el máximo de bits que un switch se compromete a transferir en un espacio
de tiempo.

Ráfaga Excesiva (BE): es el máximo de bits no comprometidos que el switch-FR trata de transferir
más allá del CIR.

Notación explicita de la congestión (FECN): cuando un SW-FR reconoce que hay una congestión
en la red, envía un paquete FECN al dispositivo destino indicando que se ha producido una
congestión.

Notación explícita de la congestión retrospectiva (BECN) o mutación retrospectiva de la


congestión: cuando un SW-FR en la red reconoce que hay una congestión envía un paquete BECN

Página 22 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

al router de origen, indicándole que reduzca la velocidad en la que está enviando los paquetes. Si
el router recibe un paquete BECN durante un intervalo de tiempo activo, reducirá la velocidad de
trasmisión en un 25%.

Laboratorio Frame Relay – Punto a Punto

Página 23 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

Designa. Nombre Tipo Dirección #DLCI Dirección Prot Contraseñas


del del Router Interface Serial fast
Router
Router 1 Amsterdam DTE 192.168.4.1 102 192.168.1.1 Eigrp Class
192.168.5.1 103 200
Router 2 París DTE 192.168.4.2 201 192.168.2.1 Eigrp Class
192.168.6.1 203 200
Router 3 Berlín DTE 192.168.5.2 301 192.168.3.1 Eigrp Class
168.168.6.2 302 200

Pasos:
Configuración de las interfaces seriales

Amsterdam(Config)#interface s0/0
Amsterdam(Config-if)#encapsulation frame-relay ietf
Amsterdam(Config-if)#frame-relay lmi-type ansi
Amsterdam(Config-if)#description ___________
Amsterdam(Config-if)#no shutdown
Los mismos pasos para Berlin y París

Crear subinterfaces

Amsterdam(Config)#interface serial 0/0.102 pont-to-point


Amsterdam(Config-subif)#description ________________
Amsterdam(Config-subif)#ip address ip msk
Amsterdam(Config-subif)#frame-relay interface-dlci 102

Amsterdam(Config)#interface serial 0/0.103 pont-to-point


Amsterdam(Config-subif)#description ________________
Amsterdam(Config-subif)#ip address ip msk
Amsterdam(Config-subif)#frame-relay interface-dlci 103
Los mismos pasos en Berlín y París
Configurar el protocolo de enrutamiento.

Página 24 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

Configuración de la central

#interface serial 0/0


#no ip address
#encapsulation frame-relay
#ip ospf network broadcast
#interface serial 0/0.100 multipoint
#ip address 10.0.0.1 255.255.255.240
#Frame-relay map ip 10.0.0.2 666 broadcast
#Frame-relay map ip 10.0.0.3 777 broadcast
#Frame-relay map ip 10.0.0.4 888 broadcast
#Frame-relay map ip 10.0.0.5 999 broadcast
#Frame-relay map ip 10.0.0.6 555 broadcast
#Frame-relay map ip 10.0.0.7 444 broadcast
#ip ospf network broadcast
#ip ospf priority 2 -> DR
#router ospf 1
#log-adjacency-changes
#network 10.0.0.0 0.0.0.15 area 0
#network 172.16.0.0 0.0.0.255 area 0

Configuración de sucursal

#interface serial 0/0

Página 25 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

#ip address 10.0.0.0.2/28


#encapsulation frame-relay
#frame-relay map ip 10.0.0.1 100 broadcast
#frame-relay map ip 10.0.0.3 100 broadcast
#frame-relay map ip 10.0.0.4 100 broadcast
#frame-relay map ip 10.0.0.5 100 broadcast
#frame-relay map ip 10.0.0.6 100 broadcast
#frame-relay map ip 10.0.0.7 100 broadcast
#frame-relay interface-DLCI 100
#Ip ospf network broadcast
#router ospf1
#log-adjacency-change
#network 10.0.0.0 0.0.0.15 area 0
#network 172.16.1.0 0.0.0.255 area 0

La misma configuración para suc 2, 3, 4, 5 y 6 (Cambiando mapeo y #DLCI’s)

Convertir Router a Switch Frame-Relay (ppp)

Convertir Router a Switch Frame-Relay

Fr-switch(config)#interface serial 0/0


Fr-switch(config-if)#frame-relay router 102 interface serial 0/1 201
Fr-switch(config-if)#interface serial 0/1
Fr-switch(config-if)#frame-relay route 201 interface serial 0/0 102

Verificación
#show frame-relay route

Página 26 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

Configurar routers locales

SJ(config)#interface serial 0/0


SJ(config-if)#encapsulation frame-relay
SJ(config-if)#ip address 192.168.192.1 255.255.255.0
SJ(config-if)#exit
SJ(config-)#router eigrp 224
SJ(config-router)#network 192.168.0.0
SJ(config-router)#network 192.168.192.0

Verificación

#show ip route

NAT (Network address Traslation)


Nat dinámico y estático

El ISP ha asignado a una empresa la dirección IP pública de enrutamiento entre


dominios sin clase (CIDR) 199.99.9.32/27.

Esto equivale a 30 direcciones IP públicas. Como la empresa tiene la necesidad


interna de más de 30 direcciones IP pública, el gerente de TI ha decidido utilizar NAT.

Las direcciones 199.99.9.33-199.99.9.39 se reservan para la asignación estática y


199.199.9.40 – 199.99.9.62 para la asignación dinámica.

Pasos:
Crear una ruta estática:
ISP(config)#ip route 199.99.9.32 255.255.255.224 200.2.2.18

Crear una ruta por defecto


GATEWAY(config)#ip route 0.0.0.0 0.0.0.0 200.2.2.17

Definir el conjunto de direcciones IP públicas utilizables.


GATEWAY(config)#ip nat pool LAN01 199.99.9.40 199.99.9.62 netmaste
255.255.255.224

Página 27 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

Definir una lista de acceso que coincida con las direcciones Ip privadas internas
GATEWAY(config)#access-list 10 permit 10.10.10.0 0.0.0.255

Definir la traducción NAT de la lista interna al conjunto externo


GATEWAY(config)#ip nat inside source list 10 pool LAN01

Especificar las interfaces


GATEWAY(config)#interface f0/0
GATEWAY(config-if)#ip nat inside
GATEWAY(config-if)#interface s0/0/0
GATEWAY(config-if)#ip nat outside

Configurar el mapeo estático


GATEWAY(config)#ip nat inside source static 10.10.10.10 199.99.9.33
GATEWAY(config)#ip nat inside source static 10.10.10.100 199.99.9.34

Verificación:
Show ip nat translation

PAT (Port address Traslation)

Nombre Dir f0/0 Tipo Serial 0/0 Looback


GATEWAY 10.10.10.0/24 DCE 200.2.2.18/30 N.A.
ISP N.A. DTE 200.2.2.17/30 172.16.1.1/32

Rutas por defecto:

Gateway(config)#ip route 0.0.0.0 0.0.0.0 serial 0


ISP(config)#ip route 199.99.9.32 255.255.255.224 200.2.2.18

Crear ACL que coincida con las IP privadas internas.

Gateway(config)#access-list 1 permit 10.10.10.0 0.0.0.255

Definir traducción PAT

Gateway(config)#ip nat inside source list 1 interface serial overload

Página 28 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

Especificar las interfaces

Gateway(config)#interface f0/0
Gateway(config-if)#ip nat inside
Gateway(config-if)#interface s0/0
Gateway(config-if)#ip nat out side

Verificación

#show ip nat traslation

Red digital de Servicios Integrados (RDSI o ISDN)

Características:

Trasmite voz y datos

Bri:

 Funciona con 2 líneas


 Actualmente se utiliza como 2 líneas
 Mayor distancia que el ADSL
 Velocidad de 128 Kbps con 2 canales B de 64 kbps cada uno

Pri:

 En USA 23B+D
 En Europa 30B+D
 D = 64 Kbps

Conmutación por circuitos

Página 29 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

DDR Legado

Dial on Demanding Routing

Dirección
Designación Nombre del Contraseña
Contraseñas fastethernet
del Router Router enable secret
/MCK
ROUTER 1 Tokyo Class Cisco 192.168.1.1/24
ROUTER 2 Moscow Class cisco 192.168.2.1/24

Designación Nombre del Números del Conexión


Números SPID
del Router Router Tel ADTRAN
51055510000001 5551000
Router 1 Tokyo Bri 1
51055510010001 5551001
51055520000001 5552000
Router 2 Moscow Bri 2
51055520010001 5552001

Configurar un Router ISDN para hacer una llamada de enrutamiento por llamada
telefónica bajo demanda (DDR) a otro Router habilitado para ISDN.

Cuando la conexión DDR se realiza con éxito, ampliar la configuración para especificar
que sólo el tráfico de http active el enlace.

Paso 1: definir el tipo de switch y los números de spid.

Es necesario especificar el tipo de switch y los números de spid en los routers.


Router(config)#hostname tokyo
Tokyo(config)#enable secret class
Tokyo(config)#isdn-switch-type basic-ni
Tokyo(config)#int f0/0

Página 30 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

Tokyo(config)#Ip address 192.168.1.1/24


Tokyo(config)#no shutdown
Tokyo(config)#int bri 0/0
Tokyo(config)#Isdn spid 1 51055510000001 5551000
Tokyo(config)#Isdn spid 2 51055510010001 5551001
Tokyo(config)#no shutdown
Moscow(config)#enable secret class
Moscow(config)#isdn switch-type basic-ni
Moscow(config)#int f0/0
Moscow(config)#ip address 192.168.2.1/24
Moscow(config)#no shutdown
Moscow(config)#int bri 0/0
Moscow(config)# Isdn spid 1 51055520000001 5552000
Moscow(config)# Isdn spid 2 51055520010001 5552001
Moscow(config)#no shutdown

Definir rutas estáticas


Moscow(config)#ip route 192.168.1.0/24 192.168.3.1
Tokyo(config)#ip route 0.0.0.0 0.0.0.0 192.168.3.2

Definer el tráfico de interés para el DDR


Tokyo(config)#dialer-list 1 protocol ip permit
Tokyo(config)#interface bri 0/0
Tokyo(config)#dialer-group 1

Configuración de la información del marcador


Tokyo(Config)#username moscow password class
Tokio(config)#int bri 0/0
Tokio(config)#encapsulation ppp
Tokio(config)#ppp authentication chap

Moscow(config)#dialer-list 1 protocol ip permit


Moscow(config)#username Tokyo password class
Moscow(config)#interface bri 0/0
Moscow(config-if)#ip address 192.168.3.2 255.255.255.0
Moscow(config-if)#dialer group 1
Moscow(config-if)#encapsulation ppp
Moscow(config-if)#ppp authentication chap
Moscow(config-if)#dialer idle-timeout 120
Moscow(config-if)#dialer map ip 192.168.3.1 name Tokyo 5551000

Tokyo(config)#interface bri 0/0


Tokyo(config)#dialer idle-timeout 120
Tokyo(config)#dialer map ip 192.168.3.2 name Moscow 5552000

Página 31 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

Backup RDSI

Configuración de Backup

Sc(config)#interface s0/0

Sc(config)#backup interface bri 0/0

Sc(config)#backup delay 6 8

Página 32 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

CAPÍTULO 3: Conclusiones

 Es necesario conocer las características básicas que se requieren a la hora de


configurar un Router, ya que estas nos permiten comunicarnos, además nos da
la posibilidad de implementar una solución puesto que generan graves riesgos de

seguridad para una red si no se toman las medidas adecuadas.


 A medida que avanza la historia computacional, sé a demostrado lo útil y fácil que es
compartir información entre computadoras.
 Una red computacional requiere para poder interactuar entre si los protocolos,
ya que estos permiten que puedan comunicarse equipos de diferentes
fabricantes, diferente hardware y software.
 Un manual nos permite organizar los diferentes comandos escritos en clase e
investigados, para contar con una herramienta de una forma más rápida y ágil.

Página 33 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

CAPÍTULO 4: Bibliografía

Bloc CCNA. (2005) Aprende Redes.com: CCNA en Español. [On line]. Disponible:
http://www.aprenderedes. com/

Bloc de Miguel. (2007, Abril 21) Bloc de Miguel: Comandos para un router. [On line]. Disponible:
http://blog.pucp.edu.pe/item/9135

Junior, R. (2008) Commandos Routers. [On line]. Disponible:


http://www.rjunior.com.br/download/commandosrouter.pdf

Buchmann, M. (2000). Cisco Certified Network Associate, Study guide, Segunda Edición. Estados
Unidos: Osborne.

Cisco Systems, Inc. (2003). Academia de Networking de Cisco Systems: Guía del primer año.
Segunda Edición. Madrid: Pearson Educación, S.A.

Página 34 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

CAPÍTULO 5: Anexos

Modelo OSI

1. Física
2. Enlace de datos (dirección MAC)
3. Red IP (Router –OSPF, EIGRP, RIP – Dirección IP)
4. Transporte (TCP, UDP, ACK’s)
5. Sesión
6. Presentación
7. Aplicación (Http, pop, smtp, ftp, telnet)

Tipos de cables

PC
CROSSOVER PC

SWITCH
DIRECTO PC

ROUTER
CROSSOVER PC

DIRECTO
SWITCH
ROUTER

Protocolos TCP-UDP y sus puertos

Puerto/pro Descripción
tocolo
n/d / GRE GRE (protocolo IP 47) Enrutamiento y acceso remoto
n/d / ESP IPSec ESP (protocolo IP 50) Enrutamiento y acceso remoto
n/d / AH IPSec AH (protocolo IP 51) Enrutamiento y acceso remoto
1/tcp Multiplexor TCP
7/tcp Protocolo Echo (Eco) Responde con eco a llamadas remotas
7/udp Protocolo Echo (Eco) Responde con eco a llamadas remotas
9/tcp Protocolo Discard Elimina cualquier dato que recibe

Página 35 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

9/udp Protocolo Discard Elimina cualquier dato que recibe


13/tcp Protocolo Daytime Fecha y hora actuales
17/tcp Quote of the Day (Cita del Día)
19/tcp Protocolo Chargen Generador de caracteres
19/udp Protocolo Chargen Generador de caracteres
20/tcp FTP File Transfer Protocol (Protocolo de Transferencia de Ficheros) - datos
21/tcp FTP File Transfer Protocol (Protocolo de Transferencia de Ficheros) - control
22/tcp SSH, scp, SFTP
23/tcp Telnet comunicaciones de texto inseguras
25/tcp SMTP Simple Mail Transfer Protocol (Protocolo Simple de Transferencia de Correo)
37/tcp Time
43/tcp Nicname
53/tcp DNS Domain Name System (Sistema de Nombres de Dominio)
53/udp DNS Domain Name System (Sistema de Nombres de Dominio)
67/udp BOOTP BootStrap Protocol (Server), también usado por DHCP
68/udp BOOTP BootStrap Protocol (Client), también usado por DHCP
69/udp TFTP Trivial File Transfer Protocol (Protocolo Trivial de Transferencia de Ficheros)
70/tcp Gopher
79/tcp Finger
80/tcp HTTP HyperText Transfer Protocol (Protocolo de Transferencia de HiperTexto) (WWW)
88/tcp Kerberos Agente de autenticación
110/tcp POP3 Post Office Protocol (E-mail)
111/tcp Sunrpc
113/tcp ident (auth) antiguo sistema de identificación
119/tcp NNTP usado en los grupos de noticias de usenet
123/udp NTP Protocolo de sincronización de tiempo
123/tcp NTP Protocolo de sincronización de tiempo
135/tcp Epmap
137/tcp NetBIOS Servicio de nombres
137/udp NetBIOS Servicio de nombres
138/tcp NetBIOS Servicio de envío de datagramas
138/udp NetBIOS Servicio de envío de datagramas
139/tcp NetBIOS Servicio de sesiones
139/udp NetBIOS Servicio de sesiones
143/tcp IMAP4 Internet Message Access Protocol (E-mail)
161/tcp SNMP Simple Network Management Protocol
161/udp SNMP Simple Network Management Protocol
162/tcp SNMP-trap
162/udp SNMP-trap
177/tcp XDMCP Protocolo de gestión de displays en X11
177/udp XDMCP Protocolo de gestión de displays en X11
389/tcp LDAP Protocolo de acceso ligero a Bases de Datos
389/udp LDAP Protocolo de acceso ligero a Bases de Datos
443/tcp HTTPS/SSL usado para la transferencia segura de páginas web
445/tcp Microsoft-DS (Active Directory, compartición en Windows, gusano Sasser, Agobot)
445/udp Microsoft-DS compartición de ficheros
500/udp IPSec ISAKMP, Autoridad de Seguridad Local
512/tcp Exec
513/tcp Login

Página 36 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

514/udp syslog usado para logs del sistema


520/udp RIP
591/tcp FileMaker 6.0 (alternativa para HTTP, ver puerto 80)
631/tcp CUPS sistema de impresión de Unix
666/tcp identificación de Doom para jugar sobre TCP
993/tcp IMAP4 sobre SSL (E-mail)
995/tcp POP3 sobre SSL (E-mail)
1080/tcp SOCKS Proxy
1337/tcp suele usarse en máquinas comprometidas o infectadas
1352/tcp IBM Lotus Notes/Domino RCP
1433/tcp Microsoft-SQL-Server
1434/tcp Microsoft-SQL-Monitor
1434/udp Microsoft-SQL-Monitor
1494/tcp Citrix MetaFrame Cliente ICA
1512/tcp WINS
1521/tcp Oracle listener por defecto
1701/udp Enrutamiento y Acceso Remoto para VPN con L2TP.
1723/tcp Enrutamiento y Acceso Remoto para VPN con PPTP.
1761/tcp Novell Zenworks Remote Control utility
1863/tcp MSN Messenger
1935/??? FMS Flash Media Server
2049/tcp NFS Archivos del sistema de red
2082/tcp CPanel puerto por defecto
2086/tcp Web Host Manager puerto por defecto
2427/upd Cisco MGCP
3030/tcp NetPanzer
3030/upd NetPanzer
3128/tcp HTTP usado por web caches y por defecto en Squid cache
3128/tcp NDL-AAS
3306/tcp MySQL sistema de gestión de bases de datos
3389/tcp RDP (Remote Desktop Protocol)
3396/tcp Novell agente de impresión NDPS
3690/tcp Subversion (sistema de control de versiones)
4662/tcp eMule (aplicación de compartición de ficheros)
4672/udp eMule (aplicación de compartición de ficheros)
4899/tcp RAdmin (Remote Administrator), herramienta de administración remota (normalmente
troyanos)
5000/tcp Universal plug-and-play
5060/udp Session Initiation Protocol (SIP)
5190/tcp AOL y AOL Instant Messenger
5222/tcp XMPP/Jabber conexión de cliente
5223/tcp XMPP/Jabber puerto por defecto para conexiones de cliente SSL
5269/tcp XMPP/Jabber conexión de servidor
5432/tcp PostgreSQL sistema de gestión de bases de datos
5517/tcp Setiqueue proyecto SETI@Home
5631/tcp PC-Anywhere protocolo de escritorio remoto
5632/udp PC-Anywhere protocolo de escritorio remoto
5400/tcp VNC protocolo de escritorio remoto (usado sobre HTTP)
5500/tcp VNC protocolo de escritorio remoto (usado sobre HTTP)

Página 37 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

5600/tcp VNC protocolo de escritorio remoto (usado sobre HTTP)


5700/tcp VNC protocolo de escritorio remoto (usado sobre HTTP)
5800/tcp VNC protocolo de escritorio remoto (usado sobre HTTP)
5900/tcp VNC protocolo de escritorio remoto (conexión normal)
6000/tcp X11 usado para X-Windows
6112/udp Blizzard
6129/tcp Dameware Software conexión remota
6346/tcp Gnutella compartición de ficheros (Limewire, etc.)
6347/udp Gnutella
6348/udp Gnutella
6349/udp Gnutella
6350/udp Gnutella
6355/udp Gnutella
6667/tcp IRC IRCU Internet Relay Chat
6881/tcp BitTorrent puerto por defecto
6969/tcp BitTorrent puerto de tracker
7100/tcp Servidor de Fuentes X11
7100/udp Servidor de Fuentes X11
8000/tcp iRDMI por lo general, usado erróneamente en sustitución de 8080. También utilizado en el
servidor de streaming ShoutCast.
8080/tcp HTTP HTTP-ALT ver puerto 80. Tomcat lo usa como puerto por defecto.
8118/tcp Privoxy
9009/tcp Pichat peer-to-peer chat server
9898/tcp Gusano Dabber (troyano/virus)
10000/tcp Webmin (Administración remota web)
19226/tcp Panda SecurityPuerto de comunicaciones de Panda Agent.
12345/tcp NetBus en:NetBus (troyano/virus)
31337/tcp Back Orifice herramienta de administración remota (por lo general troyanos)

Ejemplos de Listas de Acceso Estándar

1. Denegar la Red de RA a RB
RB(config)# access-list 10 deny 192.168.1.0 0.0.0.255
2. Denegar las redes pares y permitir el resto
RB(config)# Access-list 20 deny 192.168.1.2(3) 0.0.0.254 [2 es par y 3 impar]
RB(config)# Access-list 20 permit 192.168.1.15 0.0.0.254
RB(config)# Access-list 20 permit any
3. Denegar los host 192.168.1.15 y 192.168.1.21 hacia la red de RB y permitir el resto
RB(config)# Access-list 35 deny 192.168.1.15 0.0.0.0
RB(config)# Access-list 35 deny host 192.168.1.21
RB(config)# Access-list 35 permit any
4. Deniegue las redes 192.168.0.0, 192.168.4.0, 192.168.8.0 y 192.168.12.0 de origen hacia la red del
RB mediante sumarizar.

Página 38 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

# access-list 25 deny 192.168.{cualquiera 0,4,8,12}.{cualquiera 1-255} 0.0.12.255


5. Vlan 20 no puede tener acceso a Vlan40 (trafico ip).
RC(config)# Access-list 40 deny 192.168.2.0 0.0.0.255
6. Vlan 20 (RB) no tiene ningún tipo de acceso a la red interna de RA.
RA(config)#access-list 50 deny 192.168.2.0 0.0.0.255
RA(config)#access-list 50 permit any

Ejemplos de Listas de Acceso Extendidas

1. Los host impares de Vlan 10 (RD) no puede tener acceso por página web al servidor Http
RD(config)#access-list 100 deny TCP 192.168.10.3/ 0.0.0.254 gt 1023 host 192.168.30.2 eq 80
RD(config)#access-list 100 permit ip any any
2. Vlan 10 (RB) no puede tener acceso mediante ICMP al servidor Http, pero si por pagina web
RB(config)#access-list 101 deny ICMP 192.168.1.0 0.0.0.255 host 192.168.30.2
RB(config)#access-list 101 permit TCP 192.168.1.0 0.0.0.255 gt 1023 any eq 80
RB(config)#access-list 101 permit IP any any
3. Denegar el servicio Http del host 192.168.1.3 hacia el servidor interno de RB (TCP)
El host 192.168.1.2 no puede hacer ping al servidor 10.10.10.20 de RB (ICMP)
El resto de trafico no es permitido
RA(config)# Access-list 100 deny TCP host 192.168.1.3 gt 1023 host 10.10.10.10 eq 80
RA(config)# Access-list 100 deny ICMP host 192.168.1.2 host 10.10.10.20
RA(config)# Access-list 100 permit TCP host 192.168.1.3 gt 1023 any eq 80
RA(config)# Access-list 100 permit ip any any

Tabla de Subneteo

Binario Decimal CIDR HOSTs Clase


11111111.11111111.11111111.11111111 255.255.255.255 /32 0
11111111.11111111.11111111.11111110 255.255.255.254 /31 1
11111111.11111111.11111111.11111100 255.255.255.252 /30 4
11111111.11111111.11111111.11111000 255.255.255.248 /29 8
11111111.11111111.11111111.11110000 255.255.255.240 /28 16
11111111.11111111.11111111.11100000 255.255.255.224 /27 32
11111111.11111111.11111111.11000000 255.255.255.192 /26 64
11111111.11111111.11111111.10000000 255.255.255.128 /25 128
11111111.11111111.11111111.00000000 255.255.255.0 /24 256 C

Página 39 de 40
Manual de Comandos para Enrutamiento
Instituto Nacional de Aprendizaje

11111111.11111111.11111110.00000000 255.255.254.0 /23 512


11111111.11111111.11111100.00000000 255.255.252.0 /22 1024
11111111.11111111.11111000.00000000 255.255.248.0 /21 2048
11111111.11111111.11110000.00000000 255.255.240.0 /20 4096
11111111.11111111.11100000.00000000 255.255.224.0 /19 8192
11111111.11111111.11000000.00000000 255.255.192.0 /18 16384
11111111.11111111.10000000.00000000 255.255.128.0 /17 32768
11111111.11111111.00000000.00000000 255.255.0.0 /16 65536 B
11111111.11111110.00000000.00000000 255.254.0.0 /15 131072
11111111.11111100.00000000.00000000 255.252.0.0 /14 262144
11111111.11111000.00000000.00000000 255.248.0.0 /13
11111111.11110000.00000000.00000000 255.240.0.0 /12
11111111.11100000.00000000.00000000 255.224.0.0 /11
11111111.11000000.00000000.00000000 255.192.0.0 /10
11111111.10000000.00000000.00000000 255.128.0.0 /9
11111111.00000000.00000000.00000000 255.0.0.0 /8 A
11111110.00000000.00000000.00000000 254.0.0.0 /7
11111100.00000000.00000000.00000000 252.0.0.0 /6
11111000.00000000.00000000.00000000 248.0.0.0 /5
11110000.00000000.00000000.00000000 240.0.0.0 /4
11100000.00000000.00000000.00000000 224.0.0.0 /3
11000000.00000000.00000000.00000000 192.0.0.0 /2
10000000.00000000.00000000.00000000 128.0.0.0 /1
00000000.00000000.00000000.00000000 0. /0

Página 40 de 40