Está en la página 1de 8

PRIMER PARCIAL CÓDIGO: 9917777

CI: 9917777 LP

NOMBRE: ABNER ROLI LARICO


NOTA:
VARGAS
FIRMA
CARRERA: CIENCIAS BÁSICAS ASIGNATURA: PROGRAMACIÓN FECHA: 2/SEP/2021
CURSO: 2do Semestre DOCENTE: M.Sc. Lic. CYNTHIA RODRIGUEZ C.
1. ALGORITMOS Y PROGRAMACIÓN
UNIDADES
2. ESTRUCTURAS SECUENCIALES
TEMÁTICAS A EVALUAR
3. ESTRUCTURAS SELECTIVAS

RECOMENDACIONES A LOS ESTUDIANTES


1. Los estudiantes tienen 5 (Cinco) minutos para interpretar el examen y solicitar aclaraciones al docente.
2. El RAC-07 (RÉGIMEN DISCIPLINARIO), en el CAP IV. FALTAS Y SANCIONES, Art. 20 tipifica el
FRAUDE O INTENTO DE FRAUDE EN EXÁMENES, como “CAUSAL DE SEPARACIÓN SIN
DERECHO A REINCORPORACIÓN” de la EMI.
3. Mediante TEAMS el estudiante está en la obligación de permanecer conectado durante el desarrollo de
la prueba
4. Tiempo de Duración:

a. “90 Minutos” para resolver el EXAMEN


b. “15 Minutos” para subir el EXAMEN a la plataforma TEAMS.

1
PREGUNTA 2.
Realice una explicación de los componentes “periféricos” de salida de un computador.

2
PREGUNTA 3.
Brevemente describa las características de la Tercera Generación.

3
PREGUNTA 4.
Realizar las siguientes conversiones:

4
PREGUNTA 5:
Hacer leer un numero A, evaluar sucesivamente las expresiones siguientes y
desplegar los resultados obtenidos: a. B=A+20 b. C=4B+A c. D=A+B+C/2

5
PREGUNTA 6
Dado un numero de 3 dígitos obtener el digito mayor

N= 361 DM = 6

N=761 DM= 7

N = 189 DM=9

PASO 1:
ENTRADA: variables n, digito_mayor como entero
PROCESO:
1. Definir x Como carácter
2. Leer n
3. x <- ConvertirAtexto(n)
4. Si Longitud(x)=3 Entonces
5. digito_mayor <- 0
6. Para a<-0 Hasta 3 Hacer
7. Si ConvertirANumero(subcadena(x,a,a))>digito_mayor Entonces
8. digito_mayor <- ConvertirANumero(subcadena(x,a,a))
9. Si digito_mayor MOD 2==0 Entonces
10. digito mayor es',digito_mayor,'el numero es par'
11. el digito mayor es:',digito_mayor,'el numero es impar'
12. Mostrar el número no es de 3 digitos'
SALIDA: Mostrar el número no es de 3 digitos'(digito_mayor)

6
PASO 2:
PSEUDOCODIGO.
Algoritmo t
Definir a,digito_mayor Como Entero
Definir x Como Caracter
Escribir 'Ingresa un numero de 3 digitos'
Leer n
x <- ConvertirAtexto(n)
Si Longitud(x)=3 Entonces
digito_mayor <- 0
Para a<-0 Hasta 3 Hacer
Si ConvertirANumero(subcadena(x,a,a))>digito_mayor Entonces
digito_mayor <- ConvertirANumero(subcadena(x,a,a))
FinSi
FinPara
Si digito_mayor MOD 2==0 Entonces
Escribir 'digito mayor es',digito_mayor,'el numero es par'
SiNo
Escribir 'el digito mayor es:',digito_mayor,'el numero es impar'
FinSi
SiNo
Escribir 'el numero no es de 3 digitos'
FinSi

DIAGRAMA DE FLUJO

7
PASO 3.
PRUEBA DE ESCRITORIO

n digito_mayor MOSTRAR
El numero
123 3
mayor es 3
El numero
361 6
mayor es 6

También podría gustarte