Está en la página 1de 6

PLAN DE CLASE ÁREA DE INFORMÁTICA

TERCER PERIODO
Fecha: Septiembre 4 al 20 de 2021 Grado: Décimo Tiempo: 3 horas
Unidad temática: Estructuras de control y Procedimientos en programación
Competencia: Reconozco principios y conceptos propios de la tecnología, así como momentos de
la historia que le han permitido al hombre transformar el entorno para resolver problemas y satisfacer
necesidades.
Objetivos: Ejercitar el manejo de eventos en programación.

Momentos Actividad
¿Qué voy a aprender? Qué es un procedimiento en programación y para qué
sirve, además de afianzar las estructuras de control.
Lo que estoy aprendiendo. Realizar lectura detenida de la guía donde se muestra la
sintaxis o la forma en que se estructuran los procedimientos
para simplificar los programas.
Práctico lo que aprendí. Realizar el taller propuesto, en el cual se busca que el
estudiante logre practicar y afianzar el conocimiento sobre
estructuras de control y procedimientos en programación.
¿Cómo sé que aprendí? Una vez desarrollado enviar su trabajo al correo electrónico
informaticaitap@gmail.com o en físico a la biblioteca del
colegio debidamente marcado para su identificación.

Recursos Fotocopias, computador (si dispone de uno), videos, internet


(si dispone del servicio).
Enlaces ENLACES DE CONSULTA
https://www.youtube.com/watch?v=2QCVl9FeS7k
https://www.fio.unicen.edu.ar/usuario/ariera/b6-0/Trabajos/FuncionesPseInt.pdf
https://www.youtube.com/watch?v=RqS2puf7jkQ
https://www.youtube.com/watch?v=IodrgA_TmlI
PROCEDIMIENTOS
Al incrementar el tamaño de un programa, es imperativo
hacerlo de manera ordenada y prolija. De lo contrario, la
claridad inicial puede ofuscarse y nuestras creaciones se
transformarán en objetos de software de difícil decodificación.
Una estrategia para lidiar con el problema de un programa de
gran tamaño consiste en dividirlo en partes más pequeñas de
forma tal que, al combinar las soluciones, se pueda resolver el
problema original. En las actividades de este capítulo ponemos
en práctica esta idea usando una construcción presente en la
gran mayoría de los lenguajes de programación: los
procedimientos.
Pseudocódigo Sub Procesos

Las Sub Procesos son bloques de código utilizados para dividir un programa en partes más pequeñas,
cada una de las cuáles tendrá una tarea determinada, estos son la base de la programación
estructurada.

Permiten dar nombre a un grupo de instrucciones y que estas se ejecuten cuando las nombremos.
En PSeInt los subprocesos se crean con la instrucción SubProceso.

Podemos clasificar lo subprocesos en tres tipos:


• Acciones
✓ No aceptan entradas y no retornan valores.
✓ Solo realizan acciones.
• Acciones con parámetros

MELBA SUSANA CHAPARRO GOMEZ 1


✓ Aceptar valores de entrada que influyen en su ejecución.
• Funciones
✓ Realizan cálculos y retornan valores.

Procedimientos informáticos

También llamado función o rutina, en informática, un procedimiento representa una serie de


instrucciones que se agrupan con un mismo fin. Un programa de mediana complejidad, un videojuego
e incluso una página web suelen contener no uno sino varios de estos conjuntos de tareas. Cada
función recibe un nombre y el propósito de su existencia es que se la pueda utilizar cada vez que se
necesite, dentro del contexto en que la aplicación lo permita.

Si tomamos el juego Tetris como ejemplo, cada vez que una pieza termina de caer, se ejecuta una
rutina que verifica si se ha completado alguna línea; de dar un resultado positivo, probablemente otro
procedimiento se encargue de borrar las filas correspondientes, para finalmente continuar con la
partida. En las aplicaciones que utilizamos a diario, es común encontrar opciones para guardar, abrir,
crear nuevo documento y cerrar, y detrás de ellas, se encuentra al menos una función.

Llevándolo a términos de la vida no informática, el ejemplo más común suele ser el de la receta para
una torta. Si la comparamos con un programa, entonces cada uno de sus pasos que conlleven cierta
complejidad y que se necesario repetir, como ser revolver, batir, mezclar, podrían considerarse
funciones, ya que tienen un nombre que las identifica y consisten de al menos una acción que
realizaremos más de una vez a lo largo del proceso.

La resolución de problemas complejos se facilita considerablemente si se dividen en problemas más


pequeños; y la resolución de estos subproblemas se realiza mediante subalgoritmos.
Los subalgoritmos son unidades de programa o módulos que están diseñados para ejecutar laguna
tarea específica. Éstos, constituidos por funciones o procedimientos, se escriben solamente una vez,
pero pueden ser referenciados en diferentes puntos del programa, de modo que se puede evitar la
duplicación innecesaria del código.
El módulo principal se ejecuta en una primera instancia, que da la orden de inicio de ejecución de los
subprogramas. Puede ser ejecutado n veces. Es importante saber que datos se van a compartir entre
los programas.
El subprograma es un programa en sí mismo, ejecutado por la solicitud del programa principal o de
otro subprograma, una n cantidad de veces. Cuando realiza la solicitud, el programa se detiene hasta
que el subprograma deja de realizar su tarea, luego continúa; esto se conoce como control de
ejecución.
Ejemplos del uso de subprocesos: 1. Crear un subproceso que permita ingresar los días de la semana.

MELBA SUSANA CHAPARRO GOMEZ 2


SubProceso semana(dias,d) Algoritmo dias_semana
Para i=1 Hasta d Con Paso 1 Hacer Escribir "Ingrese los dias a mostrar"
Imprimir "Ingrese el ",i," día de la semana:" Leer d
Leer dias[i] Dimension dias[d]
FinPara semana(dias,d)
Fin SubProceso FinAlgoritmo

|
RESULTADO DE LA EJECUCIÓN

Observa que el subproceso se llama semana y es


utilizado por el programa principal dias_semana.

2. Preguntar a un usuario si tiene número telefónico e imprimir si es teléfono fijo o teléfono móvil.

SubAlgoritmo tel_movil() SubAlgoritmo tel_fijo()


Escribir "Ingrese su número de teléfono móvil" Escribir "Ingrese su número de teléfono fijo"
Leer tel Leer tel
Si tel < 9999999 Entonces Si tel > 9999999 Entonces
Escribir "No es un teléfono móvil" Escribir "No es un teléfono fijo"
Escribir "Tienen que ser 9 dígitos" Escribir "Tienen que ser 7 dígitos"
FinSi 1 FinSi 2
FinSubAlgoritmo FinSubAlgoritmo
Algoritmo Ejercicio3 RESULTADO DE LA EJECUCIÓN
Escribir "Tiene número telefónico"
Leer res Observa que los dos subprocesos tel_movil y
Si res ="no" Entonces tel_fijo son llamados en el programa principal
Escribir "Usted no tiene número telefónico" Ejercicio3
SiNo
Si res = "si" Entonces
Escribir "Que tipo de teléfono posee"
Leer telef
Si telef= "teléfono fijo" Entonces
tel_fijo()
SiNO
Si telef="teléfono móvil" Entonces
tel_movil()
FinSI
FinSi
SiNo
Escribir "El número es móvil"
FinSi
3
FinSi
FinAlgoritmo

MELBA SUSANA CHAPARRO GOMEZ 3


ACTIVIDAD

Teniendo en cuenta la siguiente situación y dado el subproceso, hacer el programa principal que de
solución a la situación planteada:

1. Ingresar los días de la semana hasta ingresar PROGRAMA PRINCIPAL


el día domingo e identificar como día no
laborable.

SubAlgoritmo dias()
Definir dia como Cadena
Repetir
Escribir "Ingrese el día"
Leer dia
Si dia<>"domingo" Entonces
Escribir " Dia laborable "
FinSi
Hasta Que dia="domingo"
Si dia="domingo" Entonces
Escribir " * Dia no laborable * "
FinSi
FinSubAlgoritmo

2. Mostrar los perímetros de 5 figuras SubProceso calcular(op)


geométricas. Definir l1,l2 como Real;
Leer fig
Si fig == 1 Entonces
SubProceso menu() Escribir "Ingrese el valor de un lado:";
Escribir "1.- CUADRADO"; Leer l1;
Escribir "2.- RECTANGULO"; pt<-l1*4;
Escribir "3.- TRIANGULO"; Escribir "El perímetro del cuadrado es : ",pt;
Escribir "4.- PENTAGON0"; SiNo
Escribir "5.- SALIR"; Si fig ==2 Entonces
Escribir ""; Escribir "Ingrese el valor de la base:";
Escribir "Figura: "; Leer l1;
FinSubProceso Escribir "Ingrese el valor de la altura:";
Leer l2;
PROGRAMA PRINCIPAL pt<-(l1*2) + (l2*2);
Escribir "El perímetro del rectángulo es : ",pt;
SiNo
Si fig ==3 Entonces
Escribir "Ingrese el valor del lado:";
leer l1;
pt<-l1*3;
Escribir "El perímetro del triángulo es : ",pt;
SiNo
Si fig ==4 Entonces
Escribir "Ingrese el valor del lado:";
RESULTADO DE LA EJECUCIÓN

leer l1;
pt<-l1*5;
Escribir "El perímetro del pentágono es : ",pt;
FinSi
FinSi
FinSi
FinSi
FinSubProceso

MELBA SUSANA CHAPARRO GOMEZ 4


3. Ejecutar las operaciones básicas PROGRAMA PRINCIPAL
empleando subprocesos.
Algoritmo Ejercicio3
Definir alt Como Entero;
SubProceso operacion(c) alt<-0;
Definir n1,n2 como Real; Repetir
Limpiar Pantalla;
Escribir "Lectura de los valores
operaciones();
numericos" Leer alt;
Escribir "Ingrese el 1° numero :"; Segun alt Hacer
Leer n1; 1:
Escribir "Ingrese el 2° numero :"; operacion(alt);
Leer n2; 2:
operacion(alt);
Segun c Hacer 3:
1: operacion(alt);
resultado<-n1+n2; 4:
2: operacion(alt);
resultado<-n1-n2; De Otro Modo:
Escribir " Cerrar";
3:
FinSegun
resultado<-n1*n2; Hasta Que (alt<1 || alt>4);
4: FinAlgoritmo
resultado<-n1/n2;
De Otro Modo:

FinSegun
Escribir "El resultado de la Operacion es :
",resultado;
Esperar Tecla;
FinSubProceso
RESULTADO DE LA EJECUCIÓN
SUBPROCESO QUE FALTA

HORARIOS DE ATENCIÓN
JUEVES: 7:00 a 7:40 DÉCIMO GRADO
PADRES DE FAMILIA: MIERCOLES Y JUEVES DE 8:20 A 9:00
ESTUDIANTES: MIERCOLES Y VIERNES DE 10:00 A 10:40

MELBA SUSANA CHAPARRO GOMEZ 5


VALORO MI TRABAJO

PREGUNTAS RESPUESTAS

1 ¿Comprendí rápidamente cómo


elaborar las actividades?

2 De todas las actividades planteadas por


el docente ¿en cuál se me presentaron
mayores dificultades?

3 ¿Realicé solo las actividades o con


ayuda de algún adulto?

4 ¿Fueron claras las orientaciones del


docente? ¿Sí? ¿No? ¿Por qué?

5 ¿Destiné tiempo suficiente para realizar


las actividades que me fueron
asignadas por el docente? ¿Sí? ¿No?
¿Por qué?

6 ¿Alcancé el objetivo de trabajo


propuesto?

VALORO EL PROCESO DE APRENDIZAJE DE MI ACUDIDO

CRITERIOS DE VALORACIÓN RESPUESTA DE LA FLIA Y/O ACUDIENTES


1. ¿Recibieron de manera oportuna las guías de
aprendizaje para continuar avanzando en su proceso
de aprendizaje?

2. Mediante el acompañamiento de la familia. ¿El


estudiante hace uso de los recursos que tiene a su
disposición para despejar dudas y lograr una
adecuada comprensión y desarrollo de las
guías/módulos de aprendizaje?

3. La familia o el acudiente hace acompañamiento


para que el estudiante desarrolle las guías/módulos
de aprendizaje de acuerdo a las orientaciones del
docente.

4. La familia o el acudiente hace seguimiento a la


calidad de las actividades propuestas en la guía de
trabajo por parte del docente.

5. El padre de familia apoya y está al tanto del


proceso de aprendizaje de su acudido y del
cumplimiento de las fechas de entrega de los trabajos
o evidencias (Videos-fotos-llamadas) según la
proyección institucional.

MELBA SUSANA CHAPARRO GOMEZ 6

También podría gustarte