Está en la página 1de 8

2021-1

UNMSM – FCF – IMF

UNIDAD IV
DOCENTE : Juan Miguel de la Torre Ostos

ASIGNATURA : Lenguaje de Programación

ALUMNO : Alex Giron Yataco

SECCION : 8 – 10 am

2021-1
Problemas propuestos
Problema N° 4.11

Realice un algoritmo y represéntelo mediante un diagrama de flujo para obtener una función

exponencial, la cual está dada por:

Las variables para la operación.

Nombre de la variable Descripción Tipo


n Número de repeticiones Entero
x Valor de “x” Real
A continuación, el diagrama de flujo. Pseudocódigo del algoritmo.

1. Inicio
2. Definir n,a Como Entero
3. Definir x,e,f Como Real
4. Escribir “Ingresar las repeticiones de la serie”
5. Leer n
6. Hacer e = 0
c=1
f=1
7. Para a = 1 hasta n
Hacer c = a
Hacer f = f*c
Hacer c = c + 1
Fin desde
Hacer e = e+(x^a)/f
Fin desde
8. Escribir “El resultado de la funsion es: ”,e + 1
9. Fin
Problema N° 4.13

Un vendedor ha realizado N ventas y desea saber cuántas fueron por 10,000 o menos, cuántas fueron por más

de 10,000 pero por menos de 20,000, y cuánto fue el monto de las ventas de cada una y el monto global.

Realice un algoritmo para determinar los totales. Represente la solución mediante diagrama de flujo,

pseudocódigo y diagrama N/S.

Las variables para la operación.

Nombre de la variable Descripción Tipo


n Número de ventas Entero

A continuación, el diagrama de flujo.


A continuación, el pseudocódigo del problema. Diagrama N/S del algoritmo.

1. Inicio
2. Definir n Como Entero
3. Definir a,b,c,total,total1,total2,total3 como real
4. Escribir "Ingresa el numero de ventas"
5. leer n
a=0
b=0
c=0
total = 0
total1 = 0
total2 = 0
total3 = 0
6. Mientras n > 0 Hacer
Escribir "Ingresa el monto de la venta ",n
leer venta
si venta <= 10000
Entonces
a=a+1
total1 = total1+venta
SiNo
si venta < 20000
Entonces
b=b+1
total2 = total2 + venta
SiNo
c=c+1
total3 = total3 + venta
Fin de comparación
Fin de comparación
total = total + venta
n=n-1
FinMientras
Escribir "El numero de ventas menores a $10,000 es: ",a
Escribir "El total de las ventas menores a $10,000 es: $",total1
Escribir "El numero de ventas mayores a $10,000 y menores a $20,000 es: ",b
Escribir "El total de las ventas mayores a $10,000 y menores a $20,000 es: $",total2
Escribir "El numero de ventas de $20,000 en adelante es: ",c
Escribir "El total de las ventas de $20,000 en adelante es: $",total3
Escribir "El monto total de la ventas es: $",total
7. Fin
Problema N°4.14

Realice un algoritmo para leer las calificaciones de N alumnos y determine el número de aprobados y

reprobados. Represéntelo mediante diagrama de flujo, pseudocódigo y diagrama N/S.

A continuación, la tabla de valores.

Nombre de la variable Descripción Tipo


X Número de alumnos Entero
N Nota de alumnos Real
A Alumnos aprobados Entero
R Alumnos desaprobados Entero
Por consiguiente, el diagrama de flujo.
Pseudocódigo del algoritmo.
1. Inicio
2. Definir X Como Entero
3. Definir N Como Real
4. Escribir “Ingresa el número de alumnos”
5. Leer X
Hacer R = 0
Hacer A = 0
6. Mientras X>0
Hacer
Escribir “Ingresa la calificación “
Leer N
Si N<6
Entonces
R = R+1
Sino
A =A+1
Fin de comparación
X = X-1
FinMientras
Escribir “El total de alumnos aprobados es: “, A
Escribir “El total de alumnos reprobados es: “, R
7. Fin

Diagrama N / S del algoritmo


Problema N°4.16

Realice un algoritmo donde, dado un grupo de números naturales positivos, calcule e imprima el cubo de estos

números. Represéntelo mediante diagrama de flujo, pseudocódigo y diagrama N/S.

A continuación, la tabla de valores.

Nombre de la variable Descripción Tipo


Total El total de números Entero
n Numero Entero

Por consiguiente, el diagrama de flujo.


El Pseudocódigo del algoritmo

1. Inicio
2. Definir total, n Como Entero
3. Escribir "Ingresa el total de numeros"
4. leer total
Mientras total > 0
Hacer
Escribir "Ingresa un numero"
leer n
si n > 0
Entonces
Escribir "El número ",n," elevado al cubo es: ",n*n*n
total = total - 1
Fin de comparación
FinMientras
5. fin

El diagrama N/S del algoritmo