Está en la página 1de 4

Tarea para el sábado 25 de julio

1. Dado un monto, calcular el descuento del 20%.

Algoritmo descuento_del_20
Definir precio,descuento Como
entero
Escribir "ingrese una cantidad"
leer precio
descuento = precio * .2
Escribir" El 20% de descuento es =
",precio - descuento
FinAlgoritmo

2. Dado un monto calcular el descuento considerando que por encima de Q 1,000.00 el descuento es el 10% y por
debajo de Q 1,000.00 el descuento es del 2%.

Algoritmo Descuento_de_1000
Definir monto, descuento Como entero
leer monto
si monto > 1000 entonces
descuento <-- monto * 10 /
1000
sino
descuento <-- monto * 2 / 1000

finsi
imprimir monto, descuento
FinAlgoritmo

3. Dadas 5 notas de un estudiante calcular el promedio de


las notas.

Algoritmo Calcular_promedio_de_notas
Escribir "ingrese 5 estudiantes"
Leer N
acum<-0
para i <-1 hasta N Hacer
Escribir "ingrese el dato",i,":"
leer dato;
acum<-acum+dato;
FinPara
prom<-acum/N
Escribir "el promedio es:",prom
FinAlgoritmo
4. De un grupo de 42 estudiantes hallar el promedio de una signatura.

Algoritmo Promedio_de_una_aignatura
Definir n,menor,suma,v Como entero
Definir i,promedio Como real
Escribir "Escriba los 42 estudiantes";
Leer n
menor<-1000;
suma<-0;
para i<-0 hasta n-1 con paso 1 Hacer
Escribir "alumnos ", i+1;
leer v;
suma<-suma+v;
Si v<menor Entonces
menor<-v
FinSi
promedio<-suma/n;
Escribir "la nota mas baja fue
",menor
Escribir "el promedio es de " ,
promedio;
FinPara
FinAlgoritmo

5. Pedir un número al usuario y mostrar su valor al cuadrado.

Algoritmo Valor_al_cuadrado
definir num1 Como Real
Escribir "Dame un numero";
leer num1;
r <- num1 * 2;
Escribir "Resultado al cuadrado
= ", r;
FinAlgoritmo
6. Solicitar un número al usuario, si el numero es positivo hallar el cuadrado, de lo contrario mostrar un mensaje
que diga “SOLO PARA NÚMEROS POSITIVOS”

Algoritmo Cuadrado_de_numero_positivos
Definir num, resultado Como real;
Escribir "Dime un numero";
leer num;
resultado <-num^2;
si num Es Negativo Entonces
escribir "SOLO PARA NÚMEROS
POSITIVOS"
SiNo
Escribir "El cuadrado de ",num " es = ",
resultado;
FinSi
FinAlgoritmo

7. El recibo de facturación de la luz consta de un cargo fijo, un consumo y el valor a cancelar es los kilovatios
consumidos por el valor de kilovatio.

8. Teniendo como referencia el ejercicio anterior si el consumo en kilovatios es cero (0) se debe cancelar el cargo
fijo, si es mayor a cero se realiza la operación del punto anterior.

Algoritmo Luz
Escribir "Ingrse la cantidad
de kilotios usados"
leer kw
si kw > 0 Entonces
Escribir "El monto a
cancelar es Q ", kw*0.29
SiNo
Escribir "El monto
es Q50 "
FinSi

FinAlgoritmo
9. Escribir un algoritmo (usando la instrucción SI) que pida un numero real de precisión sencilla y haga que
muestre los siguientes resultados:

• Si el número es menor de 50, mostrara su cuadrado.

• Si el número es igual a 25, 30 ó 75, mostrará su raíz cúbica.

• Si el número vale 10 ó es mayor que 100 ó está en los intervalos [3,8] o [77,90], mostrará el valor
dividido por 10.

También podría gustarte