Está en la página 1de 7

// ejercicio numero 1

Algoritmo mayor
n1 <- 0
n2 <- 0
Escribir 'ingresa dos números por favor'
Leer n1,n2
Si n1>n2 Entonces
Escribir 'El primer número es el mayor ',n1
SiNo
Si n2>n1 Entonces
Escribir 'El segundo número es el mayor ',n2
FinSi
FinSi
FinAlgoritmo
// ejercicio numero 2
Algoritmo menor
n1 <- 0
n2 <- 0
Escribir 'ingresa dos números por favor'
Leer n1,n2
Si n1<n2 Entonces
Escribir 'El primer número es el menor ',n1
SiNo
Si n2<n1 Entonces
Escribir 'El segundo número es el menor ',n2
FinSi
FinSi
FinAlgoritmo
// ejercicio numero 3
Algoritmo mayor_menor
A<-0;
B<-0;
C<-0;

Escribir "ingresa tres números por favor";


Leer A,B,C

si A>B & A>C Entonces


Escribir "El primer número es el mayor ",A;
SiNo
si B>A & B>C Entonces
Escribir "El segundo número es el mayor ",B;
SiNo
si C>A & C>B Entonces
Escribir "El tercero número es el mayor ",C;
sino
Escribir "todos los valores son iguales por favor ingrese otros
valores distintos"

FinSi

FinSi
finsi
// evaluar para el número menor

si A<B & A<C Entonces


Escribir "El primer número es el menor ",A;
SiNo
si B<A & B<C Entonces
Escribir "El segundo número es el menor ",B;
SiNo
si C<A & C<B Entonces
Escribir "El tercero número es el menor ",C;

FinSi

FinSi
finsi
FinAlgoritmo
proceso numero menor
A <- 0
B <- 0
C <- 0
Escribir 'ingresa tres números por favor'
Leer A,B,C
Si A<B Y A<C Entonces
Escribir 'El primer número es el menor ',A
SiNo
Si B<A Y B<C Entonces
Escribir 'El segundo número es el menor ',B
SiNo
Si C<A Y C<B Entonces
Escribir 'El tercero número es el menor ',C
SiNo
Escribir 'todos los valores son iguales por favor ingrese otros valores distintos'
FinSi
FinSi
FinSi
Finproceso
//ejercicio número 4.1
Algoritmo mayor_menor
n1<-0;
n2<-0;
n3<-0;
n4<-0;

Escribir "ingresa cuatro números por favor";


Leer n1,n2,n3,n4

si n1>n2 & n1>n3 & n1>n4 Entonces


Escribir "El primer número es el mayor ",n1;
SiNo
si n2>n1 & n2>n3 & n2>n4 Entonces
Escribir "El segundo número es el mayor ",n2;
SiNo
si n3>n1 & n3>n2 & n3>n4 Entonces
Escribir "El tercero número es el mayor ",n3;
SiNo
si n4>n1 & n4>n2 & n4>n3 Entonces
Escribir "El cuarto número es el mayor ",n4;
SiNo
Escribir "todos los valores son iguales por favor ingrese otros
valores diferentes"
Finsi

FinSi

FinSi
finsi
// evaluar para el número menor

si n1<n2 & n1<n3 & n1<n4 Entonces


Escribir "El primer número es el menor ",n1;
SiNo
si n2<n1 & n2<n3 & n2<n4 Entonces
Escribir "El segundo número es el menor ",n2;
SiNo
si n3<n1 & n3<n2 & n3<n4 Entonces
Escribir "El tercero número es el menor ",n3;
SiNo
si n4<n1 & n4<n2 & n4<n3 Entonces
Escribir "El cuatro número es el menor ",n4;

Finsi

FinSi

FinSi
finsi
FinAlgoritmo

También podría gustarte