Está en la página 1de 6

lOMoARcPSD|5630554

Fin Del Proceso - ALGORITMO

Principios de algoritmos (Universidad Tecnológica del Perú)

StuDocu no está patrocinado ni avalado por ningún colegio o universidad.


Descargado por Nu NUstu (jaisen3015@gmail.com)
lOMoARcPSD|5630554

1.Leer un número entero N y calcule y muestre su factorial N!, por


ejemplo: Si el número es4, su factorial es: 4*3*2*1= 24
Proceso Factoriall
Escribir "Ingrese el número"
Leer Num
i=1
factorial=1

Mientras i<=num Hacer


factorial=factorial*i
i=i+1
FinMientrasEscribir "El factorial del número es -> ", Factorial
finproceso

2.Determinar la cantidad de dígitos que tiene un número entero y además


mostrar la sumade los dígitos pares e impares.

Proceso Dígitoss
Escribir "Ingrese el número"
Leer n
i=0
Sn1=0
Sn2=0
Mientras n<>0 Hacer
r= n mod 10
Si r Es Multiplo De 2 Entonces
Sn1=Sn1+r
Sino
Sn2=Sn2+r
FinSi
I=i+1
n=trunc (n/10)
FinMientras
Escribir "La cantidad de dígitos es ->", i
Escribir "La suma de los dígitos pares es ->", Sn1
Escribir "La suma de los dígitos impares es ->", Sn2
FinProceso

3. Determinar la suma de los N primeros términos de la siguiente serie:

1+ X + X 2+ X3+ X 4+ ........................
2! 3! 4!

Algoritmo N_términos
Escribir "Ingrese el número de términos"
Leer T
Escribir "Ingrese el valor de X"
Leer X
i=3
ST=0
Den=1
ex=1
Num=X

Mientras i<=T Hacer


Num=Num
Den=Den+1
ex=ex+1

Descargado por Nu NUstu (jaisen3015@gmail.com)


lOMoARcPSD|5630554

ST=ST+(Num^ex/den)
i=i+1
FinMientras

SumTotal= ST+1+x
Escribir "La suma de los términos es -->", SumTotal
FinAlgoritmo

8.Construir un programa que determine la potencia de mn siendo m un


número real y n un número entero. Considere que n puede ser positivo,
negativo o cero. No use ningún método Math.

Algoritmo EJERCICIO8
Definir a,b Como Entero;
acum<-1
Escribir "indique la base";
Leer a;
Escribir "ingrese el exponente";
Leer b;
Para i<-1 hasta b con paso 1 hacer
acum<- acum*a
FinPara
Escribir a,"elevado a la ",ex,"es", acum;
FinAlgoritmo

4.A una fiesta asistieron personas de diferentes edades y sexos.


Construir un algoritmo dadas las edades y sexos de las personas.
Calcular:
-Cuántas personas asistieron a la fiesta
-Cuántos hombres y cuantas mujeres
-Promedio de edades por sexo-La edadde la persona más joven que asistió
–No se permiten menores de edad a la fiesta
-Ingresar datos hasta que se ingrese la edad cero

Escribir "Ingrese el número de personas en la fiesta"


Leer NP
i=1
SH=0
SM=0
min=200
EH=0
EM=0
E1=0
E2=0
Mientras i<=NP Hacer
Escribir "Sexo de la persona: (1) Es Hombre y (2) Es Mujer"
Escribir "Ingrese la edad de la persona"
Leer s,e
Si s=1 Entonces
SH=SH+1
EH=EH+e
E1=E1+1
Sino
SM=SM+1
EM=EM+e
E2=E2+1
FinSi
Si e<min Entonces

Descargado por Nu NUstu (jaisen3015@gmail.com)


lOMoARcPSD|5630554

min=e
FinSi
i=i+1
FinMientras
PEH=EH/E1
PEM=EM/E2
Escribir "El promedio de edad de hombres es -->", PEH
Escribir "El promedio de edad de mujeres fue -->", PEM
Escribir "--> asistieron a la fiesta " NP " personas"
Escribir "--> Fueron " SH " Hombres a la fiesta"
Escribir "--> Fueron " SM " Mujeres a la fiesta"
Escribir "La edad de la persona más joven fue -->", min

FinAlgoritmo

1. Escribir un programa que visualice una tabla de los N primero


números, siendo N un número que ingresa el usuario.

Algoritmo Primeros_números
Definir i,N,s1,s2,s3 Como Entero
Escribir "Ingrese la cantidad de números para la secuencia: "
Leer N
Para i<-1 Hasta N Con Paso 1
s1<-i
s2<-i*i
s3<-i*i*i
Escribir s1 " ", s2 " ", s3 " "
FinPara
FinAlgoritmo

2. Diseñar en Pseudocódigo que permita registrar de los empleados de


una fábrica (no se sabe cuántos) su peso y saber cuántos pesan hasta
80 kg. inclusive y cuantos pesan más de 80 kg.

Algoritmo Peso_empleados
Definir i, suma1,suma2,N,p Como Entero
Escribir "Ingrese el número de empleados: "
Leer N
Para i<-0 Hasta N-1 Con Paso 1
Escribir "Ingrese el peso del empleado: "
Leer p
Si p<=80 Entonces
suma1<-i+1
SiNo
Si p>80 Entonces
suma2<-i+1
FinSi
FinSi
FinPara
Escribir "El total de empleados con pesos iguales o menores de 80
kilos es: " suma1
Escribir "El total de empleados con pesos mayores de 80 kilos es: "
suma2-suma1
FinAlgoritmo

9. Supóngase que en una reciente elección hubo cuatro candidatos, con


identificadores 1, 2, 3, 4. Usted habrá de encontrar mediante un

Descargado por Nu NUstu (jaisen3015@gmail.com)


lOMoARcPSD|5630554

programa, el número de votos correspondiente a cada candidato


y el porcentaje que obtuvo respecto al total de los votantes.
El usuario ingresara los votos de manera desorganizada, tal y
como se obtuvieron en la elección, el final de datos está
representado por un cero.
Algoritmo Votos
Definir a,b,c,d Como Caracter
Definir i,voto,total Como Entero
Definir a1,b2,c3,d4 Como Real
a1<-0
b2<-0
c3<-0
d4<-0
total<-0
Repetir
Escribir "Ingrese su voto: "
Leer voto
Si voto=1 Entonces
a1<-a1+1
FinSi
Si voto=2 Entonces
b2<-b2+1
FinSi
Si voto=3 Entonces
c3<-c3+1
FinSi
Si voto=4 Entonces
d4<-d4+1
FinSi
Hasta Que voto=0
total<-total+a1+b2+c3+d4
Si a1=0 Entonces
Escribir "El candidato 1 obtuvo: " 0
SiNo
Escribir "El candidato 1 obtuvo: " a1 " votos, con un
porcentaje de " (100*a1)/total "%"
FinSi
Si b2=0 Entonces
Escribir "El candidato 2 obtuvo: " 0
SiNo
Escribir "El candidato 2 obtuvo: " b2 " votos, con un
porcentaje de " (100*b2)/total "%"
FinSi
Si c3=0 Entonces
Escribir "El candidato 3 obtuvo: " 0
SiNo
Escribir "El candidato 3 obtuvo: " c3 " votos, con un
porcentaje de " (100*c3)/total "%"
FinSi
Si d4=0 Entonces
Escribir "El candidato 4 obtuvo: " 0
SiNo
Escribir "El candidato 4 obtuvo: " d4 " votos, con un
porcentaje de " (100*d4)/total "%"
FinSi
FinAlgoritmo

Descargado por Nu NUstu (jaisen3015@gmail.com)


lOMoARcPSD|5630554

4.-Realizar la tabla de multiplicar de un número entre 0 y 10 de forma


que se visualice de la siguiente forma:
4x1= 4
4x2= 8

Algoritmo Multiplicación
Definir i,n Como Entero
Escribir "Ingrese el número: "
Leer n
Para i<-1 Hasta 10 Con Paso 1
Escribir n "x" i "=" (n*i)
FinPara
FinAlgoritmo

5. Hacer el algoritmo que imprima el mayor y el menor de una serie de 5


números que vamos introduciendo por teclado.

Algoritmo mayor_menor
Definir maximo,mínimo,con,n Como Entero
con <- 0
n <- 0
maximo <- 0
minimo <- 99999
Mientras con <5 Hacer
Escribir "Ingrese el número: "
Leer n
Si n > maximo Entonces
maximo = n
FinSi
Si n < minimo Entonces
minimo <- n
FinSi
con <- con + 1
FinMientras
Escribir "El mayor de los números es: "
Escribir maximo
Escribir "El menor de los números es: "
Escribir minimo
FinAlgoritmo

Descargado por Nu NUstu (jaisen3015@gmail.com)

También podría gustarte