Está en la página 1de 2

1. Leer un número entero N y calcule y muestre su factorial N!

, por ejemplo: Si el número es 4,su


factorial es: 4*3*2*1= 24

1.-Proceso factorialConRepetir
2.-Definir contador, n,factorial Como Entero;
3.-contador <- 1;factorial <- 1;
4.-Escribir 'n=';
5.-Leer n;
6.-Repetir
7.-factorial <- factorial *contador;
8.-contador <- contador + 1;
9.-Hasta Que contador > n
10.-Escribir 'factorial=',factorial;
11.-FinProceso
2. Determinar la cantidad de dígitos que tiene un número entero y además mostrar la suma de los
dígitos pares e impares.
1.-INICIO
2.-Definir num Como Entero
3.-Leer num
4.-cd<-0
5.-sumpar<-0
6.-sumimpar<-0
7.-Mientras num>0 Hacer
8.-digito<-(num MOD 10)
9.-Si digito MOD 2=0 Entonces
10.-sumpar<-sumpar+digito
11.-Si no
12.-sumimpar<-sumimpar+digito
13.-Fin Si
14.-cd<-cd+1
15.-num<-num/10
16.-Fin Mientras
17.-Escribir “La cantidad de dígitos es:“cd Escribir 'La suma de sus dígitos impares es: sumimpar
18.-Escribir 'La suma de sus dígitos pares es: ',sumpar
19.-Fin proceso

3.Determinar la suma de los N primeros términos de la siguiente serie:


1+ X + X 2+ X3+ X 4+ ........................
2!3!4!

1.-Algoritmo N_términos
2.-Escribir "Ingrese el número de términos"
3.-Leer T
4.-Escribir "Ingrese el valor de X"
5.-Leer X
6.-i=3
7.-ST=0
8.-Den=1
9.-ex=1
10.-Num=X
11.-Mientras i<=T Hacer
12.-Num=Num
13.-Den=Den+1
14.-ex=ex+1
15.-ST=ST+(Num^ex/den)
16.-i=i+1
17.-Fin Mientras
18.-SumTotal= ST+1+x
19.-Escribir "La suma de los términos es -->", SumTotal
20.-Finproceso

8.Construir un programa que determine la potencia de m,n siendo m un número real y n un


número entero. Considere que n puede ser positivo, negativo o cero. No use ningún método Math.
1.-Algoritmo determine la potencia
2.-Definir a,b Como Entero;
3.-acum<-1
4.-Escribir "indique la base";
5.-Leer a;
6.-Escribir "ingrese el exponente";
7.-Leer b;
8.-Para i<-1 hasta b con paso 1 hacer
9.-acum<- acum*a
10.-FinPara
11.-Escribir a,"elevado a la ",ex,"es", acum;
12.-Finproceso