Está en la página 1de 12

UNIVERSIDAD TECNOLÓGICA DEL CHOCÓ

“DIEGO LUIS CÓRDOBA”

LABORATORIO DE CONFIGURACIÓN DE HSRP

REALIZADO POR:
YEIFRED SALAS QUINTO

DIRIGIDO A:
ING. RAFAEL SANDOVAL MORALES

ASIGNATURA:
ELECTIVA DE PROFUNDIZACIÓN (REDES)

FECHA DE ENTREGA:
SÁBADO 12 DE SEPTIEMBRE DE 2020
LABORATORIO DE CONFIGURACIÓN DE HSRP

El objetivo de este laboratorio, es el de implementar el protocolo HSRP. Dado que


es una forma de evitar un único punto de falla en la puerta de enlace predeterminada
es implementar un router virtual.
Para realizar este laboratorio, necesitamos tener el software simulador GNS3 con
sus respectivos Routers, Switches y Máquinas Virtuales agregadas.

Nota 1:
Es necesario desactivar el Firewall en todos los PCs para que los mensajes (paquetes) que
se envíen y/o reciban puedan llegar en su totalidad al destino deseado; y, por lo tanto, no
se pierda ninguno.

TOPOLOGÍA DE RED UTILIZADA:


CONFIGURACIÓN EN ROUTER ISP

Entramos al Router R2, le cambiamos el hostname por ISP y le configuramos las


siguientes direcciones IP en sus respectivas interfaces:
enable
configure terminal
int s2/0
ip address 172.160.60.1 255.255.255.252
clock rate 64000
no shut
exit

int s2/1
ip address 172.150.50.1 255.255.255.252
clock rate 64000
no shut
exit

configuramos la interface Loopback 77

int loopback 77
ip address 100.100.100.20 255.255.255.128
no shut
exit

Realizamos el enrutamiento con el protocolo dinámico EIGRP con ID 160:


router eigrp 160
network 172.160.60.0 0.0.0.3
network 172.150.50.0 0.0.0.3
no auto-summary
exit

Configuramos la ruta estática por defecto para la Loopback 77:


ip route 0.0.0.0 0.0.0.0 loopback 77
Entramos al protocolo EIGRP 160 y añadimos la redistribución para que se puedan
comunicar a esta IP, mediante los siguientes comandos:
router eigrp 160
redistribute static
no auto-summary
exit
CONFIGURACIÓN EN ROUTER ENLACE-1
Entramos al Router R1, le cambiamos el hostname por ENLACE-1 y le
configuramos las siguientes direcciones IP en sus respectivas interfaces:
enable
conf t
int s2/0
ip address 172.160.60.2 255.255.255.252
clock rate 64000
no shut
exit

int f0/0
ip address 180.168.10.1 255.255.255.128
no shut
exit

Realizamos el enrutamiento con el protocolo dinámico EIGRP con ID 160:

router eigrp 160


network 172.160.60.0 0.0.0.3
network 180.168.10.0 0.0.0.127
no auto-summary
exit

CONFIGURACIÓN DEL SWITCHE ESW1


Aquí procedemos a configurar la IP utilizando la por defecto que es la Vlan 1.
enable
conf t
int vlan1
ip address 180.168.10.2 255.255.255.128
no shut
exit
ip default-gateway 180.168.10.1
do wr
Probando conectividad hacia la interface Loopback desde el ESW1:
CONFIGURACIÓN DEL PC WinXP2
Encendemos la máquina virtual y configuramos la siguiente dirección IP:
IP: 180.168.10.5
Máscara de subred: 255.255.255.128
Puerta de enlace predeterminada: 180.168.10.1

CONFIGURACIÓN DEL PC WinXP3


Encendemos la máquina virtual y configuramos la siguiente dirección IP:
IP: 180.168.10.4
Máscara de subred: 255.255.255.128
Puerta de enlace predeterminada: 180.168.10.1
CONFIGURACIÓN EN ROUTER ENLACE-2
Entramos al Router R3, le cambiamos el hostname por ENLACE-2 y le
configuramos las siguientes direcciones IP en sus respectivas interfaces:
enable
conf t
int s2/0
ip address 172.150.50.2 255.255.255.252
clock rate 64000
no shut
exit

int f0/0
ip address 180.168.10.15 255.255.255.128
no shut
exit

Realizamos el enrutamiento con el protocolo dinámico EIGRP con ID 160:

router eigrp 160


network 172.150.50.0 0.0.0.3
network 180.168.10.0 0.0.0.127
no auto-summary
exit
CONFIGURACIÓN DEL SWITCHE ESW2
Aquí procedemos a configurar la IP utilizando la por defecto que es la Vlan 1.
enable
conf t
int vlan1
ip address 180.168.10.16 255.255.255.128
no shut
exit
ip default-gateway 180.168.10.15
do wr
Probando conectividad hacia la interface Loopback desde el ESW2:

CONFIGURACIÓN DEL PC WinXP4


Encendemos la máquina virtual y configuramos la siguiente dirección IP:
IP: 180.168.10.17
Máscara de subred: 255.255.255.128
Puerta de enlace predeterminada: 180.168.10.15
CONFIGURACIÓN DEL PC WinXP5

Encendemos la máquina virtual y configuramos la siguiente dirección IP:


IP: 180.168.10.18
Máscara de subred: 255.255.255.128
Puerta de enlace predeterminada: 180.168.10.15

Probando conectividad desde el PC WinXP2 hacia la Loopback 77:


El color del recuadro amarillo se puede observar que hay conectividad, ya que se
reciben todos los paquetes que se envían.
El color del recuadro rojo se puede observar el Tracert donde se evidencia la puerta
de enlace del router ENLACE-1 por la cual salen los paquetes hacia su destino.
Después de verificar que tenemos comunicación de todos los dispositivos en
nuestra red, procedemos a configurar lo que es el protocolo HSRP en el router
ENLACE-1 y ENLACE-2.
Para configurar este protocolo, utilizaremos la IP virtual 180.168.10.30.
Entramos al router ENLACE-1 y agregamos los siguientes comandos:
int f0/0
standby 7 ip 180.168.10.30
standby 7 priority 250
standby 7 preempt
no shut
do wr
exit

Entramos al router ENLACE-2 y agregamos los siguientes comandos:


int f0/0
standby 7 ip 180.168.10.30
no shut
do wr
exit
Después de haber realizado lo anterior, procedemos a cambiar la puerta de enlace
predeterminada en todos los PCs y los Switches por la IP virtual 180.168.10.30 que
configuramos con anterioridad como se puede apreciar en las siguientes imágenes
respectivamente:

Quitamos la puerta de enlace predeterminada que tenía anteriormente y colocamos


la virtual.

Luego, hacemos ping extendido desde el PC WinXP2 hacia la Loopback 77


100.100.100.20, mientras al mismo tiempo quitamos el cable que conecta el router
ENLACE-1 con el Switche ESW1.
Se observa que hay dos paquetes que no llegan a su destino (señalados con una
flecha roja), pero enseguida, el tráfico retoma la nueva ruta y los paquetes llegan a
su destino.
Probamos la ruta por la cual se están yendo los paquetes ahora que el enlace
principal está ‘caído’ haciendo un Tracert a la interfaz Loopback 100.100.100.20.

Vemos que la puerta por la que salen nuestros paquetes ahora es la del router
ENLACE-2 180.168.10.15.
Ahora, volvemos a conectar el cable del router ENLACE-1 con el Switche ESW1 y
realizamos un nuevo Tracert a la interfaz Loopback 100.100.100.20.

Vemos que la puerta principal por la que salen nuestros paquetes ahora es la del
router ENLACE-1 180.168.10.1.
Con esto, damos por finalizado el laboratorio concluyéndolo con total éxito.