Está en la página 1de 7

Título de la tarea

Control 4

Estructuras condicionales y repetitivas.

Nombre Alumno

Pedro Parra L

Nombre Asignatura

Introducción a la Programación

Instituto IACC

Ponga la fecha aquí

06-julio-2020
Desarrollo

Se requiere que realice los siguientes algoritmos utilizando seudocódigos con estructuras

condicionales y repetitivas que permitan generar las salidas esperadas

1) Se tienen como entradas tres números (a, b y c). Determine cuál es el mayor de los tres.

Proceso nro_mayor

Definir a, b, c Como Entero;


a <- 0;
b <- 0;
c <- 0;
Escribir "digite el primer número";
Leer a;
Escribir "digite el primer número";
Leer b;
Escribir "digite el primer número";
Leer c;
si a > b y a > c Entonces
Escribir "El número mayor es:”,a;
SiNo
si b > a y b > c Entonces
Escribir "El número mayor es:”,b;
SiNo
Escribir "El número mayor es:",c;
FinSi
FinSi
FinProceso
2) Realizar un algoritmo que permita leer como entrada 20 números naturales e indique cuantos

son: pares, impares, positivos y negativos.

Proceso Contador_numeros

Definir x, numero, pares, impares, positivos, negativos Como Entero;

pares <- 0;
impares <- 0;
positivos <- 0;
negativos <- 0;

para x <- 1 hasta 20 Hacer


Leer numero;
si numero mod 2 = 0 entonces
pares <- pares + 1;
SiNo
impares <- impares + 1;
FinSi
si numero > 0 Entonces
positivos <- positivos + 1;
SiNo
si numero < 0 Entonces
negativos <- negativos + 1;
FinSi
FinSi
FinPara

Escribir ("los números pares son:"), pares;

Escribir ("los números impares son:"), impares;

Escribir ("los números positivos son:"), positivos;

Escribir ("los números negativos son:"), negativos;

FinProceso
3) Realizar un algoritmo que permita calcular la edad de una persona conociendo su fecha de

nacimiento. El cálculo se debe realizar la cantidad de veces que lo desee el usuario.

Proceso Edad_Persona

Definir edad, diaactual, mesactual, anoactual Como Entero;


Definir dianacimiento, mesnacimiento, anonacimiento Como Entero;

Escribir ("Dame la fecha actual, en dia,mes y año");


Leer diaactual,mesactual,anoactual ;

Escribir ("Dame la fecha de nacimiento en dia,mes y año");


Leer dianacimiento, mesnacimiento, anonacimiento;

edad <- anoactual - anonacimiento;

Si mesnacimiento > mesactual Entonces


edad <- edad - 1;
SiNo
Si mesnacimiento == mesactual Entonces
Si dianacimiento > diaactual Entonces
edad <- edad - 1;
FinSi

Si dianacimiento == diaactual Entonces


Escribir "Felicidades estas cumpliendo años";
FinSi
FinSi
FinSi
Escribir "Tu edad actual es: ", edad ," años";

FinProceso
4) A una reunión asistieron personas de diferentes edades y géneros. Construir un algoritmo

que, dadas las edades y los géneros (M / F) de las personas, calcule:

o Cuantas personas asistieron a la fiesta.

o Cuantos hombres y cuantas mujeres.

o Promedio de edades por sexo.

o La edad de la persona más joven que asistió.

o No se permiten menores de edad a la fiesta.

o Ingresar datos hasta que se ingrese el valor cero “0” en la edad que se lee.

Proceso Fiesta_Personas

Definir sexo Como Caracter;


Definir prom_edad_hombres,prom_edad_mujeres Como Real;
Definir numero,edad, hombre_men_edad, mujer_men_edad, h, m,i Como Entero;

h <- 0;
m <- 0;
prom_edad_hombres <- 0;
prom_edad_mujeres <- 0;
hombre_men_edad <- 0;
mujer_men_edad <- 0;
sexo <- "";

Escribir "Cuantas personas desea ingresar?";


Leer numero;
Para i <- 1 hasta numero Con Paso 1 Hacer

Escribir "Ingrese Edad";


Leer edad;
Escribir "Ingrese sexo";
Leer sexo;
Si edad > 0 y sexo = "M" o sexo = "F" Entonces
Si sexo = "M" Entonces
Si edad < 18 Entonces

hombre_men_edad <- hombre_men_edad + 1;


FinSi
h <- h+1;
prom_edad_hombres <- prom_edad_hombres / h;
SiNo
Si edad < 18 Entonces

mujer_men_edad <- mujer_men_edad + 1;


FinSi

m <- m+1;
prom_edad_mujeres <- prom_edad_mujeres / m;
FinSi
FinSi
FinPara

Escribir "Asisitieron a la fiesta:",numero,"personas";

Escribir "Hombres:", h;

Escribir "Mujeres:", m;

Escribir "Promedio edad hombres:",prom_edad_hombres,"años";

Escribir "Promedio edad mujeres:",prom_edad_mujeres,"años";

Escribir "Cantidad hombres que no pudieron ingresar:",hombre_men_edad;

Escribir "Cantidad mujeres que no pudieron ingresar:",mujer_men_edad;

FinProceso
Bibliografía

[Haga triple clic en cualquier parte de este párrafo para escribir la primera referencia

bibliográfica.]

Instrucciones para la sección de las citas bibliográficas:


Escriba la bibliografía aquí en orden alfabético (empezando por el apellido del primer autor o, de
no haber autor, por la primera palabra del título). Esta página ya está formateada con sangrías
francesas. Incluya sólo las citas bibliográficas a las que haya hecho referencia en su trabajo y
asegúrese de incluir todas las citas bibliográficas a las que se haya referido en el mismo.

Ejemplos de un artículo:

Apellido, A. A., Apellido, B. B., y Apellido, C. C. (año). Título del artículo específico. Título
de la Revista, número de la revista, número de página.
https://doi.org/xx.xxxxxxxxxx

Lee, H. W. (2005). Los factores que influyen en los expatriados. Journal of American Academy of
Business, 6(2), 273-279.

Osorio-Delgado, M. A., Henao-Tamayo, L. J., Velásquez-Cock, J. A., Cañas-Gutiérrez, A. I.,


Restrepo-Múnera, L. M., Gañán-Rojo, P. F., Zuluaga-Gallego, R. O., Ortiz-Trujillo, I C. y
Castro-Herazo, C. I. (2017). Aplicaciones biomédicas de biomateriales poliméricos.
DYNA, 84(201), 241-252. https://doi.org/10.15446/dyna.v84n201.60466

Nota: Si el artículo de la revista no tiene un DOI y proviene de una base de datos de investigación académica,
finalice la referencia después del rango de páginas. No incluya información de la base de datos en la
referencia. La referencia en este caso es la misma que para un artículo de revista impresa. Si el artículo de la
revista no tiene un DOI, pero tiene una URL que resolverá para los lectores (por ejemplo, es de una revista en
línea que no forma parte de una base de datos), incluya la URL del artículo al final de la referencia, en vez del
DOI.

Ejemplos de un texto:

Apellido, N. N. (año). Título del texto. Editorial. http://www.dirección.com

McShane, S. L., y Von Glinow, M. (2004). Organizational behavior: Emerging realities for the
workplace. The McGraw-Hill Companies.

Panza, M. (2019). Números: elementos de matemáticas para filósofos.  Universidad Del Valle.


https://www.reddebibliotecas.org.co/

También podría gustarte