Está en la página 1de 4

ALGORITMOS - 301303

Formato Etapa 2 - Taller fundamentos de programación -


Algoritmos
La primera actividad para dar solución a un problema mediante la
utilización de lenguajes de programación consiste en definir de una
manera clara el problema a resolver.
Una de las formas es haciéndose algunas preguntas que no le han
quedado claras después de leer el planteamiento del problema, por
ejemplo, saber cuáles son los datos que no se conocen, identificar los
datos que son posibles de calcular, determinar con claridad las variables
que se pueden utilizar e indagar sobre las fórmulas que se deben utilizar
en los problemas que así lo requieran.
Con el propósito de facilitar este proceso se ha diseñado una pequeña
plantilla, la que se debe diligenciar antes de iniciar a elabora el programa
solicitado.
Es importante que usted analice y diligencie cada uno de los puntos
solicitados en la guía.

Éxitos
Recuerde que el análisis es individual
Nombre estudiante:
1._ Análisis inicial

Planteamiento del problema a resolver: Desarrolle un Diagrama o Algoritmo que permita leer dos
valores y escribir la suma, resta, multiplicación y división de estos números.

Que datos no Que datos no Tipo Formulas a Requier Requiere


conozco y se conozco, pero Variables aplicar si se e ciclos
deben solicitar los puedo requeridas requieren condicio (si / no)
(si se requiere calcular Tipo Variabl nal (si / _ cuales
más filas por e no)
favor anexarlas)
Factores Suma entero a a+b no No
Resta entero b a-b No No
Multiplicación a*b no No
División a/b Si No

2.- Código: (se debe pegar el código – no imagen)


//Autor: Javier Mendoza Villada Fin Si

//Fecha: 07/09/2017 suma = a+b

//Doy fe que este ejercicio es de mi autoría, resta = a-b

//en caso de encontrar plagio la nota de todo mi mult = a*b

//trabajo debe ser de CERO además de las respectivas Escribir "Los resultados son:"

//sanciones a que haya lugar Escribir "Suma = ",suma

Algoritmo Ejercicio_2 Escribir "Resta = ",resta

Mientras Verdadero Hacer Escribir "Multiplicación = ", mult

Escribir "Autor: Javier Mendoza Villada" Si error = Falso Entonces

Escribir "Por favor ingrese dos números" Escribir "Division = ",div

Leer a,b SiNo

Si b = 0 Entonces Escribir "No es posible realizar


la división"
error = Verdadero
Fin Si
SiNo
FinMientras
div = a/b
FinAlgoritmo
error = Falso

3.- ¿Usted probo el resultado con diferentes valores? si (Cuales):


a=10, b=5. a= 0, b= 3560
a=20, b=0 a= 52, b= 84
4.- Resultado (captura imagen o imágenes del resultado, debe aparecer su
nombre)

También podría gustarte