Está en la página 1de 2

Separata de trabajo 10 – Estructuras repetitivas MIENTRAS

Semana 13

Ejercicios explicativos
1. Construir un algoritmo que permita ingresar un número entero calcular su factorial. Emplear la estructura
repetitiva MIENTRAS.
Proceso factoriales
Definir n,fact,aux Como Entero
fact<-1 // contador
aux<-1 // contador
Escribir "Ingrese n"
Leer n
Mientras aux<=n Hacer
fact<-fact*aux
aux<-aux+1
FinMientras
Escribir n, "! = ", fact
FinProceso

2. Dado un número entero positivo cualquiera, invertirlo y mostrarlo en pantalla.


Proceso invertido
Definir num, cf, inv, aux Como Entero
Leer num
aux<-num
Mientras aux>0 Hacer
cf <- aux MOD 10
aux <- (aux - cf)/10
inv<-inv*10+cf
FinMientras
Escribir "numero inicial :", num
Escribir "numero invertido:", inv
FinProceso
Ejercicios propuestos

1. Crear un algoritmo en pseudocódigo que permita ingresar un número positivo y muestre el número de
cifras de este.

2. Construir un programa que pida ingresar un número, luego muestre la tabla de multiplicar de dicho número
del 1 al 12. Emplear la estructura repetitiva MIENTRAS.

3. Desarrollar un pseudocódigo que luego de ingresar 2 números naturales imprima los números naturales
que hay entre ambos empezando por el menor. Asumimos que el usuario ingresa dos números diferentes
y el segundo es mayor que el primero. Emplear la estructura repetitiva MIENTRAS.

4. Calcular el precio total de una compra de “n” productos (el valor “n” se ingresa por teclado) si se ingresa el
precio de cada producto y la cantidad comprada de este. Emplear la estructura repetitiva MIENTRAS.