Está en la página 1de 7

ALGORTIMOS

ALGORTIMOS - I.E.JOSÉ MARIA MUÑOZ FLÓREZ 2

ALGORTIMOS
Programa para el uso de ciclo PARA
Se requiere una aplicación que lea principalmente el nombre de 3 estudiantes de un salón de
clases, las 2 notas parciales de cada uno y presenta um mensaje com sus respectivos nombres y
notas finales. Si la nota final es inferior a 3, presentar el mensaje “REPROBADO”, en caso
contrario presentar el mensaje “APROBADO” a cada estudiante.

Algoritmo pseucódigoNOTAS
Definir nombre Como Caracter
Definir NOTA1, NOTA2, NOTAFINAL Como Real
DEFINIR ESTUDIANTE COMO ENTERO
Para ESTUDIANTE<-1 Hasta 3 Con Paso 1 Hacer

Escribir "INGRESE EL NOMBRE DEL ESTUDIANTE"


Leer nombre
Escribir "INGRESE EL VALOR DE LA NOTA1"
Leer NOTA1
Escribir "INGRESE EL VALOR DE LA NOTA2"
Leer NOTA2
NOTAFINAL <- (NOTA1 + NOTA2)/2
Escribir "NOMBRE------>", nombre
Escribir "NOTAFINAL--->", NOTAFINAL
Si NOTAFINAL <3 Entonces

escribir "REPROBADO"

SiNo

Escribir "APROBADO"

Fin Si

Fin Para

FinAlgoritmo
2

2020
ALGORTIMOS - I.E.JOSÉ MARIA MUÑOZ FLÓREZ 3

2020
ALGORTIMOS - I.E.JOSÉ MARIA MUÑOZ FLÓREZ 4

Programa para el uso de ciclo “MIENTRAS”


Se requiere uma aplicación que lea constantemente el nombre de los estudiantes de un aula de
clases, basandonos en las 2 Notas parciales de cada uno y presente a través de este programa
un mensaje con sus respectivos nombres y notas finales. Si la nota final es inferior a 3, presentar
el mensaje “REPROBADO”, en caso contrario presentar el mensaje “APROBADO” a cada uno de
los estudiantes. Repetir este proceso hasta que alguno de ellos tenga una nota final por debajo
de 2.

Algoritmo pseucódigoNOTAS

DEFINIR NOMBRE, ESTUDIANTE Como Caracter


DEFINIR NOTA1,NOTA2,NOTAFINAL Como Real
NOTAFINAL <-99 //Se da un valor cualquiera mayor a 2 para que entre al ciclo
Mientras NOTAFINAL>=2 Hacer

Escribir "INGRESE NOMBRE DEL ESTUDIANTE:"


LEER NOMBRE
ESCRIBIR "INGRESE EL VALOR DE LA NOTA1:"
LEER NOTA1
ESCRIBIR "INGRESE EL VALOR DE LA NOTA2:"
LEER NOTA2
NOTAFINAL<-(NOTA1 + NOTA2)/2
Escribir "INFORMACIÓN DEL ESTUDIANTE"
ESCRIBIR "NOMBRE---->", NOMBRE
ESCRIBIR "NOTAFINAL---->", NOTAFINAL
Si NOTAFINAL<3 Entonces
ESCRIBIR "REPROBADO"

SiNo

Escribir "APROBADO"

Fin Si

Fin Mientras

FinAlgoritmo

2020
ALGORTIMOS - I.E.JOSÉ MARIA MUÑOZ FLÓREZ 5

2020
ALGORTIMOS - I.E.JOSÉ MARIA MUÑOZ FLÓREZ 6

Programa para el uso del ciclo “REPITA”


El programa planteado es el mismo para el ciclo “MIENTRAS”, pero en el presente apartado se
resolverá con la estrutura “REPITA”:

En la I.E.JOSÉ MARIA MUÑOZ FLÓREZ, se requiere de uma aplicación que lea constantemente el
nombre de los estudiantes de un aula de clases, basandose a su vez en 2 notas parciales de cada
uno y a través de ello, presente un mensaje con sus nombres y notas finales. Si la nota final es
inferior a 3, presentar el mensaje “REPROBADO”, en caso contrario presentar el mensaje
“APROBADO” a cada estudiante. Repetir este proceso hasta que alguno de ellos tenga uma nota
final por debajo de 2.

Algoritmo pseucódigoNOTA
Definir NOMBRE,ESTUDIANTE Como Caracter
Definir NOTA1,NOTA2,NOTA3,NOTAFINAL Como Real
// Inicio del ciclo Repita
Repetir
Escribir 'INGRESE EL NOMBRE DEL ESTUDIANTE:'
Leer NOMBRE
Escribir 'INGRESE EL VALOR DE NOTA1:'
Leer NOTA1
Escribir 'INGRESE EL VALOR DE NOTA2:'
Leer NOTA2
// Cálculo de la nota final
NOTAFINAL <- (NOTA1+NOTA2)/2
// Escritura de la salida
Escribir 'INFORMACIÓN DEL ESTUDIANTE'
Escribir 'NOMBRE--->',NOMBRE
Escribir 'NOTA FINAL--->',NOTAFINAL
Si NOTAFINAL<3 Entonces
Escribir 'REPROBADO'

SiNo
Escribir 'APROBADO'

FinSi

Hasta Que NOTAFINAL<2

FinAlgoritmo
6

2020
ALGORTIMOS - I.E.JOSÉ MARIA MUÑOZ FLÓREZ 7

2020

También podría gustarte